15:00:09 <JayF> #startmeeting Ironic
15:00:09 <opendevmeet> Meeting started Mon Oct 31 15:00:09 2022 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <opendevmeet> The meeting name has been set to 'ironic'
15:00:14 <TheJulia> o/
15:00:16 <JayF> Good morning folks o/ Who all is here?
15:00:59 <TheJulia> I'm a zombie, but I think I'm here
15:01:19 <JayF> #topic Announcements/Reminder
15:01:51 <JayF> Just a heads up: I have rearranged the Ironic whiteboard and the standard meeting agenda. Please have a look when you get a chance. To that end, I moved the usual priorities discussion to here as a reminder:
15:02:10 <JayF> Reminder to everyone: tag any patches hashtag ironic-week-prio to get them in front of reviewer eyes more quickly
15:02:14 <iurygregory> o/
15:02:17 <ajya> o/
15:02:19 <JayF> Reviewing action items from previous meeting:
15:02:26 <JayF> - I owed a cleanup of the Ironic whiteboard, that's done.
15:02:48 <rloo> o/
15:02:49 <JayF> - ebbex was going to wipe out the rest of suse support from Bifrost, I believe that work is WIP
15:03:06 <JayF> - dtantsur or arne_wiebalck were going to send out invites for Q1 2023 BM SIG sometime last or this week
15:03:14 <JayF> Thank you all for taking those actions and following up on them time permitting
15:03:29 <JayF> #topic Review Ironic CI Status
15:03:40 <JayF> Are there any major CI issues around Ironic to discuss or document?
15:04:12 <JayF> I think most of our gates are good except the usual suspects in stable branches. There are still a few outstanding zuul queue fix PRs to land as well, but the majority of them are in.
15:04:41 <TheJulia> :q
15:04:42 <TheJulia> err
15:06:11 <JayF> I'm going to take no news as good news, I guess. In future meetings if there's a persistent CI issue feel free to bring it up in this section.
15:06:18 <JayF> #topic Follow-up items from PTG
15:06:53 <iurygregory> tks for adding this section to the meeting JayF =)re CI Status
15:06:53 <JayF> #link https://review.opendev.org/c/openstack/ironic-specs/+/862538
15:07:06 <JayF> The spec for 2023.1 Ironic work items is up; and ready for review
15:07:32 <JayF> Please put comments on it
15:07:43 <dtantsur> frickler: probably none, it could be an issue that only happens on 4.10 and only if the ordering of tests align
15:07:49 <JayF> my plan is, if it has 2x+2 from core reviewers, and no negative feedback, to merge it during the meeting a week from today
15:08:15 <JayF> I see TheJulia already has comments on it, thank you and I'll review those later
15:08:24 <JayF> other PTG followup items:
15:08:45 <JayF> I have updated the Ironic Whiteboard, orienting it to track in-progress work items and archiving existing subteam status reports
15:09:07 <JayF> I purposely moved this to a sub-etherpad, versioned to this cycle, so we sorta will gte that natural archiving as we go from one cycle to the next
15:09:16 <JayF> (it's all linked from the whiteboard, have a look)
15:09:47 <JayF> in that vein; if you're working on something longer-term during 2023.1 and you want to participate in tracking status, just toss it into here: https://etherpad.opendev.org/p/IronicWorkstreams2023.1
15:09:51 <TheJulia> I presently get a HTTP 503 :(
15:10:05 <JayF> aw hell, bad timing for etherpad to be down :(
15:10:10 <JayF> oh well, you can look after the meeting
15:10:24 <JayF> I'll also take like, freeform feedback on any of this once you all can see the whiteboards
15:10:59 <JayF> I'm trying to move more of the tracking out of spec documents and into etherpad. Committed to the repo will be basically, aspirational work items for a cycle, and the release notes indicating what of those we actually got done
15:11:17 <JayF> this should make the process light enough that we're able to get some things written down but not have it be a strong thing to worry
15:11:36 <JayF> Is there any further comment or anything to add on PTG followups before we move on?
15:12:32 <TheJulia> That is basically how we've been working, just now with a versioned etherpad
15:12:45 <TheJulia> aspirational items upfront, communicated, then move on
15:12:50 <TheJulia> sounds good to me
15:12:59 <JayF> That's pretty much my thought on it, but I didn't want to assume others didn't see it differently :). Moving on.
15:13:07 <JayF> #topic Baremetal SIG
15:13:23 <JayF> Next meeting still not scheduled yet. Will be scheduled soon for Q1 2023.
15:13:29 <JayF> #topic RFE Review
15:13:45 <JayF> there's nothing here; and I haven't seen chat about any RFEs, I don't think we have anything for this either
15:13:53 <JayF> #topic Open Discussion
15:13:59 <JayF> Does anyone have any items for open discussion?
15:14:14 <arne_wiebalck> SIG: what did we decide/discuss for the meeting in Q1 2023?
15:14:21 <arne_wiebalck> I probably missed something.
15:14:50 <JayF> arne_wiebalck: At the PTG, we agreed to move it to a quarterly cadence. Last meeting, we had a weak consesnus (weak only because of participation) to make the next one Q1 2023
15:15:04 <JayF> and it was said either you might want that action item when you got back (to schedule it) or dtantsur would
15:15:24 <arne_wiebalck> do we have a topic/presentation already?
15:15:26 <JayF> The only real change beyond the cadence is we'd like to put an ICS file/calendar invite out with the SIG invite, as follow up from the PTG feedback
15:15:31 <arne_wiebalck> or do we change the format?
15:15:46 <JayF> I can talk about something if nobody else is willign
15:15:48 <dtantsur> arne_wiebalck: I was thinking about a fixed agenda that may include a presentation, but not necessarily
15:15:57 <JayF> dtantsur++ I like that idea
15:16:06 <TheJulia> Yeah, that was my takeaway as well
15:16:14 <dtantsur> I'm leaning towards more of a panel format, to be honest
15:16:18 <TheJulia> ++
15:16:29 <dtantsur> we did that for a local ironic meetup, and it worked better than just someone showing slides
15:16:33 <dtantsur> *especially* when it's virtual
15:16:52 <JayF> I really like that idea
15:18:09 <arne_wiebalck> dtantsur: does the agenda already exist?
15:18:34 <dtantsur> no, I was going to draft something, but EOVERWHELMED
15:18:57 <JayF> There's no real urgency on it, we should probably have it on the books before the end of the month.
15:19:32 <JayF> If I have a free moment, I might draft something up in an etherpad to review, for an agenda
15:19:33 <arne_wiebalck> ok ... ideally, we bring in operators/interested new users/ ... rather than having turning this into an Ironic core video call :)
15:19:49 <JayF> I was going to suggest we take a specific thing and dig into it, if we're doing a panel format
15:19:53 <TheJulia> arne_wiebalck: +1,000,000
15:19:54 <JayF> e.g. a 10 minute bifrost demo or something
15:20:08 <JayF> that might hold value even if recorded and watched async
15:20:56 <dtantsur> arne_wiebalck: yeah, and he's the thing
15:21:01 <TheJulia> Well, the overall idea is foster community and drive feedback loop
15:21:05 <dtantsur> we need to find at least one operator willing to be on the panel
15:21:12 <dtantsur> for the specific question
15:21:34 <dtantsur> e.g. for the meetup we have "bare metal and networking", and there was a guy who is doing BMaaS with switch management
15:21:40 <dtantsur> * had
15:21:49 <arne_wiebalck> dtantsur: right
15:22:17 <arne_wiebalck> dtantsur: panel format is fine, since more interactive, but we need to spend some effort to have people join
15:22:25 <dtantsur> as always :)
15:22:30 <arne_wiebalck> heh, true
15:22:41 <dtantsur> as the PTG showed, it's no longer enough to just announce the event..
15:22:55 <JayF> dtantsur: Perhaps metal3 is the topic for Q1 2023...
15:22:57 <arne_wiebalck> so everyone asking questions here, gets an invite to the next SIG meeting :-D
15:23:09 <arne_wiebalck> dtantsur: ++
15:23:10 <TheJulia> dtantsur: well stated
15:23:38 <arne_wiebalck> from my experience, people are happy to present when one asks them
15:23:40 <JayF> dtantsur: you might have an alternate operator group to tap to get someone on panel, alternate groups of operators to reach out to, and I think there are folks in the community who contribute who could learn some stuff too
15:23:42 <dtantsur> #link https://etherpad.opendev.org/p/ironic-quarterly-meetup let's plan here once the etherpad is back
15:23:59 <arne_wiebalck> like g-research or the berlin health institute ... or CERN :)
15:24:08 <dtantsur> true
15:25:41 <JayF> https://etherpad.opendev.org/p/ironic-quarterly-meetup ideas for the BM SIG Q1 2023
15:25:53 <JayF> #action dtantsur, arne_wiebalck, JayF, and anyone else interested to collab in  https://etherpad.opendev.org/p/ironic-quarterly-meetup ideas for the BM SIG Q1 2023
15:25:57 <JayF> there we go :)
15:26:08 <arne_wiebalck> JayF: awesome
15:26:10 <JayF> Is there anything else to discuss synchronously?
15:28:29 <JayF> Last call?
15:28:56 <JayF> I'll be here next week to run the meeting. Thanks all for coming.
15:29:00 <JayF> #endmeeting Ironic