15:01:52 <JayF> #startmeeting ironic
15:01:52 <opendevmeet> Meeting started Mon Dec 12 15:01:52 2022 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:52 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:52 <opendevmeet> The meeting name has been set to 'ironic'
15:01:59 <TheJulia> o/
15:01:59 <iurygregory> o/
15:02:00 <dtantsur> o/
15:02:01 <matfechner> o/
15:02:03 <hjensas> o/
15:02:11 <JayF> #topic Announcements/Reminder
15:02:14 <ajya> o/
15:02:23 <rloo> o/
15:02:29 <JayF> Standing reminder to tag your patches that are ready-for-review with hashtag ironic-week-prio
15:02:37 <JayF> and to review hashtagged changes as well
15:03:37 <JayF> Reminder also that meetings are cancelled 12/26 and 1/2 to allow folks to celebrate the holiday
15:03:47 <JayF> #topic Action items from previous meeting
15:04:05 <rpittau> p
15:04:06 <rpittau> p/
15:04:08 <rpittau> o/
15:04:10 <rpittau> argh...
15:04:10 <JayF> I did push that MR up to add an ironic-releases group; will be getting that populated with folks and getting things in place to retire old bugfix branches.
15:04:28 <JayF> I'm thinking it might be wise to wait until Jan 2023 to activate on that? Does anyone have a strong opinion?
15:04:53 <Kirill_> o/
15:06:20 <JayF> I guess nobody cares about timing on that then?
15:06:35 <JayF> rpittau: I also had you listed as having an action to remove centos8 jobs from bifrost/IPE wallaby
15:06:42 <JayF> I think I saw that patch come through?
15:07:02 <rpittau> JayF: that's done
15:07:03 <iurygregory> I don't think we are in a hurry to retire them, or are we?
15:07:12 <TheJulia> jayf: no opinion from my point of view
15:07:13 <opendevreview> Mark Goddard proposed openstack/ironic-python-agent stable/yoga: Warn when smartctl not found  https://review.opendev.org/c/openstack/ironic-python-agent/+/867159
15:07:21 <opendevreview> Mark Goddard proposed openstack/ironic-python-agent stable/xena: Warn when smartctl not found  https://review.opendev.org/c/openstack/ironic-python-agent/+/867160
15:07:29 <opendevreview> Mark Goddard proposed openstack/ironic-python-agent stable/wallaby: Warn when smartctl not found  https://review.opendev.org/c/openstack/ironic-python-agent/+/867161
15:07:39 <iurygregory> we can have a deadline but it can probably wait till begin of 2023
15:07:42 <JayF> iurygregory: the only real driving factors are that it's confusing when backporting stuff, and that the olld bugfix branches are all showing up in zuul-config-errors
15:07:55 <iurygregory> JayF, I see
15:07:57 <JayF> Yeah; I'm thinking I'll get all the commands lined up, sent to the list to review
15:08:02 <JayF> and then execute after holiday
15:08:10 <JayF> I just don't want someone to get broken christmas week :)
15:08:11 <TheJulia> ++
15:08:25 <JayF> aight it looks like we successfully did the things
15:08:38 <JayF> #action JayF to document steps needed to retire bugfix branches; and schedule it to happen sometimes post-holiday (2023)
15:08:45 <JayF> Next up
15:08:49 <JayF> #topic 2023.1 WIP
15:09:04 <JayF> Shards workflow is actively blocked on reviews at this point
15:09:15 <JayF> please help us get the spec landed in ironic side so we can start landing db /api code
15:10:06 <JayF> I'll make sure to put a review on 860731 for SQLA 2.0+inspector
15:10:19 <JayF> #link https://etherpad.opendev.org/p/IronicWorkstreams2023.1
15:10:56 <TheJulia> ++
15:11:13 <JayF> Moving on
15:11:23 <JayF> there are no RFEs for review, skipping that
15:11:26 <JayF> #topic Open Discussion
15:11:31 <JayF> Anything for open discussion today?
15:11:32 <TheJulia> I'm happy to get on a call and walk through ether the shard spec or the inspector sqlalchemy stuffs
15:11:45 <JayF> I'd be happy to participate in such a review jam
15:11:49 <JayF> such jam, wow
15:12:23 <rpittau> is anyone looking at the ironic weekly priorities recently?
15:12:29 <rpittau> https://review.opendev.org/q/hashtag:ironic-week-prio+status:open
15:12:39 <rpittau> we have a lot still under review since november
15:12:45 <dtantsur> TheJulia: I'm looking through the sqla stuffs right now
15:12:48 <rloo> (I hope to go through the shard spec one more time today, if i have outstanding questions will ping TheJulia and/or JayF)
15:13:04 <JayF> I've been trying to get the metrics bits done for reviews rpittau, I think they are incredibly down across the board
15:13:27 <JayF> rpittau: I'll personally make sure to make a pass; but I am concerned overall review capacity in the project is diminished right now for reaosns I can't see/understand
15:13:57 <JayF> I think we might have fallen into the trap where people are reviewing things they have comments for but not putting a lot of approval +1/+2s on stuff too, but I am not sure
15:14:21 <JayF> Either way I noticed that too rpittau and would appreciate if cores across the project worked to get things landed
15:14:47 <rpittau> JayF: I'll have a look this week
15:15:14 <JayF> thanks for bringing it up :D
15:15:29 <rpittau> :)
15:16:39 <JayF> Alright, is there anything else for Open Discussion?
15:16:46 <JayF> If not we can give folks a nice 40 minutes+ back :D
15:17:48 <TheJulia> sounds good to me
15:18:00 <JayF> #endmeeting ironic