15:00:53 <JayF> #startmeeting ironic
15:00:53 <opendevmeet> Meeting started Mon Jan 16 15:00:53 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:53 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:53 <opendevmeet> The meeting name has been set to 'ironic'
15:00:58 <iurygregory> o/
15:00:59 <matfechner> o/
15:01:04 <JayF> Good morning, who all is here?
15:01:08 <dtantsur> o/
15:01:13 <JayF> I'll note today is a holiday in the US; Martin Luther King Jr day today
15:01:25 <JayF> so I expect us to have less attendance than usual
15:02:18 <JayF> #topic Announcements/Reminder
15:02:19 <rpittau> o/
15:02:20 <JayF> Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:02:44 <JayF> #topic Review action items from previous meeting
15:03:58 <JayF> iurygregory was going to create an etherpad for virtual ptg
15:04:08 <JayF> iurygregory: if you've done that, share it here and I'll link the URL in the minutes
15:04:15 <JayF> otherwise that's OK; we can tackle it this week
15:05:14 <iurygregory> sharing now
15:05:57 <iurygregory> https://etherpad.opendev.org/p/ironic-bobcat-ptg
15:06:14 <JayF> #link https://etherpad.opendev.org/p/ironic-bobcat-ptg
15:06:22 <JayF> I'll look over that sometime this week and help flesh any of it out
15:06:46 <JayF> #topic Review ironic CI status
15:06:56 <JayF> It's been a mess. Big thanks for rpittau for trying to stay on top of it
15:07:10 <rpittau> "trying" is the right word!
15:07:23 <JayF> I was just thinking; I'll try and spin wheels and often you'll try and gain traction
15:07:28 <JayF> our CI is hugely complex :D
15:07:30 <rpittau> :D
15:07:38 <JayF> one good note about this; we're mostly done with zuul-config-errors
15:07:44 <JayF> after the bugfix branch retirements last week
15:08:08 <rpittau> JayF: related to CI, we should probably talk about virtualpdu
15:08:14 <JayF> oh yeah, that's not on agenda though
15:08:24 <JayF> I'll mark it for open discussion
15:08:27 <rpittau> sure
15:08:50 <JayF> One thing I'd like is if we cleaned up the last 3/4 zuul config errors this week
15:09:01 <JayF> these are branches that never got the zuul queue: param removal fix
15:09:12 <JayF> but are still new enough to be supported
15:09:48 <JayF> I can't find the dang etherpads :(
15:11:49 <JayF> ironic-inspector bugfix/10.12; ironic-inspector bugfix/10.7; IPE bugfix/2.1; IPE stable/train; python-ironicclient train
15:11:51 <JayF> among others
15:12:07 <JayF> I created a full list in an etherpad and promptly lost the URL to said etherpad
15:12:19 <JayF> basically; go here and search "ironic" https://zuul.opendev.org/t/openstack/config-errors
15:12:22 <JayF> if you wanna help with this
15:12:36 <JayF> I'm not as sharp on fixing inspector and IPE so I really hope other folks are willing to take a look :D
15:12:44 <JayF> #topic 2023.1 Work in Progress
15:12:51 <rpittau> I'll have a look
15:12:55 <JayF> I'd like, next week, to do a full review of this with folks...
15:13:05 <JayF> we have a lot of stuff we said we wanted to do this cycle that I think has barely even started
15:13:15 <JayF> it'll be a good input to the PTG planning to know what items are getting done
15:13:50 <JayF> so I strongly encourage you that next week, if you're one of the champions for an item in the workstream for this cycle; please input a status update or be here at next meeting with something to put
15:14:01 <JayF> just trying to see where we are before we go planning another six months
15:14:15 <JayF> https://etherpad.opendev.org/p/IronicWorkstreams2023.1 here is the current status doc
15:14:29 <JayF> and https://etherpad.opendev.org/p/IronicWorkstreams2023.1
15:14:41 <JayF> and https://specs.openstack.org/openstack/ironic-specs/priorities/2023-1-workitems.html is the spec we landed with the aspirational list
15:14:54 <JayF> #link https://specs.openstack.org/openstack/ironic-specs/priorities/2023-1-workitems.html
15:15:34 <JayF> #link https://etherpad.opendev.org/p/IronicWorkstreams2023.1
15:15:43 <JayF> Any comments before I move on?
15:16:49 <JayF> taking the silence as an implicit no
15:16:51 <JayF> next topic
15:17:18 <JayF> #action Future of Bugfix releases punted to next meeting; needs to be on a day that's not a US holiday so we have more contributors here
15:17:33 <JayF> #topic open discussion
15:17:38 <JayF> rpittau: wanted to mention virtualpdu
15:17:44 <rpittau> yep
15:18:51 <rpittau> ironic CI depends on it but the development has stopped since a while
15:18:51 <rpittau> now it doesn't work with python 3.10, meaning we can't move to jammy
15:18:51 <rpittau> I put together some patches to fix that but we probably need to contact the cores
15:19:06 <dtantsur> any luck emailing them?
15:19:33 <rpittau> I haven't emailed them yet as I saw JayF mentioning he wanted to check on another side
15:19:46 <JayF> I was volunteering to take it up with TC
15:19:50 <JayF> if Cores were not responsive
15:20:01 <rpittau> ok, so I'll email them first
15:20:15 <JayF> and that this; if we use it in our CI; might make sense to be an openstack project under our governance if it's not currently in a good maintenance spot
15:20:18 <rpittau> I'll do it right after the meeting
15:20:28 <JayF> #action rpittau to contact cores of virtualpdu about his changes
15:20:40 <JayF> rpittau: I suggest you also offer to be a core; or for ironic-core to be added
15:20:54 <JayF> rpittau: just very awkward for our CI to depend on packages that are not super-actively maintained
15:21:26 <rpittau> well it was working until focal, it went unnoticed until we tried to go to jammy
15:21:39 <rpittau> but I agree, we should monitor dependencies more closely
15:22:04 <JayF> I mean, who else is going to maintain a fake-PDU for CI usage but us? That's sorta our thing now LOL
15:22:48 <rpittau> :)
15:23:06 <JayF> If there's nothing else; I'm going to call the meeting :)
15:24:04 <JayF> Alright, I think we're done.
15:24:07 <JayF> #endmeeting