15:00:20 <JayF> #startmeeting ironic
15:00:21 <opendevmeet> Meeting started Mon Jan 30 15:00:20 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:21 <opendevmeet> The meeting name has been set to 'ironic'
15:00:26 <JayF> Good morning, who all is here?
15:00:28 <iurygregory> o/
15:00:29 <dtantsur> o/
15:00:37 <TheJulia> o/
15:01:01 <rpittau> o/
15:01:11 * TheJulia stumbles across the channel saying "brraaaaainns"
15:01:22 <JayF> #topic Announcements
15:01:47 <JayF> As always, please hashtag your patches #ironic-week-prio when they are ready for review, and use the priority dashboard in the whiteboard to do reviews.
15:01:57 <JayF> #link https://ironicbaremetal.org/blog/baremetal-sig-2023q1/
15:02:06 <JayF> Q1 2023 Baremetal SIG is happening Weds, f
15:02:16 <JayF> **Weds, Feb 8 from 1500-1700 UTC.
15:02:23 <JayF> Please see the linked blogpost for details.
15:02:34 * TheJulia sighs since she will be in Dallas, TX
15:02:56 <JayF> Aight, next up
15:03:03 <JayF> #topic review previous action items
15:03:27 <JayF> I am going to push my action about LP; releasenotes job stole that time
15:03:39 <JayF> #action JayF to bring a launchpad migration plan to a future meeting
15:04:00 <JayF> I did fulfill the actions I had to 1) update bugfix branch policies (these have merged) and 2) clean up core list to remove now-inactive members :(
15:04:21 <JayF> vanou had an item to update our security docs; I haven't seen that come across
15:04:25 <JayF> vanou: do you have that or should we push it too?
15:04:44 <kubajj> o/
15:05:11 <JayF> I don't think vanou is here; I'll push the action so we can check next week
15:05:12 <TheJulia> I suspect vanou is asleep
15:05:30 <JayF> #action vanou follow up on ironic security docs action from 1/23 meeting
15:05:44 <JayF> That's it for action items.
15:05:47 <JayF> #topic Review Ironic CI status
15:05:53 <JayF> Ironic CI has been bonkers.
15:06:17 <JayF> I fixed issues caused in the releasenotes job by the presence of the bugfix-x.y-eol tags -- we now configure reno to ignore them.
15:06:31 <JayF> I know rpittau has continued to work on making some stable branches happy, too. Thanks for that.
15:06:47 <JayF> I'd say I expect master should work, but some stable/bugfix branches may still be struggling
15:06:50 <rpittau> JayF: I'm removing the reno jobs from the bugfix branches, doesn't make sense to have that there
15:06:55 <JayF> ++
15:07:04 <opendevreview> Jakub Jelinek proposed openstack/ironic master: Erase swift inventory entry on node deletion  https://review.opendev.org/c/openstack/ironic/+/871394
15:07:05 <JayF> if you find something wrong, please put it in the whiteboard or comment in IRC :)
15:07:13 <JayF> Moving on
15:07:19 <JayF> #topic review 2023.1 workstream progress
15:07:41 <JayF> I'll note I haven't found much time for getting the last bit of sharding done; I'm going to try and hide somewhere today and complete it.
15:08:13 <JayF> #link https://etherpad.opendev.org/p/IronicWorkstreams2023.1
15:08:31 <JayF> looks like sqlalchemy 2.0 is just waiting on the metal3 CI job
15:08:55 <JayF> and merging inspector into ironic; kubajj has made great progress ... but I'm not sure it seems we'll get totally migrated this cycle? How is it looking?
15:09:06 <dtantsur> Totally - absolutely not
15:09:16 <dtantsur> the introspection data API is just the first step
15:09:47 <TheJulia> Does a list or rough plan exist someplace?
15:09:54 <dtantsur> yes, on storyboard. hold on
15:10:12 <dtantsur> #link https://storyboard.openstack.org/#!/story/2010275 Plan on merging inspector in ironic
15:10:34 <JayF> OK; that is super useful, thank you
15:10:44 <TheJulia> I've added the link to the etherpad
15:10:45 <JayF> TBH at this point I assume storyboard data is wrong unless someone tells me otherwise :|
15:11:18 <JayF> Thank you for that work. We need to land much of this as the release will be here before we realise it :D
15:11:29 <JayF> moving on
15:11:37 <JayF> #topic Project Maintainer Audit @ PyPI
15:11:51 <JayF> #link https://etherpad.opendev.org/p/openstack-pypi-maintainers-cleanup
15:12:07 <JayF> The results found for ironic in ^ can only be best described by an emoji screaming
15:12:32 <JayF> We have multiple repos with maintainers whom are no longer associated with the community, and in one case, not identifyable at all
15:12:56 <JayF> I am asking for unanimous consent to move forward with the TC plan to remove all existing maintainers except openstackci.
15:12:57 * iurygregory see his name in the list XD
15:13:24 <rpittau> absolutely, let's do it
15:13:29 <JayF> TBH; I'm not sure this is something that we as a community haven't even already consented to, and it's the right thing to do, but I wanted to provide a venue in case there is any disagreement
15:14:13 <TheJulia> ... *blink* *blink*
15:14:31 <iurygregory> no objections from me
15:14:50 * TheJulia wonders how monty ended up a maintainer on bifrost
15:15:07 <JayF> generally speaking; it's whoever created the PyPI project originally
15:15:25 <JayF> like I suspect the `login.launchpad.net_154` is probably one of my ex-managers at Rackspace, when we created it
15:15:32 <JayF> (it being IPA)
15:16:57 <JayF> I'm going to consider this agreed.
15:17:13 <JayF> #agreed Ironic is onboard with TC plans to unify PyPA maintainership under openstackci
15:17:28 * dtantsur has no objections
15:17:35 <JayF> #undo
15:17:35 <opendevmeet> Removing item from minutes: #agreed Ironic is onboard with TC plans to unify PyPA maintainership under openstackci
15:17:40 <JayF> #agreed Ironic is onboard with TC plans to unify PyPI maintainership under openstackci
15:18:26 <JayF> Aight, next up.
15:18:35 <JayF> No RFEs to review, skipping that
15:18:39 <JayF> #topic virtualpdu situation
15:18:47 <JayF> rpittau: o/
15:18:53 <TheJulia> did they respond?
15:18:56 <rpittau> yes, the status is not good
15:19:02 <rpittau> they did not respond
15:19:31 <JayF> So can we be clear how Ironic is impacted by the issue with VirtualPDU?
15:19:36 <TheJulia> ++
15:19:40 <JayF> Just to reset back to the original trigger
15:19:40 <TheJulia> I would like to understand that
15:19:48 <rpittau> ironic jobs depend on virtualpdu
15:19:52 <dtantsur> It's used in the SNMP job
15:19:56 <TheJulia> yes
15:19:57 <rpittau> virtualpdu is not python3 compatible
15:20:00 <TheJulia> oh, heh
15:20:02 <rpittau> we can't move to jammy
15:20:23 <iurygregory> oh wow
15:20:23 <rpittau> this is in short
15:20:37 <TheJulia> ... and without an active maintainer.. ugh
15:20:42 <JayF> So we really don't have a lot of time to resolve this either; then
15:20:48 <rpittau> this https://review.opendev.org/c/openstack/ironic/+/869052 is failing because of that
15:20:50 <dtantsur> which options we have? 1) fork virtualpdu, 2) put it in a container with old ubuntu, 3) drop the job?
15:20:55 <JayF> 4) wait longer
15:21:03 <TheJulia> 5) Ask to adopt it
15:21:04 <TheJulia> ?
15:21:10 <dtantsur> We cannot ask if they don't respond
15:21:12 <JayF> TheJulia: #5 has been done; we've not gotten any response
15:21:26 <dtantsur> If we decide to wait, the container approach can be a workaround
15:21:31 <dtantsur> to proceed with jammy
15:21:38 <rpittau> the project is abandoned since years now btw
15:21:48 <JayF> Honestly, I think it makes sense to fork it
15:21:48 <TheJulia> no response does sort of lend ourselves to lazy consensus ability
15:22:06 <JayF> We're the only people in the world with a real need to reliably support fake-hardware emulation lol
15:22:10 <dtantsur> Think about this: we can always remerge out fork if they wake up
15:22:14 <rpittau> last update was 4 years ago https://opendev.org/x/virtualpdu
15:22:14 <JayF> Yep.
15:22:21 <JayF> So it's under opendev already?
15:22:25 <rpittau> yeah
15:22:29 <JayF> Does anyone have any idea what the process is for this?
15:22:43 <JayF> and/or want to own the communication bits of this?
15:22:56 <rpittau> I can handle that
15:23:06 <TheJulia> there likely needs to be a dialog with the opendev folks to figure out what they are most comfortable with
15:23:10 <rpittau> just need some tips :0
15:23:19 <JayF> I'd go into #opendev and tell them the situation
15:23:20 <TheJulia> given being in the x/ namespace, it was once likely in openstack/
15:23:22 <TheJulia> ++
15:23:26 <JayF> that we've agreed in Ironic to adopt it
15:23:27 <rpittau> sounds good
15:23:30 <JayF> and we're willing to do that as a fork if needed
15:23:44 <JayF> or not as a fork if hijacking is an option (I probably prefer not? but they might have context we don't)
15:24:34 <JayF> #action rpittau to communicate with opendev/openstack folks to determine how best for Ironic community to adopt/fork https://opendev.org/x/virtualpdu
15:25:02 <JayF> rpittau: goes without saying, if you have any trouble or confusion please ask :) I don't have much special knowledge but I can ask everyone :D
15:25:12 <rpittau> of course :)
15:25:13 <JayF> Anything else on virtualpdu?
15:25:19 <rpittau> that's all I guess
15:25:24 <JayF> #topic Open Discussion
15:25:33 <JayF> anything for open discussion?
15:26:06 <TheJulia> nothing from my point of view at this time
15:26:43 <JayF> Aight, I'm going to call it.
15:26:45 <JayF> #endmeeting