15:00:39 <JayF> #startmeeting ironic
15:00:39 <opendevmeet> Meeting started Mon Feb 20 15:00:39 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:39 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:39 <opendevmeet> The meeting name has been set to 'ironic'
15:00:49 <TheJulia> o/
15:00:55 <matfechner> o/
15:01:02 <JayF> Good morning
15:01:08 <JayF> Who all is here?
15:01:40 <JayF> Note: it's a holiday in the US (President's Day), so be aware when working with folks from America
15:01:47 <JayF> #topic Announcements/Reminder
15:02:09 <JayF> As always, review patches marked ironic-week-prio, and hashtag your patches with it if its ready for review. For more info see the whiteboard.
15:03:02 <JayF> Checking action items from last week, none, skipping that
15:03:15 <JayF> Any updates on Ironic CI? I haven't seen anything troubling
15:03:28 <JayF> I think our efforts early/mid cycle to fix up CI are paying off with relatively smooth sailing now
15:03:38 <dtantsur> has anyone looked at the clients' CI?
15:03:45 <TheJulia> I haven't looked yet this morning. As of Friday the requirements repo still wasn't taking patches
15:03:51 <dtantsur> I think they still have stable/zed updates hanging
15:04:08 <JayF> I've not looked at clients CI
15:04:21 <JayF> dtantsur: I'm not sure what you mean by updates hanging?
15:04:34 <TheJulia> \o/ requirements is good again
15:04:37 <dtantsur> https://review.opendev.org/c/openstack/python-ironic-inspector-client/+/856419/
15:04:48 <dtantsur> possibly, the functional job requires its regular massaging
15:05:14 <TheJulia> hmm... no logging at all :(
15:05:47 <JayF> So is there someone who wants to the the action of cleaning this up?
15:06:00 <JayF> We shouldn't live troubleshoot in the meeting, but I appreciate it being brought to more light
15:06:17 <JayF> *take the action of cleaning this up
15:07:49 <TheJulia> I can take a look after the meeting
15:07:54 <JayF> thank you
15:08:14 <JayF> #action TheJulia to look into stable/zed patches needed to get python-ironic-inspector-client happy (and maybe others?)
15:08:23 <JayF> moving on
15:08:30 <JayF> rpittau: any response on virtualpdu?
15:08:36 <rpittau> o/
15:08:43 <rpittau> JayF: unfortunately not :/
15:09:08 <JayF> #note Ironic, despite having promises from a VirtualPDU maintainer that we could take it over, is now being ghosted.
15:09:23 <JayF> We should consider a hard fork soon. Maybe brainstorm some names lol
15:09:38 <TheJulia> ghosted how?
15:09:48 <JayF> The timeline as I understand it is:
15:09:52 <TheJulia> Could it be a lack of response being consent ?
15:10:01 <TheJulia> in the whole lazy-consensus model
15:10:01 <JayF> 1) We ( rpittau ) reached out, they said "yeah, you can have it"
15:10:13 <JayF> 2) rpittau said "make me a core and then I can handle everything else"
15:10:16 <JayF> 3) they disappeared
15:10:30 <TheJulia> if we have that in writing, shouldn't that be enough to get opendev to consider granting rights?
15:10:35 <JayF> because it's an "x" namespace project, unless they voluntarily make one of us a core to adopt it into openstack, we can't hostile take it over
15:10:58 <TheJulia> yeah
15:11:07 <JayF> I'm sure we could try to make that case; I'm not sure I'd want to put opendev in that position just so we don't have to change a name
15:11:36 <rpittau> I was wondering if the mail would be enough
15:11:45 <JayF> fungi: are you around, by chance?
15:11:51 <TheJulia> The conundrum that comes to mind is that this is likely going to happen to others in the community since we so heavily relied upon lazy consensus
15:12:07 <rpittau> (sorry if I'm slow answering but I'm in another meeting!)
15:12:14 <JayF> rpittau: I can't tell :)
15:12:20 <TheJulia> and inaction will then be paralysis
15:12:33 <TheJulia> Granted, it is all about balancing the needful
15:12:59 <JayF> I'm going to move on to release countdown, if we get a reply from fungi we can circle back or else just ask when he's around
15:13:07 <JayF> #topic Release countdown: 4 weeks
15:13:26 <TheJulia> hard fork is likely the cleanest option but we may want to look at shutting down the x repo namespace eventually if we can, just for clarity purposes
15:13:33 <JayF> #link https://review.opendev.org/c/openstack/releases/+/874338 Please place a review on cycle highlights if you haven't already
15:13:45 <JayF> TheJulia++
15:13:58 <JayF> #link https://etherpad.opendev.org/p/IronicWorkstreams2023.1 2023 workstreams
15:14:11 <JayF> is there anything partially complete we can work together to land entirely before the release is cut?
15:15:41 <TheJulia> I don't think so on that list, we're basically blocked on sqla right now
15:15:52 <JayF> is the metal3 job being worked on?
15:16:00 <JayF> and/or is it close?
15:16:02 * dtantsur pokes rpittau
15:16:17 <rpittau> sorry, no progress last week :/
15:17:09 <TheJulia> as for not on that list, I've got the metrics collection patch for the conductor on my screen now, and the prometheus exporter patch shouldn't take long to wrap up now that we have the requirements lib merged
15:17:17 <TheJulia> (for ironic-lib)
15:18:15 <JayF> We still need to land release notes for sharding too https://review.opendev.org/c/openstack/ironic/+/873652
15:18:27 <TheJulia> that is easy
15:18:41 <JayF> yeah just putting it in front of eyes while folks are here :)
15:18:56 <TheJulia> approved
15:18:56 <JayF> if there's something specific I can help with troubleshooting that new metal3 job, or landing patches, or whatever please let me know
15:19:06 <TheJulia> others can amend it if they so desire :)
15:19:09 <JayF> ++
15:19:35 <dtantsur> that human cloning machine that TheJulia promised us long ago... can you finish it?
15:20:06 <TheJulia> can we get the ptg etherpad added to the ironic whiteboard
15:20:17 <TheJulia> dtantsur: sadly I believe it was last assigned to mordred
15:20:18 <JayF> https://etherpad.opendev.org/p/ironic-bobcat-ptg
15:20:25 <TheJulia> JayF: thanks, adding
15:22:02 <JayF> thanks
15:22:06 <JayF> #topic open discussion
15:22:09 <JayF> anything else?
15:22:13 <TheJulia> uhh
15:22:14 <TheJulia> lets see
15:22:19 <TheJulia> I have some crazy ideas floating to the surface
15:22:34 <TheJulia> Based upon our recent baremetal sig discussion, I put words into https://review.opendev.org/c/openstack/ironic-specs/+/873662
15:22:52 <TheJulia> I've already mentioned the modify steps idea
15:23:24 <TheJulia> And I was looking at some DPU related stuff with the need to toggled multiple BMC's power/boot modes to fully deploy a node, and came up with https://review.opendev.org/c/openstack/ironic-specs/+/874189
15:23:51 <JayF> honestly I'm nervous to review that last one until after I know more about what a DPU is
15:24:01 <TheJulia> ... which would address some of the asks for the ability to speak to a BMC and say a power-strip to shutdown additional power
15:24:15 <JayF> and given the number of WTF-looks exchanged between me, dtantsur and arne during the hardware enablement track chair meetings, I think lack of knowledge about DPUs is fairly common lol
15:24:19 <TheJulia> JayF: I've got a little bit of an intro in it, but ack
15:24:32 <JayF> okay good good I'll be less scared to review it then LOL
15:24:53 <TheJulia> just think a machine could today have 3 independent BMCs
15:25:31 <TheJulia> (newer bluefield cards can be connected, or not for same BMC management, and you can have 2 in a machine)
15:26:13 * TheJulia suspects this would be the case where lots of extra power is needed
15:26:25 <TheJulia> Anyway, they are both early thoughts, I would love feedback
15:26:46 <TheJulia> and feedback on Modify steps if anyone wants to put a bunch of pieces together and realize some of the neat functionality which falls out :)
15:26:51 <TheJulia> https://review.opendev.org/c/openstack/ironic-specs/+/872349
15:27:09 <JayF> #link https://review.opendev.org/c/openstack/ironic-specs/+/872349 modify steps spec (formerly active steps)
15:27:21 <JayF> #link https://review.opendev.org/c/openstack/ironic-specs/+/874189 DPU management spec
15:27:22 <opendevreview> Merged openstack/ironic master: Fixes console port conflict occurs in certain path  https://review.opendev.org/c/openstack/ironic/+/868342
15:27:31 <opendevreview> Merged openstack/ironic master: Make metrics names a little more consistent  https://review.opendev.org/c/openstack/ironic/+/869879
15:27:38 <JayF> #link https://review.opendev.org/c/openstack/ironic-specs/+/873662 cross-conductor-rpc spec
15:27:57 <JayF> TheJulia: I'll try to get to those; but I need to do sharding api client first
15:28:29 <TheJulia> Thanks
15:28:34 <JayF> thanks for writing those up, it's good to be thinking about what's coming in bobcat
15:28:44 <JayF> #link https://etherpad.opendev.org/p/ironic-bobcat-ptg
15:29:24 <JayF> Is there anything else before we call it?
15:30:13 <kubajj> o/
15:30:27 <TheJulia> I've got nothing
15:30:31 <JayF> #endmeeting