15:02:33 <JayF> #startmeeting ironic
15:02:33 <opendevmeet> Meeting started Mon Mar  6 15:02:33 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:33 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:33 <opendevmeet> The meeting name has been set to 'ironic'
15:02:34 <TheJulia> but, yes, it is a can of worms
15:02:45 <iurygregory> o/
15:02:46 <dtantsur> true
15:02:48 <dtantsur> hi folks o/
15:02:49 <TheJulia> dtantsur: window is against the heartbeat operation still occuring
15:02:49 <matfechner> o/
15:02:59 <JayF> Should be a pretty quick one this morning; I'll try to fly through
15:03:05 <TheJulia> o/
15:03:09 <JayF> #topic Announcements/Reminder
15:03:18 <JayF> As always, tag your patches with ironic-week-prio to get them reviewed
15:03:36 <JayF> And we are counting down, focusing on any outstanding reviews would be good; I haven't looked but will make a point to check today
15:03:37 <kaloyank> TheJulia: what do you mean by application credentials exactly? How Ironic authenticates to the storage backend or something else?
15:03:43 <rpittau> o/
15:03:52 <JayF> #topic Review Actions from last meeting
15:04:15 <TheJulia> kaloyank: lets revisit once the irc meeting is over :)
15:04:20 <kaloyank> sure
15:04:23 <JayF> kaloyank: I'll be fast :D
15:04:29 <JayF> okay, action items, we had 3
15:05:00 <JayF> First one is tied to a general announcement; I will be out Weds-Mon at a conference with limited availability. If you need me urgently, email is best (anything-but-IRC).
15:05:10 <JayF> And iurygregory will be running the meeting next week in my stead
15:05:18 <JayF> I have an untaken action I'll renew
15:05:27 <JayF> #action JayF To look into VMT for Ironic
15:05:33 <JayF> That's the actions from last week
15:05:37 <JayF> moving on
15:05:40 <JayF> #topic CI Status
15:05:51 <JayF> Is there anything notable about CI from the last 7 days that people should know?
15:06:41 <rpittau> JayF: just 2 minor fix for bifrost CI
15:06:47 <rpittau> they're in the prio list
15:06:48 <JayF> Thanks for that \o/
15:06:52 <JayF> I'll look this morning
15:06:54 <TheJulia> mnasiadka: uhh... wow, that shouldn't break that way. Have you checked oslo.db is appropriate based upon requirements.txt and the xena upper-constraints.txt file from the openstack/requirements repo branch stable/xena ?
15:06:55 <rpittau> thanks
15:06:58 <JayF> #topic VirtualPDU update
15:07:01 <iurygregory> I saw some of the jobs in networking-generic-switch failing (but didn't really look to find the root cause)
15:07:18 <JayF> So, thanks to rpittau, fungi and their work, VirtualPDU has us as cores now
15:07:28 <rpittau> \o/
15:07:32 <mnasiadka> TheJulia: that's a Kolla container, I can't assume it's different but let me check :)
15:07:33 <JayF> additionally, I proposed + landed governance change to put it officially under Ironic's program
15:07:48 <iurygregory> tks everyone!
15:08:02 <JayF> So VirtualPDU is adopted. There is a further step; moving the repo from x/virtualpdu -> openstack/virtualpdu; but that requires gerrit downtime and will not happen until after the release sometime
15:08:03 <jssfr> kaloyank, specifying root_device helped, thanks!
15:08:06 <rpittau> JayF: what do we want to do for a possible release ?
15:08:13 <rpittau> for virtualpdu
15:08:19 <TheJulia> mnasiadka: the issue is it has been for 6 years, something is *very* wrong.
15:08:21 <JayF> rpittau: cut a manual one in the meantime would be my suggestion?
15:08:26 <rpittau> mmm yeah
15:08:27 <rpittau> ok
15:08:43 <JayF> I would assume release-management of virtualpdu won't be possible until after antelope is done
15:08:50 <JayF> so if we need a virtualpdu release before that; manual is the way
15:09:04 <rpittau> I'll look into that
15:09:24 <JayF> Thanks for that \o/
15:09:27 <JayF> #topic Release Countdown
15:09:38 <JayF> cycle highlights have landed
15:09:45 <JayF> probably too late to land any changes of bulk
15:10:01 <JayF> but if you have something you want in antelope, now is the time to make noise and get it reviewed
15:10:32 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/876195 release notes prelude
15:10:47 <JayF> I will revise this today and push to get it merged; if you have opinions on it post them soon :)
15:10:50 <mnasiadka> TheJulia: oslo.db==11.0.0, and yoga upper-constraints.txt says 11.2.0, yes, something is wrong :)
15:10:52 <JayF> anything else for release before I move on?
15:11:04 <JayF> #topic Open Discussion
15:11:26 <JayF> As said earlier, I will be unavailable from Weds thru Mon traveling to and participating in SCALE 20x.
15:11:29 <TheJulia> mnasiadka: so that should be xena
15:11:43 <JayF> If you need me urgently for anything, I think most of you have my email. That'll be checked much more often than IRC
15:11:51 <JayF> anything else for open discussion
15:12:02 <mnasiadka> TheJulia: sorry, mixed it up - yes, it's according to xena's u-c
15:12:16 <TheJulia> I'll also be at SCALE 20x later this week, just fyi.
15:12:34 <mnasiadka> TheJulia: what else can be wrong?
15:12:59 <TheJulia> mnasiadka: i guess step 0 is going to be open the database, ensure the column is there
15:13:14 <JayF> I'm calling it
15:13:16 <JayF> #endmeeting