15:01:06 <JayF> #startmeeting ironic
15:01:06 <opendevmeet> Meeting started Mon Jun 26 15:01:06 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:06 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:06 <opendevmeet> The meeting name has been set to 'ironic'
15:01:15 <JayF> Gooood morning Ironic'ers! Who all is here this morning?
15:01:19 <iurygregory> o/
15:01:20 <rpittau> o/
15:01:26 <matfechner> o/
15:01:54 <TheJulia> o/
15:02:02 <JayF> #topic Announcements/Reminder
15:02:20 <JayF> This is where I'd usually note to review things wiht #ironic-week-prio and to mark things as #ironic-week-prio if you want it reviewed
15:02:34 <JayF> but frankly, unit tests are a mess (to be addressed later) and we should not approve anything until they are fixes
15:02:50 <JayF> please point review love at the priority order of: unit tests; ironic-week-prio ;)
15:03:21 <JayF> There were no action items out of our 6/19 meeting, so I'm skipping that agenda item.
15:03:33 <JayF> #topic Reivew Ironic CI status
15:03:44 <JayF> you know, I put all the commenst in open discussion, but I think we can talk about this here
15:03:58 <JayF> Unit tests are broken! At least, they are until more things merge
15:04:11 <JayF> there are at least three separate things that we need to get unit tests back in good shape
15:04:17 <JayF> First: Failures when running migrations
15:04:34 <JayF> the changes we believe will fix this, and undo any attempts to mitigate the damage since it's been busted are
15:04:39 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/886985
15:04:46 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/886881
15:04:49 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/886196
15:05:03 <JayF> Second: Failures in TestNeutronVifPortMixing
15:05:22 <JayF> this one, we don't have fixed, but it's not really OK for it to fail intermittantly all the time either
15:05:31 <JayF> I proposed a change to disable it, and a bug to track re-enabling
15:05:37 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/886911
15:05:42 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2024994
15:06:11 <JayF> If you don't think this is the right approach; please comment in the bug and/or the change, I'm open to other solutions but not really Ok with us just suffering under a test that fails 5-10% of the time for any longer :D
15:06:18 <JayF> and finally
15:06:28 <JayF> Adding tests to ensure SQLA2.0 compat is not broken
15:06:38 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/885797 to fix tests under sqla 2.0
15:06:53 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/886020 adds a sqla 2.0 job (we need to rebase this once tests are fixed)
15:07:22 <JayF> #link https://review.opendev.org/c/openstack/ironic/+/886871 Fixes an SAWarning around DB schema -- I'm not sure this is really testing related, but I think it's another change we need to land to make CI fully happy
15:07:41 <JayF> Any thoughts on this? Did I miss anything? Any discussion we wanna have around this?
15:07:46 <TheJulia> to at least... remove a warning that will become an error at some point
15:08:13 <rpittau> JayF: thanks, I believe that's all, and a lot :)
15:08:15 <TheJulia> No issues, I believe the first few are already in route to CI
15:08:55 <JayF> This all just makes me wonder if there's something we can look at from a higher level to help in the future
15:09:10 <JayF> like writing something in migrations tests to ensure you never pass a SQLA object in the data dict
15:09:43 <JayF> I don't really know, but it seems obvious we need more guardrails given the age of some of the miscoded tests fixed in 886881
15:10:41 <TheJulia> It is not the most widely known aspect of sqlalchemy, fwiw
15:10:56 <JayF> and it's going to crop up more as people do sqla migrations
15:10:56 <TheJulia> so definitely not "easy"
15:11:16 <JayF> Part of me wonders if there's a guardrail to put in for oslo db
15:11:27 <JayF> to try and "save" the smaller projects from tha pain we just felt over the last two weeks
15:11:40 <TheJulia> That can be a whole debate
15:12:06 <JayF> well I might spike on having the discussion, if it gets to code then I can wail against that lol
15:12:18 <TheJulia> heh
15:12:25 <JayF> but I look at this this way: if it took us two weeks-ish, as a team that has more sqla strength than most
15:12:33 <opendevreview> Merged openstack/ironic master: Fix test_migrations with firmware information.  https://review.opendev.org/c/openstack/ironic/+/886881
15:12:34 <JayF> then a smaller project with a similar bug has very little chance
15:12:55 <JayF> but that's not an ironic problem; but I'll still try and spread the love of our lessons learned
15:13:00 <JayF> going to move on now unless there's further?
15:13:44 <TheJulia> no objection here
15:13:56 <JayF> #topic Review ongoing 2023.2 workstreams
15:13:59 <JayF> #link https://etherpad.opendev.org/p/IronicWorkstreams2023.2
15:14:22 <JayF> I've been behind on reviewing some of this stuff because I've been pointing all my brainpower at tests; going to try and correct that this week.
15:16:17 <JayF> no comments on workstreams, moving on
15:16:21 <JayF> #topic Open Discussion
15:16:26 <JayF> I have a note here on PTL availability
15:16:47 <JayF> #note JayF will be mostly unavailable upstream the week of 7/10.
15:17:09 <TheJulia> do you need someone to run the meeting that week?
15:17:12 <JayF> Can someone volunteer to run the 7/10 and also 7/17 meetings? I should be here week of 7/17 just being careful
15:17:51 <JayF> That week I'll be visiting my coworkers in the UK, so I'll be in a different timezone even if I get to point my brain at upstream :D
15:18:38 * TheJulia checks calendars
15:18:43 <iurygregory> I can't =(
15:18:52 <iurygregory> 7/10 I'm on vacation
15:19:00 <JayF> Worse case, if I put this call out next week and get some "no"s, we can cancel the meeting.
15:19:04 <iurygregory> 7/17 I'm traveling back .-.
15:19:12 <JayF> This has been the most substantive one in a while just because of the unit tests :D
15:19:20 <TheJulia> I'm available
15:19:24 <JayF> for both?
15:19:27 <TheJulia> yeah
15:19:28 <rpittau> I'm also available
15:19:41 <JayF> who wants what?
15:19:44 <TheJulia> rpittau: if you'd like to, the gavel is yours
15:19:48 <JayF> You tell me and I'll put it in an action so we can have it marked
15:19:58 <JayF> as it is voluntold, so shall it be written :P
15:20:07 <JayF> #action rpittau to run Ironic meeting 7/10 and 7/17
15:20:07 <TheJulia> hehehe
15:20:11 <TheJulia> lol
15:20:16 <TheJulia> evil man, evil :)
15:20:21 <JayF> Anything else for Open Discussion?
15:20:24 <rpittau> yay (?)
15:20:31 <TheJulia> rpittau: worst comes to worst, let lmk :)
15:20:34 <JayF> rpittau: it'll be your turn for PTL soon ;)
15:20:41 <TheJulia> heh
15:20:42 <JayF> rpittau: just embarce the gavel
15:20:43 * rpittau hides
15:20:49 * TheJulia hears evil laughter from the background
15:20:58 * TheJulia notes in our line of work, evil is good.
15:21:04 <iurygregory> ++
15:21:15 <JayF> Anything non-philosophical for the rest of open discussion? hah
15:22:04 <JayF> Aight, I think that does it then.
15:22:07 <JayF> #endmeeting