15:00:08 <JayF> #startmeeting ironic
15:00:08 <opendevmeet> Meeting started Mon Sep 18 15:00:08 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:08 <opendevmeet> The meeting name has been set to 'ironic'
15:00:13 <JayF> Welcome to the Ironic team meeting! This meeting is held under OpenInfra Code of Conduct available at: https://openinfra.dev/legal/code-of-conduct
15:00:16 <JayF> Agenda is available at https://wiki.openstack.org/wiki/Meetings/Ironic
15:00:24 <dtantsur> o/
15:00:24 <kubajj> o/
15:00:33 <iurygregory> o/
15:00:35 <JayF> #topic Announcements/Reminder
15:00:42 <JayF> #note Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:00:59 <JayF> We will be listing patches later which we want landed before release, please ensure you look and help with those, too.
15:01:11 <JayF> #note PTG will take place virtually October 23-27, 2023! https://openinfra.dev/ptg/
15:01:21 <JayF> #link https://etherpad.opendev.org/p/ironic-ptg-october-2023
15:01:51 <JayF> After release activities are complete, I'll setup a short mailing list thread and maybe sync call for us to pare down that list into items we think we should chat about, so please get your items in there.
15:02:21 <JayF> That's all our standing announcements; release is incoming but I made that a separate topic
15:02:43 <JayF> No action items outstanding; skipping agenda item.
15:02:52 <JayF> #topic Bobcat 2023.2 Release
15:03:20 <JayF> So essentially, my intention is to cut stable/2023.2 releases this week if possible. The sooner the better just because I don't want other teams waiting on us if we can help it.
15:03:41 <JayF> There are two items we've already identified as wanting to land before release:
15:03:47 <JayF> * Redfish Firmware Interface https://review.opendev.org/c/openstack/ironic/+/885425
15:03:51 <JayF> * IPA support for Service Steps https://review.opendev.org/c/openstack/ironic-python-agent/+/890864
15:03:59 <JayF> IPA Service Steps landed late Friday; so that's good news \o/
15:04:10 <JayF> Redfish firmware I believe still needs a revision from iurygregory
15:04:21 <JayF> plus the inspector-related CI shenanigans talked about before the meeting
15:04:36 <JayF> Are there any other pending changes we'd like to ensure make Bobcat?
15:04:47 <iurygregory> I'm making changes and re-testing things to make sure they are working (still trying to figure out the DB part, almost there I think)
15:05:47 <JayF> If there are no other pending changes for Bobcat; I'd like to propose that we begin to cut releases (starting with !Ironic first, to give more time), and if we cut Ironic stable/2023.2 before iurygregory's changes land, that we permit them to be backported as long as they are completed before release finalizes (even though that may mean we can't cut a release with them until
15:05:50 <JayF> a week after or so)
15:06:32 <JayF> We generally don't practice FF here, so calling it an FFE doesn't make sense; but I don't want the whole release hanging on a change when it might hold up other bits of the stack.
15:06:35 <JayF> WDYT?
15:06:58 <TheJulia> other bits of the stack?
15:07:03 <JayF> like releases team work
15:07:06 <JayF> requirements et
15:07:14 <JayF> I don't want us to hold up any of the common work that has to happen
15:07:21 <TheJulia> well, service projects don't go into requirements
15:07:47 <JayF> I don't think it's crazy of me to suggest that we have the final Ironic release done a week before the marketing-deadline for said release?
15:08:20 <TheJulia> I don't either, but it feels like your pushing for now() as opposed to in a few days
15:08:53 <JayF> TheJulia: I'm saying I'll go create PRs for stuff that's done now, and start walking down the list. We have dozens of these and I usually manually review the changes for the final release.
15:09:01 <TheJulia> we can absolutely cut the !ironic things and then cut ironic later in the week
15:09:03 <JayF> TheJulia: so I'm not just like, automating git sha readouts into yaml files
15:09:23 <JayF> I don't wanna get that process started too late, which is why I want to start now and have the freedom to do ironic e.g. Thurs or Friday
15:09:23 <TheJulia> I understand that
15:09:49 <JayF> less now() and more max(week)
15:09:51 <TheJulia> so what is the big deal then? lets do the needful and enable
15:10:07 <TheJulia> I'd say EOD Wednesday
15:10:14 <TheJulia> because release team won't push button on friday
15:10:30 <JayF> ++ that sounds pretty much exactly like what I had in mind
15:10:34 <JayF> wnated it done before Friday-europe
15:10:44 <TheJulia> for Ironic unless we have full certinty that we can solve it early thursday morning before release team disappears
15:10:57 <JayF> ++
15:11:32 <JayF> #agreed Ironic projects will begin having stable/2023.2 releases cut. Projects with pending changes (Ironic + Inspector) have at least until Wednesday EOD to land them.
15:12:05 <JayF> Anything else related to 2023.2 release?
15:13:05 <JayF> #topic Review Ironic CI Status
15:13:18 <JayF> AFAICT, things look stable-ish. Just have that POST-FAILURE for Inspector grenade to figure out.
15:14:34 <dtantsur> I think the POSTFAILURE itself is less of a problem
15:14:58 <JayF> Yeah, the breakage is earlier/in our code which is different than a postfailure usually indicates
15:15:11 <JayF> but either way it's the only outstanding CI issue I'm aware of
15:15:52 <TheJulia> yeah, read timeouts against the api surface
15:15:59 <TheJulia> could entirely be environmental
15:16:10 <TheJulia> we just need more logs to confirm that or not
15:16:20 <JayF> we'll figure it out, if there's nothing else I'll move on so I can get back to helping with that :D
15:16:36 <JayF> #topic Branch Retirement to resolve zuul-config-errors
15:16:51 <JayF> I'm going to execute on this, probably today if inspector CI doesn't eat the day -> https://lists.openstack.org/pipermail/openstack-discuss/2023-August/034854.html
15:16:54 <JayF> take notice
15:17:23 <JayF> #topic RFE Review
15:17:38 <JayF> There was an RFE spotted earlier this week, Julia and I discussed in channel, I already tagged it as approved
15:17:44 <JayF> posting here for documentation/awareness
15:17:50 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2034953 -- adding two fields to local_link_connection schema to allow physical switch integrations with OVS
15:18:16 <TheJulia> hjensas: you might find ^ interesting
15:18:18 <JayF> Basically it seems adding two fields to our local_link_connection gets us the win of supporting OVN-native switches
15:18:27 <JayF> which is a wonderful effort:value ratio
15:19:23 <dtantsur> Indeed. How popular are these?
15:19:42 <JayF> I learned they exist when I read bug 2034953 ;)
15:19:48 <dtantsur> Same :D
15:20:00 <JayF> two fields to get free support for something from neutron sounds great though
15:20:09 <JayF> and is the exact kind of good stuff we get from being stacked sometimes :D
15:20:21 <TheJulia> I don't know... There was some OVS enabled for OpenFlow switches years ago, whitebox sort of gear AIUI, I'm guessing this might just be an evolution
15:21:06 <JayF> I don't hear any objection; so I'm going to consider this one to remain approved. Probably a low-hanging fruit for someone to knock out (I have an MLH fellow starting in a couple of weeks, if we want to save this I can use it as an onboarding task)
15:21:35 <JayF> #topic Open Discussion
15:21:39 <JayF> Agenda is done; anything else
15:23:11 <JayF> Last chance?
15:23:47 <JayF> #endmeeting