15:02:14 <JayF> #startmeeting ironic
15:02:14 <opendevmeet> Meeting started Mon Oct  9 15:02:14 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:14 <opendevmeet> The meeting name has been set to 'ironic'
15:02:21 <rpittau> o/
15:02:22 <TheJulia> o/
15:02:22 <JayF> #topic Announcements/Reminder
15:02:23 <iurygregory> o/
15:02:30 <JayF> #info Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:02:47 <JayF> #topic Action items from previous meeting
15:02:51 <JayF> I was going to release a new NGS
15:02:58 <JayF> I tried to; the changes in stable/2023.2 hadn't landed
15:03:12 <JayF> and I got pushback from release team for trying to do a feature-version-bump
15:03:32 <dtantsur> o/
15:03:52 <JayF> IMO: it's too late in the cycle to backport those features to NGS
15:04:10 <TheJulia> I thought we agreed like everything waiting for ngs was basically bug fixes
15:04:15 <TheJulia> or was there more?
15:04:15 <JayF> but is there anyone invested in getting that done? Otherwise I'll ensure the bugfix patch (I think there's one?) is backported and released
15:04:28 <JayF> there was absolutely stuff I don't feel belongs in a bugfix release bump
15:04:35 <JayF> let me get it up\
15:04:51 <TheJulia> okay, we would need to take a look at it, we can sift through it later, meeting now :)
15:04:55 <JayF> #link https://review.opendev.org/q/project:openstack/networking-generic-switch+branch:stable/2023.2+status:open
15:05:01 <JayF> wanted to get the link into the log :)
15:05:14 <JayF> I think the honor ngs_save was what I was thinking was a bugfix
15:05:20 <JayF> the fake one is whatever
15:05:28 <JayF> the last one is the one I think is a bit scary to backport
15:05:34 <TheJulia> first and last looks like bug fixes
15:05:50 <TheJulia> I could go along with that
15:05:57 <JayF> ack; I'll take that action
15:06:16 <JayF> #action JayF to backport honor ngs_save fix to stable/2023.2, cut a x.y.N+1 release of NGS
15:06:18 <JayF> cool
15:06:24 <JayF> #topic Bobcat Release
15:06:27 <JayF> We had one. Thank you!
15:06:45 <JayF> also TheJulia wrote a nice blog about service steps, you should read it
15:07:03 <JayF> I recognized it because I was going to write a nice blog about service steps but she stole her own thunder before I could ;)
15:07:15 <TheJulia> blame diablo_rojo
15:07:17 <JayF> I don't think there's anything meaty to discuss here?
15:07:39 <JayF> #topic  [rpittau] Pillow/blockdiag/seqdiag issue
15:07:42 <JayF> #link
15:07:45 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2026345
15:07:51 <JayF> #link https://review.opendev.org/c/openstack/requirements/+/897537
15:08:11 <rpittau> in short blockdiag has been discontinued since a while
15:08:25 <JayF> Looks like we have an old/breaking library in our requirements. Someone invested in our state diagram should migrate it to graphwiz or similar.
15:08:27 <rpittau> nad the recent Pillow update broke compatibility
15:08:42 <TheJulia> the state machine diagram?
15:08:44 <rpittau> I've added the topic to the PTG section of documentation
15:09:02 <JayF> I assumed this https://docs.openstack.org/ironic/latest/user/states.html was the use of blockdiag
15:09:07 <JayF> is that a bad assumption?
15:09:24 <rpittau> there are multiple entries of seqdiag that need to be migrated
15:09:26 <JayF> service is not reflected in there either, I guess
15:09:27 <TheJulia> dunno, but took a look a while back and the rendering library was also sort of last updated on python2
15:09:35 <TheJulia> so we might just need to find a new tool to render it
15:09:46 <rpittau> my proposal is to move to PlantUML which is based on graphviz
15:10:00 <JayF> I'm happy to accept whatever the community or the person doing the work wants to use :D
15:10:07 <TheJulia> ++
15:10:09 <rpittau> #link https://plantuml.com/
15:10:34 <JayF> Will you have time to address this issue rpittau or is there another volunteer who might take this action?
15:10:39 <rpittau> converting directly to grpahviz is a pain
15:10:49 <rpittau> JayF: not before PTG
15:11:01 <rpittau> but we're ok until next cycle anyway
15:11:50 <JayF> I would prefer Ironic not be the long pole in any of those requirements updates generally; but that timeline is OK in any event.
15:12:06 <JayF> rpittau: how about 11/6 for a check-in date on that?
15:12:10 <JayF> just to make sure we don't drop it?
15:12:17 <rpittau> sounds good
15:12:36 <JayF> #action rpittau to tackle bug 2026345; remove our dep on blockdiag - check in 11/6
15:12:45 <JayF> I'm going to basically just carry these over during action item windows each meeting
15:12:55 <JayF> I'm doing a similar pattern in TC, it's nice to have >1 week timelines on things but still have them checked
15:13:05 <JayF> at least for how my brain works :D if it's not useful for you please bear with me
15:13:16 <JayF> moving on
15:13:19 <JayF> #topic PTG Planning for PTG October 23-27, 2023
15:13:30 <JayF> I'm going to be taking the topics from
15:13:32 <JayF> #link https://etherpad.opendev.org/p/ironic-ptg-october-2023
15:13:40 <JayF> and assigning them specific times during the windows already reserved
15:13:57 <JayF> if you have input or requested time windows for items, or work items not listed yet, go, edit, now :D
15:14:12 <JayF> I'm also happy to spin up a video chat and go over the scheduling sync if anyone wants to toil with me :D
15:14:19 <JayF> anything else on PTG?
15:15:42 <JayF> moving on
15:15:44 <JayF> #topic Review Ironic CI status & update whiteboard if needed
15:16:04 <JayF> I've honestly not looked at a lot of Ironic changes in the last week, I've been pretty busy -- is there anything notable going on gate-wise?
15:16:44 <TheJulia> I spent a while on backports/fixes on friday
15:16:59 <TheJulia> Things looked like they were in a better shape by Friday afternoon, so hopefully things are happy today
15:17:01 * TheJulia hopes
15:17:07 <JayF> nice; thank you for that
15:17:21 <JayF> moving on?
15:17:27 <JayF> no RFEs to review; skipping item
15:17:37 <JayF> #topic Open Discussion
15:17:42 <JayF> Floor is open
15:18:22 <TheJulia> I'd <3 getting eyes on the patch to switch a job or two over to using OVN for DHCPv4
15:18:30 <JayF> you wanna #link it?
15:18:41 <JayF> I think I have an old review on it, I can renew that review
15:18:48 <TheJulia> #link https://review.opendev.org/c/openstack/ironic/+/885087
15:18:48 <JayF> we should get that job started sooner rather than later
15:19:16 <iurygregory> I will add to my list
15:19:24 <TheJulia> Once v6 support lands in neutron, I'm suspect harald will want to switch the v6 job over
15:19:50 <TheJulia> I think he has a patch, but we're  the v6 change in neutron is still in review
15:20:42 <JayF> I think how OVS vs OVN interacts with Ironic would be a good topic
15:20:54 <JayF> for a blog or tech talk or brown bag or whatever cliche "way to learn things" you wanna pick lol
15:21:41 <TheJulia> for us, it is not much different, and I'm afraid it could also turn into "Ugh OVN"
15:21:57 <TheJulia> but not bad to spread awareness
15:22:12 <JayF> hearing 'for us it's not that different' while reading a big patch about the differences (at least in CI) is strange to hear :D
15:22:33 <TheJulia> it is devstack setup for the differences for our virtual testing
15:22:58 <TheJulia> because of different way OVN works. From an operator point of view, it is very similar
15:23:51 <JayF> With my ops-y hat on (which is getting old and tattered and may not fit well anymore); I am just thinking "this is new/different services in my env, which pass data differently, which I need to know what to look for and where to look for it"
15:24:36 <JayF> either way; just a suggestion
15:24:44 <JayF> I +2'd the OVN patch.
15:24:55 <JayF> We're still in open discussion; someone wanna add another thing?
15:25:21 <TheJulia> The set power state thing with nodes is a nice issue, fwiw :)
15:25:26 <TheJulia> with parent_nodes
15:25:34 <TheJulia> if the parent node task is held...
15:25:44 <JayF> I'm not sure what you're talking about without contxt?
15:25:59 <TheJulia> eh, you can't pull a lock on a task off another task off another task in our model
15:26:20 <TheJulia> so you can't say, if parent node has a task to run things on a child node, you can't pull a parent node task again to say "turn the power on"
15:26:32 <TheJulia> just a fun practicality
15:26:56 <JayF> ah, yeah
15:27:21 <JayF> locking is hard.
15:27:35 <TheJulia> Yeah, and there is a practicality we likely need to document
15:27:35 <JayF> "Don't let two things touch this unless the second thing is me in a mustache"
15:27:39 * TheJulia makes a mental todo to do that
15:27:56 <JayF> Think I'm going to close up the meeting? We seem done?
15:28:17 <TheJulia> seems so, you want people willing to discuss the ptg etherpad?
15:28:21 <JayF> #endmeeting