15:00:12 <JayF> #startmeeting ironic
15:00:12 <opendevmeet> Meeting started Mon Nov  6 15:00:12 2023 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:12 <opendevmeet> The meeting name has been set to 'ironic'
15:00:18 <JayF> #topic Announcements/Reminder
15:00:25 <JayF> #info      Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:00:33 <iurygregory> o/
15:00:35 <JayF> #topic Review action items
15:00:50 <TheJulia> o/
15:00:52 <JayF> Oh wow I had a ton, I did some of these, lets go thru em
15:01:07 <TheJulia> I can likely run the 20th
15:01:14 <JayF> #info JayF [from PTG] Merge something to metalsmith readme/release notes to announce it is going into maintenance mode before it's next release
15:01:53 <rpittau> o/
15:02:02 <JayF> #link https://review.opendev.org/c/openstack/metalsmith/+/899761
15:02:07 <JayF> That is complete, pending review of that change
15:02:14 <JayF> > JayF [from PTG] Submit something to contributor docs, drafting a bug deputy role which triages bugs, checks periodic job status, and runs a bug jam meeting
15:02:18 <JayF> this is carrying over
15:02:20 <JayF> #action JayF [from PTG] Submit something to contributor docs, drafting a bug deputy role which triages bugs, checks periodic job status, and runs a bug jam meeting
15:02:26 <JayF> this is carrying over
15:02:48 <JayF> #action JayF [from PTG] Setup IPA-builder in launchpad (just follow normal lp instructions, add to openstack group)
15:03:15 <JayF> masghar: had an action item to provide feedback about specific gaps in documentation, I've had a google doc shared, ty for that
15:04:07 <JayF> #info Completed:  JayF [from PTG] email list about IntelIPMIManagement driver usage
15:04:48 <JayF> I had put down JayF [from PTG] Update any written vendor driver policy to indicate it's about coordination/communication, not as much 3rd party CI now as well
15:04:56 <JayF> but I can't find any real written policy about this anywhere
15:05:03 <JayF> does anyone know where it might be, if it's documented?
15:05:10 <JayF> google+our docs don't always get along well
15:05:18 <JayF> I also need to carry over
15:05:27 <JayF> #action JayF Book a meeting with stakeholders; TheJulia JayF and johnthetubaguy minimum, on Nova driver bug fixing/hunting
15:05:29 <TheJulia> Last revision to the policy, I think was a spec change done by dtantsur
15:05:48 <JayF> ack, was not looking in spec repo at all for that, makes sense
15:05:55 <JayF> if it's just a spec "no action" might be the right action
15:06:05 <JayF> I'll find it and see.
15:06:26 <JayF> Either way, my todo list is slightly shorter :) I am going to be knocking this stuff more further out this week, including finishing the workstreams doc.
15:06:30 <JayF> That's all the action items.
15:06:48 <JayF> #topic Caracal Release Schedule
15:07:00 <JayF> #info Next Mulestone is at R-20, Caracal-1, on November 10th
15:07:09 <JayF> I'll note this is ususally when we'd cut the first bugfix release, if we wanted one
15:07:37 <rpittau> next bugfix should be in january
15:08:12 <JayF> if we look at doing them every 2 months, C-1 would be the first two months of this cycle, yeah?
15:08:35 <JayF> Jan 08 is C-2, which would be the potential second
15:08:57 <JayF> #link https://releases.openstack.org/caracal/schedule.html
15:09:52 <JayF> I don't consume these, I don't have strong feelings about it
15:09:56 <TheJulia> Mulestone? milestone?
15:10:14 <JayF> but just pointing out we usually align those bugfix releases with with {N}-1 or {N}-2 milestones
15:10:17 <TheJulia> I am semi-opposed to imposition of community wide milestones into our process and thinking
15:10:39 <JayF> Consider it less an imposition, and more just a convienient calendar with "1/3" marks for the 6 month cycle on it
15:11:00 <TheJulia> Okay
15:11:09 <JayF> that's literally all I'm thinking about it in context of this discussion
15:11:38 <JayF> either way, there's the schedule, if you want to cut a bugfix, do it, if you don't *shrug* :D
15:11:48 <TheJulia> That works then, just language wise inside of ironic it has less of a thing we've focused on common language wise
15:12:03 <rpittau> JayF: we could cut one in december actually now that I see the dates
15:12:22 <rpittau> stable one was mid october, right?
15:12:34 <JayF> no, late sept
15:12:56 <rpittau> ok, then I will definitely cut one at the beginning of december
15:13:15 <rpittau> I've updated the etherpad
15:13:16 <JayF> rpittau: like I said, I won't use it, I don't think anyone but RH consumes it, so it's up to you all when/how you use them, we doc we cut up to 2, at the 2/4 month marks of the cycle
15:13:27 <JayF> all I care is that the doc is close enough to right :D
15:13:34 <JayF> lol
15:13:36 <JayF> going to move on
15:13:38 <rpittau> JayF: we'll start consuming bugfix branches in metal3 :)
15:14:02 <JayF> I'm not sure I would've advised that course of action, but okay :)
15:14:06 <JayF> #topic PTG Review
15:14:14 <JayF> #info      Please review discussion and action items from: https://etherpad.opendev.org/p/ironic-ptg-october-2023
15:14:25 <JayF> I should have time to finish workstream docs this week.
15:14:58 <rpittau> JayF: discussion is still open if you want to add a comment about that https://github.com/metal3-io/ironic-image/pull/435
15:14:58 <JayF> If you have input please put it on the review here:
15:15:01 <JayF> #link https://review.opendev.org/c/openstack/ironic-specs/+/899297
15:15:28 <JayF> rpittau: ack, I will, thank you.
15:15:37 <JayF> rpittau: at a minimum, no grenade
15:15:55 <JayF> I think we can end the meeting if we go fast and I can go actually review it though :D
15:15:55 <rpittau> ack
15:16:01 <JayF> #topic Review Ironic CI Stauts
15:16:05 <JayF> #undo
15:16:05 <opendevmeet> Removing item from minutes: #topic Review Ironic CI Stauts
15:16:07 <JayF> #topic Review Ironic CI Status
15:16:12 <JayF> how ar things?
15:16:48 <rpittau> I dare to say stable
15:17:02 <JayF> it feels like just not a lot of traffic moreso than stable? lol
15:17:17 <rpittau> well, some traffic, more than during PTG :)
15:17:28 <JayF> well, lets hope we didn't jinx it :)
15:17:34 <JayF> no RFEs for review, skipping agenda item
15:17:38 <JayF> #topic Open Discussion
15:17:41 <JayF> Anything else?
15:18:39 <TheJulia> This past week was super quiet
15:18:57 <TheJulia> Which is both good and bad, since now is the time to make the most progress before end of year
15:21:13 <JayF> yeah, except thanksgiving week, now thru end of year is my time to get the most stuff done
15:21:23 <JayF> speaking of, going to close this meeting and try to do just that
15:21:26 <JayF> thanks all o/
15:21:28 <JayF> #endmeeting