15:02:00 <dtantsur> #startmeeting ironic
15:02:00 <opendevmeet> Meeting started Mon Nov 20 15:02:00 2023 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:00 <opendevmeet> The meeting name has been set to 'ironic'
15:02:04 <dtantsur> #chair TheJulia
15:02:04 <opendevmeet> Current chairs: TheJulia dtantsur
15:02:08 <TheJulia> o/
15:02:09 <iurygregory> o/
15:02:15 <dtantsur> TheJulia: wanna take it from here?
15:02:16 <TheJulia> sorry, slightly distracted this morning
15:02:17 <TheJulia> sure
15:02:40 <TheJulia> #topic Announcements / Reminders
15:03:01 <dtantsur> #info https://github.com/dtantsur/ironic-bug-dashboard is revived and can be used for triaging (run locally)
15:03:03 <TheJulia> A standing reminder to review patches tagged with ironic-week-prio. The dashboard will be linked shortly.
15:03:18 <TheJulia> #link https://tinyurl.com/ironic-weekly-prio-dash
15:03:34 <TheJulia> Does anyone else have anything to announce or remind us of?
15:03:53 <dtantsur> We need to add a section for bug triaging, don't we?
15:03:57 <TheJulia> It appears we don't have any action items
15:04:22 <iurygregory> dtantsur, ++
15:04:45 <TheJulia> Has the policy proposal change merged?
15:04:58 <dtantsur> I don't believe so (if you mean re bugs)
15:05:17 <dtantsur> #link https://review.opendev.org/c/openstack/ironic/+/900449 Bug deputy proposal
15:05:35 <dtantsur> But I was a deputy nonetheless and ready to provide an update :)
15:05:45 <TheJulia> okay, fair! :)
15:06:11 <dtantsur> #topic Bug deputy update
15:06:26 <dtantsur> First, as I've mentioned already, the bug dashboard is functional again
15:06:42 <dtantsur> We don't have a place to host it yet, but it can be trivially run locally either with `tox -erun` or with the provided Dockerfile
15:06:55 <dtantsur> #link https://github.com/dtantsur/ironic-bug-dashboard bug dashboard
15:07:22 <dtantsur> Second, I've done a major bug clean up:
15:07:31 <dtantsur> Ironic: 184 bugs (-31) + 189 wishlist items (+9). 29 new (-29), 96 in progress (-19), 3 critical (-1), 23 high (+2) and 13 incomplete (+1)
15:07:33 <dtantsur> Nova bugs with Ironic tag: 23. 0 new, 0 critical, 1 high
15:07:57 <dtantsur> A lot of bugs got stuck in the open state despite being merged, probably because of the transition to storyboard back then
15:08:07 <dtantsur> I don't think I've cleaned up everything, but I made some progress
15:08:14 <dtantsur> Third, and this is a reminder:
15:08:35 <dtantsur> #info Please triage your bugs if you're a constant member of the team. This includes setting status to Triaged, setting priority and updating tags.
15:09:03 <dtantsur> Forth, we have virtualpdu on our radar, but nobody here has ACL for its bugs.
15:09:13 <dtantsur> rpittau: was it you show worked on the virtualpdu ownership the last time?
15:09:19 <dtantsur> s/show/who/
15:09:51 <TheJulia> I believe it was rpittau
15:09:51 <rpittau> o/
15:10:08 <rpittau> yes
15:10:11 <rpittau> it was me
15:10:23 <dtantsur> rpittau: can you ping your contacts again re launchpad ownership?
15:10:47 <rpittau> of course!
15:11:08 <dtantsur> #action rpittau to ask to change the launchpad ownership for virtualpdu to us
15:11:22 <dtantsur> Last but not least, does anyone want to be the bug deputy this week?
15:12:13 <TheJulia> My schedule is moderately crazy this week and I've got a long weekend
15:12:20 <dtantsur> The crickets tell me that it's on me again :)
15:12:22 <TheJulia> I likely can next week
15:12:34 <iurygregory> I can give a try dtantsur
15:12:39 <dtantsur> nice!
15:12:51 <iurygregory> if i have questions I will ping you =P
15:13:00 <dtantsur> iurygregory: something I never got to: check the storyboard for things that we might want transfered
15:13:05 <dtantsur> and yes, never hesitate to ping me
15:13:17 <dtantsur> #action iurygregory is the bug deputy this week (and TheJulia potentially next time)
15:13:21 <iurygregory> ack
15:13:39 <TheJulia> Onward?
15:13:46 <dtantsur> Unless there are questions for me already
15:13:47 <iurygregory> yes
15:13:57 <TheJulia> #topic Caracal release schedule
15:14:02 <TheJulia> #link https://releases.openstack.org/caracal/schedule.html
15:14:18 <TheJulia> Last week was Caracal-1. Caracal-2 is the week of January 8th.
15:14:30 <TheJulia> #topic Review Ironic CI status & update whiteboard if needed
15:14:34 <dtantsur> Hmm, is it about the time we make our intermediary release?
15:14:56 <TheJulia> I suspect it was last week or is around now
15:15:08 <TheJulia> that being said we had the metal3-integration job broken last week.
15:15:13 <rpittau> I'm going for a bugfix release next week
15:15:20 <TheJulia> rpittau: ack, thanks
15:15:29 <dtantsur> Bobcat was Oct 02, so we should aim for around Dec 02, I assume?
15:15:57 <TheJulia> What is the word on the metal3-integration CI job?
15:15:59 <rpittau> dtantsur: yeah, I'll propose beginning next week, and should merge by the end of the week
15:16:00 <dtantsur> but yeah, next week will make the math somewhat better down the road
15:16:05 <rpittau> TheJulia: it's fixed
15:16:23 <TheJulia> cool, so we should be in a better place this week. That was the only issue I was aware of last week.
15:16:50 <TheJulia> Onward?
15:16:55 <dtantsur> ++
15:16:58 <rpittau> go!
15:17:08 <TheJulia> #topic Bug Deputy role proposal
15:17:18 <TheJulia> #link https://review.opendev.org/c/openstack/ironic/+/900449
15:17:27 <TheJulia> The document is still outstanding, please review this week.
15:18:02 <TheJulia> I've rechecked it to hopefully clear the -1 on it
15:18:33 <TheJulia> Since we have no RFEs to review, we shall proceed to Open Discussion if there is no further discussion ?
15:19:16 <dtantsur> ++
15:19:24 <TheJulia> #topic Open Discussion
15:19:38 <TheJulia> so, httpboot is looking good, grub just acts weird though
15:19:59 <dtantsur> stop giving catnip to your grub!
15:20:01 <dtantsur> (sorry)
15:20:04 <TheJulia> lol
15:20:12 <iurygregory> not first time grub acts weird lol
15:20:23 <TheJulia> well, I pinged some maintainers, got asked questions which I had already tried to answer
15:20:24 <dtantsur> absolutely unheard of!
15:20:34 <dtantsur> anything we can help with?
15:20:41 <TheJulia> and then opened the code, looks like it is edk2 or substrate networking
15:20:49 <TheJulia> so it might be okay, I think I'll try to polish the patches
15:21:21 <TheJulia> I just need to get the redfish sushy and sushy-tools changes merged since I'll need to update requirements.txt
15:21:47 <dtantsur> links?
15:21:50 <TheJulia> sure
15:22:05 <iurygregory> I will try to review them this week
15:22:21 <TheJulia> https://review.opendev.org/c/openstack/sushy-tools/+/901208 <-- this really fixes the prior change
15:22:37 <TheJulia> #link https://review.opendev.org/c/openstack/sushy/+/718276
15:23:05 <TheJulia> Once I can get the base ironic change updated with a released sushy-tools, the jobs will go green
15:23:11 <dtantsur> nice
15:23:42 <TheJulia> I did deviate a little from the spec on the redfish and dhcp driven network booting paths, but nothing horrible
15:24:00 <TheJulia> and ultimately gives us the ability to still sort of do the ipxe logic dance for those who really want openstack integrated ipxe
15:24:37 <TheJulia> I'll keep sorting out grub, it does the needful though, it is something in grub where we might just want to document the substrate is there, it sort of works, but we've seen some issues which are expected to be unrelated
15:25:09 * dtantsur is a bit worried by the amount of "sort of" :)
15:25:27 <TheJulia> Well, it loads shim, shim chains to grub
15:25:39 <TheJulia> and then grub sort of falls down on step 5 of packet processing semi-randomly
15:25:47 <TheJulia> which leverages the http logic handler from UEFI
15:25:49 <TheJulia> so......
15:26:11 <TheJulia> ¯\_(ツ)_/¯
15:26:29 <dtantsur> fun
15:26:46 <TheJulia> Yeah, it doesn't block us from merging an interface, but it blocks us from having verbose "it works!" docs
15:27:11 <rpittau> "it sort of works" :)
15:27:16 <TheJulia> the underlying code is all identical though, so high confidence if whatever ubuntu's grub is doing can be sorted out
15:27:25 <dtantsur> make a good sacrifice to the bootloader gods
15:27:27 <TheJulia> "It sort of works, go complain to your vendor if it doesn't"
15:27:31 <rpittau> lol
15:27:46 <dtantsur> TheJulia: can we try with another distro?
15:27:48 <TheJulia> I believe the bootloader gods are the elder gods
15:28:13 <TheJulia> dtantsur: I can, the CI changes themselves are way down the series of changes
15:28:42 <TheJulia> I'm also tempted to write a new "exercise all available boot interfaces" tempest job so we can do it in one-shot versus scenario test after scenario test
15:28:43 <dtantsur> What I"m curious about is whether this a fundamental grub problem or just something in the ubuntu build
15:29:08 <TheJulia> dtantsur: I'm honestly suspecting environmental grub + environment + ed2k
15:29:13 <TheJulia> err, edk2
15:29:53 <TheJulia> Next up, Cthulhu will appear to discuss grub
15:30:59 <rpittau> non-euclidean geometry is our last chance
15:31:19 <TheJulia> will this permit us to fold space and time, finally?
15:31:31 <TheJulia> ... it is clear, the meeting is over, we've folded it away.
15:31:36 <dtantsur> \o/
15:31:39 <TheJulia> Anything else folks before I wrap up today's meeting?
15:31:44 <rpittau> one small thing
15:32:32 <TheJulia> yes?
15:32:33 <rpittau> the api for attach detach virtual media patch has got its  first +2 https://review.opendev.org/c/openstack/ironic/+/894918
15:32:41 <TheJulia> \o.
15:33:12 <rpittau> we're a bit in a rush with  that, if anyone has a moment for a review would be great :)
15:33:43 <rpittau> that's all, thanks!
15:35:14 <TheJulia> Thanks
15:35:28 <TheJulia> Hopefully we can do the next release with some httpboot stuffs :)
15:35:32 <TheJulia> (that would be epic)
15:35:53 <dtantsur> True
15:36:40 <TheJulia> Well, if there is nothing else, it seems we have code review to do
15:37:46 <TheJulia> Thanks everyone, have a wonderful week
15:37:56 <TheJulia> Oh, one last thing
15:38:12 <TheJulia> Anyone want to run the meeting next week?
15:38:33 <dtantsur> won't Jay be back?
15:38:46 <TheJulia> He will be, but doesn't mean we can't volunteer someone so he doesn't have to worry about it
15:38:59 <rpittau> I can run it
15:39:19 <TheJulia> ack, thanks. due to daylight savings time, it is a bit early for him too
15:39:24 <TheJulia> Anyhow, thanks everyone!
15:39:26 <TheJulia> #endmeeting