15:00:10 <rpittau> #startmeeting ironic
15:00:10 <opendevmeet> Meeting started Mon Apr 29 15:00:10 2024 UTC and is due to finish in 60 minutes.  The chair is rpittau. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:10 <opendevmeet> The meeting name has been set to 'ironic'
15:00:18 <JayF> o/
15:00:25 <rpittau> hello everyone and welcome to our weekly meeting!
15:00:31 <dtantsur> o/
15:00:32 <masghar> o/
15:00:37 <TheJulia> o/
15:01:30 <rpittau> the meeting agenda for this week can be found here https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_April_29.2C_2024
15:01:39 <rpittau> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_April_29.2C_2024
15:01:58 <rpittau> #topic Announcements / Reminders
15:02:10 <rpittau> #info Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio
15:02:16 <rpittau> #link https://tinyurl.com/ironic-weekly-prio-dash
15:02:48 <rpittau> #info PTG 2024.2 topics and discussions etherpad is still available
15:02:48 <rpittau> #link https://etherpad.opendev.org/p/ironic-ptg-april-2024
15:03:14 <rpittau> #info work items for 2024.2 are ready for review
15:03:14 <rpittau> #link https://review.opendev.org/c/openstack/ironic-specs/+/916295
15:04:21 <rpittau> #info ironic meetup/baremetal sig at CERN on June 5 and openinfra days on june 6
15:04:21 <rpittau> #link https://indico.cern.ch/event/1378171/
15:04:21 <rpittau> #link https://indico.cern.ch/event/1376907/
15:04:43 <TheJulia> We likely need to discuss work items
15:05:21 <rpittau> TheJulia: yes, do you want to do it now? I can continue with the announcements afterwards
15:05:35 <TheJulia> We can do it when your ready
15:05:48 <TheJulia> in other words, after annoucmeents?
15:05:54 <rpittau> perfect
15:06:20 <rpittau> #info 2024.2 release schedule is available
15:06:20 <rpittau> #link https://releases.openstack.org/dalmatian/schedule.html
15:06:38 <rpittau> #info final zed release for ironic projects is under review
15:06:38 <rpittau> #link https://review.opendev.org/c/openstack/releases/+/916487
15:07:18 <rpittau> #topic Ironic CI status
15:07:18 <rpittau> it was stable last week so I guess we can move to discussion
15:07:40 <Sandzwerg[m]> o/
15:07:43 <rpittau> #topic Discussion
15:07:50 <TheJulia> cool, cool!
15:07:56 <rpittau> so about those work items :)
15:08:16 <TheJulia> So, I suspect we're not going to make progress on the virtual media push stuffs, so I guess I'm worried about it being on there
15:08:43 <rpittau> I think we have a lot of stuff already, more than last cycle, so removing that won't be a problem
15:09:02 <TheJulia> I suspect it is *far* more a "we need to monitor this" item
15:09:21 <TheJulia> so maybe just changing the text to reflect that might be an option as well
15:09:57 <rpittau> ok, I can work around that
15:10:54 <rpittau> #action reword the media push stuff in the work items
15:11:24 <TheJulia> Unrelated, On Friday project mercury was floated to the neutron folks in terms of awareness. No table flipping, and the neutron folks were rather receptive to the idea
15:11:27 <rpittau> (FYI my connection is very unstable at the moment)
15:11:51 <rpittau> TheJulia: well that sounds like a great news :)
15:12:50 <TheJulia> If we can get some reviews inside of ironic, I think that would be good at a high level, but I suspect the next step is likely someone goes off with a bottle of whiskey and returns with a service
15:13:06 <TheJulia> or multiple people go off :)
15:13:09 <rpittau> lol
15:13:27 <dtantsur> yeah, that's the most actionable plan
15:13:52 <rpittau> I agree, that sounds like a good way forward at the moment
15:15:27 <rpittau> anything else on the work items or related to them?
15:15:31 <TheJulia> I suspect we might need to marshall some n-g-s reviews as well, I highly suspect a side effect of all of this might end up us doing some refactoring on NGS
15:15:55 <TheJulia> but, none of that is pressing
15:15:58 <rpittau> we'll take that into account
15:18:02 <rpittau> would be nice to have the work items merged before the end of this week, I'll update them after the meeting, please review them when you get the chance, thanks!
15:18:20 <TheJulia> ++
15:18:34 <rpittau> moving forward?
15:18:40 <JayF> rpittau: I'd suggest also like, just set a time and land it
15:18:49 <JayF> rpittau: we can fix any further disagreements in follow-ups if needed
15:18:56 <JayF> but having a doc landed that's 95% good is better than no doc imo
15:19:01 <rpittau> JayF: oh ok, sounds good to me
15:19:59 <rpittau> then let's land it this week unless there's some big disagreement
15:19:59 <rpittau> we'll fix the rest later
15:21:11 <rpittau> onward!
15:21:43 <rpittau> #topic Bug Deputy Updates
15:21:43 <rpittau> no updates, very quiet week
15:22:05 <rpittau> we'll need a volunteer for this week :)
15:23:12 <JayF> I will lose the game of chicken this week ;)
15:23:14 <TheJulia> I can give it a spin this week
15:23:22 <rpittau> :D
15:23:25 <JayF> lol
15:23:29 <TheJulia> jinx?
15:23:39 <JayF> our internal "screw it, I'll volunteer" timers are synced :D
15:23:42 <JayF> you take it TheJulia
15:23:45 <JayF> and I'll get next week
15:23:48 <rpittau> #info bug deputy for week of 29/04: TheJulia
15:23:51 <TheJulia> cool cool
15:23:56 <rpittau> thanks!
15:24:21 <rpittau> #topic RFE reviews
15:24:31 <rpittau> we have 2 RFEs from JayF
15:25:26 <JayF> Basically one is a tracking "RFE" for getting rid of eventlet in IPA
15:25:34 <rpittau> #link https://bugs.launchpad.net/ironic-python-agent/+bug/2062954
15:25:38 <JayF> the full route isn't laid out perfectly yet, but we know good things we can do in the proper direction
15:25:52 <JayF> and doing those things will hopefully feedback into the future decisions
15:25:59 <TheJulia> Maybe further discussion, but we might want to go discuss the eventlet wsgi discussion on the mailing list
15:26:19 <dtantsur> There is some weird stuff in the end of the description that made me go OHNONONONO
15:26:26 <dtantsur> but the idea is reasonable, let's just not overdesign it :)
15:26:35 <TheJulia> dtantsur: +10000000
15:26:40 <JayF> dtantsur: well basically, there are three steps; and step 1/2 are obvious and step 3 (what you starting screaming about) is the fuzzy bit
15:26:56 <opendevreview> Merged openstack/ironic master: Replace glanceclient usage with openstacksdk  https://review.opendev.org/c/openstack/ironic/+/916701
15:26:58 <opendevreview> Verification of a change to openstack/ironic master failed: Replace cinderclient usage with openstacksdk  https://review.opendev.org/c/openstack/ironic/+/900265
15:27:32 <JayF> so I'm looking for just folks to be aware and onboard with this happening, even if we haven't nailed down the last technical bits yet
15:27:42 <JayF> getting there/real prototyping >>> more discussion at this point IMO
15:28:18 <TheJulia> Yeah, I'm definitely thinking some of this just requires exploration to discover the path, and as such we should just enable exploration
15:28:43 <JayF> I put it down as an RFE and in this section just so people would see and think about it :D
15:28:55 <TheJulia> cool cool
15:29:18 <TheJulia> please don't cause the universe to raise an exception :)
15:30:18 <JayF> So the other bit, is an RFE related to the work I've already discussed at length around getting nova instance metadata posted into instance_info, and using it for [conductor]automatic_lessee
15:30:20 <TheJulia> so next rfe?
15:30:33 <rpittau> #link https://bugs.launchpad.net/ironic/+bug/2063352
15:30:40 <JayF> I wrote it up in an RFE because we didn't have any Ironic-side docs for this
15:31:19 <JayF> I think we've gone over this before? Again just wanted to make sure we had it documented and a tracking bug for Ironic side
15:31:43 <TheJulia> sounds good to me.
15:32:11 <rpittau> yes, we've talked about this already, thanks for the tracker on ironic side
15:32:11 <rpittau> it sounds good to me
15:32:48 * JayF marked 2063352 as approved
15:33:23 <rpittau> thanks
15:34:04 <rpittau> #topic Open Discussion
15:34:47 <JayF> TheJulia: you are not going to be at CERN, yeah?
15:34:58 <TheJulia> That is correct
15:35:01 <JayF> It'd be really neat to have a futurism oriented talk
15:35:07 <JayF> around project mercury and other vision-y things
15:35:21 <rpittau> TheJulia: oh I thought you were coming :(
15:36:18 <TheJulia> no, unfortunately I wasn't able to get traction behind going and I've got stuff going on as well which really sort of drained out my capacity for that right now
15:36:28 <TheJulia> (read: family stuff)
15:36:32 <JayF> makes sense
15:36:59 <JayF> rpittau: if only the PTL of Ironic was going to be in attendance to give such a talk
15:37:02 <JayF> <.< >.>
15:37:05 <rpittau> :D
15:37:14 <JayF> I'm doing history of Ironic, you doing future would be fitting :D
15:37:16 <TheJulia> I suspect a basic pitch deck might make sense
15:37:23 <TheJulia> happy to collaborate on such
15:38:02 <rpittau> JayF: I can definitely do something on that, besides the metal3 presentation
15:38:14 <JayF> Yeah, I am going to do something like, timeline of Ironic
15:38:36 <JayF> middle maybe could be a collab on "use cases Ironic handles now that you didn't know it did" or similar
15:38:54 <JayF> which would include metal3, potentially (?)
15:39:11 <opendevreview> cid proposed openstack/ironic master: wip: Provision aarch64 fake-bare-metal-vms  https://review.opendev.org/c/openstack/ironic/+/915441
15:39:22 <rpittau> I could spin off from that :)
15:39:23 <JayF> then go into futurism: project mercury, step templates, node service, retirment of ir-inspector
15:39:41 <JayF> with a call to action of "what's the case you want us to handle next?" or similar
15:39:59 <JayF> I also will be checking with Arne, and looking into the viability of getting these presentations on video
15:40:16 <rpittau> that would be great
15:40:19 <JayF> even if not live, it's the sorta content that'd be good to have
15:41:02 <rpittau> a recording is enough
15:42:53 <rpittau> we nee to sync at some point
15:43:14 <JayF> this week is the time I'm going to point my brain at that
15:43:40 <rpittau> yeah. I was going to say I will be out for a good part of May, so it needs to be this week
15:43:49 <TheJulia> In entirely unrelated news: squeeeee is -> https://review.opendev.org/c/openstack/ironic/+/898010 passing
15:43:56 <cid> JayF: I will like to watch that
15:44:29 <TheJulia> (it is a tempest test being triggered which explicitly tickles the double virtual media based deploy invocation with configuration drives
15:44:40 <rpittau> I think we can close the meeting here if there's no other topics to discuss
15:44:46 <JayF> ++
15:44:53 <rpittau> thanks everyone!
15:44:55 <rpittau> #endmeeting