15:00:03 <TheJulia> #startmeeting ironic
15:00:03 <opendevmeet> Meeting started Mon May 20 15:00:03 2024 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:03 <opendevmeet> The meeting name has been set to 'ironic'
15:00:04 <TheJulia> o/
15:00:33 <mohammed_> o/
15:00:50 <TheJulia> Good morning everyone in (UGT) Universal Greeting Time!
15:00:59 <TheJulia> Today's ironic meeting can be found on the wiki
15:01:11 <JayF> o/
15:01:21 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_May_20.2C_2024
15:02:08 <TheJulia> ... do we have quorum today?
15:02:15 * TheJulia puts a cup of coffee in front of iurygregory
15:02:19 <TheJulia> :)
15:02:22 <iurygregory> o/
15:02:33 * iurygregory was looking at logs and lost track of time
15:02:40 <TheJulia> #topic Announcements / Reminders
15:03:04 <TheJulia> Your weekly standing reminder to review patches tagged with ironic-week-prio
15:03:13 <TheJulia> #link https://tinyurl.com/ironic-weekly-prio-dash
15:03:26 <TheJulia> The work items for 2024.2 have been merged.
15:03:34 <TheJulia> #link https://review.opendev.org/c/openstack/ironic-specs/+/916295
15:03:49 <TheJulia> And last, but not least, the release schedule for 2024.2
15:03:56 <TheJulia> #link https://releases.openstack.org/dalmatian/schedule.html
15:04:09 <TheJulia> This does mean this week is R-19
15:04:20 <TheJulia> #topic Review Ironic CI Status
15:04:44 <TheJulia> so, how is CI? I've noticed some more tempest test unahppiness which I'm working on trying to fix
15:05:38 <TheJulia> #link https://review.opendev.org/c/openstack/ironic-tempest-plugin/+/919762
15:06:00 <iurygregory> interesting ^
15:06:25 <TheJulia> Yeah, i think part of it is the whole "oh, there is no way we're doing a whole OS on this cloud provider" logic path
15:06:38 <TheJulia> and our continued reliance on tinycore is sort of... biting us
15:06:45 <TheJulia> Like an unhappy cat.
15:06:49 <iurygregory> ++
15:06:58 <TheJulia> Anyway, moving on!
15:07:02 <iurygregory> will keep on my radar
15:07:10 <TheJulia> It looks like a timeout, fwiw
15:07:22 <TheJulia> but you actually have to look at the ipxe text
15:07:34 <TheJulia> Moving past Discussion topics, to Bug Deputy Updates
15:07:38 <TheJulia> #topic Bug Deputy
15:08:22 <TheJulia> Last week we got down to 137 open bugs against ironic itself. A number of them are wishlist items, we should really take a look at open in progress items because I found a few which were already fixed last week.
15:08:22 <iurygregory> I will be the deputy this week o/
15:08:42 <TheJulia> #action iurygregory to be the Bug Deputy for this week.
15:08:52 <iurygregory> great job TheJulia
15:09:01 <TheJulia> Since we have no RFE topics, we will move to Open Disucssion.
15:09:05 <TheJulia> #topic Open Discussion
15:09:17 <JayF> I have an item for this, when mohammed_ is done
15:09:25 <TheJulia> \o/ as do I!
15:09:33 <TheJulia> mohammed_ is seeking reviews of https://review.opendev.org/c/openstack/sushy-tools/+/875366
15:09:38 <mohammed_> I would like to take this forward it seems hanging there for longtime I want to know if somthing is blocking I have already got +1 from dmitry
15:09:49 <JayF> I'm generally curious what the use case is? I always viewed sushy-tools as being about helping Ironic fake VMs, if we stub even further through doesn't it remove some of the value?
15:09:58 <JayF> I've avoided putting this review on your change because I don't wanna stop it if there's a good use case (sushy-tools is not high on the list of things I'm super concerned about) but I'm curious generally what the goal is
15:10:22 <TheJulia> I think a better understanding of the goal will help reviewers review it, to be honest
15:10:26 <JayF> ++
15:10:38 <mohammed_> we need mainly to testing ironic scalability but  open to discuss the needs for such fake IPAs on the sushytools on the changes :)
15:10:59 <JayF> What does IPA have to do with sushy?
15:11:02 <JayF> I guess is my root problem
15:11:16 <JayF> sushy is a library for redfish access; sushy-tools uses that library to present fake VMs
15:11:23 <JayF> why not fake IPA in virtualbmc? or virtualpdu?
15:11:34 <JayF> there's a base level misalignment that I can't figure out
15:11:40 <mohammed_> sushy has fake system faking the VM and ironic expect ipa agent to be running on these vms that we are trying to add there
15:12:13 <mohammed_> Fake driver ^
15:13:18 <TheJulia> is the intention or modeling at present such that triggering a fake run cause the fake IPA to fire up?
15:14:12 <TheJulia> I guess that sort of makes sense then
15:14:13 <mohammed_> the current model have the fakeIPA and sushytools running in different containers
15:14:18 <TheJulia> okay
15:14:25 <TheJulia> So my final question, will results be published at all?
15:14:26 <TheJulia> :)
15:14:46 <mohammed_> Did not get you :/
15:14:56 <JayF> I'm still confused enough about the whole end-to-end I doubt I'll review that change, but honestly sushy{,-tools} is not my strongest project anyway
15:15:06 <JayF> mohammed_: I think TheJulia is saying, if you land this and do performance testing, share the results with us :D
15:15:21 <TheJulia> So your doing the delopment work to bench test Ironic, are those results available for review?
15:15:39 <mohammed_> we are syncing together on these on metal3 side with dmitry
15:16:21 <TheJulia> Okay, cool
15:16:32 <TheJulia> JayF: You had an open discussion item?
15:16:38 <JayF> Yes
15:16:44 <JayF> June 5th is the BM SIG @ CERN.
15:16:59 <JayF> It's been noted that we can enable remote participation if desired
15:17:10 <TheJulia> That would be nice
15:17:11 <iurygregory> :O
15:17:28 <iurygregory> ++
15:17:42 <JayF> Then we need to discuss time. Right now the proposed start time is 10am, which is 1am pdt
15:17:57 <JayF> obviously not ideal but we can change it; I'm a little nervous about doing it because we already have some published
15:18:05 <JayF> but I didn't want to make the decision in a vacuum
15:18:21 <JayF> I doubt that there's a time we could pick that would be 1) close to the original published time and 2) not terrible for PDT
15:18:56 <JayF> we list an 8am start right now on the webpage
15:19:01 <JayF> #link https://indico.cern.ch/event/1378171/
15:19:28 <TheJulia> JayF: I will do my best to join in remotely based upon the local schedule, start based upon the people there
15:19:44 <JayF> yeah, that's what I was thinking -- which would be a 10am start for presentations, I think
15:19:45 <TheJulia> 8 AM is a bit early if one needs to train in and all
15:19:58 <TheJulia> yeah, that seems reasonable
15:20:21 <iurygregory> I think it would be complicated to change the time now, I had no idea  it could have remote participation, I will just try to join
15:20:24 <JayF> I'll note the agenda currently includes an introduction to metal3, an ~45-60m talk by me on "ironic features"
15:20:31 <JayF> and then hackathon/discussion afterwards
15:20:51 <TheJulia> Sounds good
15:20:54 <JayF> the goal is to hopefully inspire lots of "how does feature X work?" conversations after the presentations :D
15:21:02 <JayF> the other, related item for OD for me
15:21:20 <JayF> I will be in Europe next week and the week after. I'll be very rarely on IRC as a result to focus on my in-person team in UK and all
15:21:28 <JayF> So if you need me, email/sms/etc
15:21:37 <TheJulia> JayF: cool cool, enjoy
15:21:46 <TheJulia> so my one last item!
15:22:09 <TheJulia> ihrachys has raised some questions/comments on https://review.opendev.org/c/openstack/ironic-specs/+/916126. JayF and I have both responded. If there are any more thoughts/responses please try and post it in the next day or so and I'll rev the spec.
15:22:50 <TheJulia> Anything else today?
15:23:36 <TheJulia> I'll note next Monday is a holiday in the US.
15:23:51 <JayF> Please review the self-serve runbooks spec :D
15:23:56 <TheJulia> ++
15:23:57 <iurygregory> ack o/
15:23:57 <JayF> that is on hold pending community review right now
15:24:10 <iurygregory> this week I have more "free" time
15:24:17 <iurygregory> so I will double check it
15:24:21 <TheJulia> what is "free" time ;)
15:24:38 <iurygregory> a time I will not spend testing firmware update or on escalation :D
15:24:52 * JayF hears a new jira ticket being filed
15:24:57 <JayF> run iurygregory!
15:25:08 <iurygregory> well I got an escalation from a bug created today
15:25:21 <iurygregory> I'm not surprised because is monday
15:25:29 <TheJulia> in accordance with the prophecy
15:25:34 <iurygregory> yup!
15:26:08 <TheJulia> iurygregory: if you need another brain, I can deffer some stuff I was planning on doing this morning until tomorrow
15:26:13 <TheJulia> anyway! Thanks everyone!
15:26:16 <TheJulia> Have a great week!
15:26:29 <mohammed_> o/
15:26:35 <TheJulia> #endmeeting