15:02:28 <iurygregory> #startmeeting ironic
15:02:28 <opendevmeet> Meeting started Mon May  5 15:02:28 2025 UTC and is due to finish in 60 minutes.  The chair is iurygregory. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:28 <opendevmeet> The meeting name has been set to 'ironic'
15:02:31 <rpittau> can someone please chair the meeting? I'm a bit swamped downstream
15:02:35 <rpittau> thanks iurygregory
15:02:53 <iurygregory> sorry I'm late
15:03:04 <TheJulia> o/
15:03:08 <iurygregory> hello ironicers, welcome to our weekly meeting
15:03:13 <TheJulia> sorry, distracted as well :)
15:03:33 <alegacy> hello folks
15:03:53 <iurygregory> #topic Announcements / Reminders
15:04:07 <TheJulia> cardoe: ... interesting, worth discussing more soon
15:04:22 <iurygregory> #info Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:05:08 <iurygregory> oh my bad, the agenda can be found in our wiki https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_next_meeting (I noticed we still have the same info from last week, so I will omit a few things), forgot to update
15:05:34 <cid> o/
15:06:30 <iurygregory> #info 2025.2 Flamingo Release Schedule https://releases.openstack.org/flamingo/schedule.html we are at R-21 on the schedule, next week we have Flamingo-1 milestone
15:07:00 <TheJulia> wow, this year is flying by
15:07:04 <iurygregory> #topic Working Group Updates
15:07:40 <iurygregory> Standalone networking - does anyone have information that would like to share?
15:07:57 <alegacy> related to the standalone networking ... last week we discussed the possibility of setting up a call to discuss.  Can we get that setup?
15:08:12 <cardoe> alegacy: please include me
15:09:11 <TheJulia> I guess the key is going to be who is going to drive the standalone networking meeting then, do we have a volunteer to schedule something? We should ideally try to identify a date/time
15:09:11 <alegacy> who should be invited?  what day/time should we target?
15:10:04 <TheJulia> If we can avoid Tuesday, I'd prefer it
15:10:14 <alegacy> i don't mind send out a google meet link as an organizer if we can agree on date/time & who
15:10:21 <TheJulia> Would Wednesday work?
15:10:29 <cardoe> I would say we have some kind of regular-ish standing slot for it and cancel if there's nothing on the agenda and then people know to reserve that.
15:10:39 <cardoe> I'll be out the 2nd half of May.
15:11:49 <cardoe> As far as the ironic-weekly-prio patches, there's a fair number that just need a +W
15:13:01 <alegacy> wednesday works for me.  In in EST timezone so could do anything between 1200UTC-1600UTC or 1700UTC-1900UTC
15:15:08 <iurygregory> TheJulia, cardoe what slot would you prefer? ^
15:15:48 <TheJulia> 1600 UTC would be ideal for me
15:16:03 <cardoe> The later the better for me.
15:16:06 <cardoe> Yeah 1600 would be great.
15:16:25 <TheJulia> Gets you past the morning "what chaos has occured?" step right after caffination
15:16:50 <alegacy> any chance you could do an hour later... 1600 fall directly at lunch time
15:17:20 <TheJulia> I suspect for EU folks that might be a bit more difficult but that could work for me
15:17:36 <TheJulia> (Speaking of EU folks, is everyone still off today?)
15:17:50 <masghar> (nope)
15:17:51 <iurygregory> not that I'm aware..
15:18:13 <TheJulia> more coffee for everyone then? :)
15:18:15 <iurygregory> I know some are quite busy with some downstream chaos =)
15:18:21 <TheJulia> wheeeeeeeee
15:18:28 <cardoe> UK folks have a bank holiday today no?
15:18:29 <iurygregory> they probably need coffee =)
15:18:33 <masghar> (I'm trying to wrap my head around a bug)
15:18:45 <cardoe> I'd be fine with 1700 if EU/UK folks are okay with it
15:19:45 <TheJulia> cardoe: I do believe that is true, i know some folks in Ireland are also off today
15:20:06 <iurygregory> ok, we can probably figure out the time after the weekly meeting? maybe tomorrow we can figure out if the time would work for them
15:21:48 <alegacy> ok, i'll send out a meeting to this channel tomorrow morning to follow-up.  If 1700 works I'll then send out a meeting link
15:22:01 <iurygregory> tks alegacy !
15:22:48 <iurygregory> #action alegacy to follow-up if 1700 UTC works for the  Standalone networking group meeting
15:22:53 <iurygregory> moving on
15:23:11 <iurygregory> #topic Discussion topics
15:23:32 <iurygregory> We don't have any (the one in the agenda was from last week)
15:23:39 <TheJulia> alegacy: please invite my internal email address as an attendee, Thanks!
15:23:56 <JayF> I will note that I expect to have more clarity on the dynamic networking spec by EOW
15:24:03 <TheJulia> JayF: thanks
15:24:04 <JayF> TheJulia: I'm assuming I can just take over that and edit it now?
15:24:20 <cardoe> what's the dynamic networking spec?
15:24:22 <TheJulia> JayF: yeah, although you said you'd post comments and never did
15:24:36 <JayF> TheJulia: there are $reasons for that downstream
15:24:50 <TheJulia> cardoe: https://review.opendev.org/c/openstack/ironic-specs/+/945642
15:25:01 <TheJulia> #reasons_is_life ;)
15:25:16 <cardoe> ah yes good deal
15:25:30 <TheJulia> cool cool
15:26:01 <TheJulia> I've got nothing else
15:27:01 <iurygregory> are we good to move on?
15:27:14 <JayF> move on
15:27:30 <iurygregory> #topic #Bug Deputy Updates
15:27:56 <iurygregory> #info New Bugs: 1 New Bugs New RFEs: 0 New RFEs
15:28:25 <iurygregory> Who is the next bug deputy?
15:28:53 <iurygregory> this week I can't take, since I will be out wed-friday
15:29:01 <masghar> I can take it
15:29:02 <iurygregory> happy to do next week =)
15:29:16 <TheJulia> So, super curious, I'm close on the metadata fix
15:29:27 <iurygregory> #info masghar will be the bug deputy this week
15:29:39 <TheJulia> I'm wondering if folks would be interested in a "oh, you didn't send us network data, we'll just inject it anyway sort of feature
15:30:04 <TheJulia> I realize we have a weird usage divide there, so sort of curious w/r/t/ thoughts for doing so
15:31:32 <JayF> TheJulia: I guess I worry we'll expose people who rely on flat to do nothing to network and bake in network config to images
15:31:41 <JayF> TheJulia: because then you can mostly lie to openstack about networks :)
15:31:58 <JayF> TheJulia: cool idea, I'm +1 to it being optional, but I suspect there are edges around having it enabled (even in standalone)
15:32:25 <TheJulia> Oh, flat would normally include network data and dhcp
15:32:49 <TheJulia> Oh, I suspect it just won't work in standalone and hte way I've written the patch it should only work when using neutron
15:33:05 <TheJulia> as a source of data on the existing calls
15:33:09 <TheJulia> and data stuctures
15:33:10 <JayF> so what's the case?
15:33:16 <JayF> ironic-direct integrated deploy?
15:33:24 <TheJulia> Directly invoking ironic to deploy a node
15:33:26 <JayF> where you have neutron but not nova?
15:33:30 <TheJulia> but with neutron
15:33:40 <JayF> that is very interesting
15:33:40 <TheJulia> and that leads to... do we include key injection
15:33:47 <TheJulia> since that is... getting very close to "give me an instance"
15:33:59 <JayF> we don't have a pubkey object in our base api
15:34:10 <TheJulia> nope
15:34:19 <JayF> I don't hate making this easier, but I worry we'll end up reimplementing a lot more than it seems at first glance
15:34:19 <TheJulia> Just thinking outloud, it begins to open the door, for sure
15:34:36 <JayF> def something worth listing the scenarios out before going too far down that path
15:34:44 <JayF> even if the path is going somewhere cool :D
15:35:15 <JayF> (not for network_data, JFDI that; I mean for +ssh_keys+other extras)
15:36:16 <TheJulia> yeah
15:38:01 <TheJulia> ack ack, thanks
15:39:21 <iurygregory> I'm assuming we are at Open discussion, already =)
15:39:35 <iurygregory> #topic Open discussion
15:39:52 <iurygregory> does anyone have something that would like to discuss?
15:41:21 <iurygregory> so, are we good for today? =)
15:42:57 <JayF> ++
15:43:18 <iurygregory> tks everyone!
15:43:20 <iurygregory> #endmeeting