15:02:39 <JayF> #startmeeting ironic
15:02:40 <opendevmeet> Meeting started Mon Sep  8 15:02:39 2025 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:40 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:40 <opendevmeet> The meeting name has been set to 'ironic'
15:02:49 <TheJulia> OTOH, I saw an awesome post from someone on LinkedIn this past weekend which spoke very highly of the Ironic project. The comments were fairly positive, one that redfish is basically awful and doesn't work which I encouraged them to file bugs. The other comments were mostly around our docs.
15:02:53 <dtantsur> Thanks Jay!
15:03:02 <JayF> Hello everyone, welcome to the ironic meeting! Going to wait a few minutes for folks to get ready to meet; totally not using it to open the agenda :D
15:03:07 <dtantsur> TheJulia: nice, thanks for sharing! Docs are .. docs.
15:03:08 <JayF> dtantsur: link me that please
15:03:28 <dtantsur> JayF: you meant to ask TheJulia, right?
15:03:30 <TheJulia> dtantsur: yeah, I think the perception is largely rooted in the layout overall and the fact we call back to prior behavior a lot
15:03:33 <JayF> So current agenda in the wiki is 8/25
15:03:34 <JayF> yes, I did
15:03:38 <JayF> I'm going to wing it
15:03:53 <JayF> #notes Reminder to review things in our ironic-week-prio dashboard: https://tinyurl.com/ironic-weekly-prio-dash
15:04:06 <JayF> All flamingo releases have been cut now, right?
15:04:13 <JayF> I didn't check to see if the patches merged, but I reviewed them
15:04:17 <dtantsur> I feel like Ironic is pending still
15:04:22 <dtantsur> at least I don't see the branch
15:04:47 <JayF> #note Ironic releases are pending review from release team: https://review.opendev.org/q/topic:%22ironic-releases-2025.2%22
15:05:00 <TheJulia> JayF: https://www.linkedin.com/posts/nilesh-chandekar-304b4b57_opensource-osa-openstack-activity-7365744037502345218-Nx3A should work
15:05:32 <TheJulia> Yeah, I am not a release manager so there is no "trust" of me putting the patch in to release
15:05:34 <JayF> We generally ask members of the community, core reviewers, contributors, operators, to take some time before the official release late this month/early October to help test.
15:05:57 <JayF> #topic Working Group Updates
15:06:05 <JayF> Do we have any updates for Standalone networking?
15:06:13 <JayF> I assume it's probably been a little quiet with release activities?
15:06:17 <TheJulia> Alan is out this week as well, he should be back next week
15:06:29 <TheJulia> or, maybe he is back this week but just getting back today
15:06:34 <TheJulia> so I wouldn't expect anything until sometime next week.
15:06:45 <JayF> For eventlet removal team, https://review.opendev.org/c/openstack/ironic/+/959870 was posted last week and needs to land, both in master and be backported to the (eventual) 2025.2
15:06:53 <JayF> We thought we were done but surprise!
15:07:04 <JayF> I suspect we'll find a few more surprises as time continues.
15:07:59 <JayF> There are no discussion topics on the agenda. Skipping that section. New business can go in Open Discussion.
15:08:05 <JayF> #topic Bug Deputy Updates
15:08:16 <JayF> clif was bug deputy for the last 2 weeks, since the meeting was cancelled
15:08:22 <JayF> clif: do you have anything of note for the meeting?
15:08:31 <JayF> Also; who wants to be the next deputy?
15:08:45 <clif> Pretty quiet two weeks. I think there was just one new ironic bug filed in that time.
15:08:56 <cid> o/
15:09:18 <JayF> cid: is that a volunteer to be deputy next week?
15:09:23 <clif> Perhaps two? I self-assigned this https://bugs.launchpad.net/ironic/+bug/2121702
15:09:30 <clif> Will take a look at it soon
15:09:46 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2121702
15:09:48 <JayF> >  When triggering a automated cleaning the ports are not created in the cleaning network Edit
15:09:50 <cid> JayF, I guess so. It also doubles as attendance :D
15:10:07 <JayF> haha be careful when you raise your hand :D thank you for your volunteering :D
15:10:17 <cid> :)
15:10:19 <JayF> #note Next bug deputy: cid
15:10:47 <JayF> No RFEs for review.
15:10:50 <JayF> #topic Open Discussion
15:10:54 <JayF> I have one thing for this
15:11:08 <JayF> We have multiple repos in Ironic/Bare Metal program which are coming up on EOL.
15:11:15 <JayF> Metalsmith. *inspector*
15:11:41 <JayF> I will likely be taking action (starting with a formal ml discussion) around retiring these in October.
15:11:49 <JayF> Please speak now if you have interest in keeping these alive
15:12:03 <JayF> or if you have other repos under our governance which are hiding under a rock that need to be removed from our governance
15:12:25 <TheJulia> ++
15:12:50 <kubajj> I am just excited to try using Ironic without inspector as a separate repo ;P
15:13:25 <dtantsur> ++
15:13:32 <JayF> #agreed Metalsmith and Inspector-related repos being considered for retirement early in the *G* cycle. Please speak quickly if you have good reason for them to stay alive, and/or want to volunteer to maintain them. Note that inspection will still exist and has been migrated to primary Ironic repos.
15:13:48 <JayF> Anything else for open discussion
15:14:10 <JayF> One other interesting question: Anyone else going to be at Summit in Paris?
15:14:21 <dtantsur> Yep
15:14:22 <JayF> Enough for an Ironic dinner, perhaps?
15:14:29 <TheJulia> I might be, awaiting approval.
15:14:37 <JayF> I'll be there +2 folks from the downstream GR team
15:15:09 <dtantsur> From us, at least rpittau, masghar and myself, I think, and I don't remember about janders and iurygregory
15:15:34 <JayF> oh, nice! So yeah, we can pencil something in I hope.
15:15:59 <dtantsur> Let's do it rather early than late if possible please since we're also trying to have a team dinner :)
15:16:01 <JayF> I know little about the area and don't speak French so that may be a limitation, but I doubt we'll have trouble finding a nice place for a few folks to eat in *Paris*
15:16:14 <dtantsur> it's not quite *in* Paris
15:16:21 <JayF> Here is where someone volunteers to organize it who isn't an ocean away and only speaking english
15:16:30 <dtantsur> we can wait for rpittauto return next week and make puppy eyes
15:16:46 <TheJulia> dtantsur: that sounds like an excellent plan
15:16:59 <masghar> ++
15:17:01 <JayF> #voluntold rpittau to help arrange team dinner (please?)
15:17:11 <kubajj> JayF: I will be there
15:17:15 <TheJulia> #prettypleaseultiplier
15:17:55 <JayF> #agreed 10+ Ironic contributors/operators will be at France summit. We're going to try to do a team meal.
15:18:03 <JayF> Anything else before I close the meeting?
15:18:08 <dtantsur> yep, 1 sec
15:18:19 <dtantsur> I want to highlight https://review.opendev.org/c/openstack/ironic/+/959690
15:18:26 <dtantsur> (I hope the delivery does not interrupt me right now lol)
15:18:41 <dtantsur> This is an attempt to bring a more granular Metal3 job to Ironic
15:19:16 <dtantsur> Together with a potential addition of a baremetal-operator functional tests job, this should eventually replace the cryptic metal3-integration job which nobody really knows how to debug :)
15:19:32 <kubajj> I would also want to highlight https://review.opendev.org/c/openstack/ironic-python-agent/+/937342 as it might spark some discussion
15:19:37 <JayF> Does this have external dependencies which will break at release barriers?
15:20:00 <dtantsur> JayF: fewer. Neither depend on CAPI, which is a big source of these breakages.
15:20:23 <dtantsur> Of course, we need to observe how the newly added jobs behave on OpenInfra nodes
15:20:26 <JayF> ack; sounds good. My only real question is if experimental makes more sense; but it's a weak question as experimental jobs are easily forgotten :D
15:20:36 <dtantsur> I want some statistics
15:20:58 * dtantsur picks up delivery, sorry
15:21:39 <JayF> We can pickup the discussion in gerrit
15:21:47 <JayF> similarly kubajj I've added your patch to my review queue
15:22:15 <kubajj> JayF: thanks, it is the one where you said you will not like to review 🫠
15:22:18 <JayF> #note please review 959690 (ironic standalone operator testing) and 937342 (IPA raid-device-cleaning-skip fixes)
15:22:35 <JayF> kubajj: I like patches sitting with no feedback for weeks much, much less :(
15:24:05 <JayF> Last call (chapter 2) for anything new for open discussion
15:24:41 <TheJulia> ptg?
15:25:05 <JayF> Has anyone done serious planning for the PTG other than creating the etherpad?
15:25:27 <dtantsur> We already have an etherpad? :D
15:25:49 <JayF> #note Ironic already has a PTG etherpad: https://etherpad.opendev.org/p/ironic-ptg-2026.1
15:25:56 <JayF> it's been in the whiteboard for a couple of weeks
15:27:05 <kubajj> (I had to look up when it is - October 27 to 31)
15:28:01 <TheJulia> I've already added a few topics to the etherpad
15:29:16 <TheJulia> Largely I'm getting tons of network/storage asks these days
15:29:35 <TheJulia> Strong enough I'm tempted to just publish a prioritized list
15:29:48 <JayF> that sounds really useful
15:30:04 <JayF> "prioritized list" = operator menu, and I can see if my downstream wants a #3 (proverbially)
15:30:51 <TheJulia> Well, where folks can collaborate around most value
15:31:05 <JayF> Absolutely. Or maybe find a common thread that can unite some of the asks
15:31:15 <TheJulia> like, my networking stuff is drastically different than yours, but... there is overlap and opportunity collaborate regardless
15:31:20 <TheJulia> exactly
15:32:12 <JayF> Sounds good.
15:32:19 <JayF> A couple reminders along these lines:
15:32:27 <JayF> we need to get on scheduling the ptg in the next week or two
15:32:41 <JayF> we need to ensure release liasons get +1s on the pending release PRs that were linked at the top of the meeting
15:32:53 <JayF> Most of the rest is stuff that can be coordinated in etherpad
15:34:14 <TheJulia> ++
15:34:49 <JayF> I think that's it for the meeting?
15:34:55 <JayF> Last call v3 :)
15:37:17 <JayF> #endmeeting