15:03:24 <TheJulia> #startmeeting ironic
15:03:24 <opendevmeet> Meeting started Mon Sep 29 15:03:24 2025 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:24 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:24 <opendevmeet> The meeting name has been set to 'ironic'
15:03:30 <rpittau> o/
15:03:32 <TheJulia> The Corgi does *not* like diesel engines or air breaks
15:03:43 * iurygregory is late
15:03:46 <iurygregory> o/
15:03:51 <TheJulia> Anyhow! Since I seem to be driving the crazy ironic bus this week!
15:03:56 <TheJulia> *insert evil laughing*
15:03:56 <kubajj> o/
15:04:42 <TheJulia> Our agenda for the week can be found on the Wiki!
15:04:45 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_September_29.2C_2025
15:05:00 <TheJulia> #topic Announcements / Reminders
15:05:22 <TheJulia> As a general reminder, our ironic-week-prio review items can be reviewed via a dashboard.
15:05:24 <TheJulia> #link https://tinyurl.com/ironic-weekly-prio-dash
15:05:52 <TheJulia> This week is release week, R-0.
15:05:54 <TheJulia> #link https://releases.openstack.org/flamingo/schedule.html
15:06:27 <TheJulia> Which means, we should now begin focusing full steam ahead, or accelerator depressed so the Corgi doesn't bark with opinions.
15:06:42 <TheJulia> (This... actually happens, he likes us at at least 55MPH.)
15:07:09 <clif1> good dog
15:07:11 <TheJulia> As a reminder, our next PTG will be in the end of October after the Summit.
15:07:14 <TheJulia> #link https://etherpad.opendev.org/p/ironic-ptg-2026.1
15:07:18 <cid> o/
15:07:21 <JayF> o/
15:07:24 <TheJulia> There is already a *lot* there, and we should add more!
15:07:41 <TheJulia> clif: just imagine if the corgi was an engineering manager.....
15:07:43 <TheJulia> eek.
15:07:56 <rpittau> lol
15:07:58 <TheJulia> Does anyone have anything else to announce or remind us of?
15:09:17 * TheJulia takes silence as a no
15:09:23 <TheJulia> #topic Working Group Updates
15:10:08 <TheJulia> alegacy: I believe you posted some patches this past week and it seems like you need some review traffic. Is there anything specific which needs to be called out?
15:10:27 <alegacy> I now have all my change requests opened.  3 of them are WIP that still need a bit of massaging and cleanup.
15:10:44 <TheJulia> Cool cool
15:11:01 <alegacy> I've added Depends-On on the ones that have cross-repo dependencies in the hopes that satisfies the testing aspects of them.
15:11:34 <TheJulia> Excellent
15:11:43 <alegacy> Will monitor for comments as address as they come in.
15:12:06 <TheJulia> Have they been labeled with the ironic-week-prio hashtag?
15:12:08 <alegacy> Hoping that the spec changes could get reviewed/merged first to make sure we get agreement on that sooner rather than later.
15:12:24 <alegacy> yes, they have been labeled... except for the 3 WIP ones.  Should I label those as well?
15:13:12 <TheJulia> I suspect it might help, but if you feel they are still works in progress its a fine line because because we generally use the label to drive folks to review changes to get them merged
15:13:25 <TheJulia> I guess we should just press forward as time permits
15:13:28 <alegacy> ok, i'll wait another week on those
15:13:55 <TheJulia> Okay, if folks involved could please review alegacy's WIP changes as well during this week, that would be most excellent
15:14:14 <TheJulia> Regarding eventlet, is there anything else to focus on in this working group at this time?
15:15:27 * TheJulia takes the sounds of crickets as a no, and that we should remove the item from the agenda.
15:15:44 <TheJulia> Moving on then!
15:15:48 <TheJulia> #topic Discussion topics
15:16:06 <TheJulia> rpittau: looks like you have two topics, and once your done I'll raise a related point.
15:16:10 * TheJulia gives rpittau the floor
15:16:15 <rpittau> thanks TheJulia
15:16:33 <rpittau> the first topic is the outreachy project for the next round
15:16:43 <rpittau> hroy and myself have proposed a project
15:16:50 <rpittau> for ironic
15:17:24 <rpittau> it's kind of a combination of 2 RFEs that are alreaady in launchpad:
15:17:24 <rpittau> https://bugs.launchpad.net/ironic/+bug/2072333
15:17:24 <rpittau> https://bugs.launchpad.net/ironic/+bug/2098693
15:17:46 <rpittau> in short we'd like to extend the existing Ironic node history api
15:18:28 <rpittau> so for example adding more details and adding filters
15:18:51 <JayF> I'll note on a related but different note, I have an MLH fellow for a few weeks this cycle as well. So if you have anything there that slips outta the scope but would be a good story for someone else; awesome
15:18:59 <rpittau> plus the possiblity to check for example only the most recent historyu for a given node
15:19:25 <TheJulia> rpittau: It seems interesting to me because the node-history was largely geared as a journal with events rolling off eventually
15:19:42 <TheJulia> That seems a bit difficult to determine/query/map how long a node was deployed, for example for billing purposes.
15:20:17 <rpittau> yeah
15:21:18 <TheJulia> The times was largely to aid in billing/utilization timing, I mean maybe it might work if its a clear set of values
15:21:46 <TheJulia> and are de-preferenced for deletion or somehow kept for longer. That gets a little weird but doable at the DB level.
15:23:03 <TheJulia> I guess somehting in writing which clearly articulates the vision of how you want to merge the two items together would be helpful
15:23:28 <rpittau> we'd really like to focus on the history details part
15:23:28 <rpittau> and we plan to have an RFE in lauchpad of course
15:23:47 <rpittau> jsut wanted to get preliminary feedback
15:23:58 <kubajj> rpittau: this would be great
15:24:10 <JayF> The thing that's extra fun
15:24:14 <JayF> if you're doing a multitenant cloud
15:24:21 <JayF> that node history "how long was X provisioned" == billing history
15:24:22 <kubajj> also, TIL that node name is optional
15:24:41 <rpittau> JayF: indeed
15:24:46 <rpittau> kubajj: it is! :D
15:25:27 <TheJulia> rpittau: I think it could definitely work, just have to navigate the overall needs, and would move things forward in a rather useful way for folks
15:26:07 <rpittau> alright
15:26:07 <rpittau> we also need the project to be accepted in Outreachy! :D
15:26:56 <TheJulia> I guess the other aspect on top of mind is history is largely modeled around nodes, not across nodes, maybe a history view overall might be good, dunno.
15:27:12 <TheJulia> I guess it also depends on how folks would handle billing and data gathering for it.
15:27:46 <JayF> oh that's true
15:27:46 <TheJulia> We should likely move on to the next discussion topic, fwiw.
15:28:03 <rpittau> yep
15:28:07 <JayF> that's a good idea though, a history-through-time endpoint that's not node-oriented. Would be annoying to engineer
15:28:33 <TheJulia> Yeah, but you could filter it to get that data if its a unique label :)
15:30:55 <TheJulia> So a dinner or meetup at OIS?
15:31:14 <rpittau> yeah so OIS is in Paris
15:31:26 <rpittau> and I saw JayF volunteering me to organize something :D
15:31:40 <rpittau> JFYI Paris is crazy on Friday and Saturday
15:31:43 <iurygregory> rpittau, you are the local person :D
15:31:48 <rpittau> so we really need to plan in advance
15:31:49 <JayF> You speak Parisian and I only speak 'Murica rpittau ;)
15:31:50 <JayF> lol
15:31:56 <iurygregory> so he is totally right to ask you
15:32:04 <iurygregory> lol
15:32:12 <TheJulia> Has anyone checked what night the member event is?
15:32:19 <rpittau> I've prepared a simple etherpad for a list of participants https://etherpad.opendev.org/p/Ironic_OIS_community_dinner_in_Paris
15:32:34 <opendevreview> Allain Legacy proposed openstack/networking-generic-switch master: WIP: Add standalone driver interface  https://review.opendev.org/c/openstack/networking-generic-switch/+/962037
15:32:54 <iurygregory> rpittau, worth sending to the ML I would say =)
15:33:40 <rpittau> iurygregory: definitely my plan, but I would like at least to have people in the meeting adding their name if they're willing to participate
15:34:02 <iurygregory> ++
15:35:02 <TheJulia> Good to move on at this point?
15:35:23 <rpittau> I think so
15:37:12 <TheJulia> Shoudl we cancel the weekly meeting meetings until after the PTG?
15:37:21 <TheJulia> s/Shoudl/Should/
15:37:59 <TheJulia> Specifically, I could see maybe meeting the 13th, but 20th we'll be traveling (or some folks taking pto), and 27th is PTG week.
15:38:42 <JayF> Sounds reasonable to me.
15:38:56 <rpittau> yep, should be fine
15:39:05 <TheJulia> Do we want to meet on the 13th then?
15:39:48 * TheJulia takes silence as a yes
15:39:48 <JayF> Why not the 6th?
15:39:49 <rpittau> not necessarily, that's the OIS week
15:39:58 <TheJulia> oh
15:40:11 <TheJulia> so last meeting until after the ptg on the 6th?
15:40:17 <iurygregory> OIS is on the weekend no?
15:40:19 <JayF> I think having the 6th, skipping the 13/20/27 makes sense
15:40:26 <rpittau> agreed
15:40:36 <TheJulia> iurygregory: yes, Friday, Saturday, Sunday
15:40:39 <TheJulia> Okay then
15:40:51 <TheJulia> Seems like we're reaching consensus, I can take the action item to send it out
15:40:58 <iurygregory> tks TheJulia
15:41:07 <TheJulia> #action TheJulia to send a mailing list post regarding cancelled meetings in the month of october
15:41:23 <TheJulia> #topic Bug Deputy Updates
15:42:19 <TheJulia> Looks like we only really have one new bug this past week and its a reasonable RFE, to auto-close consoles
15:42:42 <TheJulia> Who wants to be the deputy for the next week?
15:43:15 <cid> \o, I would.
15:43:28 <TheJulia> Okay then, thanks cid!
15:43:38 <TheJulia> Since we have no RFEs to review, we should move on to Open Discussion
15:43:42 <TheJulia> #topic Open Discussion
15:43:53 <TheJulia> Anything to discuss?
15:43:58 <opendevreview> Julia Kreger proposed openstack/ironic-ui master: WIP/DNM: Node history support  https://review.opendev.org/c/openstack/ironic-ui/+/962517
15:43:59 <opendevreview> Julia Kreger proposed openstack/ironic-ui master: WIP/DNM: Add conductor list view into ironic-ui  https://review.opendev.org/c/openstack/ironic-ui/+/962518
15:44:00 <opendevreview> Julia Kreger proposed openstack/ironic-ui master: WIP/DNM: Add node traits support to ironic-ui  https://review.opendev.org/c/openstack/ironic-ui/+/962519
15:44:00 <opendevreview> Julia Kreger proposed openstack/ironic-ui master: WIP/DNM: Add conductor_group and shard field support  https://review.opendev.org/c/openstack/ironic-ui/+/962520
15:44:01 <opendevreview> Julia Kreger proposed openstack/ironic-ui master: WIP/DNM: Add vif support to ironic-ui  https://review.opendev.org/c/openstack/ironic-ui/+/962521
15:44:07 <iurygregory> TheJulia, I have one topic
15:44:39 <TheJulia> iurygregory: go ahead!
15:44:42 <iurygregory> I'm checking the amount of time we have for the topics for the PTG, just want to double check with folks if there is any day we should avoid booking slots
15:45:04 <iurygregory> normally monday has TC meetings etc
15:45:24 <TheJulia> Monday is traditionally cross-projecty things as well
15:45:38 <iurygregory> https://etherpad.opendev.org/p/ironic-ptg-april-2025
15:45:47 <TheJulia> huh?
15:45:52 <iurygregory> was planning to follow the slots we had in april
15:45:57 <iurygregory> if it's ok =)
15:46:21 <iurygregory> unless someone has something against
15:46:44 <TheJulia> It seemed to work, but I think we had some monday conflicts we had to navigate
15:47:08 <TheJulia> I don't have any objections. Does anyone else object?
15:47:12 <iurygregory> cardoe, JayF thoughts?
15:47:56 <iurygregory> we can talk async, and finish the meeting =)
15:48:03 <TheJulia> Okay then!
15:48:10 <TheJulia> Anyone else have any topics?
15:48:17 <TheJulia> Everyone adding more and more stuff to the PTG etherpad, right?!
15:48:42 <iurygregory> I think I will add topics (need to double check)
15:48:44 <TheJulia> (This might end up being a thousand-line etherpad by the end of the PTG....)
15:48:52 <JayF> iurygregory: I don't have any specific conflicts AFAICT, I will take time today to carve up my calendar and ask my team to point out any conflicts
15:49:05 <iurygregory> JayF, awesome, thank you!
15:50:27 <cardoe> No objections
15:51:08 <TheJulia> Well sounds like we're done meeting this week.
15:51:11 <TheJulia> Thanks everyone!
15:51:11 <opendevreview> Merged openstack/ironic-python-agent-builder master: trivial: minor typo fixes on the firmware list  https://review.opendev.org/c/openstack/ironic-python-agent-builder/+/962210
15:51:31 <TheJulia> #endmeeting