15:00:34 <JayF> #startmeeting ironic
15:00:34 <opendevmeet> Meeting started Mon Dec  1 15:00:34 2025 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:34 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <opendevmeet> The meeting name has been set to 'ironic'
15:00:36 <TheJulia> I've not had breakfast much less coffee yet :)
15:00:41 <dtantsur> o/
15:00:42 <janders> o/
15:00:43 <kubajj> o/
15:00:47 <TheJulia> o/
15:00:48 <JayF> Welcome to the Ironic weekly meeting. We operate under the usual Code of Conduct.
15:00:57 <JayF> #topic Announcements
15:01:06 <JayF> #note  Standing reminder to review patches tagged ironic-week-prio and to hashtag any patches ready for review with ironic-week-prio: https://tinyurl.com/ironic-weekly-prio-dash
15:01:18 <rpittau> o/
15:01:47 <JayF> It's R-17. Trailing release cycle stuff for Flamingo is due by today; that doesn't impact us.
15:01:53 <JayF> s/today/this week/
15:01:54 <iurygregory> o/
15:01:59 <clif> o/
15:02:13 <JayF> #topic Working Group Updates
15:02:19 <JayF> Do we have an update on Standalone Networking?
15:02:21 <alegacy> o/
15:02:35 <alegacy> Yep
15:02:53 <alegacy> updated my patch series last week to address everyone comments
15:02:56 <cid> o/
15:03:07 <alegacy> i see that one of them has merged as of this morning.
15:03:15 <TheJulia> \o/
15:03:40 <alegacy> if there are further comments on the remaining patches I'll take a look!
15:03:51 <JayF> You wanna link the chain here for the notes?
15:04:15 <alegacy> https://review.opendev.org/q/topic:%22feature/standalone-networking%22+status:open
15:04:23 <JayF> #link https://review.opendev.org/q/topic:%22feature/standalone-networking%22+status:open
15:04:31 <JayF> #note patches are landing for standalone networking; please prioritize review
15:04:38 <JayF> Thank you for the update alegacy, I assume that's it?
15:04:43 <alegacy> yes sir
15:04:51 <JayF> Anything new on AsyncIO work?
15:06:14 <dtantsur> No, and won't be for a week more
15:06:19 <JayF> Ack.
15:06:21 <dtantsur> 2 weeks really
15:06:29 <JayF> #note No new info on AsyncIO, probably not for 2+ weeks.
15:06:34 <JayF> VXLAN Networking, then?
15:06:51 <TheJulia> I believe I revised the spec I've got posted. Discussions seem stalled at the moment.
15:07:14 <TheJulia> dtantsur: I did reproduce the toc or lack of toc entry issue. That is weird, but I'll try to figure it out this week.
15:07:33 <TheJulia> I won't be around next week, so likely no progress on my end until sometime until later in the month
15:08:00 <JayF> #note VXLAN spec updated; please review. Progress note expected until later in the month.
15:08:11 <JayF> #topic Discussion Topics
15:08:21 <JayF> I think the first one here, based on my reading of the ML earlier, is a leftover?
15:08:34 <JayF> We have already decided to cancel Dec. 22, Dec 29 meetings, yes?
15:08:41 <rpittau> yep
15:08:42 <TheJulia> Yes, I sent out that email already
15:08:44 <TheJulia> its a left over
15:08:57 <JayF> What about iRMC/DMTF items, new or leftover cc: janders
15:09:02 <janders> new
15:09:07 <JayF> you have the floor
15:09:45 <janders> w/r/t iRMC we are very much done. Depreciation change is merged. FJ were consulted and are on board, so we're nearly done. Should I go ahead and send an email to the ML stating what we decided to close the loop?
15:10:33 <TheJulia> Yes please
15:10:35 <JayF> I'd say yes, plese
15:11:07 <janders> OK, will do. Once that's done we can tick this item off. I will team up with someone more experienced since it's the first depreciation I am handling.
15:11:20 <janders> Any closing comments on iRMC? If not I will move to the DMTF topic.
15:11:52 <janders> OK, moving on.
15:12:15 <janders> I approached DMTF folks about the issue of machines with key resources spread across multiple Systems. They are happy to talk about it and advised best way to get attention is to open an issue in their GH space.
15:13:09 <JayF> I also have had an interaction with someone invested in DMTF, who pointed me at two people, one of whom is mraineri, for feedback. I suspect this will be duplicating noise but I won't turn down the opportunity to help advocate for a more Ironic-friendly Redfish spec :D
15:13:09 <janders> Unfortunately this space is private, but I do have access to it. I think it's worth pursuing this. However I think it would be best if we can colaborate on the problem description to best explain to them what we want to know
15:13:28 <janders> yeah I also exchanged emails with Mike
15:13:47 <janders> JayF since you raised this issue, I thought perhaps the two of us collaborate via gDoc with whoever else may be interested?
15:14:01 <janders> once we have a draft for the issue I can post it and raise it in upcoming DMTF meetings
15:14:17 <janders> (upcoming/tomorrow one is heavily booked, but the following one should be better for this)
15:14:28 <janders> would this be a good course of action? WDYT folks?
15:14:42 <TheJulia> I think a doc makes sense to get an issue in place as a starting point
15:14:51 <JayF> janders: I think that's a good idea, but I don't really have cycles this week. I'm flying out to Dallas on Wednesday.
15:15:30 <janders> JayF noted. I will share the gDoc with you anyway so you can contribute when you have time.
15:15:39 <TheJulia> Sounds like this may be a slow burn until the end of the year, tbh
15:16:12 <janders> TheJulia would you have some time to look at the initial version of what I am putting together?
15:16:15 <JayF> #note Those interested in collaborating on a feedback packet for DMTF should contact janders.
15:16:22 <janders> ++
15:16:23 <JayF> #action janders to email the list about iRMC retirement
15:16:32 <janders> OK, that's me, thanks folks
15:16:39 <TheJulia> janders: I would be happy to, I'm not sure I will have anything constructive in the short term, but if you ping me I'll take a look.
15:16:51 <janders> thank you TheJulia
15:16:58 <JayF> #topic Bug Deputy Updates
15:17:06 <JayF> cid: it says you were the bug deputy
15:17:46 <cid> Yeah. I was
15:18:02 <cid> Update, 1 RFE
15:18:12 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2133499
15:18:58 <TheJulia> I can see where folks might be pushing us and dmitry wants to go to solve it, I think a slightly deeper discussion may be needed because it feels like we're unlocking a closet of foot-guns.
15:19:14 <TheJulia> Maybe that is a spec, I dunno.
15:19:26 <JayF> At a minimum I don't fully grok the use case
15:19:55 <TheJulia> I kind of do, but it feels like a footgun shaped giant lever
15:20:00 <JayF> once I understand what the use case is and why a hard node delete doesn't solve it I would have a better opinion
15:20:13 <TheJulia> That is great point
15:20:27 <TheJulia> And it would help
15:20:41 <janders> was thinking the same - why not force-delete?
15:21:10 <TheJulia> we've been skittish of anything which is a forcing behavior in the past because it begins to reset expectations
15:21:42 <TheJulia> I guess I'm worried the next is "force active with a verb", which heads us on a path to "force ipa to make me whipped cream for my pies"
15:21:53 <JayF> We'll get more detail.
15:21:57 <JayF> I put a comment in the bug just now.
15:22:06 <TheJulia> I did as well earlier
15:22:12 <JayF> I don't care if that detail is in spec or more-fleshed-RFE form
15:22:30 <TheJulia> TBF, we're talking verbs, behavior changes, and state machine as well
15:22:34 <TheJulia> That really puts it in spec territory
15:22:47 <TheJulia> But, a little more detail first might help the discussion
15:24:03 <JayF> OK, who wants to be bug deputy this week?
15:24:36 <cid> I will be bug deputy this week. I think most folks will be out.
15:24:36 <TheJulia> I can, but I won't be around next monday
15:24:45 <TheJulia> cid: ack
15:24:51 <JayF> #note CID to be bug deputy again
15:24:58 <JayF> #topic Open Discussion
15:25:18 <JayF> As a first note for open discussion, I'll be out the last half of this week traveling so if you need something from me speak soon :)
15:26:04 <TheJulia> Fair, I'll be out next week
15:27:04 <janders> Since it's quiet I will go: I have a question related to hardware health monitoring (https://review.opendev.org/c/openstack/ironic/+/966946). In one of the reviews Steve asked me if there is an issue or a spec for this. From the PTG discussion it seemed to me this is lightweight enough not to need one. Am I right or do you feel there is further
15:27:04 <janders> discussion needed about this? Asking so I can give Steve a solid answer.
15:28:08 <JayF> my usual personal rule is to make a rfe bug if someone asks for one
15:28:16 <JayF> and upgrade that to a spec if demanded in the meeting
15:28:26 <JayF> but that's not like, policy, just now I approach ti
15:28:29 <TheJulia> I think consensus was largely "we agree to the idea", but we didn't require a spec. RFE bug does make sense to just treat as something approved to track it
15:28:44 * dtantsur finally back to the screen
15:28:59 <dtantsur> JayF: force deletion won't clean up anything, that's a big issue now
15:29:11 <dtantsur> (cache, PXE configs, neutron configs, you name it)
15:29:22 <dtantsur> also right now force deletion is only possible in a couple of states
15:29:55 <JayF> That helps focus the use case for sure
15:30:19 <dtantsur> TheJulia: retired is an entire different purpose (planned retirement vs "this thing burned in its track")
15:30:49 <TheJulia> fair enough, why an entirely new db field though?
15:30:53 <dtantsur> Think about getting a bricked machine out of the provision state samsara
15:31:06 <dtantsur> TheJulia: so that various code throughout Ironic can stop doing what it's tryign to do
15:31:30 <dtantsur> e.g. trying to power it on/off during cleaning, even though the thing will never respond to IPMI packages ever again
15:31:31 <TheJulia> Well, if there is an open task, they aren't going see if if they currently hold another task
15:32:07 <TheJulia> (sort of feels like something we should be doing with the state machine too, but more pondering needed)
15:32:14 <dtantsur> That's a fair point. Another part of it is to be able to reject new tasks.
15:32:39 <dtantsur> Also, your long-running task spec may make TaskManager re-entrant
15:33:02 <JayF> If y'all are Ok with this discussion happening outside the meeting, I'm going to close up the official logger?
15:33:04 <TheJulia> eh, sort of, but i have no time to revisit that at hte moment
15:33:17 <dtantsur> sure, it's not urgent
15:33:24 <dtantsur> in fact, I won't have time to work on it in any near future
15:33:31 <TheJulia> Really, the deferred task bit expects the state might change on the task itself, at least, that is how I envisioned it
15:33:33 <dtantsur> (but maybe some interns...)
15:33:42 <TheJulia> fair far
15:34:09 <TheJulia> dtantsur: could you put a little more clarity in to the RFE and lets try to revisit the discussion in a few days?
15:34:20 <TheJulia> Just give brains time to do the brain thing
15:34:46 <dtantsur> definitely. I want to write the thought down before I forget it
15:34:52 <dtantsur> (squirell brain, you know)
15:34:59 <TheJulia> fair fair
15:35:39 <JayF> Any other topics for Open Discussion?
15:35:58 <janders> I will create that RFE for monitoring.
15:36:03 <janders> Thanks!
15:36:38 <JayF> That does it for the Ironic meeting, thanks all, see you next week same metal-time, same metal-channel o/
15:36:40 <JayF> #endmeeting