15:01:28 <TheJulia> #startmeeting ironic
15:01:28 <opendevmeet> Meeting started Mon Feb 23 15:01:28 2026 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:28 <opendevmeet> The meeting name has been set to 'ironic'
15:01:30 <TheJulia> o/
15:01:39 <dtantsur> o/
15:01:44 <TheJulia> Everyone getting cofffffeeeeee?
15:01:55 <rpittau> o/
15:02:02 <JayF> o/
15:02:27 <clif> o/
15:02:35 <dtantsur> 4pm, so today's 4 coffees should be enough :)
15:02:36 <TheJulia> It feels like we're just going to scrape by with Quorum this week
15:02:56 <TheJulia> Welcome to this week's crazy zaney ironic meeting featuring US!
15:03:07 <TheJulia> Our agenda, as always, can be found on the wiki!
15:03:09 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic#Agenda_for_February_23.2C_2025
15:03:22 <TheJulia> #topic Announcements / Reminders
15:03:57 <TheJulia> As a standing reminder, please take time this week to review ironic-week-prio items. Furthermore, this week is R-5, which means openstack feature freeze, requirements freeze, client release freeze.
15:04:10 <TheJulia> So, we need to get a bunch of stuff landed this week, in other words.
15:04:14 <TheJulia> #link https://tinyurl.com/ironic-weekly-prio-dash
15:04:25 <TheJulia> #link https://releases.openstack.org/gazpacho/schedule.html
15:04:44 <cid> o/
15:05:05 <TheJulia> Beyond that, it seems the metal3-integration job has been fixed and we've been asked to re-instate the ci job
15:05:13 <TheJulia> #link https://review.opendev.org/c/openstack/ironic/+/977006
15:05:28 <TheJulia> NVMD, already workflowed!
15:05:43 <TheJulia> Anyone have anything else to announce or remind us of?
15:06:11 <TheJulia> Next up, working group updates!
15:06:16 <TheJulia> #topic Working Group Updates
15:06:36 <TheJulia> First up is standalone networking
15:06:38 <TheJulia> #link https://etherpad.opendev.org/p/ironic-standalone-networking
15:06:45 <TheJulia> alegacy_: anything for us this morning?
15:07:58 * TheJulia takes silence as no
15:08:17 <TheJulia> #link https://etherpad.opendev.org/p/ironic-asyncio
15:08:23 <TheJulia> dtantsur: anything regarding asyncio ?
15:08:35 <dtantsur> I'm fresh out of 2 weeks of PTO and have no idea who I am and what I'm doing here :D
15:08:46 <dtantsur> if anything has been happening, I'm blissfully unaware
15:08:51 <TheJulia> fair enough
15:09:08 <TheJulia> #link https://etherpad.opendev.org/p/ironic-vxlan
15:09:32 <TheJulia> So, the vxlan status is we've got a CI job ready to roll and it works with vxlan and geneve set as the types for OVN networks.
15:10:08 <dtantsur> Wow, it's moving rapidly, good job!
15:10:22 <TheJulia> That being said, there are a number of patches to review https://review.opendev.org/q/topic:ironic-vxlan+status:open
15:10:45 <TheJulia> Most critically are NGS changes right now as well as the remaining networking-baremetal patches, that being said there are also two patches against ironic and docs as well.
15:11:49 <TheJulia> Please if your willing to extend a little trust, go ahead and approve the n-g-s patches. If you'd like to go look at a successful run for two jobs (although, an unrelated other race condition impacted the overall patchset), see: https://review.opendev.org/c/openstack/networking-baremetal/+/977081
15:11:57 <TheJulia> Any questions/concerns?
15:12:52 <dtantsur> n-g-s docs will need a bit of clean up
15:13:24 <TheJulia> the proposed docs, or pre-existing docs?
15:13:39 <dtantsur> the proposed docs make the issues in pre-existing docs even worse
15:13:53 <dtantsur> not a blocking concern, but I think they may be unreadable now
15:14:17 <dtantsur> (see my comment on one of the patches)
15:15:12 <TheJulia> Yeah, we're going to need to likely restructure the docs heavily
15:15:27 * TheJulia adds that to the next topic's etherpad
15:16:02 <TheJulia> Anything else?
15:16:26 <TheJulia> #topic Discussion Topics
15:16:30 <TheJulia> #link https://etherpad.opendev.org/p/ironic-ptg-2026.2
15:17:06 <TheJulia> First and only item is the PTG. Iury created us an etherpad and I realize some ideas have started to flow into it.
15:17:24 <TheJulia> Is there anything we feel we need to discuss, or do we just need to remind folks to engage and put items in?
15:18:04 <dtantsur> some items need more context
15:18:11 <TheJulia> Indeed
15:18:26 <TheJulia> We're like 2 months out from the PTG
15:18:37 <TheJulia> so, we have time, just wanted to highlight and try and get people to begin engaging
15:19:37 <JayF> I'll note that I intend on working with Nova to get us a shared ptg session to try to improve the Nova compute service ha/startup time story
15:19:49 <JayF> I've already talked a little bit with Sean, but I'm going to have a personal goal of landing a spec in hibiscus
15:20:30 <TheJulia> Given challenges getting the console stuff in, I've also wondered if we need to leverage AI agents and make a serious effort with ironic-ui this coming cycle
15:20:58 <TheJulia> Control our own destiny and whatnot.
15:21:09 <dtantsur> hint: adding ironic-ui to bifrost would make it much easier for anyone to test/extend it
15:21:32 <JayF> The idea of it is nice, but I worry that we don't have anyone who would recognize or know when horrible UI code is being written
15:21:47 <dtantsur> isn't all UI code horribe? :-P
15:21:50 <JayF> I've held on to the idea that these tools can be dangerous. If you don't have an experienced person reviewing them. Do we really have enough people who feel confident reviewing ironic UI code to make significant feature progress?
15:22:13 <JayF> Part of the reason I have well-formed thoughts on this is that I've had the exact same thought as Julia has and so I've gone back and forth in my own head about it
15:22:19 <TheJulia> JayF: added an item
15:22:36 <dtantsur> If we rewrite it from using a lot of JS to a good old django-serving-HTML, I'll feel comfortable reviewing it
15:22:43 <dtantsur> I think the JS frameworks is the problem for this group
15:23:12 <TheJulia> I'm going to be honest, the UI is actually a lot simpler, but takes a little time to grok how it is put together, Happy to spend time walking folks through reviews of it
15:23:27 <TheJulia> Well, JS frameworks in general
15:23:36 <TheJulia> the issue is, it has to be compatible with horizon as it is a plugin.
15:24:13 <JayF> As long as we have humans with understanding approving changes and not just rubber stamping PR's based on screenshots and clicking around, I'm on board
15:24:42 <TheJulia> Okay, anything else to discuss regarding the PTG?
15:26:50 <TheJulia> #topic Bug Deputy Updates
15:27:06 <TheJulia> Who was our bug deputy for the last week or two?
15:27:25 <cid> I did bug triages this week. There were 5 newly reported bugs
15:27:49 <cid> Specific links on teh wiki https://wiki.openstack.org/wiki/Meetings/Ironic
15:28:39 <TheJulia> cardoe: was it you, or jayf who was talking about trying to improve exceptions out of nova recently?
15:29:03 <JayF> I've been gone for a week so if I was talking about it I certainly don't remember it now
15:29:50 <cardoe> Could have been me?
15:29:58 <TheJulia> maybe?!
15:29:59 <TheJulia> https://bugs.launchpad.net/ironic/+bug/2141635
15:30:00 <cardoe> I've complained about it.
15:30:10 <TheJulia> Many have :)
15:30:21 <cardoe> Yes that bug is what I've got.
15:30:54 <cardoe> 2137673 as well in my notes
15:31:10 <cardoe> https://bugs.launchpad.net/nova/+bug/2137673 maybe?
15:32:27 <TheJulia> so it feels like the bug I linked is a duplicate
15:32:29 <TheJulia> at this point
15:33:02 <cardoe> https://review.opendev.org/c/openstack/nova/+/972601 looks like my fix failed tests... I'll figure out why.
15:33:15 <cardoe> But the question is... will the nova folks merge it?
15:33:32 <TheJulia> Maybe a cross-project session?
15:33:48 <cardoe> I mean I would love to get the trunk stuff done.
15:34:00 <cardoe> But they've worn me down.
15:34:07 <TheJulia> :(
15:34:27 <TheJulia> I've heard this same story many times, we need to recharge ourselves.
15:34:33 <cardoe> It literally has a spec and an implementation and tests and even a tempest test.
15:34:41 <opendevreview> Merged openstack/ironic master: Re-enable metal3-integration  https://review.opendev.org/c/openstack/ironic/+/977006
15:34:47 <opendevreview> Merged openstack/ironic master: fix: missing comma in VENDORS_REQUIRING_FULL_BOOT_REQUEST  https://review.opendev.org/c/openstack/ironic/+/977571
15:35:07 <TheJulia> Console stuff is in a similar boat
15:35:28 <TheJulia> They even demanded we refactor tempest stuffs to make it cleaner and... yeah.
15:36:26 <JayF> Once you've got Sean's plus two on stuff over there, you often have to fight and fight for someone else to look
15:36:39 <JayF> Ironic is just not on anyone's radar by default so you have to be noisy to get anything merged in our driver, no matter how trivial
15:37:03 <JayF> I don't think there's any malice, just out of sight out of mind and everyone being busy with their own stuff
15:37:07 <cardoe> Yeah I've attended the nova meeting and got a promise someone would look at it.
15:37:13 <JayF> I would literally be posting that change in their IRC twice a week or more
15:37:44 <TheJulia> I think the issue in part is by culture in ironic, we really try not to be jerks about stuff, but... at some point maybe we need to be
15:37:44 <TheJulia> dunno
15:37:57 <TheJulia> Anyway, last item for the Bug Deputy Updates, who is going to be the deputy for this next week?
15:37:58 <dtantsur> A new AI bot: nagging-nova-as-a-service
15:38:01 <clif> just be... persistently annoying?
15:38:29 <cardoe> Need one for neutron too
15:38:37 <JayF> It comes naturally to me Clif 😂
15:38:56 <TheJulia> Yeah, we would (still are?!?) waiting for reviews over there and wouldn't have made any vxlan progress if we were still waiting
15:40:12 <cardoe> So https://review.opendev.org/c/openstack/ironic/+/973381 is a stupid little tool for testing inspection rules. Thinking about making it a real boy entry point script that installs with the package so I can use it with uvx. Thoughts? The TBN simulator can be done as well.
15:41:31 <TheJulia> cardoe: make it a real testing robot?!
15:41:39 * TheJulia likes the idea
15:41:49 <cardoe> I'm trying to have a lot more of our hardware handling be native in Ironic so I've been encouraging folks to set traits on the boxes. So my thought is I take some "openstack baremetal node show <node-id> -f yaml > node-id.yaml" dumps of a couple of representative machines. I also take some dumps of "openstack baremetal node inventory save <node-id> -f yaml > node-id-inventory.yaml"
15:42:13 <cardoe> Well this is for my own repo but I'm happy to commit something into Ironic CI
15:42:36 <TheJulia> Sounds generally useful
15:42:45 <cardoe> My folks would have to have their rules files pass against my tester from 973381.
15:43:25 <cid> ++
15:43:26 * cid will be bug deputy.
15:43:42 <cardoe> It takes the syntax of "rules-tester.py node-id.yaml node-id-inventory.yaml rules.yaml" and it spits out the results of what it would do. But it's also got a -f json mode and it outputs the results as JSON.
15:44:05 <TheJulia> Cool cool
15:44:10 <cardoe> So I've got a GitHub Action right now that confirms that trait XYZ has been set as a result of that rules file being applied.
15:44:18 <TheJulia> Since we have no open bug topics
15:44:23 <TheJulia> err, RFE topics
15:44:28 <TheJulia> #topic Open Discussion
15:44:35 <TheJulia> Any (additional) open discussion this morning?
15:44:46 <cardoe> Well finishing that thought...
15:45:04 <cardoe> Should the entry point be generic "ironic-sim" or something?
15:45:28 <cardoe> "ironic-sim rules" and "ironic-sim tbn" and "ironic-sim <next thing>"
15:45:59 <cardoe> or "ironic-inspection-rules-sim" and "ironic-tbn-sim" as two separate entry points.
15:46:21 * dtantsur votes from less generic and more verbose
15:46:22 <JayF> I'm partially back a week early. Recovering well from my surgery. I'm going to be doing some useful stuff in stealth this week, but if you need my brain for anything in particular I'm wide open so it's a good week to ask for it.
15:47:28 <TheJulia> JayF: would a review-jam be of interest where you don't have to drive?
15:48:24 <JayF> I'm always up for a review jam
15:48:30 <JayF> Preferably not today simply because my brain is not warmed up TBH
15:49:18 <cardoe> JayF: ya gonna make me write a release note for https://review.opendev.org/c/openstack/ironic/+/977498 ?
15:50:01 <cardoe> I'm up for a review jam.
15:50:13 <JayF> cardoe: if you have to ask, you know the answer
15:50:14 <TheJulia> Would tomorrow work?
15:50:22 <JayF> Yes. After 9:00 a.m. Pacific
15:50:29 <TheJulia> does that work for other folks?
15:50:31 <dtantsur> I can do 1500 or 1700 UTC tomorrow
15:50:33 <cardoe> I'd appreciate some feedback on https://review.opendev.org/c/openstack/ironic/+/976626 which is trying to add storage controller details to inspection.
15:50:47 <cardoe> JayF: well it's not user visible. It's a @staticmethod decorator that's missing.
15:50:54 <JayF> Got to take my kitty to the oncologist 😕
15:51:04 <cardoe> So I didn't know what to write in the note.
15:51:27 <JayF> cardoe: you only need a release note if it's operator facing. It's only operator facing in this case if it was in an API interface base class like a base driver
15:51:43 <TheJulia> JayF: :(
15:51:49 <dtantsur> Wouldn't the bug in question cause a user-visible failure?
15:52:11 <TheJulia> dtantsur: 1700 UTC would be 9 am pacific, does that time work for everyone?
15:52:15 <opendevreview> Merged openstack/ironic master: Add a `reattach_networking` service step  https://review.opendev.org/c/openstack/ironic/+/973413
15:52:48 <cardoe> dtantsur: I don't get how it's not causing a user facing error.
15:53:05 <JayF> TheJulia: if you can, send out a meeting invite?
15:53:12 <cardoe> That works for me.
15:53:18 <TheJulia> #action Julia to send a meeting invite for tomorrow
15:53:23 <TheJulia> Anything else discussion wise?
15:53:37 <TheJulia> Time check, 6 minutes to the top of the hour.
15:56:40 <TheJulia> #topic Who will run the next meeting?
15:56:48 <TheJulia> Any volunteers for our next meeting?
15:57:43 <JayF> I will
15:58:49 <TheJulia> Cool cool
15:58:51 <TheJulia> Thanks everyone!
15:59:44 <TheJulia> Meeting invite sent to Jay, Doug, Dmitry, and myself, if anyone else wants an invite please ping me with your email address
16:00:09 <TheJulia> And with that, thanks for another great ironic meeting, and remember to review ALL THE THINGS (this week)! :)
16:00:11 <TheJulia> #endmeeting