15:00:19 <JayF> #startmeeting Ironic
15:00:19 <opendevmeet> Meeting started Mon Mar  2 15:00:19 2026 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:19 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:19 <opendevmeet> The meeting name has been set to 'ironic'
15:00:36 <JayF> Welcome to the Ironic meeting everyone! I'm going to refresh the coffee and wait for quorum :)
15:00:50 <alegacy_> o/
15:00:58 <rpittau> o/
15:01:37 <TheJulia> o/
15:01:47 <dtantsur> o/
15:01:51 * TheJulia presses the coffee machine button
15:02:07 <Mahnoor> o/
15:02:15 <JayF> okay caff has begun to flow :)
15:02:24 <opendevreview> Riccardo Pittau proposed openstack/ironic-python-agent master: [DNM] TEST CI  https://review.opendev.org/c/openstack/ironic-python-agent/+/978486
15:02:25 <JayF> #topic Announcements/Reminders
15:02:42 <JayF> Please review patches hashtagged "ironic-week-prio" and hashtag your ready to review patches
15:02:50 <JayF> #link https://tinyurl.com/ironic-weekly-prio-dash
15:03:15 <JayF> The release is LOOMING. It's R-4. Cycle highlights are due this week.
15:03:22 <JayF> #link https://releases.openstack.org/gazpacho/schedule.html
15:03:39 <JayF> #topic Working Group Updates
15:03:48 <JayF> Standalone networking is first up. alegacy_?
15:04:14 <alegacy_> Only outstanding change is the bifrost patch: https://review.opendev.org/c/openstack/bifrost/+/962394
15:04:21 <cid> o/
15:04:28 <alegacy_> other than that, I owe a couple of minor follow-ups which I plan to get to in the next week or so
15:04:37 <cardoe> alegacy_: it's failing CI so I removed ironic-week-prio on it.
15:05:05 <alegacy_> ok, i'll check.  thanks.
15:05:20 <JayF> Congrats on a successful project \o/
15:05:26 <JayF> What about AsyncIO? Any updates there?
15:05:49 <cardoe> I believe the spec has been pushed and needs some feedback from everyone else.
15:06:06 <dtantsur> Yep, collecting more feedback
15:06:10 <TheJulia> I think a review jam to review/discuss would be good
15:06:14 <dtantsur> Otherwise, I'm really short on time to code anything... :(
15:06:22 <cardoe> https://review.opendev.org/c/openstack/ironic-specs/+/972754
15:06:36 <JayF> Who wants to own scheduling said jam?
15:06:41 <JayF> [touches nose[
15:06:42 <cardoe> Once we cut 2026.1 from master of ironic, I'm gonna try and bring sushy into the ironic code base.
15:06:54 <TheJulia> I can own scheduling it
15:07:03 <JayF> #action TheJulia to coordinate review jam for asyncio spec
15:07:06 <TheJulia> folks, when would we like to meet, tomorrow? Wednesday?
15:07:18 <TheJulia> Friday?
15:07:22 <JayF> Last but not least, VXLAN Networking ... is this another story of celebration time?
15:07:51 <JayF> TheJulia: tomorrow after 11am (or at 10am PST if we wanna roll it into GR-OSS review jam downstream)
15:07:51 <cardoe> Biggest item for VXLAN networking are the docs... https://review.opendev.org/c/openstack/ironic/+/977102 Jay and I have +2'd it but he's got valid concerns in comments.
15:08:09 <cardoe> I suspect we'll shake out those items as follow on changes however but I wanted to let TheJulia weigh in.
15:08:10 <JayF> TheJulia: or thursday with a couple of 30 minute chunks in the way, or friday after noon
15:08:14 <TheJulia> The whole kit and caboodle of vxlan stuffs, except for a docs patch or two has landed. Direction is likely to shift to testing/sharp edge removal next.
15:08:26 <JayF> I'll call it mostly done \o/
15:08:33 <rpittau> TheJulia, alegacy_: I'm holding the bifrost release until end of this week for OCI registry support and standalone networking
15:08:36 <JayF> Is there anyone specifically doing cycle highlights yet?
15:08:40 <JayF> If not; I'll take the action
15:08:53 <TheJulia> I have not, I'm trying to prepare a blog post for ironicbaremetal.org
15:09:03 <JayF> sounds like a good segmentation of work
15:09:05 <TheJulia> I think we'll want to do *several* posts
15:09:06 <JayF> we can each see if we miss something
15:09:13 <JayF> #action JayF to draft cycle highlights
15:09:23 <JayF> Moving on to
15:09:27 <JayF> #topic Discussion Topics
15:09:32 <JayF> two are listed here; first is PTG
15:09:39 <JayF> #link https://etherpad.opendev.org/p/ironic-ptg-2026.2
15:09:55 <JayF> I-personally haven't taken the time I should on this yet; I'll dig into it some today
15:10:28 <TheJulia> We're still in early idea phase, that is sure based upon the state of the etherpad
15:10:56 <JayF> I suggest the team make a special effort to populate PTG etherpad further this week so maybe we can have a bigger chat about it next week-ish?
15:11:09 <TheJulia> I agree
15:11:32 <JayF> Second item for discussion is https://review.opendev.org/c/openstack/ironic/+/973279/4/ironic/conductor/deployments.py
15:11:40 <JayF> some weird behavior came to light in this change:
15:11:52 <JayF> if we ABORT a state that's on the last step, that last step can't be aborted ... we just let it finish
15:12:07 <JayF> this is existing behavior in CLEANING/SERVICING and was proposed for DEPLOYING there when I got confused and raised a flag
15:12:33 <JayF> my preference, after talking with dtantsur is that we land his change with consistent behavior, then make the behavior abort in all cases (or at least configurable)
15:12:54 <JayF> it seems very operator-expectation-breaking that ABORT on a DEPLOYWAIT node could end in ACTIVE
15:13:09 <dtantsur> yeah, it may be a nightmare to program the state machine for a consumer
15:13:14 <TheJulia> I'm onboard with that plan. It feels like a bit of a hyper-optimizaiton, but also likley best if we take the most recently requested action
15:13:23 <TheJulia> as it obviously superceeds the original request
15:13:39 <JayF> I'm thinking when this matters, it really matters -- like abuse preventation trying to block builds in flight
15:13:42 <TheJulia> But, we don't have to iterate to get it right on that patch, it can be a follow-up since it really is a bug fix
15:13:52 <JayF> exactly, it's actually better if we make it consistently gross
15:13:54 <JayF> then fix it
15:14:00 <JayF> than if we make it inconsistent and leave a loose thread
15:14:10 <opendevreview> Allain Legacy proposed openstack/bifrost master: Add support for standalone ironic networking  https://review.opendev.org/c/openstack/bifrost/+/962394
15:14:15 <JayF> at least then it's a full consistent story
15:14:15 <TheJulia> Or, even if we document it and then fix it later
15:14:22 <TheJulia> I'm just wanting to make sure we don't forget it
15:14:33 <JayF> yeah, my comment on the review was to JFDI fix it or bug it
15:14:36 <JayF> I think a bug is the right route
15:15:03 <JayF> Any other thoughts/input on this before moving on?
15:15:07 <TheJulia> a bug gives us a basis for fixing in backport as well which we can weigh once we have a patch
15:16:34 <JayF> moving on
15:16:37 <dtantsur> I can file a bug or do you want to JayF?
15:16:45 * dtantsur would appreciate a W+1 now
15:16:48 <JayF> if you wanna do it r/n I won't complain
15:16:52 <JayF> and if you link it I can approve
15:16:55 <dtantsur> ack
15:16:56 <JayF> #topic Bug Deputy Updates
15:17:01 <JayF> Who was bug deputy?
15:17:16 <cid> I was bug deputy
15:17:33 <cid> I found two newly reported bugs and two possible RFEs
15:17:39 <cid> Link on the wiki page
15:18:00 <cid> First RFE is already somewhat discussed
15:18:01 <cid> https://bugs.launchpad.net/networking-generic-switch/+bug/2142771 - Cache and reuse ssh connections
15:18:35 <JayF> seems a little like an obvious one, but I'd warn the implementor about sessino limits
15:18:37 <TheJulia> I'm good with the idea, I've not sat down and thought through the fine details there
15:18:46 <JayF> there are some switches which those peristent connections might choke out other connections to the switch
15:18:53 <JayF> e.g. if you can only have one or two incoming ssh sesh at a time
15:18:59 <TheJulia> JayF: they are already aware and have set it for a per-switch knob
15:19:37 <JayF> I am +1 to approving 2142271
15:19:45 <TheJulia> Same
15:19:56 <TheJulia> I think the value benefit makes a nice and strong case
15:19:57 <cid> Cool, cool.
15:20:00 <cid> The second is only an RFE if we determine it to be
15:20:09 <cid> https://bugs.launchpad.net/networking-generic-switch/+bug/2142786
15:20:21 <cid> The question is if we should honor `ngs_max_connections` limit with a file locks fallback when `backend_url` is not provided.
15:20:31 <cardoe> So this is almost similar to the NGS agent idea.
15:22:08 <TheJulia> Yeah, I'm honestly kind of split on that one. I think its the right move to do it (i.e. as proposed in the lp item), but the basic challenge is we're talking older style OSes versus more modern multi-user switch OSes
15:22:19 <TheJulia> Its a super weird line for us to walk as well
15:22:45 <TheJulia> because if we artificially force all OSes into the oldest OS pattern, we actually force sub-optimal behavior
15:22:56 <TheJulia> so... its a weird one I guess.
15:23:07 <JayF> sounds like as much a docs bug as a bug-bug
15:23:18 <JayF> since fixing it would maybe add a decoder ring for folks to figure out to "fix" performance
15:23:26 <TheJulia> Yeah, kind of is. Requires some context and "know thy network gear"
15:23:46 <cid> Yeah!
15:23:47 <cid> FWIW, I already pushed a patch over the weekend to just log a warning, now merged (thanks to TheJulia, cardoe) which I believe is a good enough immediate addressing of the original report.
15:24:33 <cid> That's all the updates I have. Also happy to take up the role for next week unless someone else volunteers
15:24:47 <TheJulia> Yeah, I concur, I think doing anything more than just adding clarifying documentation does become a bit problematic. But shermanm did say most of the switches are dell OS9 and OS10, OS9 being the more problematic ones.
15:25:31 <JayF> Does anyone want to ensure there's not a cid-shaped rut in our Bug Deputy station?
15:25:35 <JayF> :D
15:25:49 <TheJulia> I'll take it on this week
15:25:58 <JayF> #action TheJulia as bug deputy
15:26:06 <JayF> Next topic is RFE review, which we did inline. Skipping it.
15:26:10 <JayF> #topic Open Discussion
15:26:17 <dtantsur> Speaking of bugs, https://bugs.launchpad.net/ironic/+bug/2143060 is the requested bug about aborting actions
15:26:23 <JayF> No premade agenda items here; anyone have anything for open discussion?
15:26:42 <TheJulia> I was assuming open discussion would be a giant party?
15:26:49 <dtantsur> party \o/
15:27:11 <TheJulia> Seriously everyone, we've made some huge strives this cycle. Three major networking pushes all at once
15:27:11 <dtantsur> Spring is here \o/ (except for those on the bottom half of the Earth - sorry folks!)
15:27:42 <TheJulia> spring++
15:27:42 <JayF> Who wants to chair the next meeting on March 9?
15:28:00 <JayF> I'll do it again. I probably owe a few :D
15:28:06 <JayF> #action JayF to chair March 9 meeting
15:28:12 <TheJulia> heh
15:28:20 <JayF> That's going to bring the meeting to a close. Please stay for an afterparty, apparently.
15:28:21 <JayF> #endmeeting