15:00:03 <JayF> #startmeeting Ironic
15:00:03 <opendevmeet> Meeting started Mon Mar  9 15:00:03 2026 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:03 <opendevmeet> The meeting name has been set to 'ironic'
15:00:09 <alegacy> o/
15:00:13 <kubajj> o/
15:00:16 <Mahnoor> o/
15:00:17 <clif> o/
15:00:24 <JayF> Hello everyone! Many of your clocks may look strange but the meeting is right on (UTC) time :D
15:00:34 <TheJulia> o/
15:00:44 <TheJulia> Good morning!
15:00:56 <JayF> This is your courtesy annual warning that meetings shared between US-ians and non-US-ians are going to be silly for a few weeks as clocks mismatch :D
15:01:06 <JayF> #topic Announcements/Reminders
15:01:13 <dtantsur> o/
15:01:16 <JayF> #link https://tinyurl.com/ironic-weekly-prio-dash
15:01:20 <rpittau> o/
15:01:26 <JayF> Make sure to review #ironic-week-prio patches, please. We are nearly at 0 last I checked.
15:01:35 <TheJulia> 2, we have 2.
15:01:37 <JayF> Also set hashtag:ironic-week-prio on things you want reviewed
15:02:07 <JayF> Gazpacho release is flying down the track, it's R-3 which is RC1 target week for most (not us) openstack deliverables
15:02:18 <JayF> #link https://releases.openstack.org/gazpacho/schedule.html
15:02:21 <rpittau> we're definitely on track :)
15:02:30 <JayF> #topic Working Group Updates
15:02:40 <cardoe> And make sure your stuff is actually ready to review... otherwise I'm kicking it outta that tag.
15:02:40 <JayF> speaking of being on track, I think we're going to have a lot of "it's done" for these :D
15:02:55 <JayF> Any updates for Standalone networking? alegacy?
15:03:17 <dtantsur> I think Allain is now busy with the Metal3 side mostly
15:03:33 <alegacy> Looks like the last change (bifrost) is going to merge soon.  Other than that working on getting this integrated into Metal3!!
15:03:42 <JayF> #note Standalone networking is feature-complete for Gazpacho, and focus has moved on to implementing it in Metal3.
15:03:47 <alegacy> ...and working on some minor follow-ups that I owe
15:03:53 <JayF> Good stuff!
15:04:16 <JayF> AsyncIO updates? dtantsur
15:04:34 <dtantsur> I need to check the comments on the spec
15:04:52 <dtantsur> After that, I'll be looking for someone to help me with actual coding, unless I magically find much more time :-/
15:05:18 <JayF> I don't have any suggestions; I don't think that's likely to be a priority for my team.
15:06:24 <TheJulia> Sensor data is sort of useful :)
15:07:12 <JayF> #note AsyncIO spec nearing merge; looking for interested volunteers to help implement asyncio for sensor data in H
15:07:24 <JayF> finally, VXLAN networking. TheJulia? cardoe?
15:07:35 <cardoe> I think we're in a good place.
15:07:47 <cardoe> I need to deploy what we've landed and kick the tires some in a real environment.
15:08:30 <TheJulia> Vxlan got all the key patches landed. That being said hjensas has been moving through individual switch drivers and working on doing specific case testing where we will have some backportable fixes as we move forward and it looks like I'll need to do multicast vxlan support as well which we'll land in the next cycle.
15:09:26 <JayF> #note VXLAN implementation is in place. Fixes are coming as the implementation integrates with the real world. Next up will be multicast support in VXLAN in H.
15:09:31 <JayF> #topic Discussion Topics
15:09:36 <JayF> We have a PTG incoming!
15:09:43 <JayF> #link https://etherpad.opendev.org/p/ironic-ptg-2026.2
15:10:02 <JayF> Everyone should be dedicating time to reviewing PTG etherpad, putting details on ideas in there and such.
15:10:27 <JayF> I'll personally be sending an email this week proposing a nova/ironic shared PTG session around impoving the startup story for nova-compute w/ironic driver
15:11:12 <TheJulia> I reached out to Neutron, they are likely a few weeks behind us in figuring out their PTG but there does already seem to be consensus in doing some sort of session
15:11:37 <JayF> About what, specifically?
15:12:05 <TheJulia> Two items, they have a bug regarding our lacking support of vlan transparency which is their name for handing whole trunk ports to "instances"
15:12:05 <cid> o/
15:12:35 <TheJulia> The other is in hind sight looking at the networking-baremetal mech driver stuff, I think mech drivers should be able to "push an e-stop on binding"
15:12:39 <JayF> oh, neat. We have no way of modeling that whatsoever. That sounds like it's going to be painful.
15:12:46 <JayF> ++
15:13:17 <JayF> #action JayF emailing list about nova/ironic shared PTG session around nova-compute onlining (resource tracking, placement, etc)
15:13:19 <TheJulia> because it *IS* actually possible for the mech driver to sanity check and say "no, this ain't going to work" and we really should use a defensive with feedback model as a opportunistically try to make this work model with ml2 drivers.
15:13:38 <JayF> #note TheJulia working with neutron for a joint session on vlan transparency and failure modes inside ML2 drivers
15:15:20 <JayF> #topic Bug Deputy Updates
15:15:28 <TheJulia> Actually, vlan transparency is one of those cases where we should likely go  "no, you don't bind this"
15:15:29 <JayF> we don't have labelled here who the deputy was
15:15:33 <TheJulia> Oh, sorry, I was
15:15:36 <JayF> #undo
15:15:36 <opendevmeet> Removing item from minutes: #topic Bug Deputy Updates
15:15:37 <TheJulia> we had one bug come in
15:15:54 <JayF> Why wouldn't Ironic support binding trunk ports?
15:16:21 <JayF> do we require more information? e.g. we won't hook into a network at L2 only, we need L3 deets?
15:16:22 <TheJulia> Well, today we can't and in that model if it was QinQ, it would be okay
15:17:02 <TheJulia> but ultimately at some level also handing an "instance" "everything vlan wise" and having no outer bound on what gets passed, it starts to get a bit concerning.
15:17:13 <JayF> you'd almost have to have code in ironic that borderline could be used to create a full router/switch
15:17:31 <JayF> if you were trying to serve use cases like passing thru an l2 vlan, without having an ip on it, to a VM
15:18:03 <JayF> any case you get to of "I want this bare metal machine to have a trunk port, but I don't want to tell you the VLANs/networks/IPs off that trunk port" would end up with unbounded complexityh
15:18:05 <TheJulia> That is orthognal to the issue really. The use case for vlan transparency is "I have a VNF workload, and I 'trust' it to do what it needs to do networking wise
15:18:08 <JayF> I think I see what you're saying now
15:18:53 <JayF> TheJulia: like, deploying an application image onto bare metal that contained [networking lb software] for instance?
15:19:03 <JayF> I am trying to crystalize this into a use case so I can understand
15:19:15 <TheJulia> yeah, and the application and even it's configuration is a blackbox to the infrastucture, but it has to tie in deeply with it
15:19:39 <TheJulia> Or maybe not, *shrug*. Sort of why we need to have a longer chat than a short back and forth in a bug
15:19:41 <JayF> I guess if we were somehow able to scope out configdrive information
15:19:52 <JayF> it might be at least a small enough feature to implement
15:20:00 <JayF> but if we had to write out a network_json for god-knows-what
15:20:02 <JayF> :-|
15:20:20 <JayF> clearly PTG-level of discussion to happen there
15:20:24 <TheJulia> or, nobody knows what the config really is, but yeah
15:20:29 <JayF> #topic Bug Deputy Updates
15:20:34 <JayF> TheJulia was the bug deputy
15:20:34 <TheJulia> So yes, one new item
15:20:43 <TheJulia> #link https://bugs.launchpad.net/ironic/+bug/2143675
15:20:57 <TheJulia> Reads as a bug to me
15:21:07 <JayF> Ah yeah, I agree, clif found that doing TBN milestone 2
15:21:25 <JayF> It should be pretty straightforward if someone wanted an easy fix
15:21:40 <JayF> I'll point my brain and/or claude at it eventually if we don't get someone plucking the low hanging fruit soon enough :)
15:21:44 <clif> if no one takes it I'll work on it once I've got TBN milestone 2 mostly done
15:22:16 <TheJulia> Seems logical
15:22:22 <shermanm> if there are there cases where we know in advance that "x won't work", would it make sense to fail during precommit in the ml2 driver?
15:22:53 <TheJulia> shermanm: ideally yes, but today the ml2 manager code just ignores the exception
15:22:57 <JayF> shermanm: I think that was the second prong of what TheJulia said our session with Neutron was for; improving failure cases when dedected in an ML2 mech driver
15:23:29 <opendevreview> Merged openstack/bifrost master: Add support for standalone ironic networking  https://review.opendev.org/c/openstack/bifrost/+/962394
15:24:21 <JayF> Who will be the next bug deputy?
15:25:46 <cid> I will!
15:25:50 <JayF> Thanks!
15:26:01 <JayF> No RFEs for review, skipping that topic.
15:26:04 <JayF> #topic Open Discussion
15:26:14 <JayF> no topics preseeded here, the floor is open if anyone has an item for the meeting
15:27:23 <clif> I'll just say I'm aiming to have code up for review for TBN milestone 2 in the next day or so
15:27:31 <clif> Please take a look if you're interested
15:27:40 <TheJulia> clif: ack, thanks!
15:27:52 <JayF> Nice, thank you! I am working on ramdisk driver stuff too, doug w/stackhpc is testing my changes now so hopefully we can get that in too
15:29:18 <JayF> While the floor is open for more discussion items, someone want to volunteer to run the next meeting?
15:29:37 <JayF> I'm willing to if folks want me to keep running them, I don't really mind and it gives me a nice Monday morning kickstart
15:29:55 <JayF> especially now that it's 8a local instead of 7a local so I don't have to run the first 10 minutes of the meeting while finding caff :D
15:30:16 <TheJulia> I can likely run the next one if folks want
15:30:33 <JayF> You and I can trade off for a while, sure :D
15:30:46 <JayF> #note March 16 meeting to be chaired by TheJulia
15:30:52 <JayF> Last call for meeting discussion items.
15:32:54 <JayF> Thanks for coming!
15:32:56 <JayF> #endmeeting