15:00:00 <JayF> #startmeeting ironic
15:00:00 <opendevmeet> Meeting started Mon Mar 23 15:00:00 2026 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'ironic'
15:00:16 <JayF> Gooooood morning and welcome to the Ironic meeting. We're operating under the OpenInfra Code of Conduct as usual.
15:00:24 <JayF> I'll give a minute or five for people to trickle in.
15:00:29 <iurygregory> o/
15:00:36 <mumesan[m]> o/
15:02:13 <clif> o/
15:03:03 <cid> o/
15:03:18 <FreemanBoss[m]> o/
15:03:43 <opendevreview> Olamide Ojo proposed openstack/ironic master: Improve reference consistency of the intel-ipmi file  https://review.opendev.org/c/openstack/ironic/+/981789
15:04:06 <JayF> Looks like weak quorum if quorum at all :)
15:04:17 <JayF> I hope folks are off enjoying the downtime between releases, at least
15:04:23 <JayF> #topic Announcements/Reminders
15:04:33 <JayF> #link https://tinyurl.com/ironic-weekly-prio-dash
15:04:42 <JayF> Please review changes hashtagged ironic-week-prio
15:04:59 <JayF> If you have patches ready for review, passing CI, good to go, add hashtag "ironic-week-prio" to get them onto this dashboard
15:05:06 <JayF> #link https://releases.openstack.org/gazpacho/schedule.html
15:05:18 <JayF> We spent 6 months making a cold soup, and it's here :)
15:05:43 <JayF> This is R-1 week: last chance to cut any releases.
15:05:51 <JayF> There is an open question in the agenda: is all our stuff released?
15:06:00 <JayF> I don't know the answer for this for sure, I hope it's "yes"?
15:06:04 <cid> Weak quorum for sure
15:06:19 <iurygregory> I saw we cut off a lot of branches last week
15:06:29 <iurygregory> I can double check, riccardo is at kubecon this week
15:06:49 <JayF> Ironic, IPA, IPA-B all branches
15:06:57 <JayF> I'll spot-check the networking repos
15:07:18 <JayF> NGS/NBM both branched
15:07:33 <JayF> and the prometheus exporter
15:07:45 <JayF> if we remembered IPE; we remembered everything 🤞
15:08:00 <iurygregory> XD
15:08:04 <iurygregory> fair enough
15:08:25 <JayF> nothing https://review.opendev.org/q/repo:openstack/releases+status:open here for ironic
15:08:28 <JayF> so I call us good
15:08:38 <clif> branched means what in this context? these are release candidate branches?
15:08:51 <cardoe> 🎉
15:08:52 <JayF> I'm looking for `stable/2026.1` branches
15:09:00 <JayF> it means we have cut a release and indicated it is a part of the stable release
15:09:33 <clif> does that mean the release is 'live' or does it now go through a release process?
15:09:36 <JayF> for any of the projects that use a cycle-* model, that's the indicator that they've "branched". In cycle-with-rc (Ironic does NOT use this on any projects), the release from that stable/2026.1 branche could be an RC
15:10:01 <JayF> In cycle-with-intermediary (Ironic projects, most of them), the release for the 2026.1 release is cut atomically with the branch
15:10:41 <JayF> so at this point, all cycle-* deliverables (I think everything in Ironic sans virtualbmc/sushy-tools/clients) should have a stable/2026.1 branch, and in Ironic's case, that implies release automation already cut the release
15:11:22 <JayF> clif: to be as specific as possible: https://opendev.org/openstack/releases/commit/e4ea04eff8d543f16447bc2b25a55aa4ffca549f this change led to both the releases and the branch cut
15:11:38 <JayF> clif: iurygregory: Really, we should *also* validate the SHAs there map to the correct commits for the releases
15:11:52 <JayF> and that we don't need to backport anything into stable/2026.1 branch
15:12:04 <iurygregory> ++
15:12:36 <JayF> if those aren't a new enough commit, we backport stuff and add a key to that releases list with x.y.z+1 release and another sha
15:12:36 <clif> thanks for the rundown
15:12:39 <iurygregory> I will check things
15:13:13 <JayF> (or x.y+1.z or whatever based on changes, but generally for stable it should be patch releases only unless something exceptional is going on)
15:13:31 <JayF> That ends OpenStack Ironic Release Engineering 101, please study for the final exam Tomorrow /s
15:13:35 <JayF> #topic Working Group Updates
15:13:46 <JayF> We have Async IO here and VXLAN. I think stuff is mostly done?
15:14:23 <JayF> I'd suggest https://etherpad.opendev.org/p/ironic-asyncio and https://review.opendev.org/c/openstack/ironic-specs/+/972754 are good places to read if you're interested in asyncio+ironic.
15:14:30 <JayF> Anything on any of our working groups before I move on?
15:15:17 <JayF> Moving on.
15:15:23 <JayF> #topic Discussion Topics
15:15:30 <JayF> PTG is the only item here.
15:15:37 <JayF> #link https://etherpad.opendev.org/p/ironic-ptg-2026.2#L16
15:15:47 <JayF> cid has put together a rough/high level time allocation proposal for topics
15:15:58 <JayF> please review it, if you have any concerns/questions/etc please work with cid
15:16:23 <JayF> also as usual please make sure to take the time needed to review the PTG doc, participate in discussions/research async so we can reserve PTG time for discussing contention points :)
15:17:10 <cid> ++
15:17:49 <JayF> Alright. Our weak quorum is showing :D
15:17:53 <JayF> #topic Bug Deputy Updates
15:18:01 <cid> I intend to update the Mailing list within the week
15:18:19 <JayF> Mahnoor was the bug deputy last week. It looks like we have three new bugs that were in and triaged in NBM/NGS.
15:18:27 <JayF> Mahnoor: anything to comment here?
15:19:43 <iurygregory> I think it's public holiday for her, not sure she is around
15:19:52 <JayF> Ah, she did mention that didn't she.
15:20:09 <JayF> Full update is in the agenda, given the number of NGS/NBM patches floating around I'd be surprised if those aren't fixed or in progress already.
15:20:39 <JayF> Who wants to be the bug deputy next week?
15:20:55 <clif> pick me
15:21:27 <JayF> aight, cool, clif is the bug deputy for next week
15:21:49 <clif> and by next week, you mean... this week?
15:21:54 <JayF> Mon-Mon
15:22:06 <clif> March 23 - March 30?
15:22:11 <JayF> just make sure before you EOD on Friday, or Monday prior to meeting, you update agenda with results https://wiki.openstack.org/wiki/Meetings/Ironic
15:22:12 <JayF> yep
15:22:43 <JayF> PTG Review topic is empty, skipping.
15:22:48 <JayF> #topic Open Discussion
15:22:58 <JayF> Anything on anyones' mind that wasn't on the agenda?
15:23:21 <iurygregory> I have one
15:23:44 <iurygregory> #link https://bugs.launchpad.net/ironic/+bug/2141926
15:24:18 <JayF> It reads straightforward, and you just brought it up in open discussion
15:24:24 <JayF> what's the hidden tiger? :D
15:24:33 <iurygregory> tl;dr basically some HPE has a chance to fail the updates because the PLDM channel may not be ready
15:24:49 <iurygregory> I want to hear thoughts on the implementation before pushing upstream hehe
15:25:18 <JayF> it seems like an extremely straightforward fix to me, but I don't know what I don't know
15:25:26 <JayF> e.g. if hardware exists that this isn't true for
15:25:37 <iurygregory> https://paste.opendev.org/show/b1YINYtLDLJKZtD5Nfms/
15:25:46 <iurygregory> this is a fix we tested downstream
15:26:47 <JayF> would there be value in for line 20
15:26:51 <JayF> making the default True?
15:27:05 <JayF> So that if that attr is missing, we treat it similarly to how we did before?
15:27:16 <iurygregory> not sure if using Updatable parameters is the right way to check, to me this would add much more overhead, since most vendors currently doesn't implement a reference to the right firmware_inventory
15:28:03 <JayF> I think that is a good concern to raise at code review, but given it's needed for hardware compat, I think you'll need this code, the only question is if the behavior is optional/gated by a driver_info flag
15:28:16 <iurygregory> JayF, at least according to the redfish docs the Updatable parameters would tell us if we can update that via redfish
15:28:18 <JayF> unless you know some secretly better way to fix it you're hiding :D
15:28:22 <iurygregory> nothing else
15:28:35 <JayF> iurygregory: I'm saying existing code doesn't require that to exist; new code does. Has that attr always been in the standard?
15:28:50 <JayF> iurygregory: with stuff like this, I just think defensively because I don't know the full array of hardware variety in the world
15:28:54 <iurygregory> yeah, the att is in the standard
15:29:17 <iurygregory> I only think its a bit overkill look at all entries in firmware inventory to find the right one
15:29:25 <JayF> yeah
15:29:39 <JayF> but like, we do a lot of overkill at times because hardware is terrible :)
15:29:57 <iurygregory> like, new hardware might have this fixed and have the reference to the firmware_inventory and we could check things
15:30:22 <JayF> even still the old gear that needs this code would exist though
15:30:33 <JayF> IDK; I'd push it up and bring up your concerns in a self-review
15:30:46 <JayF> curious if hjensas or dtantsur might have more expert feedback in that area for ya
15:31:52 <iurygregory> gotcha
15:31:58 <iurygregory> will do that JayF o/
15:32:24 <JayF> Any other items for Open Discussion?
15:34:39 <JayF> Aight, last thing: who wants to volunteer to run the meeting next week?
15:34:58 <iurygregory> i can run the meeting
15:34:59 <JayF> These since-DST-8am meetings are trivial for me to keep running if nobody wants to; just offering the chair if desired.
15:35:11 <JayF> Cool. You can have it Iury :) I'll be around and can backup if needed
15:35:21 <JayF> #action iurygregory to chair the meeting next week
15:35:22 <iurygregory> ack o/
15:35:25 <JayF> Thanks all o/
15:35:26 <JayF> #endmeeting