15:03:31 <TheJulia> #startmeeting ironic
15:03:31 <opendevmeet> Meeting started Mon Mar 30 15:03:31 2026 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:31 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:31 <opendevmeet> The meeting name has been set to 'ironic'
15:03:42 <TheJulia> Welcome to our weekly Ironic meeting where we will have maximum irony!
15:03:44 <dtantsur> o/
15:04:13 <TheJulia> Our agenda can be found on the wiki!
15:04:16 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic
15:04:19 <TheJulia> #chair JayF
15:04:19 <opendevmeet> Current chairs: JayF TheJulia
15:04:49 <TheJulia> Our get coffee agenda item has been removed. Queue sadness
15:05:05 <TheJulia> #topic Announcements / Reminders
15:05:32 <JayF> TheJulia: don't do drugs, kids
15:05:39 <TheJulia> Your general reminder to please review items tagged ironic-week-prio.
15:05:44 <TheJulia> #link https://tinyurl.com/ironic-weekly-prio-dash
15:05:57 <TheJulia> JayF: I have cold meds!
15:06:28 <TheJulia> This week is R+0. Meaning it is official release week!
15:06:39 <dtantsur> Release all the things \o/
15:07:28 <JayF> I'm releasing a bagel into the toaster :) R+yum
15:07:36 <dtantsur> ++
15:07:37 <TheJulia> JayF: I guess your doing OI Live this week?
15:07:42 <JayF> yep
15:07:56 <TheJulia> Cool cool. Next week we also have the ironic specific session. Folks need to work on their slides!
15:07:58 <JayF> and will be doing notes for my "emcee" job a week from thurs
15:08:11 <TheJulia> ++
15:08:25 <dtantsur> Warm KubeCon EU feedback: Ironic is a recognized brand, people know and trust it. Some choose Metal3 because of Ironic specifically.
15:08:43 <TheJulia> JayF: does that mean your taking charge of pushing folks regarding slides on the ironic update?
15:08:48 <TheJulia> dtantsur: That is full of awesome.
15:08:57 <clif> that is nice to hear
15:09:18 <JayF> TheJulia: it means I get to vamp live on camera while they go "oh f$%@$ what was I gonna say" :D
15:09:50 <TheJulia> Anything to announce or remind ourselves of for this week?
15:10:06 <TheJulia> It might be the cold meds, but I want to see a vampireesq cape on you now.
15:10:22 <TheJulia> Holloween!
15:11:01 <JayF> You made me check the calendar
15:11:18 <JayF> "did I just sleep through 6 months? seems plausible..."
15:11:19 <TheJulia> woot woot
15:11:52 <TheJulia> Anyway! onward!
15:12:02 <TheJulia> #topic Working Group Updates
15:12:12 <TheJulia> Anything for asyncio ?
15:12:26 <dtantsur> Not really. We'll see when and in which form we pick it up again in the coming months.
15:12:35 <TheJulia> cool cool!
15:13:18 <TheJulia> Regarding vxlan, hjensas is working through testing various config and switch simulators, and has hit a snag on arista EOS. If anyone with arista EOS gear could ping hjensas and maybe compare some notes, that might be helpful!
15:14:21 <TheJulia> hjensas: if there is anything to add, please feel free to chime in, but in the mean time I'm going to move us along to Discussion topics
15:14:26 <TheJulia> #topic Discussion Topics
15:14:39 <TheJulia> First up, and the only item, the PTG!
15:14:58 <TheJulia> Looks like someone went through and did a time allocation and rough schedule
15:14:59 <TheJulia> #link https://etherpad.opendev.org/p/ironic-ptg-2026.2#L16
15:15:08 <JayF> That was cid's work as mentioned last meeting
15:15:21 <JayF> he's got something in open dicussion around if folks want to pair up post-meeting to validate
15:16:44 <TheJulia> cool cool
15:17:15 <TheJulia> Just looking throguh it, it looks good from my point of view. The big unknown I think is neutron and nova because they are different stages of their PTG planning and that is okay.
15:17:40 <TheJulia> Onward I guess?
15:18:13 <dtantsur> ++
15:18:13 <JayF> ++
15:18:18 <TheJulia> #topic Bug Deputy Updates
15:18:29 <TheJulia> clif: Looks like you were our deputy this past week
15:18:36 <clif> yep
15:18:39 <clif> sorry
15:19:17 <clif> To summarize new bugs this past week: 5 were filed to Ironic, 1 to python-ironicclient, and 1 to networking-baremetal
15:19:41 <clif> all the new Ironic bugs appear to be assigned and actively worked on
15:19:53 <TheJulia> cool cool
15:20:02 <JayF> the ironicclient one was anandkaranubc found a private method from osc-lib we use in python-ironicclient
15:20:11 <JayF> which means we either need to not do that, or we need to make it public in osc-lib
15:21:20 <JayF> Seems as non-exciting as we would expect.
15:21:27 <TheJulia> simple enough, is someone taking that on?
15:21:28 <TheJulia> :)
15:21:37 <clif> I also reviewed the periodic stable jobs and all three links show what appear to be legitimate failures
15:21:38 <TheJulia> Looks like the networking-baremetal one harald is already working on
15:22:22 <JayF> TheJulia: it was one of those "make a bug so it's documented" but I don't think it's at the top of anyones' list
15:22:22 <clif> openstack/ironic: “openstack-tox-py313-with-oslo-master” Seems to be failing consistently. Consistent failure with ironic and no other project.
15:22:36 <clif> openstack/iornic-ui: “propose-translation-update” appears to be failing consistently against “stable/2025.{1,2}” branches. “ModuleNotFoundError: No module named ‘pkg_resources’”.
15:22:43 <clif> ironic-ui*
15:22:51 <clif> openstack/virtualpdu: openstack-tox-py312 - Consistently failing - “No module named ‘pbr’”
15:22:55 <JayF> ironic-ui needs a setuptools pin in those branches
15:23:17 <JayF> clif officially the only person ever to do the "review periodic CI health" portion of bug deputy :D
15:23:21 <clif> haha
15:23:31 <TheJulia> Indeed!
15:23:31 <clif> its in the bug deputy guide!
15:23:37 <TheJulia> There is a guide?!
15:23:41 * TheJulia hides
15:23:46 <JayF> clif officially the only person ever to read the bug deputy guide /s
15:23:49 <clif> https://docs.openstack.org/ironic/latest/contributor/bug-deputy.html
15:23:53 <JayF> I know that's not true, I wrote it so at least I read half of it ;)
15:23:57 <TheJulia> cliff gets all the awards!
15:24:02 <clif> \o/
15:24:07 <clif> I'll settle for another coffee
15:24:22 <TheJulia> coffee++
15:24:47 <clif> Should I also send an email to the list or does the meeting report suffice?
15:25:01 <TheJulia> I think the meeting report suffices
15:25:04 <TheJulia> Thanks!
15:25:07 <clif> yw
15:25:13 <JayF> Yeah, some projects do the reports to the ML, I'm not sure that holds value for us :)
15:25:28 <TheJulia> So who will be our bug deputy for this week?
15:26:09 <JayF> I mean, it's R+0
15:26:13 <JayF> bug deputy vacation this week
15:26:22 <clif> no bugs this week
15:26:29 <JayF> ZARRO BOOGS ALLOWED
15:26:41 * TheJulia clearly needs more or less cold meds
15:26:47 <TheJulia> okay then!
15:26:55 <TheJulia> So, no RFEs this week
15:26:59 <TheJulia> So onward to Open Discussion
15:27:02 <TheJulia> #topic Open Discussion
15:27:09 <JayF> I've got a thing for here.
15:27:14 <JayF> iLO driver retirement.
15:27:26 * TheJulia gets out the plasma cutter
15:27:27 <JayF> I'd like to do it, it's borderline if it's been long enough yet, but we either do it now or in a year.
15:27:30 <JayF> So I vote for now.
15:27:40 <JayF> I just kinda want affirmative consent from the big users of Ironic who are cores
15:27:49 <JayF> metal3 doesn't support ilo so that shouldn't matter
15:27:53 <JayF> cardoe: you good with ilo being gone?
15:28:02 <JayF> and I know GR migrated all stuff to redfish driver
15:28:07 <cardoe> 😢
15:28:12 <cardoe> Yeah it should be.
15:28:21 <cardoe> But I do have some ilo5 gear still that needs to go.
15:28:35 <JayF> Aight.
15:28:43 <JayF> #action JayF to continue with removement of ilo driver
15:28:44 <TheJulia> I think its time to drop the ilo driver, I think I'll extend tls support to 1.1 for ilo4 gear with older firmware.
15:28:59 <TheJulia> yeah, ilo5 hosts with redfish should be okay
15:29:08 <hjensas> There was a few bugs for networking-generic-switch as well, did you miss those clif? (I started working on most of them, patches in gerrit ...)
15:29:12 <TheJulia> That reduces the overall dependency matrix
15:29:29 <clif> hjensas: lemme check
15:30:24 <cid> o/
15:31:04 <clif> I think I missed most of those if they were filed on Friday, but saw a couple
15:31:27 <clif> So yes networking-generic-switch also had 7 bugs filed
15:31:47 <clif> I'll triage them
15:31:49 <hjensas> ah, yes it was friday and some late friday even ... :)
15:31:58 <TheJulia> Cool cool!
15:32:08 <TheJulia> Anything else for Open Discussion?
15:33:11 <clif> for some reason I cannot set triage state for networking-generic-switch bugs
15:33:20 * TheJulia raises an eyebrow
15:33:32 <clif> I can confirm the bug
15:33:38 <clif> but the triage state is greyed out
15:33:47 <clif> and I can't set the importance in that state
15:34:52 <TheJulia> if you reload, you should be abel to now
15:35:20 <clif> yes I can, thank you
15:36:49 <TheJulia> cool cool
15:37:19 <clif> I've triaged the new networking-generic-switch bugs that were not already in progress
15:37:35 <TheJulia> cool cool
15:37:38 <clif> hjensas: thanks for reminding me
15:38:07 <TheJulia> #topic Who is chairing our next meeting?
15:38:45 <TheJulia> Who are we going to voluntell to chair next week's meeting?
15:39:37 <clif> not it?
15:40:06 <TheJulia> If I begin to bounce off the walls saying "not it", then I'm inherently voluteering
15:40:13 <TheJulia> which I guess I could
15:40:57 <TheJulia> I guess it's me!
15:42:11 <opendevreview> Abhishek Bongale proposed openstack/ironic master: Limit interfaces to fake-graphical for testing  https://review.opendev.org/c/openstack/ironic/+/982270
15:42:16 <TheJulia> Okay, thanks everyone!
15:42:23 <TheJulia> #endmeeting