15:00:09 <JayF> #startmeeting ironic
15:00:09 <opendevmeet> Meeting started Mon Jun  8 15:00:09 2026 UTC and is due to finish in 60 minutes.  The chair is JayF. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:09 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:09 <opendevmeet> The meeting name has been set to 'ironic'
15:00:20 <JayF> Hey all, welcome to the Ironic meeting. We're following the OpenInfra Code of Conduct.
15:00:28 <JayF> Agenda is at https://wiki.openstack.org/wiki/Meetings/Ironic
15:00:37 <JayF> #topic Announcements/Reminders
15:00:49 <JayF> Please review things hashtag:ironic-week-prio. Need reviews? Add that hashtag.
15:00:59 <JayF> #link https://tinyurl.com/ironic-weekly-prio-dash
15:01:03 <kubajj> o/
15:01:07 <JayF> I'll give us a few minutes for quorum to develop
15:01:08 <rpittau> o/
15:01:22 <TheJulia> o/
15:01:38 <Mahnoor> o/
15:01:48 * TheJulia wonders if a "qourum compiler" exists
15:01:51 <dtantsur> o/
15:03:47 <mumesan[m]> o/
15:04:07 <cid> o/
15:05:03 <JayF> Alright! First up
15:05:06 <JayF> #topic Working Group Updates
15:05:11 <JayF> Anything to speak to here around Async IO?
15:06:43 <JayF> That's a lot of silence I'm going to take as a no.
15:06:52 <JayF> The other working group item I added here was around Security
15:07:22 <JayF> for some context; there's an Ironic "coresec" team -- myself, TheJulia, rpittau, dtantsur -- we are the folks who initially get access to security sensitive bug reports and deal with their disposition.
15:07:25 <JayF> And we've been busy!
15:07:39 <TheJulia> exceptionally so.
15:07:42 <JayF> Last week, Ironic released three OSSA (advisories) and one OSSN (note).
15:08:31 <JayF> #link https://security.openstack.org/ossa/OSSA-2026
15:08:36 <JayF> #undo
15:08:36 <opendevmeet> Removing item from minutes: #link https://security.openstack.org/ossa/OSSA-2026
15:08:41 <JayF> #link https://security.openstack.org/ossa/OSSA-2026-017.html
15:08:52 <JayF> #link https://security.openstack.org/ossa/OSSA-2026-018.html
15:08:55 <JayF> #link https://security.openstack.org/ossa/OSSA-2026-019.html
15:09:08 <JayF> #link https://wiki.openstack.org/wiki/OSSN/OSSN-0099
15:10:16 <JayF> Please let someone know if you have any issue with the fixes.
15:10:26 <JayF> #topic Discussion Topics
15:10:55 <JayF> Improvement to firmware updates -- PTG followup has iurygregory (not here?) and janders listed
15:11:16 <dtantsur> I think the conversation happened last time
15:11:24 <Mahnoor> I *think* this was done last meeting, yes
15:11:30 <JayF> ack; moving on
15:11:33 <JayF> #topic Bug Deputy Updates
15:11:37 <TheJulia> Sort of did, jacob followed up with an initial spec super early this morning
15:11:37 <JayF> Mahnoor is listed as bug deputy
15:12:00 <JayF> #undo
15:12:00 <opendevmeet> Removing item from minutes: #topic Bug Deputy Updates
15:12:17 <Mahnoor> 3 new bugs in ironic, and 1 RFE
15:12:25 <JayF> TheJulia: the spec isn't attached to the bug in the agenda
15:12:38 <JayF> Mahnoor: hang on, wanna make sure janders' work gets recognized properly
15:12:49 <Mahnoor> ack
15:12:55 <JayF> #link https://review.opendev.org/c/openstack/ironic-specs/+/992208
15:13:03 <JayF> Please take time and review the spec posted by janders this morning :)
15:13:09 <JayF> now to kick it over to Mahnoor :D
15:13:11 <JayF> #topic Bug Deputy Updates
15:13:31 <Mahnoor> There were 3 new bugs in ironic :)
15:13:49 <Mahnoor> I've mentioned in the notes the links
15:14:24 <JayF> Do we have a volunteer to bug deputy next week?
15:15:32 <cid> I don't mind.
15:15:52 <JayF> #action cid is bug deputy next week
15:15:53 <cid> By the way, kudos to the coresec team on security fixes so far
15:16:05 <Mahnoor> ++, must be a lot
15:16:35 <cid> Yup :-)
15:16:54 <JayF> #topic RFE Review
15:16:59 <JayF> We have one listed in here, hopefully not stale
15:17:06 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2154817
15:17:11 <JayF> it was commented that it was a duplicate of
15:17:22 <JayF> #link https://bugs.launchpad.net/ironic/+bug/2098693
15:18:17 <Mahnoor> Its part of Outreachy, it says. But I was a little confused by multiple people working on it..and why there was a need to duplicate
15:18:35 <Mahnoor> Its not a crisis though :)
15:18:46 <TheJulia> i, too, have been confused about this
15:19:10 <JayF> a lot of the things being worked on are things we'd often ask for a spec for, too
15:19:11 <JayF> like API changes
15:19:13 <rpittau> me too, and I'm directly involved :D
15:19:29 <JayF> it seemed a little weird to have a bunch of new folks drop in working on an API change we didn't have specified
15:19:38 <rpittau> that was a misunderstanding
15:19:54 <TheJulia> rpittau: even better!
15:19:59 <JayF> I know we are often loosey goosey with specs so I didn't wanna assume lol
15:20:29 <TheJulia> I feel like, yes, there is a validity to what multiple folks seem to be trying to drive forward
15:20:40 <TheJulia> There are some baseline challenges though, I want them all to be successful
15:21:03 <TheJulia> obviously, that is not *always* possible
15:21:05 <rpittau> we've reduced the scope of https://review.opendev.org/c/openstack/ironic/+/983349
15:21:05 <rpittau> our outreachy intern estherd[m] will work on the rest
15:21:41 <TheJulia> is this just a case of others seeing the project and maybe thinking they could possibly still qualify if they go work it separately?
15:22:27 <rpittau> no, it was mistaken as something open to all the outreachy candidates
15:22:30 <Mahnoor> or they thought it was part of the contribution phase? 🤔
15:22:34 <rpittau> yeah
15:22:36 <TheJulia> oh, i see
15:22:36 <rpittau> kind of
15:24:03 <JayF> So we should mark that new bug as a dupe? Or the old one?
15:24:09 <JayF> What's the adjudication here for Mahnoor to execute
15:24:51 <rpittau> not a duplicate, we'll close the fdirst one once the relataed patch merges
15:25:00 <JayF> ack, okie dokie :D
15:25:04 <rpittau> thanks :)
15:25:06 <JayF> #topic Open Discussion
15:25:11 <JayF> Anything to discuss not on the agenda?
15:26:09 <TheJulia> i've got nothing right now
15:26:17 <TheJulia> oh!
15:26:47 <TheJulia> Last call for: https://review.opendev.org/c/openstack/ironic-specs/+/954612
15:28:35 <TheJulia> And we can close out the  meeting then
15:28:43 <JayF> nope, one more
15:28:46 <JayF> Who is chairing next week?
15:28:58 <JayF> Do we have a volunteer?
15:29:00 <TheJulia> I can
15:29:06 <JayF> sgtm,
15:29:14 <JayF> #action TheJulia to emcee the next meeting
15:29:18 <JayF> Thanks all, meeting over o/
15:29:19 <JayF> #endmeeting