16:00:11 <TheJulia> #startmeeting ironic_bfv
16:00:13 <openstack> Meeting started Thu Aug  3 16:00:11 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:15 <TheJulia> o/
16:00:17 <openstack> The meeting name has been set to 'ironic_bfv'
16:00:45 <dtantsur> o/
16:00:51 <hshiina> o/
16:01:10 <TheJulia> Welcome to another weekly Boot from Volume meeting!
16:01:11 <phuongnh> o/
16:01:20 <TheJulia> Our agenda, as always, is on the wiki!
16:01:22 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-BFV
16:01:37 <TheJulia> #topic Announcements/Reminders
16:01:53 <TheJulia> I have none for this week, anyone have anything to bring up this week?
16:02:40 <dtantsur> nope
16:02:49 <hshiina> i have nothing
16:03:27 <TheJulia> #topic Current Status
16:03:47 <dtantsur> api-ref was merged this week
16:03:53 <TheJulia> Yup!
16:04:04 <hshiina> thank you for the review!
16:04:12 <TheJulia> I went through the outstanding patches this morning on the ether pad, and things are looking quite good.
16:04:26 <TheJulia> #link https://etherpad.openstack.org/p/Ironic-BFV
16:04:32 <dtantsur> what else do we have, func tests and https://review.openstack.org/#/c/479326/ ?
16:04:33 <mjturek> o/
16:05:03 <mjturek> I have two patches that I need to get updated but they aren't critical
16:05:24 <TheJulia> dtantsur: devstack docs
16:05:28 <dtantsur> right!
16:05:47 <TheJulia> Which I noted as needing a revision on the etherpad.
16:06:11 <mjturek> (two patches I was referring to https://review.openstack.org/#/c/476601/ and https://review.openstack.org/#/c/472856/ )
16:06:33 <TheJulia> mjturek: any progress on admin/user centric docs?
16:06:34 <dtantsur> also the iRMC patch is reasonable close to landing, unless I'm missing something critical
16:07:01 <TheJulia> mjturek: One of those we will be a PTG topic, so yeah, no rush
16:07:27 <mjturek> TheJulia: Hoping to have a draft of the docs up sometime tomorrow
16:07:29 <TheJulia> dtantsur: I kind of felt the same when I last sifted through the iRMC patch, I'll try to review it today before I crash
16:07:37 <mjturek> sorry for the delay I haven't had much time this week for BFV
16:07:48 <TheJulia> mjturek: Regardless, awesome and thanks!
16:07:57 <dtantsur> TheJulia: a quick glance would be enough, don't crash please :)
16:08:17 <dtantsur> mjturek: docs would be awesome, /me likes reviewing docs :)
16:08:22 <TheJulia> dtantsur: I think it was only 340 lines :)
16:09:10 <TheJulia> dtantsur: I feel like the devstack docs are critical to get in with-in the next week, that other docs can take their time
16:09:41 <dtantsur> I'd say the other way around, but ok :)
16:09:53 <hshiina> i will update the devstack doc
16:09:55 <dtantsur> any docs can be backported anyway
16:10:07 <TheJulia> true :)
16:10:14 <TheJulia> hshiina: Awesome, thanks!
16:11:01 <TheJulia> So I think that is it for current status, anyone have anything else to report?
16:11:52 <dtantsur> we need to move the experimental job to the check queue
16:11:57 <dtantsur> anyone doing it?
16:12:46 <hshiina> dtantsur, not yet. but i will do
16:12:50 <dtantsur> thanks!
16:12:52 <TheJulia> hshiina: Thanks!
16:14:03 <TheJulia> #topic Priorities
16:15:05 <TheJulia> I don't think we have anything aside from reviews/docs at this time. Are we in consensus?
16:15:38 * dtantsur +2
16:15:56 <mjturek> yeah agreed
16:16:13 <hshiina> i agree
16:16:23 <dtantsur> I wonder for how long we should continue this meeting
16:16:27 <TheJulia> Okay then, I think we are safe to move on to discussion
16:16:36 <TheJulia> dtantsur: I was just about to get there ;)
16:16:37 * dtantsur shuts up till open discussion
16:16:41 <dtantsur> aha!
16:16:43 <TheJulia> #topic Discussion
16:18:21 <TheJulia> I wanted to raise the question of if we should cancel this meeting until the week before the PTG since we are at the end of cycle, and there is always more work to be done on such massive features like this. Cancelling until the week before the PTG would give us time to collect thoughts/ideas and have a coherent list in time for the PTG.
16:20:41 <mjturek> I think that's a good idea. The meeting's content has slowed down, which is awesome as it means we've made some big progress.
16:21:09 <dtantsur> what are we going to have here after that point?
16:21:12 <TheJulia> mjturek: exactly what I was thinking, and it is not like we can really do much aside from docs at the end of the cycle.
16:22:52 <TheJulia> dtantsur: Well, we have several other scenarios that are defined by the spec that we should discuss and possibly implement, if we choose not to implement, then we should rip them out of the spec. We also need to consider collection of connector data for things like inspection, but that is a whole other conundrum since that may end up being hardware dependent in some more specific cases
16:23:00 <mjturek> dtantsur: probably depends on what comes out of PTG. FCoE still needs some work right?
16:23:54 <dtantsur> right. FCoE, UEFI, iBFT (??)
16:24:05 * dtantsur knows fancy abbreviations!
16:24:25 <dtantsur> ok, I agree with the proposal
16:24:58 <hshiina> i'm fine with the idea
16:24:59 <TheJulia> dtantsur: interbank funds transfer?
16:25:14 <TheJulia> :)
16:25:39 <dtantsur> via IPA (as in beer)
16:26:16 <mjturek> I'd like to be able to boot from a glass of water if possible, but we can discuss at PTG
16:26:20 <TheJulia> #Agreed We have agreed that we will cancel the BFV meeting until 9/7, and to plan and resume our efforts into the next cycle.
16:26:40 <TheJulia> mjturek: I think there are requirements that we only support beer
16:26:44 <mjturek> :)
16:27:00 <TheJulia> or possibly whisky.
16:27:23 <TheJulia> Anyway, I guess we can move on to Open Discussion then
16:27:31 <TheJulia> #topic Open Discussion
16:27:44 <TheJulia> Do we have any new topics to discuss?
16:28:13 * dtantsur thinks of whisky, too late
16:29:06 <mjturek> I'm good!
16:29:32 <hshiina> i have nothing to discuss
16:30:01 <TheJulia> Awesome, well, Thank you everyone! If anyone wants to toss around ideas before the meeting, as always #openstack-ironic is the best place :)
16:30:24 <mjturek> thanks everyone!
16:30:25 <hshiina> thanks!
16:30:29 <phuongnh> thanks
16:30:31 <tiendc> thanks
16:30:40 <TheJulia> #endmeeting