16:02:42 <Sukhdev> #startmeeting ironic_neutron
16:02:43 <openstack> Meeting started Mon Aug 31 16:02:42 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:46 <openstack> The meeting name has been set to 'ironic_neutron'
16:03:00 <Sukhdev> we are in business :-)
16:03:11 <Sukhdev> #topic: Agenda
16:03:25 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron
16:03:45 <Sukhdev> Anybody wants to add anything to the agenda?
16:04:17 <Sukhdev> #topic: Announcements
16:04:29 <Sukhdev> Neutron FF is later this week
16:05:00 <Sukhdev> We are good from the Neutron FF point of view except for ML2 documentation
16:05:25 <Sukhdev> There is Neutron core meeting later today, I will double check if we are bound by the deadline for that
16:05:53 <Sukhdev> This FF is not applicable to vendor repo's for ML2 drivers
16:06:06 <jroll> docs are never blocked by feature freeze iirc
16:06:17 <jroll> or from what I've seen, anyway
16:06:37 <Sukhdev> jroll: right, but, still it is good to double check
16:06:51 <Sukhdev> Any body has any other announcement?
16:07:15 <Sukhdev> if not, lets dive into the agenda
16:07:35 <Sukhdev> #topic: Plan actions from last week
16:07:55 <Sukhdev> We covered a lot last week in terms of the plan for the week
16:08:19 <Sukhdev> 1) I was suppose to follow up with amotoki regarding documentation -
16:08:42 <Sukhdev> I made several attempts - have not been able to - he had family emergency -
16:09:10 <Sukhdev> will continue to do so, otherwise, I will write up the document myself
16:09:38 <Sukhdev> lazy_prince: was suppose to upload the patch with authentication issue resolved
16:09:58 <Sukhdev> I saw updated patch - have not had time to review it or test it
16:10:17 <Sukhdev> lazy_prince: does it address the admin context issue - the one we discussed with devananda?
16:10:44 <lazy_prince> yea.. so i have the patch but need to resolve some merge conflicts while rebasing.. will be done by tomorrow..
16:11:04 <lazy_prince> Hopefully. it should unblock you..
16:11:14 <Sukhdev> lazy_prince: the fix suggested by devananda worked?
16:11:29 <lazy_prince> in my env, it worked..
16:11:46 <jroll> yeah, get_admin_context() is a thing that works :P
16:12:07 <Sukhdev> lazy_prince: perfect - when you are able to resolve the rebase issue, ping me, I will get it tested
16:12:16 <lazy_prince> sure..
16:12:24 <Sukhdev> jroll: we missed you last week :-)
16:12:31 <jroll> Sukhdev: :)
16:13:17 <Sukhdev> cragusa: You were going to work with Will to push the updated patch for the DB issue
16:13:29 <Sukhdev> cragusa: any luck with that?
16:13:36 <cragusa> Will fixed that
16:13:53 <cragusa> and pushed the patches already
16:14:04 <cragusa> AFAIK should be working
16:14:23 <Sukhdev> cragusa: cool - I must have missed the updated patch -
16:14:36 <cragusa> was done earlier on today
16:14:45 <cragusa> Sukhdev: can you test it?
16:15:01 <Sukhdev> chigang: ah that makes sense
16:15:32 <Sukhdev> chigang: yes, I will look for it and test it along with lazy_prince's patch - both are needed to get us going to the next step
16:15:45 <Sukhdev> chigang, lazy_prince: thanks for the updates
16:16:11 <Sukhdev> #topic: Integration Effort
16:16:19 <Sukhdev> We covered this topic last week -
16:16:54 <Sukhdev> We were blocked (for jroll's benefit - to catch up) in our integration effort because of couple of issues
16:17:35 <Sukhdev> now that we have updated patches, I will go back and test it and see if this unblocks us to move forward with the integration testing
16:18:21 <Sukhdev> any body wants to add anything to what I have already said?
16:18:39 <Sukhdev> well, moving right along
16:19:09 <Sukhdev> #topic: Discussion on the planning for next few weeks until the release
16:19:42 <Sukhdev> Now that we have all players present here, I think it will be a good idea to discuss the plan for next few weeks
16:20:47 <Sukhdev> I think we should distribute the work and all pitch in to test various parts to make sure we are in good shape to be able to get all Ironic patches merged in time
16:21:42 <Sukhdev> One of the issues - CI testing
16:21:44 <lazy_prince> I still see gate-ironic-python27 failing for the patches..
16:23:05 <Sukhdev> yes - we need to ensure that basic gate issues are in order - so that once the code gets reviewed, we are blocked from merges
16:23:16 <jroll> lazy_prince: are you taking over all of the patches?
16:23:21 <Sukhdev> jroll had put some comments on the etherpad about it
16:23:25 <jroll> or is everyone just doing it?
16:23:45 <jroll> oh, right
16:24:09 <jroll> so network_provider defaulting to neutron shouldn't make patches fail CI until it's used
16:24:17 <jroll> but even the first patch in the chain is failing
16:25:13 <lazy_prince> that was what i wanted to come to.. :) first patch failure..
16:25:24 * yhvh was in the wrong room :(
16:25:38 <Sukhdev> yhvh :-)
16:25:49 <lazy_prince> and for the network_provider, i have made it as default to none...
16:26:08 <jroll> lazy_prince: this looks like the new WSME release, I think, rebase might just fix it or you could poke lucas about it
16:26:20 <lazy_prince> for time being and then will switch to neutron once all other patches are working..
16:26:25 <jroll> lazy_prince: something about throwing 400 for not-exposed fields in req/resp object
16:26:59 <lazy_prince> probably yhvh should take a look at it..
16:27:12 <yhvh> are these the current test failures?
16:27:37 <jroll> yes
16:27:39 <jroll> http://logs.openstack.org/32/206232/21/check/gate-ironic-python27/4a76b62/console.html
16:27:40 <yhvh> I will look into it
16:27:43 <yhvh> ty
16:27:57 <jroll> thanks!
16:28:38 <Sukhdev> yhvh: py27 errors on https://review.openstack.org/#/c/206232/ - as an example
16:29:37 <Sukhdev> lazy_prince yhvh: are there any issues that are blocking you?
16:30:04 <yhvh> no, but I did want to ask Om to carefully review the rebase I did on his patch today
16:30:09 <Sukhdev> #action: yhvh to look into py27 related errors in the gate
16:30:11 <lazy_prince> nope.. I just have to finish the rebase...
16:30:40 <Sukhdev> yhvh: I assigned you the action - hope you are OK with it?
16:30:47 <yhvh> yes
16:32:01 <Sukhdev> So, I am concentrating on testing two pieces - 1) to make sure when port groups of switch-ids are configured, they are correctly populated into the DB
16:32:29 <Sukhdev> 2) and to verify that the correct switch-id, (profile info) correctly flows to the ML2 drivers
16:32:37 <yhvh> my recent patchsets should help with 1
16:33:17 <Sukhdev> yhvh: there was some documentation issue (i.e help strings issue with the CLI) - hope you fixed it as well
16:33:38 <Sukhdev> Other than 1 and 2, there are more pieces need to be tested
16:33:56 <yhvh> Sukhdev: not pushed this yet, just the db bug
16:33:58 <Sukhdev> We need volunteers to test other parts as well
16:34:33 <Sukhdev> yhvh: last time we had to struggle a bit to figure out the format for the data-entry for the CLIs
16:35:13 <yhvh> yes fyi it's like: local_link_connection='{"some":"value"}'
16:35:21 <Sukhdev> yhvh: hopefully, your next update will fix this
16:35:41 <Sukhdev> yhvh: yup - we figured it out :-)
16:36:10 <Sukhdev> yhvh: thanks
16:36:39 <Sukhdev> So, going back to my previous question - we need to test the other parts as well -
16:37:07 <Sukhdev> how do we plan that testing?
16:37:29 <Sukhdev> to make sure that all pieces are going land in place
16:38:23 <Sukhdev> any ideas, thoughts?
16:38:55 <yhvh> we are still setting up our CI infrastructure, we just hired a CI guy so things should move faster
16:39:07 <yhvh> but we can't promise anything at this time
16:39:52 <jroll> \what other parts need to be tested?
16:40:38 <Sukhdev> jroll: all negative test paths - ensure we basically rugged -
16:41:17 <Sukhdev> jroll: I am only testing the positive path - i.e. I can configure the profile information - and make sure it gets to the ML2 driver
16:41:37 <jroll> ah, I see
16:42:04 <Sukhdev> I am not testing any negative test cases - e.g. if I mis-configre things - those are detected correctly
16:42:24 <Sukhdev> or I configure the same interface over and over - what happens, etc..etc..
16:42:29 <Sukhdev> you get the idea...
16:43:17 <Sukhdev> Another thing I am trying to test is the network flip -
16:43:45 <Sukhdev> but, it is not ready yet - because of blocking issue - hopefully I can progress this week on this
16:44:06 <lazy_prince> so on that... I have a question.. if a network does not have any subnet associated, should the port creation be allowed..?
16:44:25 <Sukhdev> I noticed one issue - (it is listed on ehterpad) on the first create_port(), we need to ensure that vnic_type is set correctly - presently it is not set
16:44:58 <Sukhdev> jroll: perhaps this fix can go with your patch - when the host_id is set, this can be set as well
16:45:28 <jroll> Sukhdev: yeah, I'll try to update that soon
16:45:39 <jroll> lazy_prince: can a neutron network exist without a subnet?
16:46:04 <lazy_prince> yes.. just net-create and no subnet-create..
16:46:19 * j1mehta slaps blogan around a bit with a large fishbot
16:46:24 <Sukhdev> jroll: it can - but, we need it in order to create a port on it - to get appropriate IP address
16:46:48 <jroll> sigh
16:46:56 <blogan> that was interesting
16:47:22 <jroll> lol
16:47:30 <Sukhdev> blogan:: was it interesting or painful - :-)
16:47:31 <lazy_prince> so basically such call should fail...
16:48:03 <Sukhdev> lazy_prince: yes, if you do a create_port without subnet, I think it will fail
16:49:08 <blogan> Sukhdev: both? i feel violated
16:49:26 <Sukhdev> blogan: :-)
16:49:27 <lazy_prince> i was thinking, it could be useful for some cases where you just put the port on network and then use the port for ovs switch etc...  but anyways.. we will see that later..
16:51:25 <Sukhdev> lazy_prince: did not understand it - so, you want to create a subnet later, after having created ports on a network? How do you assign the IP address?
16:52:05 * Sukhdev time check - only 9 min. left
16:52:17 <lazy_prince> lets talk about it later on... for now lets go with the flow on the topic at hand..
16:52:28 <Sukhdev> lazy_prince: +1
16:53:17 <Sukhdev> Also, please make sure to update ehterpad to list all correct patches - I am only using the etherpad
16:53:53 <Sukhdev> there are few patches there that should be abandoned - and notice some patches floating around that are not on the etherpad
16:54:46 <Sukhdev> can everybody take time to review it and make sure your patches are listed there - and anything that does not belong there (ie. irrelevant or old) remove it from there
16:54:59 <cragusa> sure
16:55:13 <lazy_prince> remove or strike-through...
16:55:17 <Sukhdev> we will use etherpad to track all the code and track the merge status
16:55:41 <Sukhdev> lazy_prince: either one is OK - strikethrough may be better
16:56:01 <lazy_prince> yeah.. that will preserve history though..
16:56:22 <Sukhdev> #topic: Open Discussion
16:56:29 <Sukhdev> we are down to 4 min.
16:56:41 <Sukhdev> anything we have not covered, needs discussion?
16:57:20 <yhvh> we have some patches for ironic-inspector and diskimage-builder to add the extra info we need during the discovery phase, is this interesting to you?
16:57:26 <Sukhdev> jroll: when you update your patch, please ping me - I will include those in the testing
16:57:36 <jroll> Sukhdev: ok
16:57:57 <Sukhdev> yhvh: that is not in the scope for this phase
16:58:01 <jroll> yhvh: yes, those are interesting, please put them up :)
16:58:13 * yhvh flips a coin :)
16:58:17 <jroll> they're lower priority but we can do that work in parallel
16:58:36 <yhvh> ok I was holding off to keep attention on current work
16:58:51 <Sukhdev> jroll: I though we did not want to do the discovery part as a part of this effort
16:59:14 <jroll> Sukhdev: no, but if someone else wants to then we should do it
16:59:25 <jroll> Sukhdev: the inspector and DIB review teams are different teams, too
16:59:32 <jroll> so not much resource constraint
16:59:54 <Sukhdev> jroll: as long as it does not impact our work, I am OK
17:00:08 <jroll> +1
17:00:14 <yhvh> ok I will post this week
17:00:15 <jroll> it doesn't do much without our work getting done anyway :)
17:00:39 <Sukhdev> yhvh: create a separate section on the etherpad and you can list it there -
17:00:55 <yhvh> Sukhdev: kk
17:00:58 <Sukhdev> we will not address them here
17:01:06 <Sukhdev> We are out of time -
17:01:12 <Sukhdev> thanks everybody
17:01:16 <Sukhdev> bye
17:01:19 <Sukhdev> #endmeeting