16:01:34 <Sukhdev> #startmeeting ironic_neutron
16:01:35 <openstack> Meeting started Mon Oct  5 16:01:34 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:38 <openstack> The meeting name has been set to 'ironic_neutron'
16:01:49 <Sukhdev> Good morning folks
16:01:57 <Sukhdev> #topic: Agenda
16:02:01 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron#Meeting_October_5.2C_2015
16:02:10 <lazy_prince> o/
16:02:35 <Sukhdev> #topic: Announcements
16:03:02 <Sukhdev> Will and Carmelo are at linuxcon and hence, will not be joining us today
16:03:19 <Sukhdev> I do not have any other announcement -
16:03:20 <lazy_prince> :(
16:03:39 <Sukhdev> Do you have any annoncement to make?
16:03:53 <lazy_prince> not really..
16:04:11 <Sukhdev> OK - in that case, lets dive into the agenda
16:04:18 <Sukhdev> #topic: Integration Status
16:04:47 <Sukhdev> I was able to make good progress - the new patches were very helpful
16:05:11 <Sukhdev> I can now see the the network flip logic working
16:05:40 <Sukhdev> the only remaining issue I see is that upon the deletion of VM, the ports are not removed/cleaned from the tenant netowork
16:05:40 <lazy_prince> \o/
16:06:26 <Sukhdev> lazy_prince and I have been communicating daily on this effort - this helped a lot
16:06:45 <lazy_prince> So.. I just was wondering.. is that something being done by nova (ironic virt) driver or the ironic conductor service..
16:07:08 <jroll> yeah, that should be done by nova
16:07:46 <lazy_prince> can we look at the nova patches and see which ones are needed and so we can try addressing that too..
16:08:04 <lazy_prince> s/look/relook/
16:08:54 <Sukhdev> I do not see any patch other than this - https://review.openstack.org/#/c/206163
16:09:17 <jroll> Sukhdev: I'd love to see the nova-compute logs for that problem
16:09:21 <lazy_prince> Well.. on the etherpad, we have three patches listed..
16:09:55 <lazy_prince> Sukhdev: so log is needed, is that something you can share..?
16:10:20 <Sukhdev> jroll: so, you want to see the logs when "nova delete" is issued?
16:10:28 <Sukhdev> I can provide that later today -
16:10:31 <lazy_prince> I think so..
16:10:40 <jroll> Sukhdev: yeah, I don't see any reason why the ports wouldn't be cleaned up
16:11:02 <Sukhdev> I thought the same way as well - but, something is preventing
16:11:22 <jroll> right
16:11:31 <jroll> so let's come back to that offline
16:11:46 <Sukhdev> lazy_prince: do you see the same issue on your setup as well?
16:12:16 <Sukhdev> jroll: right - I will ping you later with the details
16:12:28 <lazy_prince> Nope.. I have not been able to get to that point.. struggling with the devstack networks.. :(
16:12:47 <Sukhdev> Ah OK
16:13:22 <Sukhdev> Other than that, lazy_prince and I saw an issue with the CLI - I have logged that on the etherpad as well
16:13:35 <yhvh> hi /me lurks on conference wifi
16:14:10 <Sukhdev> yhvh: thanks for signing in -
16:14:38 <Sukhdev> yhvh: did you have a chance to look at the etherpad about one of the CLI issue?
16:15:39 <yhvh> no I will checkout and fix
16:16:17 <Sukhdev> yhvh: we have a work around - so, no rush, when ever you return back from conference, it will be nice to get that fixed
16:16:46 <Sukhdev> Anything else on the integration effort?
16:16:56 <Sukhdev> lazy_prince: do you have anything to add/share?
16:17:28 <lazy_prince> umm.. One thing..
16:18:31 <lazy_prince> so we decided that network_provider will be an attribute to the node.. and we also decided that, in case if a node does not have it, it will default to the config file default..
16:18:46 <lazy_prince> is that right understanding..?
16:19:10 <jroll> if I remember correctly, yes
16:19:47 <Sukhdev> I think that is the case, but, double check - I think this is documented in the spec -
16:20:07 <lazy_prince> okay. in such case how is ironic virt driver supposed to get the network_provider from config file in case if node does not have it..
16:20:19 <Sukhdev> I have not tested that case, hence, like jroll, going only by faded memory :-):-)
16:21:01 <lazy_prince> are there APIs to get config parameters from ironic..?
16:21:27 <lazy_prince> Just curious... and wondering..
16:21:39 <jroll> lazy_prince: in nova, hmm
16:21:44 <jroll> the node object should be available
16:21:52 <jroll> we have all of the node data in nova
16:22:41 <lazy_prince> yeah.. but is the node does not have the network_provider set, then how is nova supposed to get it from Ironic..
16:22:44 <jroll> oh, the other way, my mistake
16:23:01 <lazy_prince> s/is/if/
16:23:10 <jroll> great question
16:23:19 <jroll> maybe we have the same config in nova?
16:24:21 <lazy_prince> or ironic compute broadcasts it as attribute to nova sch which can later be used by virt driver or something..?
16:24:49 <lazy_prince> I know the former sounds easy..
16:25:30 <jroll> yeah, afaik there's not a way for nova to grab configs from ironic
16:25:43 <jroll> and we should probably avoid that, seems like a layer violation
16:26:25 <lazy_prince> We can come back to it later or ask from nova folks what they have in store for us..
16:26:31 <jroll> ya
16:27:20 <Sukhdev> lazy_prince: shall I assign you this action item?
16:27:25 <lazy_prince> jroll: will you be checking this with nova folks..?
16:27:36 <Sukhdev> or should jroll own this?
16:27:42 <jroll> lazy_prince: checking what, specifically?
16:27:59 <jroll> I don't think nova should pull configs from ironic, it should have its own config
16:28:46 <lazy_prince> okay... then lets agree on making this as part of nova config.. under ironic namespace..
16:28:57 <jroll> yeah, agree
16:29:19 <lazy_prince> jroll: will you be updating the nova patch then..?
16:29:36 <jroll> lazy_prince: I guess so, that's been on my list for a while
16:29:44 <lazy_prince> great..
16:30:11 <lazy_prince> In case you are busy, we could take that up for you..
16:31:05 <lazy_prince> Thats all I had to discuss..
16:31:26 <jroll> lazy_prince: alright, we'll figure it out. thanks :)
16:32:17 <Sukhdev> #action: jroll and lazy_prince to work out the plan to populate network_provider info into nova node config
16:32:37 <Sukhdev> anything else on this topic?
16:33:00 <Sukhdev> #topic: Action Items from previous week(s)
16:33:33 <Sukhdev> Carmelo published a patch on Ironic documentation - https://review.openstack.org/#/c/228496/2/doc/source/deploy/install-guide.rst
16:33:59 <Sukhdev> I see some review comments on this - please provide your feedback so that this can be cleaned up
16:34:52 <Sukhdev> I have not had a chance to work on the ML2 documentation - was too much consumed with making things work -
16:35:25 <Sukhdev> now that things are falling in place, should be able to work on the documentation this week or next
16:35:47 <Sukhdev> Actually, I have ML2 code sprint next three days - so, it will probably fall to next week
16:36:37 <Sukhdev> #topic: Patches under review
16:36:53 <Sukhdev> The patches are looking much better now
16:37:19 <Sukhdev> I have not reviewed or tested anything related to port-groups yet
16:38:08 <Sukhdev> lazy_prince: I know you have been testing port-groups - how is that looking?
16:38:36 <lazy_prince> Overall, it looks good with couple of cli issues..
16:39:28 <Sukhdev> the cli issues that we already covered, right?
16:40:41 <Sukhdev> moving along....
16:41:08 <Sukhdev> since we have already covered documentation - lets jump to next topic
16:41:11 <Sukhdev> #topic Open Discussion
16:41:44 <Sukhdev> Tokyo summit is fast approaching
16:41:52 <Sukhdev> I am assuming I will see you all there -
16:42:02 <yhvh> yes
16:42:14 <Sukhdev> jroll: you devananda and I have to work on presentation
16:42:27 <jroll> Sukhdev: yeah..... that's a thing
16:42:52 <devananda> :)
16:42:57 <lazy_prince> I will be there too.. :)
16:42:58 <Sukhdev> I can dump some initial thoughts and pass it along to you guys
16:43:39 <Sukhdev> jroll devananda: I am thinking using google presentation and share three-way - that way we can edit together
16:43:50 <jroll> Sukhdev: sure, that's fine
16:44:02 <devananda> can I just stand there and look pretty?
16:44:03 <jroll> I don't love google presentation but we can at least start there
16:44:12 <devananda> (j/k)
16:44:39 <Sukhdev> devananda: ha ha - as long as you do a good job looking pretty :-)
16:44:42 <devananda> I'm fine with google presentation, though I prefer reveal.js - which also means we could collaborate through git
16:45:41 <Sukhdev> I have no clue about reveal.js - lets start with google, when we get to consensus, then we can move to any other format
16:45:57 <devananda> Sukhdev: it's just html/css
16:46:47 <Sukhdev> yhvh: we should hook up and discuss the plan for design summit idea - as per our previous discussion
16:47:02 <yhvh> sure
16:47:09 <Sukhdev> yhvh: have to added the design idea to the etherpad that jroll provided last week?
16:47:17 <devananda> Sukhdev: eg, http://devananda.github.io/talks/ironic-modern-deployment.html#/ == https://github.com/devananda/talks/blob/master/ironic-modern-deployment.html
16:47:48 <jroll> Sukhdev: I assume you mean this one? https://etherpad.openstack.org/p/mitaka-ironic-design-summit-ideas
16:47:57 <yhvh> Sukhdev: no
16:48:08 <Sukhdev> jroll: yes, thanks
16:48:20 <Sukhdev> yhvh: do you want to add or want me to do so?
16:48:28 <Sukhdev> devananda: wow!!!
16:49:24 <Sukhdev> devananda: It will take me long time to work on this -
16:50:15 <devananda> Sukhdev: if gdocs is easier for you - that's fine
16:50:17 <Sukhdev> devananda jroll: lets initially agree on the subject matter and the flow - as to what we want to cover and how to present - then we can switch to any format
16:50:34 <jroll> yeah, I'm not opinionated on the tool though I do prefer reveal.js
16:51:54 <Sukhdev> devananda, jroll : This week is busy for me - will put together something next week and send your way - unless you want to take the lead
16:52:07 <jroll> Sukhdev: ok, thanks
16:52:19 <Sukhdev> yhvh: ?
16:52:45 * Sukhdev 8 min left - anybody wants to discuss anything else?
16:53:17 <Sukhdev> I guess we are done
16:53:31 <Sukhdev> I will ping yhvh off-line and work out the details with him
16:53:37 <Sukhdev> Thanks folks
16:53:46 <lazy_prince> I guess, we need reviews from cores on the patches..
16:53:46 <Sukhdev> bye
16:54:01 <jroll> lazy_prince: will try to get some eyes on it
16:54:03 <jroll> thanks all
16:54:09 <Sukhdev> lazy_prince: yes, we do -
16:54:11 <lazy_prince> cool..
16:54:38 <Sukhdev> once I get a bit more testing, then I will start to bug them :-):-)
16:55:08 <Sukhdev> thanks everybody
16:55:08 <Sukhdev> bye
16:55:11 <Sukhdev> #endmeeting