16:01:54 <Sukhdev> #startmeeting ironic_neutron
16:01:55 <openstack> Meeting started Mon Nov  9 16:01:54 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:00 <openstack> The meeting name has been set to 'ironic_neutron'
16:02:09 <jroll> \o
16:02:22 <Sukhdev> #topic: Agenda
16:02:29 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron#Agenda
16:02:53 <Sukhdev> This is our first meeting after the summit as well as time change
16:03:47 <Sukhdev> #topic: Announcements:
16:04:19 <Sukhdev> hope everybody is back and over their jet-lags
16:04:33 <sambetts> nearly there :)
16:05:00 <Sukhdev> sambetts: I got back on Saturday - still fighting it :-)
16:06:13 <sambetts> Sukhdev: good luck :)
16:06:16 <Sukhdev> The summit was hectic, but, productive - lots of interest in the work that we are trying to do here
16:07:38 <Sukhdev> Anybody has any announcements - before we dive into agenda?
16:07:50 * jroll does not
16:08:12 * sambetts also does not
16:08:13 <Sukhdev> lets get going in that case
16:08:29 <Sukhdev> #topic: Integration status
16:08:48 <Sukhdev> I updated the etherpad last night to reflect the latest status of our testing
16:08:58 <Sukhdev> #link: https://etherpad.openstack.org/p/ironic-neutron-mid-cycle
16:09:12 <Sukhdev> most of the critical items are under control -
16:09:32 <Sukhdev> if you look at the list of issues - only 7,9, and 10 remain to be addressed
16:09:50 <sambetts> 2 ?
16:10:02 * Sukhdev looking
16:10:41 <Sukhdev> sambetts : you are correct my bad - I missed that one
16:11:17 <sambetts> :)
16:11:19 <Sukhdev> sambetts : we have a work around for that - hence, did not strike me when I was looking at it last night - sorry about that
16:11:57 <sambetts> :) no problems
16:12:01 <Sukhdev> at this point, if somebody wanted to play with the code, they actually could
16:12:56 <Sukhdev> yhvh : are you here?
16:13:41 <jroll> is there documentation for setting this up in devstack for testing?
16:14:27 <Sukhdev> jroll : that was one of the items that I wanted to cover under documentation -
16:15:15 <Sukhdev> there are two items that I wanted to cover today -
16:15:26 <jroll> okay
16:15:30 <Sukhdev> 1) CI - i.e. testing
16:15:45 <Sukhdev> 2) documentation
16:16:27 <Sukhdev> lazy_prince is not here - he had kicked off some work on the CI
16:17:12 <Sukhdev> I was hoping he will provide us some feedback on this
16:18:20 <Sukhdev> in his absence, we can skip the CI part and move to documentation -
16:18:32 <sambetts> For the devstack senario are we going to modify the ovs/linux bridged ml2 drivers to support plumbing the ssh driver nodes?
16:20:01 <Sukhdev> sambetts : that is what lazy_prince was looking into and I was hoping he will chime in
16:21:37 <Sukhdev> so, there are two parts to this - one ties into the CI and other ties into the documentation
16:22:12 <Sukhdev> i.e. how do we make sure all the tests are going to pass/work with this code in the baseline - and, second,
16:22:15 <Sukhdev> what one has to do to use it
16:25:40 <Sukhdev> in order to avoid double work, I will ping lazy_prince off line and see if he has made any headways or have any thoughts as to how to go about it
16:26:12 <Sukhdev> then accordingly, we can jump in help with what ever is needed to get this going -
16:26:29 <Sukhdev> I am sure this will be a blocker for the patches to be merged
16:27:06 <Sukhdev> I do not have much to add to it -
16:27:13 <Sukhdev> jroll : your thoughts?
16:27:26 <jroll> Sukhdev: on what, specifically?
16:27:31 <jroll> we need CI, we need docs
16:27:33 <jroll> ¯\_(ツ)_/¯
16:27:48 <jroll> that's really all I have to say about it
16:27:56 <Sukhdev> jroll : I meant the approach
16:28:01 <yhvh> sorry here
16:28:12 <Sukhdev> no disagreement as to we need both -
16:28:27 <jroll> Sukhdev: the only approach I see is you will ping lazy_prince offline
16:29:36 <Sukhdev> correct - I was asking if you have anything to add to it?
16:29:52 <Sukhdev> yhvh : welcome
16:29:55 <jroll> I don't think so, no
16:30:20 <Sukhdev> yhvh :  hope you are well rested and out of jet-lag
16:30:36 <yhvh> yup after monday was ok
16:31:14 <Sukhdev> yhvh : there are couple of items in the issues section ( 9 and 10) that you were looking at prior to summit - wonder if you have any update?
16:31:44 <yhvh> this are done and pushed to gerrit
16:31:52 <yhvh> I will strike out now
16:32:05 <Sukhdev> yhvh : cool - thanks
16:32:24 <Sukhdev> that leads to the documentation
16:32:35 <Sukhdev> #topic: Documentation
16:33:23 <jroll> Sukhdev: I need to step away for the rest of the meeting, sorry - ping me offline if there's anything you need from me
16:33:37 <Sukhdev> I have an action item to work on the ML2 documentation - which I will pick up this week
16:33:44 <Sukhdev> jroll : will do - thanks
16:34:19 <Sukhdev> carmello pushed a patch for the Ironic side of documentation - https://review.openstack.org/#/c/228496
16:34:46 <yhvh> He has more changes in response to comments
16:35:03 <Sukhdev> The question is where do we want to document the devstack related documentation?
16:35:29 <yhvh> Ironic carries devstack instructions no?
16:35:35 <Sukhdev> yhvh : yup - he did - it is looking much better
16:36:31 <yhvh> Sukhdev: there are more updates (docs and code) coming, we have been trying to keep the number of updates to a min
16:36:32 <Sukhdev> yhvh : I did not think so - but, I have not seen the latest one since the summit
16:36:50 <Sukhdev> yhvh : oh I see -
16:37:13 <yhvh> I am thinking of this I think http://docs.openstack.org/developer/ironic/dev/dev-quickstart.html#deploying-ironic-with-devstack
16:39:19 <Sukhdev> yhvh : correct - but, we have been making some local changes to use devstack to work with new feature
16:39:50 <Sukhdev> for example disable installation of the python-ironicclient
16:41:04 <Sukhdev> yhvh : come to think, if the python-ironicclient code is released, then this may not be needed
16:42:01 <yhvh> yeah it's been good since early sept
16:42:35 <Sukhdev> yhvh : barring those couple of issues that I mentioned earlier
16:43:07 <yhvh> :P they were bugs in ironic but became manifest in the cli :B
16:43:21 <yhvh> so the cli code hasn't changed since september
16:43:22 <yhvh> :)
16:44:02 <Sukhdev> correct - they seem to give the feeling as cli has issue
16:45:00 <Sukhdev> Perhaps if we address the CI issue, we may not need any specific documentation for devstack per se
16:45:06 <Sukhdev> sambetts : do you agree?
16:46:48 <Sukhdev> #action : Sukhdev to follow up with lazy_prince on the CI related enhancement
16:46:51 <sambetts> I think that one will definatly help solve the other
16:47:30 <Sukhdev> I will follow up with lazy_prince
16:48:03 <Sukhdev> anything else?
16:48:12 <Sukhdev> #topic: Open Discussion
16:48:51 <Sukhdev> yhvh : I will look for the updated patches and test them as time permits
16:49:15 <Sukhdev> I do not have anything else -
16:49:31 <Sukhdev> anybody wants to discuss anything else?
16:49:40 <yhvh> I want to pack as much as I can into each update, I have around 6 commits here addressing comments
16:49:56 <Sukhdev> yhvh : cool - thanks
16:50:02 <Sukhdev> will look for those
16:50:37 <Sukhdev> anything else ?
16:50:48 * Sukhdev waiting
16:51:12 <Sukhdev> OK - lets call it a day
16:51:13 <Sukhdev> Thanks everybody
16:51:17 <yhvh> thanks
16:51:20 <Sukhdev> bye
16:51:26 <Sukhdev> #endmeeting