16:01:15 <Sukhdev_> #startmeeting ironic_neutron
16:01:15 <openstack> Meeting started Mon Nov 30 16:01:15 2015 UTC and is due to finish in 60 minutes.  The chair is Sukhdev_. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:20 <openstack> The meeting name has been set to 'ironic_neutron'
16:01:55 <pas-ha> o/
16:01:57 <vdrok> o/
16:02:11 <Sukhdev_> #topic: Agenda
16:02:36 <Sukhdev_> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron#Meeting_November_30.2C_2015
16:02:50 <Sukhdev_> Hope folks have had a chance to look at the agenda -
16:03:06 <Sukhdev_> if you would like to see anything added to the agenda, please us know
16:03:22 <Sukhdev_> #topic: Announcements
16:03:29 <Sukhdev_> jroll is out today
16:04:02 <Sukhdev_> Nova spec for this integration work was approved last week
16:04:32 <Sukhdev_> Couple of patches for nova were also updated and are ready to go as well
16:04:51 <Sukhdev_> #link: https://review.openstack.org/#/q/status:open+project:openstack/nova+branch:master+topic:bp/ironic-networks-support,n,z
16:05:11 <Sukhdev_> The last (third) patch needs work - other two are good for approval as well
16:05:25 <Sukhdev_> Any question on that?
16:05:50 <Sukhdev_> #topic: Action Items from last week
16:06:22 <Sukhdev_> kevinbenton_  and I had an action to work on Neutron patch for ML2 driver for OVS for CI testing
16:06:29 <Sukhdev_> kevinbenton_ : are you here?
16:06:53 <Sukhdev_> #link: https://review.openstack.org/#/c/249265/
16:06:54 <kevinbenton_> Sukhdev_: sorry, i'm traveling right now so my connection is unreliable
16:07:22 <Sukhdev_> kevinbenton_ : Thanks for checking in - was mentioning about your patch
16:07:37 <Sukhdev_> I had an opportunity to test it and it looks good
16:08:43 <Sukhdev_> However, vsaienko came up with another approach to CI - which leads us into the next main topic on the agenda
16:08:51 <Sukhdev_> #topic: CI discussion
16:09:06 <Sukhdev_> Last week we discussed one approach
16:09:22 <Sukhdev_> based upon that kevinbenton posted the patch -
16:09:25 <kevinbenton> before i go offline, i just want to say that I would like to go with vsaienko's approach because it doesn't require upstream changes
16:09:50 <Sukhdev_> kevinbenton : I was going to dive into that -
16:10:26 <Sukhdev_> #link: http://lists.openstack.org/pipermail/openstack-dev/2015-November/080492.html
16:10:49 <Sukhdev_> kevinbenton : you had a comment on vsaienko's approach on the ML
16:11:43 <Sukhdev_> we may have lost kevinbenton
16:12:03 <Sukhdev_> vsaienko : would you want to take the floor to explain it for the benefit of the rest
16:12:31 <vsaienko> sure
16:13:57 <vsaienko> the generic_switch driver is usual ML2 Neutron driver, and it configures OVS switch via ssh commands
16:14:39 <vsaienko> the code can be found https://github.com/jumpojoy/generic_switch and some instruction how to tests it on devstack https://github.com/jumpojoy/ironic-neutron/blob/master/devstack/examples/ironic-neutron-vm.md
16:15:11 <Sukhdev_> #link: https://github.com/jumpojoy/generic_switch
16:15:24 <Sukhdev_> #link: https://github.com/jumpojoy/ironic-neutron/blob/master/devstack/examples/ironic-neutron-vm.md
16:16:28 <Sukhdev_> vsaienko : can you touch on the differences between the this approach vs. the one kevinbenton took
16:17:16 <vsaienko> It doesn't require changes to neutron code
16:18:07 <vsaienko> And the working flow is the same as in real use-case
16:19:06 <vsaienko> also this generic_switch driver support hardware switches as well
16:20:15 <vsaienko> at the moment it was tested with Cisco catalyst, but it can be easily extended with any vendor/switch that supports ssh
16:21:32 <Sukhdev_> vsaienko : our main use presently will be to use it for the CI gate testing so that we can test all the present patches
16:22:02 <Sukhdev_> and then incorporate it for tempest testing
16:22:34 <vsaienko> I've created some patches to devstack that allow to test ironic/neutron integration on VMs
16:23:21 <vsaienko> and as far I know yyekovenko is working on tempest tests at the moment
16:23:32 <Sukhdev_> vsaienko : Thanks for the patches - I looked at them briefly over the weekend - have not had a chance to give a full review yet
16:23:50 <Sukhdev_> vsaienko : did you test those devstack patches?
16:24:11 <Sukhdev_> with the rest of neutron/nova/ironic patches yet?
16:24:24 <vsaienko> yes, I've prepared short doc how to do it
16:24:35 <vsaienko> #link: https://github.com/jumpojoy/ironic-neutron/blob/master/devstack/examples/ironic-neutron-vm.md
16:26:34 <Sukhdev_> I looked at the steps briefly - I assume devstack  patches automates those steps
16:27:01 <Sukhdev_> s/automates/automat
16:28:18 <vsaienko> some of them, adds opportunity to perform ironic neutron testing
16:29:21 <vsaienko> the following patch allows to create ironic ports with llc information
16:29:25 <vsaienko> #link: https://review.openstack.org/#/c/248048/
16:32:48 <Sukhdev_> vsaienko : one thing I was looking into the steps - local.conf changes for this
16:34:12 <vsaienko> #link: https://github.com/jumpojoy/ironic-neutron/blob/master/devstack/examples/ironic-neutron-vm-local.conf
16:35:40 <Sukhdev_> vsaienko : I mean any modifications/additional config options to this file?
16:36:06 <Sukhdev_> never mind - I see some here
16:37:55 <Sukhdev_> I do not see lazy_prince here today - he is missing
16:38:22 <Sukhdev_> Any body has any questions?
16:38:57 <Sukhdev_> vsaienko : I will give it a spin later this week and reach out to you for any follow up questions
16:39:19 <vsaienko> sure
16:39:57 <Sukhdev_> vsaienko : Thank you so much for taking on this much needed effort
16:40:23 <vsaienko> sukhdev_: I think it would be great if we have repo on openstack.org for generic_switch
16:41:31 <Sukhdev_> vsaienko : jroll is not here - I will discuss this with him off-line and see what is the best way to go about it
16:42:02 <vsaienko> sukhdev_: thank you!
16:42:09 <Sukhdev_> anybody has any questions for vsaienko before we move to the next topic?
16:42:45 <Sukhdev_> #action: Sukhdev to discuss with jroll and kevinbenton about repo for generic_switch
16:43:22 <Sukhdev_> #topic: tempest testing
16:43:41 <Sukhdev_> vsaienko your work leads us into the next topic of automated testing
16:44:38 <Sukhdev_> yuriy - are you here?
16:45:06 <Sukhdev_> #link: https://bugs.launchpad.net/tempest/+bug/1520230
16:45:06 <openstack> Launchpad bug 1520230 in tempest "Test Case: Create a test scenario to verify that Ironic supports multitenancy" [Undecided,New] - Assigned to Yuriy Yekovenko (yyekovenko)
16:45:25 <Sukhdev_> vsaienko : are you working with Yuriy on this?
16:46:07 <vsaienko> yes, I can get in touch with him
16:47:06 <vsaienko> sukhdev_: it seems yury_yekovenko just joined us
16:47:40 <Sukhdev_> yury_yekovenko : would you please want to share your thoughts with the team?
16:47:41 <yury_yekovenko> hi everybody!
16:48:51 <yury_yekovenko> well, for now my idea is to implement a new scenario test that covers basic ironic multitenancy flow
16:49:10 <yury_yekovenko> as I described in launchpad bug
16:49:13 <Sukhdev_> yury_yekovenko : I saw the description of the test case in the bug description
16:50:43 <Sukhdev_> yury_yekovenko : have you made any headways yet?
16:51:25 <yury_yekovenko> I'm starting to implement that test
16:51:37 <yury_yekovenko> but don't have some significant results for now
16:52:02 <Sukhdev_> yury_yekovenko : understandable - please let us know if we can help
16:52:16 <yury_yekovenko> yes, of course. thanks
16:54:16 <Sukhdev_> vsaienko : will you be patching some of your work into the CI framework for gate testing?
16:54:50 * Sukhdev_ time check 6 min left
16:55:08 <Sukhdev_> #topic: Open Discussion
16:55:16 <Sukhdev_> yhvh : hello
16:55:37 <vsaienko> sukhdev_: sure, but I need to figure out how CI  works
16:56:20 <vsaienko> I will dig into CI deeper tomorrow
16:56:25 <Sukhdev_> vsaienko : couple of our regular guys are missing today - they are more familiar with it
16:56:59 <Sukhdev_> vsaienko : reach out to jroll on the ironic channel - he will be a great resource
16:57:21 <vsaienko> sukhdev_:  ok thanks!
16:57:45 <Sukhdev_> yhvh : are you here
16:58:22 <Sukhdev_> vsaienko yury_yekovenko : will you guys be joining us here on a regular basis?
16:58:33 <vsaienko> sukhdev_:  I will
16:58:48 <Sukhdev_> cool - thanks. this will help
16:58:50 <yury_yekovenko> sukhdev_: I will too
16:58:59 <Sukhdev_> excellent -
17:00:13 <Sukhdev_> vsaienko yury_yekovenko : the short term goal will be to take your framework and plumb it into the CI so that we can get all our outstanding patches merged
17:01:00 <Sukhdev_> we would like the Ironic CI to posting votes on these patches
17:01:12 <Sukhdev_> oppss... sorry out of time
17:01:18 <vsaienko> sukhdev_: got it
17:01:32 <Sukhdev_> Thanks for attending everybody -
17:01:36 <Sukhdev_> bye
17:01:38 <sambetts> o/ thanks Sukhdev_
17:01:47 <vsaienko> thanks for all, bye bye
17:01:48 <Sukhdev_> bye
17:02:01 <Sukhdev_> #endmeeting