16:01:19 <Sukhdev> #startmeeting ironic_neutron
16:01:20 <openstack> Meeting started Mon Oct  3 16:01:19 2016 UTC and is due to finish in 60 minutes.  The chair is Sukhdev. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:24 <openstack> The meeting name has been set to 'ironic_neutron'
16:01:44 <Sukhdev> who do we have here for this meeting?
16:02:01 <hshiina> o/
16:02:12 * devananda|away lurks
16:02:34 <Sukhdev> #topic: Agenda
16:02:43 <Sukhdev> #link: https://wiki.openstack.org/wiki/Meetings/Ironic-neutron#Meeting_October_3.2C_2016
16:03:08 <Sukhdev> I will move slow to give others time to join in
16:03:30 <Sukhdev> devananda : did you have a chance to review the SG patch?
16:04:13 <Sukhdev> sambetts jroll : are you around?
16:04:20 <sambetts> Hi
16:04:27 <jroll> \o
16:04:39 <devananda> Sukhdev: I have not, sorry
16:04:54 <Sukhdev> #topic: Announcements
16:05:32 <Sukhdev> Other than Ocata is open for patch submittal, I do not have any other annoncement
16:05:48 <Sukhdev> two week vacation makes you forget everything :-)
16:06:28 <Sukhdev> you guys have anything to share with the team?
16:06:34 * jroll has none
16:07:02 <sambetts> nothing from me, /me is largly focused on networking-cisco at the moment with releases coming up
16:07:33 <Sukhdev> sambetts : same here - working on some customers deliveries
16:07:47 <Sukhdev> moving on -
16:07:58 <Sukhdev> #topic: Security Groups
16:08:15 <Sukhdev> #link: https://review.openstack.org/#/c/361451
16:08:40 <Sukhdev> I am waiting for the reviews for this patch - I think this is good to go
16:08:49 * jroll rechecks, gate is fixed now
16:09:08 <Sukhdev> unless of course some issues are found during reviews
16:09:49 <Sukhdev> jroll : other than this patch, is there anything else expected for SG ?
16:10:07 <jroll> Sukhdev: docs?
16:11:14 <Sukhdev> jroll: good point - I can get on it as well. I can push a patch to address it
16:11:20 <jroll> thanks
16:11:44 <Sukhdev> #action: Sukhdev to push a patch for SG documentation
16:11:59 <Sukhdev> anything else on this topic?
16:12:25 <Sukhdev> #topic: Port Groups
16:12:26 <jroll> Sukhdev: left some comments on the release note
16:12:43 <Sukhdev> jroll : thanks - will review and respond
16:13:04 <jroll> thanks
16:13:18 <Sukhdev> Port Groups patches are also looking good
16:13:55 <Sukhdev> This requires three way coordination to complete the feature -
16:14:16 <Sukhdev> 1) the patches listed on the wiki to deal with the ironic conductor side
16:14:32 <Sukhdev> 2) the bond interface related config
16:14:46 <Sukhdev> 3) Nova side plumbing
16:14:58 <Sukhdev> And, of course 4) ML2 drivers
16:15:22 <Sukhdev> 4) is really vendor specific stuff and can be ignored
16:15:44 <Sukhdev> do you agree?
16:16:37 <sambetts> something that I mentioned in the last meeting, is that I think the attach/detach interface logic should potentially become a prerequist to some of the port groups patches on the nova side
16:17:58 <Sukhdev> sambetts : I missed that part of the meeting - sorry
16:18:14 <sambetts> the main reason for it was I didn't want for us to merge logic we then remove a week later
16:18:35 <Sukhdev> can you elaborate what do you mean by attach/detach interface?
16:18:50 <jroll> sambetts: fwiw, I could still go either way on that
16:18:54 <sambetts> https://bugs.launchpad.net/ironic/+bug/1582188
16:18:56 <openstack> Launchpad bug 1582188 in Ironic "[RFE] Add interface attach API" [Wishlist,In progress] - Assigned to Sam Betts (sambetts)
16:19:06 <sambetts> Sukhdev: ^
16:19:17 <sambetts> other links are in the agenda too
16:19:41 <sambetts> basically it provides an API in Ironic to handle the vif to pif mapping instead of doing it in Nova
16:20:08 <sambetts> which is were we'll be adding code to handle the vif_port_id for the portgroups
16:21:24 <Sukhdev> ah I see -
16:22:23 <Sukhdev> is this necessary to do via this interface? I thought there was a port-group create API, which deals with the associating individual ports to the port-group
16:22:47 <Sukhdev> and then that is used to populate the local_link_information (?)
16:22:50 <sambetts> Sukhdev: its not the ports to the portgroups, its the vifs to the portgroups
16:22:59 <sambetts> neutron ports to portgroups
16:23:56 <jroll> sambetts: so both patches are done, it's just a matter of which we try to rebase
16:23:59 <jroll> right?
16:24:24 <jroll> and given we haven't even approved the spec for the attach API I think we should just get the portgroups in and then focus on that
16:24:36 <jroll> unless there's back compat concerns with that
16:24:36 <sambetts> makes sense
16:24:46 <Sukhdev> jroll +1
16:25:17 <sambetts> potentially more issues with having to support checking vif_port_id in extra on portgroup update but I can handle that
16:26:06 <jroll> cool
16:26:08 <jroll> thank you :D
16:26:58 <Sukhdev> anything else on this?
16:27:22 <sambetts> jroll: have you had a chance to get your cloud-init code public?
16:27:38 <jroll> sambetts:I have not, all the crazy last week
16:27:50 <jroll> sorry, I will bug people now
16:28:19 <sambetts> awesome, if we can use that as a base that should reduce the thought processing required to get the network config intergrated over there
16:28:33 <jroll> ya
16:28:35 <sambetts> do you know what their release process is?
16:28:58 <sambetts> I have wondered how quick it would be that prebuilt images would pick up a change merged into cloud-init
16:29:13 <jroll> I think they're pretty open to releasing quickly
16:29:18 <jroll> the bigger question is about packaging
16:29:32 <sambetts> ++
16:30:07 <sambetts> do we have any way to CI the portgroups too?
16:30:35 <jroll> someone (either vdrok or vasyl) was looking into bonding support in cirros
16:30:42 <jroll> I don't think it's done yet
16:30:46 <jroll> s/yet/today/
16:31:39 <sambetts> I wasn't sure if OVS had LACP or no for the simulated VMs, but if it does that is awesome
16:32:44 <Sukhdev> sambetts: If I were to speculate, I would say yes - as you can use port-groups with VMs
16:32:52 <sambetts> sweet :D
16:33:23 <jroll> sambetts: oh yeah, we have the support to do it in the infra stuff, I think
16:33:26 <jroll> just not in the guest
16:34:25 <sambetts> excellent :) I think if I remember correctly the only problem on the Cirros side is the kernel module not being loaded, so it looks like we're well on the way to getting that working
16:35:09 <jroll> sambetts: oh! I thought it wasn't there at all. might be thinking of something else though :)
16:37:08 <jroll> ok shall we continue?
16:37:23 <Sukhdev> yes -
16:37:26 <Sukhdev> sambetts : can you check the wiki to ensure I have listed all the relevant patches for port-groups?
16:37:36 <sambetts> Sukhdev: ++
16:37:57 <sambetts> sure :)
16:38:13 <Sukhdev> #topic : Vlan Aware severs
16:38:46 <Sukhdev> I was going to check the status of vlan aware vms on the neutron side - but, my vacation derailed it -
16:39:02 <Sukhdev> sambetts : do you know if the framework made it in the newton release?
16:39:29 <sambetts> Nothing much to add here, it seems like the API etc all merged on the neutron side, I was waiting for the doc patches to land to know everything
16:39:41 <sambetts> I need to go and dig it all up again
16:41:17 <Sukhdev> sambetts : sounds good - now we have a framework to work with
16:41:50 <sambetts> Yup :) the patches all need a bit of rework
16:42:03 <sambetts> and the spec still needs further review
16:42:18 <Sukhdev> it will be fun to have port-groups working with vlan aware servers :-):-)
16:42:47 <Sukhdev> sambetts : I have listed the spec on the wiki - can you add the patches as well?
16:43:12 <sambetts> Yup will add them in once I've updated them
16:43:55 <Sukhdev> cool
16:44:00 <Sukhdev> anything else on this?
16:44:22 <Sukhdev> #topic: Open Discussion
16:44:51 <Sukhdev> looks like we will have hands full this release cycle with networking stuff as well
16:45:39 <sambetts> ++
16:46:23 <Sukhdev> anybody has anything to ask/share with the team?
16:46:50 <sambetts> Nothing from me as far as I can remember
16:47:07 <Sukhdev> Silence is golden - I will take it as No
16:47:19 <Sukhdev> We are done folks - thanks for attending
16:47:25 <sambetts> thanks Sukhdev #
16:47:39 <Sukhdev> #endmeeting