17:00:40 <jlvillal> #startmeeting ironic-qa
17:00:41 <openstack> Meeting started Wed Nov  4 17:00:40 2015 UTC and is due to finish in 60 minutes.  The chair is jlvillal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:45 <openstack> The meeting name has been set to 'ironic_qa'
17:01:06 <vdrok> o/
17:01:35 <jlvillal> o/
17:01:42 <aarefiev22> hi
17:02:33 <jlvillal> Welcome to the very first meeting :)  I think turnout is likely to be low today as it only got added yesterday.
17:02:57 <aarefiev22> :)
17:03:04 <jlvillal> #topic Grenade testing
17:03:22 <jlvillal> So I have been working on Grenade testing and trying to get it to work.
17:03:43 <sambetts> Hey jlvillal
17:03:53 <jlvillal> I have multiple patches in-flight to fix part of the issue
17:03:58 <krtaylor> o/ sorry I'm late
17:03:59 <jlvillal> #link https://review.openstack.org/241018
17:04:11 <jlvillal> #link https://review.openstack.org/241044
17:04:51 <jlvillal> #link https://review.openstack.org/#/c/241393/
17:05:00 <jlvillal> #link https://review.openstack.org/#/c/241426/
17:05:06 <jlvillal> Welcome :)
17:05:47 <jlvillal> #link https://bugs.launchpad.net/ironic/+bug/1512544
17:05:47 <openstack> Launchpad bug 1512544 in Ironic "Ironic grenade jobs are failing" [High,In progress] - Assigned to John L. Villalovos (happycamp)
17:06:13 <jlvillal> So those various patches make it so that grenade will use the 'regex' of 'baremetal' to run the tempest tests.
17:06:41 <jlvillal> This has fixed the first tempest run during the grenade job so that it passes. Then it fails after that
17:06:46 <jlvillal> So some progress has been made.
17:06:50 <krtaylor> good stuff jlvillal
17:06:54 <jlvillal> Thanks
17:07:00 <jlvillal> Any questions/comments before moving on?
17:07:14 <jlvillal> Okay moving on :)
17:07:24 <jlvillal> #topic functional testing
17:07:41 <jlvillal> aarefiev22, Would you like to give a status update on your work?
17:07:49 <aarefiev22> sure
17:08:20 <aarefiev22> https://review.openstack.org/#/c/216701/  base patch for tests
17:08:41 <aarefiev22> needs attention
17:09:04 <aarefiev22> I've made job non voting
17:09:15 <aarefiev22> for functional tests
17:09:39 <jlvillal> Is it passing yet?
17:10:02 <aarefiev22> yes it's passing
17:10:18 <aarefiev22> also Sergii Turivnyi is working on test coverage
17:10:37 <aarefiev22> he has series of patches
17:10:39 <aarefiev22> https://review.openstack.org/#/c/238577/
17:10:53 <aarefiev22> https://review.openstack.org/#/c/239506/
17:11:04 <jlvillal> #info Patch to for functional testing in python-ironicclient is working.
17:11:12 <jlvillal> #link https://review.openstack.org/#/c/216701/
17:11:49 <jlvillal> #undo
17:11:51 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x955c810>
17:11:54 <jlvillal> #undo
17:11:55 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0x955cb10>
17:12:02 <jlvillal> #info Patch for functional testing in python-ironicclient is working.
17:12:05 <jlvillal> #link https://review.openstack.org/#/c/216701/
17:12:22 <jlvillal> I'm looking at patches...
17:12:55 <aarefiev22> few of them already have +2
17:13:15 <jlvillal> #info Additional functional tests are being proposed for python-ironicclient
17:13:23 <jlvillal> #link https://review.openstack.org/#/c/238577/
17:13:31 <jlvillal> #link https://review.openstack.org/#/c/239506/
17:13:41 <jlvillal> aarefiev22, Thanks for the update!
17:14:14 <aarefiev22> jlvillal: np
17:14:23 <jlvillal> #info jlvillal has started a very early patch for ironic functional testing. Comments requested
17:14:27 <jlvillal> #link https://review.openstack.org/235612
17:14:54 <jlvillal> #info Basic idea is to be able to start ironic-api, ironic-conductor, and rabbitmq.
17:15:17 <jlvillal> So I think those three services should be all that is needed to do functional testing for Ironic.
17:15:27 <jlvillal> I would love to get some comments feedback on it.
17:15:46 <jlvillal> At the moment I have shifted focus to Grenade as jroll requested that I make it the highest priority.
17:16:05 <jlvillal> Anything else regarding functional testing?
17:16:23 <jlvillal> Moving on then...
17:16:28 <jlvillal> #topic 3rd party CI
17:16:41 <jlvillal> Does anyone have anything to discuss for 3rd party CI?
17:16:50 <krtaylor> I have a draft for the third party ci spec
17:16:57 <jlvillal> Link?
17:17:06 <krtaylor> https://review.openstack.org/#/c/241294/
17:17:13 <jlvillal> #info krtaylor has a draft for a 3rd party CI spec
17:17:19 * jroll apologizes for being late
17:17:19 <jlvillal> #link https://review.openstack.org/#/c/241294/
17:17:21 <krtaylor> I need to discuss milestones and content
17:17:38 <krtaylor> as well as repos for moved/demoted drivers
17:17:44 <jroll> I tagged thingee on that review, btw, he's going to help with a lot of the comms etc
17:18:19 <krtaylor> jroll, thanks, he will be  abig help
17:18:45 <jlvillal> krtaylor, So still need to add some more content to the spec? But I assume would appreciate comments/reviews for what you have.
17:18:48 <krtaylor> once the milestones are decided, then we need to start email thread
17:19:08 <krtaylor> I need content - team input
17:19:13 <jroll> krtaylor: yeah, I'm supposed to touch base with him this week on the comms
17:19:18 <jlvillal> krtaylor, What are your next steps?
17:19:32 <krtaylor> need to get team decision on milestones
17:19:33 <jlvillal> Are you blocked?
17:19:38 <krtaylor> then we can communicate
17:19:51 <jlvillal> jroll, Is that an email discussion?  Meeting discussion?
17:20:12 <jroll> I think what we agreed on at the summit was ability to post comments by end of M, running on all patches by end of N
17:20:32 <jroll> and thingee and I had a goal of making initial contact this week
17:20:47 <jroll> and follow up with direct email, phone calls, if required
17:20:48 <krtaylor> jroll, comments by end of M will be hard for teams
17:21:09 <jroll> krtaylor: the ability to post comments, not commenting on every patch
17:21:12 <krtaylor> my experience with third party systems says that it takes months
17:21:16 <jroll> so, making the accounts, getting permissions right etc
17:21:20 <jroll> not actually running jobs
17:21:51 <jroll> does that make sense?
17:21:54 <krtaylor> but posting a comment and receiving events requires IT involvement for a lot of big companies
17:22:05 <krtaylor> that can take time
17:22:08 <jroll> sure. they have something like 4 months.
17:22:18 <krtaylor> I'm not saying its not doable, but we'll have to move fast
17:22:27 <sambetts> my goal was to have an assertTrue(True) system by M
17:22:30 <jlvillal> #info Agreed at the summit was to have the ability to post comments by end of Mitaka (permissions, accounts, etc), running on all patches by end of N_RELEASE
17:22:37 <jroll> sambetts++
17:22:44 <jlvillal> #chair jroll
17:22:44 <openstack> Current chairs: jlvillal jroll
17:22:50 <jroll> krtaylor: right, which is why we're communicating this week
17:23:02 <krtaylor> jroll, ok, thats the info I needed
17:23:14 <krtaylor> I'll get it documented and we can email
17:23:34 <krtaylor> broad first, but we'll have to identify individual contacts per driver
17:23:35 * jroll comments to this effect on the spec
17:23:39 <jroll> yep
17:23:45 <krtaylor> perfect, thanks!
17:23:52 <jroll> we have that somewhere in a treasure chest in an attic somewhere :)
17:24:08 <jroll> thank you!
17:24:15 <krtaylor> so, on the repo - any thoughts?
17:24:24 <jlvillal> Who is going to send email?  krtaylor?
17:24:26 <krtaylor> should we have a ironic/attic
17:24:48 <jroll> jlvillal: thingee or myself will be handling the comms
17:25:09 <krtaylor> I'd vote jroll
17:25:20 <jroll> krtaylor: so I think for community maintained drivers that don't get CI (things like AMT, ipmitool), we should have an openstack repo for those
17:25:23 <jlvillal> #action jroll or thingee to email expectations for 3rd party CI to list
17:25:26 <jroll> for vendor drivers, we'll leave it up to them
17:25:44 <jroll> but they won't be under the ironic umbrella
17:26:09 <sambetts> jroll: what happens to vendor drivers that dont have a point of contact? do they simply get deleted completely or moved into an attic location?
17:26:32 <jroll> sambetts: I believe we have some sort of contact for all drivers, but good question
17:26:36 <krtaylor> that was my concern
17:27:05 <jlvillal> Maybe we can come up with a policy and document it.
17:27:09 <jroll> it would take non-zero effort to move them
17:27:12 <krtaylor> as long as we send lots of email, and announce at every meeting, etc
17:27:38 <jroll> example of driver this will likely happen to: seamicro. they don't have funding to work on it any more
17:27:41 <jlvillal> But not sure if that is a QA/testing topic. Seems different scope.
17:28:06 <jroll> yeah, we can revisit that elsewhere
17:28:17 <jlvillal> Seems like a main Ironic meeting topic.
17:28:18 <krtaylor> copy me then please
17:28:25 <jlvillal> Or an email list topic.
17:28:46 <jlvillal> Anything else regarding 3rd party CI?
17:28:52 <krtaylor> I'd say we keep it together
17:28:55 <jroll> yeah, it'll be dev list or ironic meeting
17:29:11 <krtaylor> else we can only discuss process here and policy in main meeting
17:29:24 <sambetts> I was thinking should we setup a etherpad and have a ironic subteam like status reporting system for the thirdparty CIs?
17:29:33 <krtaylor> we can complete a recommendation here and take to main meeting
17:29:54 <krtaylor> we have an etherpad
17:29:57 * krtaylor looking
17:30:17 <jlvillal> #action sambetts to setup an etherpad and have ironic subteam like status reporting system for the thirdparty CIs. Or find existing etherpad
17:30:26 <jlvillal> :)
17:30:46 <jroll> krtaylor: yeah, I'm fine with talking about it here at a later time, I'd like to think about it and talk with some other folks
17:31:13 <krtaylor> https://etherpad.openstack.org/p/mitaka-ironic-test-qa
17:31:29 <krtaylor> but it is focused on mitaka summt prep
17:31:38 <jlvillal> I personally would vote for removing drivers that there is nobody maintaining.
17:31:49 <krtaylor> a general qa subteam etherpad would be good
17:31:50 <jlvillal> I think make the etherpad non-release specific
17:32:06 <krtaylor> agreed, sambetts proceed
17:32:16 <sambetts> :) will do
17:32:21 <jlvillal> Anything else in 3rd party CI?
17:32:36 <jlvillal> Okay, moving on
17:32:37 <krtaylor> that should do it for now
17:32:43 <jlvillal> #topic Opens
17:32:52 <jlvillal> Anyone have opens?
17:33:24 <jlvillal> Going once...
17:33:28 <jlvillal> twice...
17:33:31 <jlvillal> three times...
17:33:38 <jlvillal> Okay looks like we are done :)
17:33:46 <krtaylor> jlvillal, you have to let us latency/slow typing people catch up  :)
17:33:55 <jlvillal> Thanks for attending the kick-off meeting
17:34:00 <jlvillal> krtaylor, Oh did you have something?
17:34:08 <jlvillal> waits.....
17:34:09 <krtaylor> no, I'm good :) thanks!
17:34:16 <jroll> ya, let open discussioni sit for a few minutes usually
17:34:30 * jlvillal is too impatient :)
17:34:37 <sambetts> thanks jlvillal :D
17:34:44 <jroll> I'm all set though, thanks for hosting jlvillal
17:34:54 <jlvillal> Okay. Thanks all.
17:34:55 <krtaylor> yes, thanks jlvillal !
17:35:00 <jlvillal> I'm going to end it :)
17:35:06 <jlvillal> #endmeeting