17:00:49 <krtaylor> #startmeeting ironic-qa
17:00:49 <openstack> Meeting started Wed Nov 11 17:00:49 2015 UTC and is due to finish in 60 minutes.  The chair is krtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:53 <openstack> The meeting name has been set to 'ironic_qa'
17:01:03 <krtaylor> who is here for ironic-qa meeting?
17:01:08 <liliars> o/
17:01:10 <Watanabe_isao> o/
17:01:11 <cdearborn> o/
17:01:17 <maurosr> o/
17:01:54 <krtaylor> jlvillal is out today and asked me to chair for him
17:02:04 <krtaylor> hi everyone
17:02:14 <krtaylor> here is the agenda:
17:02:20 <krtaylor> #link https://wiki.openstack.org/wiki/Meetings/Ironic-QA
17:02:49 <krtaylor> any quick announcements?
17:03:35 <liliars> I think the etherpad Sam created and was an action item of the last meeting
17:03:42 <liliars> but it is already in the wiki page
17:03:46 <krtaylor> yes, we have an etherpad now
17:03:53 <krtaylor> #link https://etherpad.openstack.org/p/IronicCI
17:04:16 <krtaylor> ok, let's get started then
17:04:29 <krtaylor> #topic Grenade testing of Ironic
17:05:13 * krtaylor checks the contact
17:05:40 <krtaylor> we need to put discussion owners in the agenda so we can get status
17:06:06 <krtaylor> anyone have anything to discuss on Grenade?
17:06:27 <liliars> true, I think this was something jlvillal was taking over
17:06:29 <krtaylor> I know jlvillal has been making progress there, hit a couple of snags
17:06:36 <liliars> yeah same
17:06:45 <krtaylor> yeah, we may need to defer to next week
17:07:11 <liliars> didn't have time to take a loot at it though, but will do
17:07:15 * krtaylor is slow in irc meetings, tooo many distractions  :)
17:07:34 <liliars> hah I know the feeling
17:07:49 <krtaylor> lets move on then
17:08:01 <krtaylor> #topic Functional testing of Ironic
17:08:41 <krtaylor> I have not been focused on this effort the past week at all
17:08:56 <krtaylor> anyone have status/discussion points?
17:09:01 <liliars> I kinda have a question involving that
17:09:29 <liliars> we talked about driver specific functional tests not being in the ironic umbrella
17:09:41 <liliars> the ones that apply for drivers in general too?
17:10:12 <liliars> because we could contribute with some of our functional tests if it was the case
17:10:25 <liliars> the ones not oneview-specific
17:10:31 <krtaylor> I agree with that, but wonder is a base case should be tested
17:11:49 <liliars> hmm, I think yes
17:11:55 <maurosr> I think that at very least sharing your base tests helps the other of us trying to do the same, +1 for it
17:12:01 <krtaylor> since we can't deploy hardware in infra, do we start with pxe_ssh and do a deploy?
17:12:13 <krtaylor> maurosr ++
17:12:24 <liliars> yeah, would be happy to do it (:
17:13:04 <krtaylor> liliars, do you have a repo to drop them?
17:13:20 <liliars> right now is just internal
17:13:28 <krtaylor> we have a third party ci repo I created for just such things
17:13:46 <liliars> oh ok cool, I think there is a link in the spec right?
17:13:49 <liliars> now that you mentiones
17:13:53 <krtaylor> I know cinder has used if for CI tools, I don't see why we couldn't use it to share ironic things as well
17:13:53 <liliars> mentioned*
17:14:19 <krtaylor> liliars, yes, it is there under the third party working group
17:14:43 <liliars> cool will take a look
17:14:59 <liliars> we could probably put it there yeah, will talk to folks over here
17:14:59 <krtaylor> liliars, the tests would be very interesting, I'll work with you to share there if you wish
17:15:23 <liliars> krtaylor, cool! will let you know asap
17:15:43 <krtaylor> ok, anything else on functional testing?
17:16:14 <Watanabe_isao> krtaylor, could you give me a link of it, please? The third party working group you mentioned.
17:16:29 <sambetts> Sorry I'm late
17:16:57 <krtaylor> Watanabe_isao, sure
17:17:00 <krtaylor> #link https://wiki.openstack.org/wiki/ThirdPartyCIWorkingGroup
17:17:25 <liliars> Watanabe_isao: https://review.openstack.org/#/c/241294/3 you can also find it in the spec (and take a look at it meanwhile :))
17:17:40 <krtaylor> I no longer chair that group, but it is in even better hands with asselin now  :)
17:17:47 <asselin_> Watanabe_isao, hi
17:17:55 <krtaylor> speakin gof  :)
17:18:01 <krtaylor> and of
17:18:07 <Watanabe_isao> krtaylor, thank you very much. Looking..:)
17:18:23 <krtaylor> since we are discussing already...
17:18:26 <Watanabe_isao> asselin_, hi.
17:18:32 <krtaylor> #topic third party CI
17:18:48 <krtaylor> so, the spec is making good progress
17:18:54 * krtaylor fumbles for a link
17:19:13 <Watanabe_isao> https://review.openstack.org/#/c/241294
17:19:13 <krtaylor> #link https://review.openstack.org/#/c/241294/
17:19:16 <krtaylor> hehheh
17:19:31 <krtaylor> thanks Watanabe_isao
17:19:32 <liliars> hahh
17:19:37 <krtaylor> and liliars
17:19:44 <Watanabe_isao> :)
17:19:44 <krtaylor> I see you also posed it
17:19:55 <krtaylor> anyway, reviews are welcome
17:20:01 <liliars> (:
17:20:22 <krtaylor> it is somewhat unusual spec in that it doesn't push code exactly
17:20:39 <krtaylor> but will drive doc changes, patches to move drivers, etc
17:20:45 <cdearborn> thx
17:20:56 <sambetts> lucas left a comment to that effect I think,
17:21:08 <liliars> yeah just saw lucas's comment
17:21:14 <krtaylor> sambetts, yes, I wanted to discuss with him
17:21:45 <krtaylor> I personally think it is a useful place to document what is agreed upon
17:22:05 <cdearborn> +1
17:22:14 <krtaylor> but agree it is somewhat unusual
17:22:39 <krtaylor> any questions or comments?
17:23:13 <krtaylor> I'll crank out another version today incorporating the review comments, so reviews today would be great
17:23:14 <sambetts> I think we need to talk to lucas and see what he's thinking
17:23:22 <krtaylor> sambetts, agreed
17:23:45 <liliars> I also don't have an issue with it being a spec, but we should def talk to lucas
17:24:07 <krtaylor> absolutely, I'll take that action
17:24:27 <Watanabe_isao> liliars, what is the etherpad of IronicCI related with CI works, please?
17:24:29 <krtaylor> #action krtaylor to discuss CI spec with lucas
17:24:29 <Watanabe_isao> https://etherpad.openstack.org/p/IronicCI
17:24:32 <liliars> thanks
17:25:03 <liliars> thats the etherpad yeah
17:25:54 <Watanabe_isao> liliars, do you know if vendor need to update their progress there or something?
17:26:06 <liliars> mostly third-party CI driven
17:26:17 <liliars> if I'm not mistaken we did agree on that
17:26:24 <liliars> sambetts might know better
17:27:04 <liliars> though I also think krtaylor was about to start on that (:
17:27:07 <krtaylor> Watanabe_isao, I'd expect vendors to come here and to the infra third party CI, and document their progress in the etherpad
17:27:19 <krtaylor> I can document that in the spec  :)
17:27:23 <sambetts> I personally think thats something we should do, it gives us somewhere to track the progress of all the different drivers so that we don't have to waste any time in each of these meetings going over everyones progress
17:27:45 <krtaylor> exactly, and it fits with this mission for sure
17:27:50 <liliars> sambetts +1
17:28:07 <Watanabe_isao> krtaylor, sambetts liliars ,thanks for the answer.
17:28:07 <liliars> yeah then we can discuss mostly issues and such
17:28:16 <Watanabe_isao> +1
17:28:36 <sambetts> :) ironic does the same thing for all the subteams
17:28:44 <liliars> true
17:28:45 <krtaylor> #agreed vendor third party CI status will be tracked in the Ironic CI etherpad
17:29:06 <krtaylor> we can summarize and report in the subteam status
17:29:26 <sambetts> I've included sections for the community drivers too, because I believe we're treating them the same way
17:29:53 <krtaylor> yes, and its a good list to make sure it's all covered (or not)
17:30:06 <krtaylor> like ipmi
17:30:14 <liliars> do we already have someone to link to these drivers? I reckon we talked about it but no conclusion
17:30:32 <cdearborn> qq - at the summit, I believe it was agreed that the goal was to have the CI plumbing working for the drivers by the end of Mitaka, actual testing was not necessary at that milestone.  Is this still the case?
17:30:38 <krtaylor> jroll mentioned that there was a list of driver contacts, but I have not found it yet
17:31:02 <krtaylor> cdearborn, I think we said M2, it is in the spec  :)
17:31:14 <liliars> I think we have some sort of list in the ironic white board etherpad, 1 sec
17:31:32 <cdearborn> krtaylor, thx!  will review today or tomorrow
17:31:43 <sambetts> I think we want to make sure there is someone linked to each driver for accountablity
17:31:52 <liliars> yeah under drivers https://etherpad.openstack.org/p/IronicWhiteBoard
17:31:53 <krtaylor> cdearborn, that would be great
17:32:02 <liliars> but I don't see community drivers
17:32:38 <krtaylor> liliars, well, community drivers would have either infra testing or be out of tree unless someone picked up testing for them
17:32:58 <cdearborn> https://wiki.openstack.org/wiki/Ironic/Drivers
17:33:32 <krtaylor> excellent, I'll put a link in the spec
17:33:43 <liliars> yeah yeah I remember that discussion, just wanting to know if we have a name (if any) yet for such drivers
17:34:01 <krtaylor> I know ipmi is still being worked
17:34:28 <liliars> ohh didn't remember that link cdearborn thanks (:
17:34:43 <cdearborn> liliars, np!
17:35:09 <liliars> quick question
17:35:27 <krtaylor> we can document these links in the wiki as well, we have several, I want to work through that with jlvillal
17:36:02 <liliars> our ci is voting as code-review now and we talked about it only being able to vote as verify with a deploy job, any other requirements to be discussed?
17:36:12 <liliars> so we can prepare (:
17:37:25 <krtaylor> liliars, good question, I am suggesting that voting not be allowed initially for the new driver testing, until proved reliable
17:37:34 <krtaylor> it woul dbe comment only initially
17:37:48 <krtaylor> but in this case, I don't know
17:38:21 <liliars> yeah I agree with the reliable thing, just don't know what are we gonna consider reliable
17:38:42 <krtaylor> we don't want a situation where driver testing is unreliable and untrusted, that will lead to the results being ignored
17:38:42 <liliars> like up and running for a specific time frame or something
17:38:52 <krtaylor> we have seen that in other projects
17:39:01 <liliars> yeah I totally agree
17:39:23 <krtaylor> well, that is an ongoing discussion, but first we needed a dashboard to track
17:39:35 <krtaylor> but that needs enhancements to make sure they are good results
17:39:59 <krtaylor> but that is a discussion we can have in the third party ci working group meeting
17:40:05 <liliars> yeah, also logs
17:40:09 <liliars> sure! (:
17:40:11 <krtaylor> it is a global problem across all projects
17:40:25 <sambetts> Yeah, i believe other projects do it based on time frame
17:40:56 <krtaylor> sambetts, each project determines reliability and their requirements for voting a bit differently
17:41:13 <krtaylor> that can be a follow on discussion as well for ironic requirements
17:41:18 <sambetts> yup :)
17:41:35 <krtaylor> ok, so any more discussion on ironic CI?
17:41:57 <krtaylor> let's move on then
17:42:02 <krtaylor> #topic General QA topics
17:42:26 <krtaylor> not sure the content to be discussed here
17:43:23 <krtaylor> if no one has anything specific to this topic, I'll just shift to open discussion
17:43:36 <sambetts> I've got nothing
17:43:36 <liliars> fine by me
17:43:38 <krtaylor> #topic Open Discussion
17:44:43 <krtaylor> liliars, once the spec work settles down, I'd like to organize around the documentation for QA
17:44:54 <krtaylor> I know jlvillal has some ideas
17:45:11 <krtaylor> we should figure out what sections, where they'll live, etc
17:45:25 <liliars> cool, we can help
17:45:41 <liliars> havent had the time to look into our docs recently but will do
17:45:59 <liliars> things like how we set up the env and such
17:46:11 <krtaylor> no worries, I'm still digging out from summit  :)
17:46:12 <liliars> and I also think we have some docs on planning the functional tests
17:46:15 <liliars> 90% sure
17:46:16 <liliars> hah
17:46:23 <krtaylor> perfect
17:46:43 <krtaylor> anything else? anyone?
17:46:53 <maurosr> krtaylor: a quick question, in that ironicCI etherpad our team status will be under ipmitool as well?
17:47:07 <maurosr> disclaimer: I work with Kurt =)
17:47:24 <krtaylor> maurosr, excellent question, we are somewhat different
17:47:40 <sambetts> I think there are docs needed for how to configure devstack ironic to work with physical hardware, I know this might be a vendor specific in somecases but it'll give us all a standard to work from
17:47:44 <sambetts> ?
17:47:50 <sambetts> WDYT?
17:47:51 <krtaylor> maurosr, we'll have to talk about how we show platform testing, since we will be using community drivers
17:48:14 <liliars> also the link to the third-party-ci etherpad could be in the specs krtaylor (:
17:48:25 <liliars> yeah sambetts I agree
17:48:32 <liliars> we have some
17:48:34 <maurosr> right, I think it will probably br similar to libvirt's driver in nova for kvm in power  and kvm in x86
17:48:57 <krtaylor> sambetts, agreed, we had to change things up a bit from standard infra in order to work with baremetal
17:49:06 <liliars> some drafts* lets put it this way hah
17:49:37 <krtaylor> maurosr, thats what I'm thinking as well, that opens it up for other platforms too, like ARM
17:49:56 <sambetts> same, maybe we need to add some code to our devstack plugin to be able to disable the vms and all that setup they do for testing too, and ready it for physical
17:50:15 <sambetts> the ironic devstack plugin I mean
17:50:45 <liliars> also a troubleshooting section with things folks may face when setting up their envs as I personally think this is the worst part
17:51:29 <sambetts> +1
17:51:47 <krtaylor> liliars, but we also don't want to duplicate the excellent help given by the infra team CI meetings
17:51:59 <krtaylor> liliars, but we can keep it ironic specific
17:52:11 <liliars> yeah of course
17:52:23 <liliars> just to sum up (:
17:52:35 <sambetts> yeah I'm think debugging of ironic devstack, not the jenkins wizardry side of things
17:52:51 <liliars> hah +1
17:53:17 <krtaylor> yes, and network configuration
17:53:21 <krtaylor> maurosr, ^^^
17:53:27 <liliars> +1000
17:53:34 <krtaylor> that has been...fun
17:53:35 <sambetts> and thats all going to change when the ml2 stuff goes in too
17:54:15 <liliars> yay
17:54:30 <liliars> lets focus on the positives hah
17:54:35 <sambetts> :-P
17:54:41 <maurosr> hehe
17:54:50 <krtaylor> ok, it feels like we are winding down
17:54:54 <krtaylor> well, I didn't think we'd fill our time slot, but we are nearing the top of the hour
17:55:13 <krtaylor> any last points?
17:55:20 <sambetts> Nothing from me :)
17:55:37 <cdearborn> thx everyone, this was definitely helpful
17:55:37 <liliars> me neither
17:55:44 <krtaylor> ok, I'll call it then, good meeting everyone, thanks for participating !
17:55:52 <sambetts> o/ bye
17:55:54 <Watanabe_isao> :)
17:55:57 <maurosr> great, bye!
17:55:59 <cdearborn> c-ya
17:56:03 <liliars> thx guys, cya next weds, byee
17:56:06 <Watanabe_isao> bye-bye!
17:56:17 <krtaylor> #endmeeting