17:01:10 <jlvillal> #startmeeting ironic_qa
17:01:11 <openstack> Meeting started Wed Feb 3 17:01:10 2016 UTC and is due to finish in 60 minutes. The chair is jlvillal. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:14 <openstack> The meeting name has been set to 'ironic_qa'
17:01:18 <thingee> o/
17:01:25 <cdearborn> \o
17:01:31 <mjturek1> o/
17:01:31 <vdrok> o/
17:01:33 <rpioso> o/
17:02:09 <jlvillal> Hello everyone. As usual the agenda is here: https://wiki.openstack.org/wiki/Meetings/Ironic-QA
17:02:17 <krtaylor> o/
17:02:17 <maurosr> \p
17:02:24 <jlvillal> #topic Announcements
17:03:10 <jlvillal> So I think the gate is working now and seems to be doing well.
17:03:27 <jlvillal> I haven't checked it out this morning. But yesterday things seemed good.
17:03:42 <jlvillal> #info The gate appears to be much better now and working normally.
17:03:48 <jlvillal> I don't have any other announcements
17:04:00 <jlvillal> Moving on
17:04:09 <jlvillal> #topic Grenade testing
17:04:42 <jlvillal> #info jlvillal got tied up with other work related items and was not able to spend much time on it over the last week :(
17:04:44 <devananda> o/
17:05:08 <jlvillal> Sorry about that. I have been interrupted by other work for a lot of the last week.
17:05:25 <jlvillal> I should be able to get back onto it full time this week.
17:05:36 <jlvillal> If nothing else...moving on.
17:05:40 <krtaylor> there is a lot of that going around
17:05:45 <jlvillal> :(
17:05:51 <jlvillal> Darn employers! ;)
17:05:55 <krtaylor> silly day job ...
17:06:00 <jlvillal> #topic Functional testing
17:06:10 <jlvillal> I don't think anyone is working on this at the moment.
17:06:15 <jlvillal> If you are please speak up :)
17:06:37 <jlvillal> #info No updates regarding functional testing.
17:06:40 <jlvillal> Moving on
17:06:43 <mjturek1> jlvillal: our team has been meaning to
17:06:52 <mjturek1> but we've been sidetracked on other work
17:06:56 <jlvillal> mjturek1: Great. Looking forward to it.
17:07:01 <jlvillal> And understand on that.
17:07:04 <jlvillal> See above :)
17:07:11 <mjturek1> thanks jlvillal :)
17:07:16 <jlvillal> #topic 3rd Party CI (krtaylor)
17:07:26 <jlvillal> krtaylor: All yours. I'll drink some coffee now.
17:07:31 <krtaylor> not much to report, due to downstream distractions :)
17:07:37 <krtaylor> seems to be a common theme
17:07:44 <thingee> o/
17:08:02 <jlvillal> #help
17:08:06 <thingee> this seems to be a pretty accurate report that I double checked yesterday https://etherpad.openstack.org/p/IronicCI
17:08:38 <krtaylor> thingee, agreed, I was going to check that against the accounts also
17:08:39 <jlvillal> Hmm. bot lies about #help command :(
17:08:47 <krtaylor> hehheh
17:08:53 <jlvillal> #CI report at: https://etherpad.openstack.org/p/IronicCI
17:08:58 <jlvillal> #info CI report at: https://etherpad.openstack.org/p/IronicCI
17:09:11 <thingee> krtaylor: so we have some drivers that aren't where there suppose to be
17:09:31 <thingee> also volunteers for some of these non-vendor solutions haven't really popped up with anything
17:09:43 <jlvillal> #chair krtaylor
17:09:44 <krtaylor> yeah, I am thinking so also
17:09:44 <openstack> Current chairs: jlvillal krtaylor
17:09:58 <jlvillal> krtaylor: I think you can do #info. Not sure if you couldn't before.
17:10:13 * jlvillal thinks anyone can #info, but isn't sure.
17:10:25 <krtaylor> thanks
17:10:46 <krtaylor> thingee, I did see Lucas email about the Staging Drivers project, so we have a place to move things
17:11:10 <thingee> krtaylor: sorry which?
17:11:42 <krtaylor> its a project for drivers that are untested
17:11:57 <devananda> thingee: I've had no traction yet getting something going here for IPMI testing
17:12:05 <devananda> jroll: any on your end?
17:12:10 <jroll> ohai
17:12:16 <krtaylor> devananda, we will be, but not on x86 :)
17:12:21 <devananda> krtaylor: right
17:12:22 <thingee> devananda: anything I can help? infra has some help resources here as well.
17:12:27 <jlvillal> #info http://lists.openstack.org/pipermail/openstack-dev/2016-January/085128.html
17:12:29 <devananda> krtaylor: well - will you be testing ipmitool or pyghmi?
17:12:38 <mjturek1> ipmitool
17:12:40 <krtaylor> ipmitool, initially
17:12:40 <jroll> devananda: so I have a verbal commitment to hardware, I owe folks a network diagram
17:12:40 <jlvillal> thingee: http://lists.openstack.org/pipermail/openstack-dev/2016-January/085128.html
17:12:45 <devananda> krtaylor: oh - that's great
17:12:59 <thingee> jlvillal: thanks
17:13:10 <krtaylor> devananda, alongside all the other PowerKVM testing
17:13:21 <devananda> that raises an interesting question, actually
17:13:41 <jroll> devananda: and that hardware is racked and online, so the slow part is done
17:13:46 <devananda> where a single python driver (eg, agent_ipmitool) can be used against several types of hardware ... how do we want to track them upstream?
17:14:00 <krtaylor> yes, the old platform agnostic question
17:14:19 <jroll> devananda: good question, and how fine-grained :)
17:14:22 <devananda> jroll: great. and someone to do the care and feeding of the CI bots?
17:14:28 <krtaylor> we have been simply saying it is on ppc64, as with our long-running nova testing
17:14:34 <jroll> devananda: heh. hi.
17:14:41 <devananda> jroll: ohhai. yea ... bad idea
17:14:45 <jroll> devananda: I expect I can get more people helping though
17:14:45 <devananda> you're already oversubscribed
17:14:49 <jroll> yeah I know
17:14:58 <devananda> that's the main hold up on my end as well - I can get the hardware
17:15:03 * jroll will be chatting with folks
17:15:22 <jlvillal> Please #info anything of note :)
17:16:02 <krtaylor> devananda, see http://docs.openstack.org/developer/nova/support-matrix.html
17:16:16 <devananda> thingee: for the requirement that a hardware driver have a CI system, I think krtaylor's ipmitool testing against ppc64 would be sufficient to meet those criteria. yes?
17:16:18 <krtaylor> I think we can list the platform architectures
17:17:02 <thingee> I'd recommend whatever is common for your users. Because that's ultimately going to be the well tested thing
17:17:08 <krtaylor> it would be good to test both, I mean we would like to move on to IPA instead of using our bearmetal for ipmitool
17:17:18 <jroll> that makes sense to me, ipmi protocol doesn't differ between platforms afaik
17:17:26 <jroll> shouldn't*
17:17:28 <thingee> that's typically what we do for reference impl testing for other things in the gate
17:17:40 <devananda> jroll: eehh.... shouldn't ;)
17:17:49 <jroll> would be nice to throw something else at it, I'd love to see opencompute tested
17:17:57 <devananda> krtaylor: nice chart. we should do a similar doc.
17:17:58 <jroll> as it's sort of the baseline, IMO
17:18:06 <jroll> not much fancy vendor stuff
17:18:11 <devananda> also, that chart is wrong for ironic .... /me spins up a patch to nova
17:18:13 <krtaylor> devananda, agreed
17:19:43 <krtaylor> so, as far as CI and driver milestones, does someone want to email the teams not updating their account info? or is that me :)
17:20:27 * krtaylor notices everyone take one step back
17:20:29 <devananda> krtaylor: I think that's you :)
17:20:50 <devananda> unless thingee wants to do that
17:20:57 <krtaylor> hehheh, ok, I'll push some other stuff aside and get that done as soon as I can
17:21:05 <devananda> might be a little more officialish to have the foundation say "hey folks, you're lagging"
17:21:16 <thingee> devananda, krtaylor the communication is what I volunteered to do
17:21:23 <devananda> great :)
17:22:24 * devananda senses an action item coming
17:22:26 <krtaylor> thingee, so much appreciated, how about I use the IronicCI etherpad to list the systems that have not registered, then we can keep that list current going forward
17:22:52 <thingee> krtaylor: yes, that seems to be up-to-date as I double checked it yesterday
17:23:35 <krtaylor> thingee, against the thirdpartysystems page or the accounts page or both?
17:25:03 <thingee> I compared the account page with what's reported on the IronicCI etherpad. The etherpad is accurate.
17:25:38 <thingee> but yes lets use the etherpad.
17:25:43 * thingee is in two meetings :)
17:26:06 <krtaylor> ok, let me check against the systems page, that fulfills the infra requirement
17:26:50 <krtaylor> #action krtaylor to verify third party dirver CI teams against the ThirdPartySystems wiki page
17:26:54 <rajinir> we would like to hear if we full filled M release requirement ( Dell drac driver)
17:27:25 <krtaylor> #action thingee to notify test teams that need to create and update their info
17:27:42 <krtaylor> rajinir, you work with cdearborn ?
17:27:46 <rajinir> yes
17:28:03 <krtaylor> yes, I looked at it last week, all looks good
17:28:11 <rajinir> thanks
17:28:25 <krtaylor> so I think we have a plan
17:28:30 <krtaylor> anything else?
17:28:43 * jlvillal learns #help is not help from the bot but a 'Call for Help' to recruit people to help out....
17:29:22 <krtaylor> then I'll turn it back to you jlvillal
17:29:41 <jlvillal> Thanks krtaylor and everone else :)
17:30:05 <jlvillal> krtaylor: Was there anything that should be #info before we move on?
17:30:15 <jlvillal> Or are we good?
17:30:32 <jlvillal> s/everone/everyone/
17:30:44 <krtaylor> I think we're good
17:30:47 <jlvillal> Okay
17:30:49 <jlvillal> moving on
17:30:58 <jlvillal> #topic Open Discussion / General QA topics
17:31:13 <jlvillal> Anyone?
17:31:34 * jroll thinks it's time for breakfast
17:31:48 <jlvillal> :)
17:32:14 <jlvillal> Okay, if nothing to discuss.
17:32:18 <jlvillal> I will go ahead
17:32:22 <jlvillal> and end
17:32:24 <jlvillal> the
17:32:27 <jlvillal> meeting
17:32:29 <jlvillal> ....
17:32:31 <jroll> thanks jlvillal :)
17:32:38 <jlvillal> jroll: Thanks
17:32:43 <jlvillal> And thanks to everyone else!
17:32:52 <jlvillal> #endmeeting