18:00:17 <TheJulia> #startmeeting ironic_ui
18:00:19 <openstack> Meeting started Tue Mar  7 18:00:17 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:23 <openstack> The meeting name has been set to 'ironic_ui'
18:00:23 <TheJulia> o/
18:00:26 <crushil> \o/
18:00:52 <jroll> \o
18:01:10 <TheJulia> #topic Announcements / Reminders
18:01:23 <TheJulia> #info Welcome everyone to the first meeting for the ironic-ui! \o/
18:01:35 <mgould> o/
18:01:56 <TheJulia> Greetings ppiela and everyone else
18:02:13 <soliosg> o/
18:02:16 <ppiela> Hello
18:02:29 <TheJulia> Are we all here?
18:03:32 <TheJulia> I guess we should get started
18:03:50 <TheJulia> #topic Current Status - Items Under Development
18:04:22 <TheJulia> ppiela has been kind enough to push forward on the development of some missing features in the ironic-ui.  Thank you ppiela!
18:04:34 <TheJulia> #info Support for network_interface
18:04:41 <TheJulia> #link https://review.openstack.org/432599
18:04:49 <soliosg> Is there an etherpad with the agenda?
18:05:13 <TheJulia> You know, that would help if I had pasted that link
18:05:14 <TheJulia> One moment
18:05:45 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-ui
18:06:20 <soliosg> Great, thank you
18:07:24 <TheJulia> The other feature ppiela has been working on is support for console activation/access information/deactivation in the UI.
18:07:35 <TheJulia> #info Support for starting/stopping console
18:07:41 <TheJulia> #link https://review.openstack.org/437419
18:08:19 <TheJulia> ppiela: Are there any other high level items that your currently working on?
18:09:03 <ppiela> I am adding support for newer power transitions: reboot, soft reboot, and soft power off
18:09:26 <TheJulia> Awesome, is there a review up yet?
18:09:44 <ppiela> Also working on a bunch of refactoring and cleanup, we have learnt a lot in the past year
18:10:05 <ppiela> No review yet, coming later this week
18:10:13 <TheJulia> #info ppiela is Also working on additional power state transitions, soft power-on/off, as well as some refactoring. Expect some code later this week.
18:10:29 <TheJulia> Awesome, Thank you ppiela!
18:10:52 <TheJulia> Is anyone else working on any additions to the UI that would be pertinent to raise at this time?
18:12:04 * TheJulia hears crickets
18:12:47 * jroll too
18:13:00 <TheJulia> I guess not, especially since this is our first meeting on this topic.
18:13:01 <jroll> please don't add crickets to the UI, though, that will be filed as a bug
18:13:02 <TheJulia> Moving on...
18:13:13 <TheJulia> jroll: Awwwwwwww, it could be fun!
18:13:20 <jroll> :)
18:13:22 <TheJulia> #topic Current Status - Missing Features
18:13:47 <TheJulia> So in comparison to Ironic, the UI is missing a number of features, primarily due to the nature of it trailing the main project.
18:14:01 <mgould> jroll: "filed as a bug" - groan
18:14:15 <TheJulia> #info Missing features - Portgroup support, setting/getting boot device, RAID configuration, Ability to set resource_class
18:14:30 <TheJulia> I believe I’ve recorded most of these originally on my a spreadsheet I made and in launchpad bugs. I’ll try and clean-up the launchpad bugs this week.
18:14:31 <jroll> mgould: \o/
18:14:43 <TheJulia> #action TheJulia to clean-up launchpad this week.
18:14:46 <soliosg> I think in this section the spreadsheet with missing features might be handy
18:14:51 <TheJulia> #link https://bugs.launchpad.net/ironic-ui
18:14:59 <TheJulia> #link https://docs.google.com/spreadsheets/d/1petifqVxOT70H2Krz7igV2m9YqgXaAiCHR8CXgoi9a0/edit?usp=sharing
18:15:36 <jroll> +1 for launchpad bugs
18:15:52 <TheJulia> Is anyone interested in looking at some of those items? I'm more than happy to spend time sharing context.
18:16:35 <TheJulia> Launchpad should be considered the source of truth for our purposes.
18:16:46 <TheJulia> But I'll fix it :)
18:17:00 <crushil> TheJulia, I was planning on working on some of those
18:17:46 <TheJulia> I guess this logically moves us into Planning/Priorities, moving on if there are no objections?
18:18:28 <TheJulia> #topic Planning/Priorities
18:19:24 <TheJulia> crushil: Was there a specific item or two that you were looking at working on?  I'm curious so we can make sure ppiela and yourself don't step on each others toes. :)
18:20:38 <crushil> TheJulia, I'm still acclimatising myself with the ironic-ui and ironic in general. I still need to look in-depth as to what specifically I want to work on
18:20:50 * mgould would like to have a look at node-get-boot-device
18:21:13 <ppiela> crushil: dont hesitate to reach out
18:21:23 <crushil> ppiela, ack
18:21:30 <TheJulia> crushil: Same for myself, and I suspect the bulk of the ironic community :)
18:21:55 <TheJulia> mgould: Seems like that is an option, is that action worthy ? :)
18:22:51 <TheJulia> Overall, I would really like for us to get support in place for portgroups by the end of the cycle, but that is just my hope.
18:23:03 <mgould> TheJulia: sure
18:23:22 <ppiela> TheJulia: I can take on portgroups
18:23:25 <TheJulia> #action mgould to look at adding support for node-get-boot-device to the UI
18:24:22 <TheJulia> ppiela: That does kind of make sense given you've been in the ports interface recently
18:24:59 <ppiela> TheJulia: that was my thinking also
18:25:11 <TheJulia> Action item worthy ? :)
18:25:26 <JayF> /win 26
18:25:36 <JayF> whoops :( My lurking is revealed
18:25:37 <TheJulia> s/\ // :)
18:27:51 <TheJulia> #info ppiela is anticipating to look at adding portgroup support.
18:28:22 <TheJulia> That is really all I have, does anyone have anything else regarding planning/priorities?
18:29:26 <mgould> not me
18:30:05 <TheJulia> Well, if there is nothing on that subject, we should move on.  Since we have no explicit discussion items that I see, I propose we move on to Open Discussion
18:30:30 <ppiela> TheJulia: sounds good
18:30:45 <TheJulia> Oh, there is one more item on the agenda!
18:31:55 <TheJulia> Regarding testing, I believe we're waiting on some guidance from Horizon on integration testing. I'm not expecting that to appear quickly this cycle, but I'll follow-up later this week or early next week to see when we can expect guidance.
18:32:37 <TheJulia> #action TheJulia to follow-up on testing write-up/guidance that the Horizon team indicated they would attempt to provide this cycle.
18:33:04 <TheJulia> So, since there is noting else (hopefully), moving on in a minute. :)
18:33:54 <TheJulia> #topic Open Discussion
18:34:39 <TheJulia> Do we have anything else to discuss today? Questions? Crazy ideas? Preferred coffee houses for UI development?
18:35:17 <soliosg> I wonder if missing items in the spreadsheet are reflected on https://bugs.launchpad.net/ironic-ui
18:35:41 <soliosg> Or are there any bug/features to create in launchpad yet?
18:36:27 <mgould> "no support for getting/setting boot devices" seems to be missing from Launchpad
18:36:35 <ppiela> Launchpad is not complete
18:36:40 <TheJulia> soliosg: The bugs on launchpad need to be updated to become the source of truth. I was planning on trying to take care of that later this week, unless someone wants to volunteer to take a first pass?
18:36:40 <crushil> Wait, why are we still tracking this in a bug? Shouldn't there be a bp associated with this?
18:37:18 <TheJulia> Ironic really doesn't use blueprints, and also we're presently chasing functionality in the CLI.  So realistically, they are defects/bugs that need to be addressed for parity.
18:38:25 <soliosg> TheJulia: Agree, having the bug/features 'ready to pick-up' in launchpad would be easier to spot where work is needed
18:39:44 <TheJulia> I think if there is something that is like "major addition" that goes above and beyond the scope of parity, then it might be time to discuss something like an RFE bug or a specification depending on the scope being proposed.
18:40:36 <soliosg> TheJulia: I can help you with the first round to check missing items parity between spreadsheet and launchpad. This would help me spot which issue/bug I could work on
18:41:05 <TheJulia> But, that is just my point of view, and consensus and common context/direction is the key to my point of view. I can be convinced of otherwise as well :)
18:41:06 <crushil> TheJulia, Thanks for catching me up
18:41:14 <ppiela> I would love to get feedback from operators
18:41:18 <TheJulia> soliosg: Awesome, Thank you!
18:41:48 <TheJulia> #action soliosg to take a first pass at reconciling bugs in the ironic-ui launchpad bug tracker.
18:41:57 <TheJulia> crushil: no problem :)
18:42:17 <TheJulia> #info ppiela is seeking operator feedback.
18:43:05 <TheJulia> ppiela: I think that will begin to surface more as the cycle proceeds since the pipeline from project release to operator consumption tends to be elongated.
18:43:36 <TheJulia> ppiela: This may also be a topic to raise on the operators mailing list
18:43:54 <TheJulia> jroll: Thoughts?
18:44:05 * jroll in another meeting, catches up
18:44:21 <ppiela> TheJulia: sounds good
18:44:23 <jroll> TheJulia: thoughts on how to get feedback, you mean?
18:44:32 <TheJulia> jroll: Yes
18:44:47 <jroll> I've always had trouble with that, the ops list is a good place to start
18:45:39 <TheJulia> ppiela: Would you like to seek feedback, or would you like someone else to actively seek feedback from the operators mailing list?
18:45:40 <jroll> I'd be curious how many ops are running a "reasonable" version of -ui
18:45:50 <jroll> recent might be a better word
18:45:58 <TheJulia> jroll: Same
18:46:51 <ppiela> TheJulia: We have a strong dependency on the structure of the language used to describe driver properties. Just want  to make a note of that.
18:47:34 <ppiela> TheJulia: I will reach out to the operators
18:47:44 <TheJulia> Ahh yes, since we have no way of otherwise really determining required items.
18:47:48 <TheJulia> ppiela: Awesome
18:48:10 <TheJulia> #action ppiela to seek feedback from the Operators Mailing list.
18:48:56 <TheJulia> ppiela: I'll see if I can chat up a solution to help us with the driver properties.
18:49:19 <ppiela> TheJulia: We extract a bunch of metadata like: default, enumerated values, dependency relationships
18:51:46 <TheJulia> #info Presently ironic-ui extracts metadata from descriptions about driver property values to convey defaults, values, dependency relationships. This needs raised visibility and consistency in ironic's drivers, or some other solution to help provide clarity to users.
18:52:30 <TheJulia> We have about 8 minutes remaining, is there anything else to discuss today?
18:53:21 <ppiela> TheJulia: One of the primary use cases I see for the UI is debugging failed deployments. Not sure if others agree?
18:54:36 <ppiela> If so, is there more data that we can collect and present. My experience is that people are spending a bunch of time grepping logs
18:56:11 <TheJulia> We don't surface a huge amount of failure related data via the API, but as a community we are working on improving that.  Maybe provide insight into potentially missing fields, but that would be more "something might be missing", however clean-up operations wipes some of that off of the API if memory serves.
18:56:25 <TheJulia> I do agree though, there is value in that visibility for an operator
18:57:41 <TheJulia> Well, we're almost out of time, I hope this has helped everyone. :)
18:58:04 <ppiela> I was wondering if interesting failure data might be generated in terms of notifications to telemetry
18:58:22 <ppiela> TheJulia: Thanks for organizing
18:58:41 <TheJulia> ppiela: That is definitely something to ponder :)
18:58:53 <TheJulia> Thank you everyone for attending, and we'll chat again next week! :)
18:58:54 <soliosg> Discussion was really helpful. Thank you everyone.
18:58:54 <crushil> Thanks everyone. \o/
18:59:11 <TheJulia> #endmeeting