18:00:22 <TheJulia> #startmeeting ironic_ui
18:00:22 <openstack> Meeting started Tue Mar 14 18:00:22 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:26 <openstack> The meeting name has been set to 'ironic_ui'
18:00:26 <TheJulia> o/
18:00:59 <jroll> \o
18:01:00 <ppiela> hello
18:01:34 <TheJulia> Our agenda for this week:
18:01:41 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-ui#Agenda
18:02:32 <TheJulia> #topic Announcements / Reminders
18:03:15 <dtantsur> o/
18:03:16 <TheJulia> #info Per a discussion with robcresswell, we should not expect guidance on improving testing from the horizon team until the end of Pike-1
18:03:36 <robcresswell> o/
18:03:38 <TheJulia> Does anyone else have anything announcement worthy?
18:03:54 <ppiela> Not me
18:04:15 <crushil> \o
18:04:32 <TheJulia> Then moving on
18:04:39 <TheJulia> #topic Current Status
18:05:53 <TheJulia> #info TheJulia updated launchpad bugs earlier today, so it should be considered the source of truth moving forward.
18:05:56 <TheJulia> #link https://bugs.launchpad.net/ironic-ui
18:06:33 <TheJulia> #info ppiela sent a note to the Operators mailing list soliciting feedback. No replies as of yet.
18:07:14 * dtantsur wonders what can be done to grab more attention to the project
18:07:28 <TheJulia> If anyone has feedback from with-in their organizations regarding the ironic-ui, it would be helpful to direct that feedback to ppiela.
18:07:49 <dtantsur> we did not get to properly testing it so far..
18:08:45 <dtantsur> btw I'd give https://bugs.launchpad.net/ironic-ui/+bug/1663840 high or critical priority, if you ask me
18:08:45 <openstack> Launchpad bug 1663840 in Ironic UI "add devstack plugin" [Undecided,New]
18:09:00 <TheJulia> Sounds like we're already moving on :)
18:09:18 <TheJulia> Does anyone have any other status information to convey?
18:09:33 <dtantsur> ooops, sorry :D
18:09:38 <TheJulia> No worries :)
18:09:50 * TheJulia hears crickets
18:10:16 <TheJulia> #topic Planning/Priorities
18:10:55 <TheJulia> We have several new bugs that could use input from the community regarding prioritization, so I figured it would just be easiest to go through them quickly.
18:11:23 <TheJulia> #info 3 outstanding/new bugs need priority set.
18:11:46 <TheJulia> Starting with the first one...
18:11:52 <TheJulia> #link https://bugs.launchpad.net/ironic-ui/+bug/1671567
18:11:52 <openstack> Launchpad bug 1671567 in Ironic UI "UI has no way to get/set a node's current boot device" [Undecided,New] - Assigned to Miles Gould (mgould)
18:12:05 * dtantsur votes low/wishlist
18:12:24 <jroll> ditto
18:12:26 <dtantsur> users don't need to actually do that too often, if ever, right?
18:12:26 <TheJulia> I think this should also be low or wishlist
18:12:34 <jroll> dtantsur: that's my thought
18:12:59 <TheJulia> If there are no objections, low?
18:13:35 <TheJulia> With some semblance of console support, I could see it being a logical troubleshooting aid in a sense.
18:14:00 <TheJulia> ppiela: any thoughts?
18:15:25 * TheJulia wonders if ppiela has gone afk
18:15:41 <TheJulia> Anyway, We can always change it later if we decide otherwise.
18:15:48 <dtantsur> yep, it's not too hard
18:15:55 <TheJulia> #agreed bug 1671567 to low
18:15:55 <openstack> bug 1671567 in Ironic UI "UI has no way to get/set a node's current boot device" [Undecided,New] https://launchpad.net/bugs/1671567 - Assigned to Miles Gould (mgould)
18:16:01 <TheJulia> #undo
18:16:02 <openstack> Removing item from minutes: #agreed bug 1671567 to low
18:16:03 <ppiela> sorry, on another call with my boss
18:16:06 <TheJulia> #agreed bug 1671567 to low priority
18:16:15 <dtantsur> or to put it different: asking for forgiveness is easier than for permission :D
18:16:23 <TheJulia> ppiela: eek, sorry for the interruption then :)
18:16:53 <TheJulia> Next up
18:17:02 <TheJulia> #link https://bugs.launchpad.net/ironic-ui/+bug/1663840
18:17:02 <openstack> Launchpad bug 1663840 in Ironic UI "add devstack plugin" [Undecided,New]
18:17:34 <crushil> I feel it is critical or at least high
18:17:35 <dtantsur> as I mentioned above, this may delay adoption, so high/critical
18:17:42 <TheJulia> dtantsur earlier indicated he thought this was high/critical, I'm inclined to agree that it is also critical
18:17:44 <jroll> +1 from me
18:18:07 <TheJulia> Okay, seems like we are agreeing on critical
18:18:42 <TheJulia> #agreed bug 1663840 to critical priority
18:18:42 <openstack> bug 1663840 in Ironic UI "add devstack plugin" [Undecided,New] https://launchpad.net/bugs/1663840
18:19:16 <TheJulia> And third and final for the day
18:19:22 <TheJulia> #link https://bugs.launchpad.net/ironic-ui/+bug/1672729
18:19:23 <openstack> Launchpad bug 1672729 in Ironic UI "UI is unaware of driver composition node *_interface fields." [Undecided,New]
18:19:42 <jroll> I'd say it's high/critical by the end of this cycle
18:19:52 <crushil> +1
18:20:00 <TheJulia> I would also agree it is high
18:20:00 <dtantsur> yeah, at least high
18:20:10 <ppiela> me too
18:20:23 <TheJulia> Awesome!
18:20:42 <TheJulia> #agreed bug 1672729 to high priority
18:20:42 <openstack> bug 1672729 in Ironic UI "UI is unaware of driver composition node *_interface fields." [Undecided,New] https://launchpad.net/bugs/1672729
18:21:28 <TheJulia> Any other items that require prioritization or planning at this time?
18:21:37 * TheJulia guesses the answer is no, but wanted to raise the question anyway
18:22:47 <TheJulia> #topic Discussion
18:23:47 <TheJulia> ppiela raises the first discussion topic, which is should the ironic-ui be targeting more recent API versions.  ppiela If your able to, I would kind of like you to elaborate a little more.
18:24:53 <dtantsur> I may misunderstand the question, but it may be not unfair for ironic-ui from Pike to target the latest Pike API..
18:25:55 <jroll> right, I guess I'm curious why we wouldn't do that
18:25:56 <TheJulia> The ui's client invocation does have a version lock pin, presently at 1.20, essentially it is chasing ironic in terms of features and functionality.
18:26:36 <dtantsur> well, we're still doing the versioning wrong..
18:26:49 <jroll> dtantsur: ?
18:26:52 <dtantsur> what should happen is ironic-ui learning the version and adjusting user experience accordingly
18:27:02 <dtantsur> we've never been good at that though :)
18:27:07 <jroll> ah, fair
18:27:17 <TheJulia> I agree, although we're definitely not there in terms of functionality :)
18:27:18 <dtantsur> thinking aloud about how all this versioning started :)
18:27:40 <dtantsur> I think while we're still getting there, chasing master is probably the best idea
18:27:55 <TheJulia> The primary version for the pin was a behavior change originally with node creation/enrollment
18:28:23 <TheJulia> At this point, that need has passed, and I'm wondering if the ui might be able to consume latest, although it might not know how to present some of the data.
18:28:37 <dtantsur> a client (e.g. UI) can have a minimum supported version as well. but again, that's for the future. a wishlist item.
18:28:49 <jroll> eh, I think pinning is best, so we can't break it by accident
18:29:01 <jroll> (or on purpose)
18:29:19 <TheJulia> So, I think the agreement may be, to continue with what the UI is doing, pinning as new feature/functionality is added since we are chasing master's functionality
18:29:30 <dtantsur> versioning idea assumes that you have a range supported by the client (e.g. 1.10 - 1.20) and supported by the server (e.g. 1.1 - 1.18)
18:29:41 <dtantsur> of which you pick the maximum supported by both (1.18 in my example)
18:30:20 <dtantsur> TheJulia, yes, that's the best idea at this stage of the development
18:30:56 <TheJulia> #agreed Continue with API client version pinning for the time being, and consider evolving to better support API versioning as time goes on.
18:31:37 <TheJulia> So the next item, is presently there is no separate view of ports, they are bound to hosts and and that is essentially the whole interaction with the node in the UI.
18:32:30 <TheJulia> However portgroups is a further evolution and my curiosity is if we should consider it to be a separate view into the data.  I.e. see ports separately from nodes.
18:32:31 <dtantsur> (full disclosure: I haven't seen ironic-ui in action) when I start with some UI, I kind of like having one entry point, from which I can develop everything else.
18:32:45 <dtantsur> but probably separating is cleaner..
18:33:14 <jroll> yeah, I'm also unsure, idk how much it makes sense to interact with ports without interacting with nodes
18:33:16 <TheJulia> I guess my question boils down to, how often does someone have to go look at just ports?
18:33:43 <dtantsur> troubleshooting?
18:33:48 <jroll> every time I've used 'ironic port-*' it's been while troubleshooting a node
18:34:15 <TheJulia> so perhaps the right thing to do is to more treat any full view of ports in the ui as troubleshooting enablement?
18:34:50 * TheJulia feels like we have consensus
18:35:00 <jroll> I'm not sure what troubleshooting begins with a port-list ¯\_(ツ)_/¯
18:36:04 <TheJulia> There is a case to have a stray port in the API, a separate view would help expose it, but if we fix the api such that doesn't happen, then it really wouldn't be needed
18:36:29 <jroll> mmm, right
18:37:05 <TheJulia> I guess further consideration and possibly making sure we have an open bug for that behavior
18:37:46 <TheJulia> I'll take that as an action item to look into
18:38:03 <jroll> that sounds reasonable to me
18:38:22 * dtantsur nods
18:38:36 <TheJulia> #action TheJulia to look into the stray port creation case, and if we don't have a bug in ironic, open it as that is the main case for when a full port view would even really be needed.
18:39:15 <TheJulia> Okay, two final discussion items! \o/  I guess ppiela's item from open discussion is worth raising now, since the last item is less important.
18:39:42 <JayF> A little late; but one thing we could consider is when ironic-ui has a devstack plugin, to increase visibilty, add a note to ironic devstack guide on how to also enable ironic-ui
18:39:52 * JayF would probably build his devstack with UI by default in that case
18:40:04 * dtantsur too
18:40:05 <TheJulia> ppiela inquires if the ui should be using node "reservation" value to limit submission of actions?
18:40:23 <dtantsur> TheJulia, not sure if I understand it.. like do nothing if this field is not empty?
18:40:29 <dtantsur> s/do nothing/wait/
18:40:30 <jroll> JayF: +1
18:40:40 <TheJulia> dtantsur: wait if the field is populated, I think.
18:40:42 <JayF> TheJulia: I'd look at the CLI as an example: it has the same information, but still submits the request and lets the api complain
18:40:47 <JayF> TheJulia: I think that's the best path forward
18:41:04 <JayF> TheJulia: why add the complexity of what is allowed when, when the API is supposed to indicate that with response codes?
18:41:26 <jroll> yeah, I agree with that
18:41:43 * dtantsur cannot make up his mind, but tends to trust JayF
18:41:55 <jroll> but beyond that, it might be useful to use the response code combined with whether reservation is null to give a more useful message :)
18:41:57 <TheJulia> I kind of think it might not make sense, since what JayF points out regarding the api client as well as there is a delay between the information being seen by a user and then action being able to be taken
18:42:20 <TheJulia> so even if the field is not empty, that field might clear moments later but the data returned the api client is then out of date
18:42:22 <JayF> dtantsur: don't you put that evil on me ;) we're in big trouble if 'trust Jay' is proof :P
18:42:27 <dtantsur> haha
18:42:30 <TheJulia> JayF: lol
18:42:47 <JayF> TheJulia: if we made etags required, I could see more value in waiting at that point
18:43:00 <JayF> TheJulia: beacuse you're almost guaranteed the tag will change before you can update, if the node is reserved
18:43:13 <JayF> TheJulia: but I'm arguing against making etags required in that spec soo..... :)
18:44:20 <TheJulia> I tend to think of this as the reservation will typically be power state checks, which are transient, I kind of feel like nothing really needs to change, but that is just my perception.
18:44:28 <dtantsur> we can make them required for UI without making them always required
18:44:44 <TheJulia> I guess I'm more worried about UI interaction being blocked because a momentary transitory thing happening in the background
18:45:01 <jroll> TheJulia: +1
18:45:08 <JayF> dtantsur: Yeah, someone in that spec wants to make them always-required, which I'm extremely -1 to :)
18:45:27 <JayF> TheJulia: I mean, I just think with a project that doesn't have a lot of contributors, the answer to any question is KISS
18:45:39 <TheJulia> JayF: +1
18:45:41 <JayF> the simpler it is the easier it will be to maintain with less [wo]manpower
18:45:53 <dtantsur> ++ to that
18:45:55 <TheJulia> So it essen like "lets just leave this as-is, and not worry"
18:46:00 <TheJulia> err, it seems
18:46:53 <TheJulia> #agreed We should not use the reservation field to block UI behavior as there are transitory background actions.
18:48:00 <TheJulia> So the last discussion item, was simply a question to the community asking if there is anything we can do to improve testing velocity?
18:48:59 <dtantsur> you mean, amount of people testing ironic-ui or...?
18:49:01 <TheJulia> With a lack of guidance from horizon on improving plugin testing, perhaps some community members have ideas?
18:49:46 <dtantsur> you can try chatting with tripleo-ui folks, in case they have ideas
18:49:55 <jroll> selenium is the thing the frontend world tends to use, afaik
18:50:00 <dtantsur> there is some overlap between the projects
18:50:10 <dtantsur> also yeah, I've heard the word "selenium" as well :)
18:50:13 <TheJulia> dtantsur: Good idea
18:50:30 <TheJulia> jroll: That is kind of what I've been thinking, having used it in the past. :)
18:50:34 <dtantsur> TheJulia, jtomasek or akrivoka are people to grab, I guess
18:50:45 <robcresswell> Selenium is still in the requirements for Horizon too. Tempest plugin is another possibility.
18:50:58 <jroll> tempest plugin? O_o
18:51:05 * JayF has never known anyone who used Selenium and was happy about the decision
18:51:21 <TheJulia> JayF: heh
18:51:25 <robcresswell> Yeah, we had so many problems with selenium that we dropped our integration tests.
18:51:28 <JayF> I'm not an expert in the field, so IDK anything specific, but I know I've heard more rants from UI people about selenium than all other topics combined
18:51:30 <JayF> lol
18:51:36 <jroll> ah hrm
18:51:42 <jroll> there's another thing, I forget what it is
18:51:45 * jroll googles around
18:51:47 <robcresswell> I mean it broke every other week and totally hosed the gate
18:51:48 <JayF> cucumber?
18:51:55 <JayF> I remember cucumber for some reason.
18:51:58 <TheJulia> robcresswell: That is good background for us
18:52:01 <jroll> cucumber is a ruby thing afaik
18:52:10 <TheJulia> JayF: A lot of people use cucumber to drive selenium
18:52:33 * jroll asks friends
18:52:33 <JayF> aha, that makes sense then. I knew some of the frontend testers of a Rackspace control panel would use that
18:53:36 <TheJulia> robcresswell: Mind if I chat you up a little this week and try to get a little more background regarding the selenium experience, as to what sorts of problems were being had?
18:54:35 <TheJulia> #info It seems we need to do a little more research into testing possibilities for full blown integration testing of ironic-ui. A topic for a future meeting.
18:55:08 <TheJulia> Since we only have 5 minutes left, if there are no screaming of "Noooo!", I'm moving us to Open Discussion
18:55:24 <TheJulia> #topic Open Discussionf
18:55:26 <robcresswell> TheJulia: Sure
18:55:28 <TheJulia> #undo
18:55:29 <openstack> Removing item from minutes: #topic Open Discussionf
18:55:31 <TheJulia> #topic Open Discussion
18:56:09 <TheJulia> Any one have any items for discussion that are not on the agenda?
18:56:35 <JayF> I'll just say in general, I don't intend on doing any real work towards ironic-ui, the leading reason of which is that I've never done frontend work before :)
18:56:45 <JayF> but I do intend to keep up on what's going on, drop into meetings, etc
18:56:52 <TheJulia> JayF: Awesome!
18:56:57 <JayF> feel free to ping me if there's anything I can help with that is /not/ writing js or whatever :P
18:57:12 <TheJulia> :)
18:57:23 <dtantsur> JayF, ditto
18:57:52 <TheJulia> Well, since I'm only otherwise hearing crickets, it seems like this meeting is about over.  Thank you everyone!
18:57:59 <crushil> \o
18:58:18 <TheJulia> #endmeeting