18:01:18 <TheJulia> #startmeeting ironic_ui
18:01:19 <openstack> Meeting started Tue May 16 18:01:18 2017 UTC and is due to finish in 60 minutes.  The chair is TheJulia. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:23 <openstack> The meeting name has been set to 'ironic_ui'
18:01:34 <TheJulia> Greetings everyone!
18:01:52 <TheJulia> Our agenda this week can be found at: https://wiki.openstack.org/wiki/Meetings/Ironic-ui
18:01:54 <TheJulia> #link https://wiki.openstack.org/wiki/Meetings/Ironic-ui
18:02:14 <TheJulia> #topic Announcements/Reminders
18:03:11 <TheJulia> I have no announcements this week, does anyone have anything this week?
18:03:27 <ppiela> nothing from me
18:04:19 <TheJulia> Well, then I guess we will mov on if nobody has anything else.
18:04:26 <TheJulia> #topic Current Status
18:05:09 <TheJulia> Presently https://review.openstack.org/#/c/437419/11 is in need of a second review.  It is holding up some of ppiela's other work. We can discuss reviews in general later on.
18:05:10 <ppiela> I am starting to look at portgroups
18:05:23 <TheJulia> ppiela: \o/
18:05:41 <TheJulia> #info ppiela is beginning to look at implementing port groups
18:06:29 <TheJulia> Also, it looks like https://review.openstack.org/#/c/463852/ just needs a quick re-review.
18:06:54 <ppiela> Yes, I will +2 it
18:06:57 <TheJulia> #link https://review.openstack.org/#/c/437419/11
18:07:07 <TheJulia> #link https://review.openstack.org/#/c/463852/
18:07:10 <TheJulia> Awesome
18:07:27 <TheJulia> I think that is it for current status, unless anyone else has anything?
18:08:35 <anupn> do we have weekly priorities to review like we do for ironic?
18:09:05 <TheJulia> anupn: sort of, although we're not tracking on an ether pad, it is more of a "what is outstanding" question, which we sort of just went over
18:09:22 <anupn> TheJulia: yup cool
18:09:24 <TheJulia> #topic Priorities
18:09:54 <TheJulia> That being said, it is not set in stone
18:10:47 <TheJulia> Also, I need to go through launchpad, and reconcile/check everything outstanding.  We could use that for priority review if there are people looking for suggestions of what they might work on to contribute?
18:11:07 <TheJulia> #info TheJulia will go through the ironic-ui launchpad bug list early next week.
18:11:57 <anupn> sounds great
18:13:11 <TheJulia> Anyone have any other priority items?
18:13:27 <ppiela> Not me
18:14:02 <TheJulia> Okay
18:14:07 <TheJulia> Easy enough :)
18:14:08 <TheJulia> #info Priorities for this week are the outstanding review items noted in Current Status
18:14:18 <TheJulia> Onward to the discussion!
18:14:46 <TheJulia> #topic Discussion
18:15:41 <TheJulia> I sent out an email to the mailing list about reducing the review threshold for ironic-ui in order to allow us to iterate faster.
18:15:44 <TheJulia> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/116690.html
18:16:09 <ppiela> Thanks for doing that, I am in agreement
18:16:22 <TheJulia> I saw the PTL replied with positive feedback, but I wanted to give meeting attendees a chance to object or ask questions.
18:16:43 <crushil> I am good. Thanks for sending out the post
18:17:35 <ppiela> If we run into problems we can re-evaluate
18:17:38 <TheJulia> Well, if there are no objections, I'll mark it as being agreed upon.
18:17:42 <TheJulia> ppiela: exactly! :)
18:17:51 <rama_y> Hi TheJulia, I picked up https://bugs.launchpad.net/ironic-ui/+bug/1648553 and https://bugs.launchpad.net/ironic-ui/+bug/1671567
18:17:53 <openstack> Launchpad bug 1648553 in Ironic UI "UI lacks the ability to set the raid configuration" [Medium,Confirmed] - Assigned to Ramamani Yeleswarapu (ramamani-yeleswarapu)
18:17:54 <openstack> Launchpad bug 1671567 in Ironic UI "UI has no way to get/set a node's current boot device" [Wishlist,In progress] - Assigned to Ramamani Yeleswarapu (ramamani-yeleswarapu)
18:18:44 <rama_y> Depending on the priority, I can start on one; which one is of higher priority?
18:18:49 <ppiela> Support for boot-device was done by mgould
18:19:00 <ppiela> I believe
18:19:17 <rama_y> Get boot device was done and then it was not assigned to anyone after that, ppiela
18:20:40 <rama_y> I meant, set boot device part is still outstanding.
18:20:42 <TheJulia> rama_y: I think that is fine. Setting the boot device should be a good first step and then raid device configuration with may require a little more complexity
18:20:50 <TheJulia> rama_y: Thank you!
18:21:03 <rama_y> TheJulia: thanks, sounds good.
18:21:50 <ppiela> rama_y and others. It's great to have your contributions. Thanks!
18:21:50 <TheJulia> #agreed The meeting attendees are in agreement to lowering the review requirement as noted in the mailing list email. We will re-evaluate and change as needed if the need or issue arises.
18:22:16 <TheJulia> I guess we're basically in Open Discussion now :)
18:22:17 <rama_y> Thanks, good to be part of ironic-ui.
18:22:24 <TheJulia> #topic Open Discussion
18:22:25 <TheJulia> :)
18:22:37 <anupn> TheJulia, I assigned driver composition bug https://bugs.launchpad.net/ironic-ui/+bug/1672729 to myself
18:22:39 <openstack> Launchpad bug 1672729 in Ironic UI "UI is unaware of driver composition node *_interface fields." [Undecided,New] - Assigned to Anup (anup-d-navare)
18:22:39 <TheJulia> So! What else shall we talk about?
18:22:49 <ppiela> Just a general reminder that we need to work on our unit tests
18:22:50 <TheJulia> anupn: Awesome! Thank you
18:23:03 <anupn> are there any notes already discussed on how driver interfaces should be seen in UI?
18:23:22 <TheJulia> Yes, we do need to work on our unit tests.  betherly are you on?
18:23:23 <anupn> I mean it should go under node correct?
18:23:50 <TheJulia> anupn: Yes, it should go under the node.  It is kind of like the driver, except they are the interfaces that make up a driver that can now be set
18:24:00 <TheJulia> so, I guess under a node makes sense....
18:24:20 <TheJulia> Truthfully, I've not thought about it much more than the data model
18:24:51 <anupn> TheJulia, np, just came up to my mind when going over the bug
18:25:13 <TheJulia> anupn: it is a great question to ask
18:25:40 <TheJulia> ppiela: Do you have any feelings/preferences towards placement/view?
18:25:59 <ppiela> Under the node makes sense. The node-details configuration page is getting quite big, and could be split into separate tabs, but I finding that having th info on one page is useful.
18:26:30 <TheJulia> I guess we could get it in and shuffle it around later if it makes sense
18:26:32 <ppiela> I have done prototype splits, and not been happy with the results
18:26:36 <anupn> TheJulia, ppiela: ++
18:26:56 <anupn> TheJulia, ppiela: may be under driver_info under node_configuration
18:27:18 <TheJulia> anupn: except that would be misleading since that is a distinct field under a node
18:27:18 <ppiela> I am hoping for some actual operator feedback to guide us
18:28:04 <ppiela> Until then I think we should follow the existing patterns. I am open to any suggestions.
18:28:33 <TheJulia> That sounds good to me.
18:28:56 <anupn> Sounds good
18:29:09 <TheJulia> Is there anything else to discuss today?
18:29:31 <ppiela> Good here
18:29:39 <crushil> nothing from me
18:29:43 <anupn> nothing more from me
18:29:58 <rama_y> nothing more from me
18:30:32 <TheJulia> Awesome, well then, seems like we all get a half hour back!
18:30:39 <TheJulia> Thank you everyone, and have a wonderful week!
18:30:46 <crushil> thanks. \o
18:30:53 <ppiela> Thanks all!
18:30:56 <TheJulia> #endmeeting