15:00:29 <krotscheck> #startmeeting javascript
15:00:30 <openstack> Meeting started Mon Jun 13 15:00:29 2016 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:33 <openstack> The meeting name has been set to 'javascript'
15:00:45 <krotscheck> #link Agenda: https://etherpad.openstack.org/p/javascript-meeting-2016-06-13
15:01:08 <krotscheck> Good morning, everyone! Who made it?
15:01:13 <vkramskikh> hi
15:01:15 <Zara> I'm here to lurk
15:01:30 * krotscheck plans on dragging Zara into the open when we do introductions :)
15:01:34 <Zara> :{
15:01:43 <yujunz> Hi
15:01:49 <krotscheck> welcome, yujunz!@
15:01:55 <yujunz> Good midnight...
15:02:07 <krotscheck> yujunz: Whoa, is it that late where you are?
15:02:16 <yujunz> 11pm in Shanghai
15:02:19 <krotscheck> Yikes.
15:02:29 <krotscheck> vkramskikh: What time is it where you are?
15:02:37 <vkramskikh> krotscheck: 6pm
15:02:51 <krotscheck> Hrm. It's 8AM here, maybe we can move the meeting up an hour
15:03:03 <krotscheck> Well, we'll talk about that in a minute.
15:03:10 <krotscheck> #topic Introductions
15:03:26 <krotscheck> Hello everyone!
15:03:39 <krotscheck> I'd like to introduce everyone who'm I know is planning on showing up.
15:04:10 <krotscheck> Firstly, there's vkramskikh, who works on Fuel-UI, using (I think) react, webpack, and... a few other things?
15:04:15 * krotscheck doesn't know if he's PTL.
15:04:36 <vkramskikh> Fuel UI has no PTL :) Fuel has
15:04:46 <vkramskikh> I'm a core reviewer of fuel-ui repo
15:04:49 <krotscheck> vkramskikh: Well then, are you the Fuel PTL?
15:05:00 <vkramskikh> nope, Vladimir Kozhukalov is Fuel PTL
15:05:12 <krotscheck> Gotcha
15:05:17 <krotscheck> Well, you're awesome anyway.
15:05:30 <vkramskikh> thanks :)
15:05:31 <krotscheck> Next is Zara, in the UK, who's the StoryBoard PTL.
15:05:44 <Zara> hi! I'm also not really a PTL (but core!)
15:05:48 <yujunz> The story board we are using?
15:05:52 <krotscheck> They use Angular, Grunt, and... a few other things?
15:05:58 <krotscheck> yujunz: Yep
15:06:04 <yujunz> Awesome project
15:06:15 <krotscheck> Three cheers for Zara :)
15:06:32 <Zara> (yeah... bower... npm to install stuff... maybe other things I haven't yet found... :D)
15:06:35 <Zara> thank you
15:06:46 <krotscheck> Next is betherly, who's on holiday right now in the land of no internet.
15:06:54 <krotscheck> So she's not here, because she's busy surfing.
15:07:26 <krotscheck> She works on ironic-ui, ironic-webclient, and is really kindof awesome on all things CSS.
15:07:58 <krotscheck> Then there's yujunz, who works for ZTE corp in Shanghai, and has most recently been contributing to js-generator-openstack.
15:08:13 * krotscheck doesn' tknow much more about yujunz, how about you introduce yourself?
15:08:36 <yujunz> keywords, angular, d3js, grunt, gulp anything that will work
15:09:04 <Zara> :D nice to meet you
15:09:07 <krotscheck> yujunz: Oooh, I think Zara had a question about d3js a while ago, maybe you two can talk when it's a more convenient time zone for both of you :)
15:09:30 <yujunz> No problem
15:09:33 <Zara> heh, I have no idea if it's still a question, t'was on behalf of a colleague, but thank you!
15:09:37 <Zara> I'll find out
15:10:03 <krotscheck> And lastly there's me, who's infra-support for all things javascript. Which means mirrors, build jobs, eslint rules, etc.
15:10:14 * krotscheck waves.
15:10:24 * Zara waves back from the UK
15:11:01 <krotscheck> Also, other individuals who do a lot of javascript things are tsufiev, SotK, hurgleburglar, tyr... most of the horizon team really.
15:11:40 <krotscheck> The reason I wanted to get everyone in a room is because most of OpenStack is Python, thus it's often difficult to get mindshare with others to do UI-based design discussions
15:12:02 <krotscheck> i.e. birds-of-a-feather kinds of things.
15:12:17 <krotscheck> But that's part of the next topic.
15:12:23 <krotscheck> #topic What Is This Meeting For?
15:12:33 <krotscheck> So, waht is everyone looking for out of this?
15:13:12 <Zara> I want to keep up to date with JS things, as most openstack is python, most of my workplace use things like python, and I still feel pretty new to JS
15:13:21 <Zara> and web-development more generally
15:13:24 <krotscheck> \o/
15:13:38 <yujunz> As a newcomer, I'd like to know a bit about the coding conventions in openstack javascript team
15:13:51 <vkramskikh> As for me, probably to have time to sync and discuss some questions when most of the poeople are present and can express their opinions
15:15:04 <krotscheck> Things sound pretty freeform, more like a birds-of-a-feather session.
15:15:47 <krotscheck> In that case, I'd suggest we just keep the agenda open.
15:15:56 <krotscheck> And not try to be too rigid about what we talk about.
15:16:32 <krotscheck> i.e. Anyone can add anything to the agenda, and we'll address them in order. Any objections?
15:16:41 <Zara> wfm
15:16:45 <vkramskikh> no objections
15:17:01 <krotscheck> Cool, next topic.
15:17:06 <krotscheck> #topic How frequently should we meet.
15:17:24 <krotscheck> (also: Should we change the meeting time)
15:17:29 <krotscheck> 11PM is hard for Shanghai.
15:17:41 <krotscheck> 6PM is not... great... for vkramskikh.
15:18:00 <vkramskikh> 6PM is actually perfectly fine for me
15:18:05 <krotscheck> Oh, alright
15:18:06 <yujunz> 11pm is the latest time slot I can make
15:18:13 <Zara> I think I'll mainly be lurking so if it's a time that's bad for me, it's not the end of the world
15:18:14 <vkramskikh> Here in Moscow people usually come to work about noon :)
15:18:26 <Zara> I don't have strong opinions on js things, mainly interested in listening at this point
15:18:35 <krotscheck> vkramskikh: Sounds like my kind of city...
15:18:43 * krotscheck is woken up by an infant at 5AM every morning
15:19:19 <yujunz> how old?
15:19:28 <krotscheck> So I'm usually at work at 7AM. Does anyone have any objections to moving the meeting up an hour to 1400UTC to give yujunz a little more sleep? :)
15:19:40 <vkramskikh> I don't
15:19:42 <krotscheck> yujunz: 9 months. Crawling, pulling himself up, super cute :)
15:19:46 <Zara> fine by me
15:19:57 <yujunz> Thank you for that
15:20:20 <krotscheck> yujunz: I'd make it even earlier if I could. Sadly, I'm the least-conveniently placed for you.
15:20:26 <krotscheck> (timezone wise).
15:20:49 <yujunz> Two 15-month babies keep me away from work before 9pm every day.
15:21:07 <krotscheck> yujunz: Whoa. Twins?
15:21:16 <yujunz> Yes, a boy and a girl
15:21:17 <krotscheck> yujunz: I... wow. Respect.
15:21:35 <krotscheck> #agreed Switch meeting time to 1400UTC.
15:21:46 <krotscheck> Next question: Weekly or bi-weekly?
15:22:16 <yujunz> I would prefer weekly efficient meeting
15:23:05 <vkramskikh> I'd suggest to start with weekly meeting and if they are not so many topics to discuss, then switch to biweekly meetings
15:23:13 <krotscheck> I'm alright with that.
15:23:26 <krotscheck> #agreed Meetings to be weekly
15:23:53 <krotscheck> On to the project overview.
15:24:00 <krotscheck> #topic Project Introductions
15:24:24 <krotscheck> I added this really as an educational point, to make people aware of all the JavaScript we currently have going on in OpenStack.
15:25:02 <krotscheck> vkramskikh: Would you mind introducing fuel?
15:25:55 <vkramskikh> Fuel is an OpenStack installer, which is mostly being developed by Mirantis, but recently more people started to contribute
15:26:13 <vkramskikh> Fuel has Fuel UI - a simple user interface
15:26:22 <vkramskikh> Fuel UI project which was started 4 years ago (previously lived in fuel-web repo). It survived a few overhauls, migrating from Backbone to React, from TBS2 to TBS3, from require.js to webpack, from Grunt to Gulp. Fuel UI has been a single page aplication since day one.A few months ago it was separated to its own repo - fuel-ui, which is JS-only.
15:26:33 <vkramskikh> I think that's it, any questions?
15:27:11 <krotscheck> How many contributers to you have to it?
15:27:26 <vkramskikh> hmm, let me think
15:27:51 <vkramskikh> we have 2 cores, and about 4-6 people who contribute frequently
15:28:27 <vkramskikh> and about 10-15 people who made some minor fixes in code, styles and translations
15:28:30 <krotscheck> By far the largest pure-js project we have so far I think :)
15:28:44 <yujunz> so the connected backend must be fuel
15:29:07 <vkramskikh> yes, it can be considered as a browser-based client for Fuel
15:29:24 <vkramskikh> and it's REST API server - nailgun, which still lives in fuel-web repo
15:29:40 <yujunz> ok, you've answered my question before I ask...
15:29:43 * krotscheck has a nailgun in his garage. it's pretty frightening.
15:29:54 <krotscheck> Alright, next projects.
15:30:25 <krotscheck> The Ironic-Webclient is a standalone UI against the OpenStack Ironic, allowing non-horizon bare metal management. Contributors include myself and betherly. it's... been under incubation for the last year, because I've had to build a lot of infrastructure things to get it rolling.
15:30:47 * krotscheck is hoping to release it in the Newton Cycle, but he's not certain he can pull that off solo.
15:31:25 <betherly> Hi all! Signal is a bit broken but wanted to pop my head in to say hi and please feel free to contact with any qs re the ironic UI in particular :)
15:31:40 <krotscheck> Hi betherly! Enjoying the surf? :)
15:31:58 <Zara> hi betherly!
15:31:59 <krotscheck> It uses gulp, angular, bootstrap, and I've also started to incubate a generic set of angular controls inside of it that may be useful in a common library, assuming that said common library uses angular.
15:32:13 <krotscheck> Any questions? Else I'll ask Zara to introduce storyboard :)
15:32:20 <betherly> krotscheck: surf is awful but its nice to be in devon :)
15:32:41 <Zara> quick everyone ask questions
15:32:45 <yujunz> which version of angular?
15:32:55 <krotscheck> yujunz: 1.5.something
15:33:19 <yujunz> OK, I heard that 2.x is totally different
15:33:28 <krotscheck> yujunz: I've heard that too.
15:33:54 <krotscheck> Ok, Zara, go ahead
15:34:05 <Zara> ok! I typed mine up ahead since I type slowwwly
15:34:08 <Zara> StoryBoard's a task tracker, for cross-project work!
15:34:08 <Zara> Sometimes it's used as a bugtracker, too.
15:34:08 <Zara> It has a mysql db, a python api and a webclient written in angularjs,
15:34:11 <Zara> that uses bootstrap.
15:34:13 <Zara> krotscheck did the bulk of the original work on the webclient. SotK
15:34:16 <Zara> and I are the current cores, though we're not really JS experts, so
15:34:18 <Zara> are interested in learning more whenever we can.
15:34:21 <Zara> /wall-of-text
15:35:01 <Zara> does anyone have any questions?
15:35:36 <yujunz> Is it developed dedicated for openstack?
15:35:55 <yujunz> I mean openstack projects
15:36:38 <Zara> it's under the infra umbrella and was originally designed for openstack use, but can stand alone
15:36:59 <krotscheck> yujunz: It was, originally. Then OpenStack dropped it, and CodeThink took over to make it meet their needs. Now OpenStack looked at it again and said: Oh, we want this, and so it's a... hybrid... now?
15:37:13 <krotscheck> ¯\_(ツ)_/¯
15:37:14 <Zara> sounds about right
15:37:40 <krotscheck> I feel like at this point it has enough varying stakeholders that it will follow its own path.
15:37:52 <krotscheck> Ok, next....
15:38:00 <krotscheck> OpenStack-Health Dashboard is a test visualization dashboard for openstack infra. Contributors include timothy89. You can see it here: http://status.openstack.org/openstack-health/#/ , and it's maintained by the QA team.
15:38:12 <krotscheck> That's all I know about it, timothy isn't here :(
15:38:41 <krotscheck> However, they tend to incubate things that make interfacing with QA tooling way, way easier (like subunit reporting for example), so occasionally we'll get something from them that gets rolled into infra.
15:38:57 <krotscheck> I'd offer to answer questions, but I don't really have any answers.
15:39:10 <krotscheck> There's a few infra projects:
15:39:13 <krotscheck> js-afs-blob-store and js-openstack-registry-hooks are two plugin projects which back the registry-static NPM mirroring project, in order to make it useful for our infrastructure. It's maintained by infra and myself, and they're more or less in functional maintenance right now (updates, bug fixes, and library upgrades only).
15:39:53 <krotscheck> Also, there's a new project called karma-subunit-reporter that's being proposed here: https://review.openstack.org/#/c/327945/
15:39:59 <krotscheck> Any questions on those?
15:40:40 <yujunz> nope
15:40:51 <krotscheck> Alright, and last we have the JavaScript SDK projects.
15:41:08 <krotscheck> They consists of tooling for the NPM/Github community who want to build Node/Browser apps that interface with our API's.
15:41:22 <krotscheck> there's eslint-config-openstack, which is OpenStack's language rules.
15:41:33 <krotscheck> Any questions on that one?
15:41:55 <yujunz> es5?
15:42:09 <krotscheck> Both, now, actually. vkramskikh has been proposing es6 rules.
15:43:29 <yujunz> OK, does it include also jsxlint which would apply for react based projects
15:43:44 <krotscheck> I... don't know. vkramskikh?
15:43:59 <vkramskikh> maybe you meant jsxhint?
15:44:05 * krotscheck vaguely remembers a JSX flag there somwhere sometime.
15:44:08 <yujunz> yes
15:44:31 <vkramskikh> it's actually not needed anymore since eslint has all necessary things, including plugin for linting JSX
15:44:42 <yujunz> ok, got it
15:44:43 <vkramskikh> https://github.com/yannickcr/eslint-plugin-react here it is, and Fuel UI uses it
15:44:46 <krotscheck> Oh nice!
15:45:46 <krotscheck> Next is js-generator-openstack, which... well, I want it to have a bunch of different jobs.
15:46:03 <krotscheck> In its simplest form it's a yeoman generator for OpenStack javascript projects.
15:46:16 <krotscheck> As in, "I want to build something against the OpenStack API's, where do I get started.
15:46:47 <krotscheck> Secretly, however, it'll also handle things like keeping our javascript versions synchronized, much like the requirements.txt proposal bot.
15:47:14 <krotscheck> In other words, re-running it against a project will update it.
15:48:03 <krotscheck> I had a video that I used to pitch it to my bosses.... youtube.com/watch?v=qcgvKIj4Ins&feature=youtu.be
15:48:24 <krotscheck> Any questions on that?
15:49:14 <yujunz> What if there is a version conflict between different projects?
15:49:45 <krotscheck> yujunz: Well, the hope is that we'll automate this over time, and individual projects can subscribe to it.
15:50:17 <krotscheck> I'm guessing that there'll be a major and maintained release for the generator for newton, Ocata, etc - most OpenSTack release cycles.
15:50:26 <krotscheck> But, well, that's all still up for discussion.
15:50:47 <yujunz> So the target is all subscribers are aligned in the same version of dependency
15:51:03 <krotscheck> Yep, if they so choose.
15:51:25 <yujunz> OK, they have a choice
15:51:26 <krotscheck> The dependency alignment I expect will really only be used inside of openstack to keep our released artifacts in sync
15:52:12 <krotscheck> Good thought though, we should probably add a 'manage-dependencies' flag to the generator.
15:52:38 <krotscheck> We're running low on time, so I'm goign to move on.
15:52:49 <krotscheck> js-openstack-lib: Is BRAND NEW, and is in response ot the death of libcloud.
15:53:10 <krotscheck> Well, not death. I spoke to the maintainer last week though and he told me that it's basically done.
15:53:29 <krotscheck> The hope here is that it'll be the core of a JavaScript SDK
15:53:56 <krotscheck> However, no real design decisions have been made yet, except "We can't be opinionated about the engine or the framework"
15:54:34 <vkramskikh> so I think other important decisions will be made on the next meeting here?
15:54:50 <krotscheck> vkramskikh: Yep. THis meeting seems to be mostly intorductory
15:55:00 <krotscheck> There was too much to cover.
15:55:37 <krotscheck> Any questions on this? I'd like to do 5 minutes of open discussion if we can.
15:56:31 <krotscheck> I'll take that as a no:
15:56:34 <krotscheck> #topic Open Discussion
15:56:44 <krotscheck> Anyone have questions, comments, concerns, things they really want to bring up next session?
15:56:58 <vkramskikh> I think 5 minutes is not enough, it should take about ~30 - there are lots of decisions need to be made :)
15:57:16 <yujunz> Any homepage for the javascript group?
15:57:19 <vkramskikh> I believe we should start the next meeting with discussion of js-openstacklib
15:57:31 <krotscheck> vkramskikh: Let's put it on the agneda :)
15:57:37 <yujunz> Need a place to gather all information
15:57:38 <krotscheck> yujunz: Not yet, no.
15:57:42 <krotscheck> Other than the etherpads.
15:57:55 <krotscheck> We could probably grab a wiki...
15:58:20 <Zara> +1 , easier to find the url again
15:59:06 <krotscheck> Alrightey, anyone want to set that up?
15:59:31 <krotscheck> We can use the Python-OpenStackSDK wiki structure as a template.
15:59:50 <krotscheck> Ooookay. I guess I'm doing that.
16:00:07 <Zara> hah, I went looking around and couldn't find where to add it
16:00:07 <krotscheck> #action vkramskikh Get js-openstacklib onto next weeks' agenda
16:00:14 <krotscheck> #action krotscheck Get a wiki up
16:00:18 <krotscheck> That's time!
16:00:20 <krotscheck> Todles everyone!
16:00:25 <krotscheck> #endmeeting