#openstack-meeting: javascript

Meeting started by krotscheck at 14:00:33 UTC (full logs).

Meeting summary

    1. https://etherpad.openstack.org/p/javascript-meeting-2016-06-22 (krotscheck, 14:00:58)

  1. Core elections! (krotscheck, 14:01:46)
    1. ACTION: krotscheck Add vkramskikh as core to js-openstack-lib (krotscheck, 14:13:29)
    2. ACTION: krotscheck add betherly as core to js-generator-openstack (krotscheck, 14:13:38)
    3. ACTION: reach out to notmars and yujunz for their consent as project cores on js-generator-openstack (krotscheck, 14:13:56)
    4. ACTION: krotscheck reach out to notmars and yujunz for their consent as project cores on js-generator-openstack (krotscheck, 14:14:28)
    5. ACTION: vkramskikh Update javascript meeting chairs in openstack-meetings (krotscheck, 14:16:03)

  2. js-openstack-lib design: Isomorphism (krotscheck, 14:16:16)
    1. AGREED: js-openstack-lib should be isomorphic. (krotscheck, 14:21:18)

  3. js-openstack-lib design: ES5 or ES6 (ES2015) (krotscheck, 14:21:39)
    1. https://blog.nodeswat.com/what-i-learned-from-analysing-1-65m-versions-of-node-js-modules-in-npm-a0299a614318 (krotscheck, 14:24:16)
    2. https://kangax.github.io/compat-table/es6/ about a half (vkramskikh, 14:30:09)
    3. https://kangax.github.io/compat-table/es6/ (krotscheck, 14:30:24)
    4. https://review.openstack.org/#/c/332458/ (krotscheck, 14:37:38)
    5. https://onsen.io/blog/mocha-chaijs-unit-test-coverage-es6/ (cardeois, 14:38:29)
    6. ACTION: vkramskikh Research ES6 transpiling options with regards to Node4, Node6, npm publishing, and update spec. (krotscheck, 14:39:40)
    7. AGREED: As much ES6 as possible. (krotscheck, 14:40:02)

  4. js-openstack-lib design: What is server interaction approach? (krotscheck, 14:40:53)
    1. https://review.openstack.org/#/c/331772/ here's how we switched to fetch in fuel (vkramskikh, 14:43:48)
    2. https://review.openstack.org/#/c/331772/1/webpack.config.js that's what was necessary to add polyfill to the project (vkramskikh, 14:44:05)
    3. https://review.openstack.org/#/c/331801/ (krotscheck, 14:53:17)

  5. Open Discussion (krotscheck, 14:56:19)


Meeting ended at 15:00:45 UTC (full logs).

Action items

  1. krotscheck Add vkramskikh as core to js-openstack-lib
  2. krotscheck add betherly as core to js-generator-openstack
  3. reach out to notmars and yujunz for their consent as project cores on js-generator-openstack
  4. krotscheck reach out to notmars and yujunz for their consent as project cores on js-generator-openstack
  5. vkramskikh Update javascript meeting chairs in openstack-meetings
  6. vkramskikh Research ES6 transpiling options with regards to Node4, Node6, npm publishing, and update spec.


Action items, by person

  1. betherly
    1. krotscheck add betherly as core to js-generator-openstack
  2. krotscheck
    1. krotscheck Add vkramskikh as core to js-openstack-lib
    2. krotscheck add betherly as core to js-generator-openstack
    3. krotscheck reach out to notmars and yujunz for their consent as project cores on js-generator-openstack
  3. openstack
    1. krotscheck Add vkramskikh as core to js-openstack-lib
    2. krotscheck add betherly as core to js-generator-openstack
    3. reach out to notmars and yujunz for their consent as project cores on js-generator-openstack
    4. krotscheck reach out to notmars and yujunz for their consent as project cores on js-generator-openstack
    5. vkramskikh Update javascript meeting chairs in openstack-meetings
  4. vkramskikh
    1. krotscheck Add vkramskikh as core to js-openstack-lib
    2. vkramskikh Update javascript meeting chairs in openstack-meetings
    3. vkramskikh Research ES6 transpiling options with regards to Node4, Node6, npm publishing, and update spec.


People present (lines said)

  1. krotscheck (129)
  2. vkramskikh (39)
  3. cardeois (24)
  4. azemlyanov (21)
  5. msmol (9)
  6. betherly (8)
  7. Zara (8)
  8. jprivard (5)
  9. timothyb89 (4)
  10. SotK (4)
  11. jaranovich (3)
  12. openstack (3)
  13. tsufiev (2)
  14. nbogdanov (1)
  15. larainema (1)


Generated by MeetBot 0.1.4.