14:00:22 <vkramskikh> #startmeeting javascript
14:00:22 <vkramskikh> hmm, doesn't seem to work :(
14:00:22 <openstack> Meeting started Wed Jul  6 14:00:22 2016 UTC and is due to finish in 60 minutes.  The chair is vkramskikh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:27 <openstack> The meeting name has been set to 'javascript'
14:00:28 <vkramskikh> oh it does
14:00:33 <vkramskikh> hi everyone
14:00:37 <vkramskikh> who's there?
14:00:41 <azemlyanov> hello there
14:00:55 <vkramskikh> #link https://etherpad.openstack.org/p/javascript-meeting-2016-07-06
14:00:57 <cardeois> Hello
14:01:00 <jaranovich> hi!
14:01:03 <vkramskikh> here is the agenda for this meeting
14:01:12 <jprivard> hello
14:01:17 <vkramskikh> not so many things to discuss, so feel free to add your items
14:01:41 <vkramskikh> #topic ES2015 & Build approach
14:02:03 <larainema> hello
14:02:14 <vkramskikh> I've created a spec for transpiler integration and build/testing approaches
14:02:18 <vkramskikh> #link https://review.openstack.org/#/c/332458/
14:02:25 <vkramskikh> feel free to review
14:02:45 <vkramskikh> I've used modules/technologies that we agreed to use on the last meeting
14:02:52 <betherly> o/
14:02:55 <cardeois> yep sounds good
14:02:57 <vkramskikh> jasmine, karma, babel
14:03:11 <cardeois> however I did a checkout of this review
14:03:19 <vkramskikh> the only thing which we didn't discuss is the tool which builds browser version of the library
14:03:21 <cardeois> and npm install takes around 480MB
14:03:36 <cardeois> I mean node_modules, is that acceptable? and are you reproducing this?
14:04:02 <vkramskikh> the most popular modules for this are Browserify and Webpack
14:04:03 <vkramskikh> I've chosen Webpack since I have experience with it
14:04:03 <cardeois> As for the browser version I think webpack is the best choice right now
14:04:04 <azemlyanov> what's the builder? webpack?
14:04:43 <cardeois> I have experience with Browserify and if I'm not mistaking they say on their repo to use webpack now
14:04:48 <azemlyanov> browserify is much simpler tool
14:04:53 <cardeois> It's more modular
14:05:18 <vkramskikh> cardeois: what did you install to get 480MB of node_modules?
14:05:49 <azemlyanov> transpiler is heavy, it's dev deps, not prod deps
14:06:02 <vkramskikh> just checked Fuel's node_modules - it uses babel, webpack and lots of other stuff - it takes 175MB
14:06:34 <cardeois> vkramskikh sorry I'm wrong I did checkout this review https://review.openstack.org/#/c/334268/and did `npm install`
14:06:38 <vkramskikh> Babel is heavy, yes
14:06:38 <vkramskikh> but since 6.8 it takes less space
14:06:44 <vkramskikh> because before 6.8 it has dependency on Babel 5 to compile itself
14:07:16 <vkramskikh> cardeois: interesting, I'll check it
14:07:28 <vkramskikh> BTW, are you using NPM3?
14:07:40 <cardeois> But it uses babel 6.10
14:07:55 <cardeois> no but if I use npm3, it's smaller yes
14:08:08 <vkramskikh> NPM3 has dedupe functionality enabled by default, which results in much smaller node_modules
14:08:33 <vkramskikh> so, does anyone has any objections against using webpack?
14:08:40 <cardeois> yeah however is that a problem to force using npm3 or something?
14:08:43 <vkramskikh> I'll wait for 1 minute
14:08:49 <cardeois> nope webpack is good for me
14:08:50 <azemlyanov> no real competitors to webpack now
14:09:29 <jaranovich> +1 for webpack
14:09:38 <vkramskikh> cardeois: don't think so, and AFAIR Ubuntu Xenial has NPM3
14:10:07 <vkramskikh> #agreed Use Webpack for creating browser version of js-openstack-lib
14:11:32 <vkramskikh> I'll try to create some PoC by the next week with karma/jasmine/webpack/babel
14:11:33 <vkramskikh> #topic Open Discussion
14:11:34 <vkramskikh> so, does anyone have any more topics to discuss?
14:11:57 <azemlyanov> what's the status of fetch?
14:12:17 <vkramskikh> it's ready for reviewing :)
14:12:38 <cardeois> But isn't it already done in this review https://review.openstack.org/#/c/334268/ ? (the PoC)
14:13:05 <vkramskikh> cardeois: I didn't review it yet, will take a look
14:13:30 <cardeois> yeah it contains webpack/jasmine/karma/babel all you want
14:14:26 <vkramskikh> awesome, maybe I'll take it over and resolve your comments since krot_vaca_jul19 is on vacation :)
14:14:34 <cardeois> ok
14:14:35 <cardeois> For open discussion, I have some questions, I could ask them in openstack-javascript but as everybody's there
14:14:51 <cardeois> I started with jprivard to understand how to setup a devstack gate
14:15:24 <cardeois> first item will be to add a functionnality (or integration) test in js-openstack-lib that our gate job will call, does that make sense?
14:16:08 <vkramskikh> I think yes
14:16:09 <cardeois> As no test setup is done yet should I depend on an existing review? (Sorry but I'm very new to all this opensource process)
14:16:48 <vkramskikh> cardeois: it seems the only option
14:16:58 <cardeois> ok cool
14:17:32 <cardeois> Also, a lot of python projects are using tempest to run the tests, We are using javascript though, so I guess we don't want to integrate with tempest?
14:18:44 <vkramskikh> I have no idea. we wanted to be a pure JS repo, though we already use sphinx for docs which is a python library
14:19:15 <cardeois> ok I'll try to find out by myself then, thanks anyway
14:20:08 <vkramskikh> I saw on the previous meeting there was a discussion about adopting Node6. Could anyone remind me why we need it?
14:20:34 <vkramskikh> to get rid of transpiler for node version of the library?
14:20:50 <vkramskikh> or just because it will have LTS status by October?
14:21:03 <cardeois> Maybe yes, but node6 even if it will be LTS is not LTS yet
14:21:40 <cardeois> And we need to support previous LTS node4. But yeahh the goal was to get all new functionnalities from node6
14:22:48 <vkramskikh> if it's about ES2016 features, it appears to be not really necessary as Babel covers most of the cases
14:23:23 <vkramskikh> except some rarely used features like Proxies - they're just not polyfillable
14:23:39 <larainema> i have talked with krostcheck, he wanted the new features from node6, but we also need to support previous node4
14:23:41 <cardeois> ok
14:24:02 <msmol> sorry for being late
14:24:51 <vkramskikh> msmol: we don't have many topics to discuss today, so it's time for open discussion
14:25:02 <cardeois> yeah so we can get a compromise: Use node6 features that babel can transpile
14:27:42 <vkramskikh> does anyone else have anything to discuss? if no, I'll close the meeting in 1 minute
14:28:40 <msmol> nothing on my end
14:28:44 <cardeois> I have a last question for open discussion. We are starting to support cloud.yaml format (as JSON) so we can initiate communications with openstack. However, if we use our lib in server side and we want to keep the token, shouldn't we support a way to load our lib from a auth-token or something? My point being if a client has a server with sessions using our lib, how to we keep
14:28:44 <cardeois> the connection?
14:30:01 <cardeois> maybe it's a bad use of our lib I don't know, but in the apps at my job, we often store the catalog and token in session, so new request calls from browsers can reuse the token
14:30:46 <azemlyanov> I think lib and http server are different things
14:30:47 <vkramskikh> cardeois: you want to initialize the library using existing token instead of username/password?
14:31:11 <azemlyanov> I think both are ok
14:31:16 <cardeois> as an alternative yes
14:31:35 <vkramskikh> i think we should support it
14:32:04 <cardeois> yeah otherwise people using our lib in an http server will find our lib not that useful, or will hack it to find their way
14:32:19 <cardeois> That's what we did a long time ago with python-novaclient
14:32:30 <vkramskikh> our dummy sample keystone client already supports initialization with both token and username/password
14:32:38 <vkramskikh> https://review.openstack.org/#/c/332461/1/src/identity/index.js@37
14:32:41 <cardeois> oh alright, didn't see that
14:33:10 <azemlyanov> I think http servers are in python and nobody happy with node http servers
14:35:22 <vkramskikh> ok, if we still have anything to discuss, let's do it in #openstack-javascript
14:35:22 <vkramskikh> bye!
14:35:23 <vkramskikh> #endmeeting