#openstack-meeting: javascript

Meeting started by krotscheck at 14:00:02 UTC (full logs).

Meeting summary

    1. Agenda: https://etherpad.openstack.org/p/javascript-meeting-2016-08-17 (krotscheck, 14:00:54)

  1. Action Followup (krotscheck, 14:01:03)
    1. https://specs.openstack.org/openstack/api-wg/guidelines/microversion_specification.html (krotscheck, 14:05:57)
    2. ACTION: Discuss microversions in depth next meeting (krotscheck, 14:13:23)

  2. jsdoc integration with sphinx (krotscheck, 14:13:39)
    1. http://docs.openstack.org/infra/shade/ (krotscheck, 14:15:24)
    2. http://libcloud.readthedocs.io/en/latest/ (krotscheck, 14:15:47)
    3. http://js-generator-openstack.openzero.net/ (yujunz, 14:17:47)
    4. https://rally.readthedocs.io/en/latest/ (krotscheck, 14:17:55)
    5. http://openzero-zte.github.io/js-generator-openstack (yujunz, 14:19:26)
    6. https://github.com/openzero-zte/js-generator-openstack/tree/gh-pages (yujunz, 14:20:20)
    7. AGREED: Keep jsdoc output unintegrated from sphinx for the moment, get uploaded with the rest of our docs. (krotscheck, 14:22:48)
    8. https://review.openstack.org/#/c/322881/ (krotscheck, 14:25:05)
    9. ACTION: krotscheck get jsdoc building added to our docs build (krotscheck, 14:25:23)

  3. bindep (krotscheck, 14:26:11)
  4. Keystone Development progress (krotscheck, 14:27:18)
  5. Method promise response signature (krotscheck, 14:32:41)
    1. ACTION: Everyone brainstorm method promise response signatures. (krotscheck, 14:48:16)

  6. Open Discussion (krotscheck, 14:48:36)
    1. ACTION: Agenda for next meeting: team purpose and scope. (krotscheck, 14:54:35)
    2. ACTION: token persistence added to next week's agenda (krotscheck, 14:59:13)
    3. ACTION: Outreach education on next week's agenda (krotscheck, 14:59:47)


Meeting ended at 14:59:55 UTC (full logs).

Action items

  1. Discuss microversions in depth next meeting
  2. krotscheck get jsdoc building added to our docs build
  3. Everyone brainstorm method promise response signatures.
  4. Agenda for next meeting: team purpose and scope.
  5. token persistence added to next week's agenda
  6. Outreach education on next week's agenda


Action items, by person

  1. krotscheck
    1. krotscheck get jsdoc building added to our docs build
  2. UNASSIGNED
    1. Discuss microversions in depth next meeting
    2. Everyone brainstorm method promise response signatures.
    3. Agenda for next meeting: team purpose and scope.
    4. token persistence added to next week's agenda
    5. Outreach education on next week's agenda


People present (lines said)

  1. krotscheck (141)
  2. cardeois (17)
  3. yujunz (17)
  4. vkramskikh (13)
  5. msmol (10)
  6. betherly (7)
  7. openstack (4)
  8. larainema (1)


Generated by MeetBot 0.1.4.