#openstack-meeting: javascript

Meeting started by krotscheck at 14:00:14 UTC (full logs).

Meeting summary

    1. Agenda https://etherpad.openstack.org/p/javascript-meeting-2016-08-24 (krotscheck, 14:00:27)

  1. Action Followup (krotscheck, 14:01:21)
    1. https://review.openstack.org/#/c/358120/ (krotscheck, 14:01:55)
    2. http://docs-draft.openstack.org/20/358120/4/check/gate-js-openstack-lib-nodejs6-npm-docs/e531b12//doc/build/html/ (krotscheck, 14:02:05)
    3. https://review.openstack.org/#/c/359445/ (yujunz, 14:04:25)
    4. ACTION: krotscheck Create story to fix bugs in jsdoc-sphinx (krotscheck, 14:06:46)

  2. Team Purpose and Scope (krotscheck, 14:07:19)
    1. https://review.openstack.org/#/q/status:open+project:openstack/js-openstack-lib+branch:master+topic:keystone (krotscheck, 14:17:18)
    2. ACTION: krotscheck, cardeois, and larainema to figure out what methods are needed to get to MVP (krotscheck, 14:26:44)

  3. Token Persistence (krotscheck, 14:27:07)
    1. AGREED: Token Persistence not necessary for MVP. (krotscheck, 14:34:28)

  4. Outreach Education (krotscheck, 14:34:35)
    1. https://etherpad.openstack.org/p/js-sdk-outreach (betherly, 14:42:14)
    2. ACTION: krotscheck split design-by-documentation into to-implement segments. (krotscheck, 14:50:47)
    3. ACTION: everyone Brainstorm outreach ideas. (krotscheck, 14:52:01)
    4. ACTION: everyone Make sure you insist on documentation patches :) (krotscheck, 14:52:14)

  5. Microversions (krotscheck, 14:52:39)
    1. AGREED: Stick to one version for the MVP. Handle Most-Recent-OpenStack version at all times, and support older versions via release branches until deprecated. (krotscheck, 14:57:11)

  6. Method Promise Response Signatures (krotscheck, 14:57:25)
  7. Open Discussion (krotscheck, 14:59:19)


Meeting ended at 14:59:56 UTC (full logs).

Action items

  1. krotscheck Create story to fix bugs in jsdoc-sphinx
  2. krotscheck, cardeois, and larainema to figure out what methods are needed to get to MVP
  3. krotscheck split design-by-documentation into to-implement segments.
  4. everyone Brainstorm outreach ideas.
  5. everyone Make sure you insist on documentation patches :)


Action items, by person

  1. cardeois
    1. krotscheck, cardeois, and larainema to figure out what methods are needed to get to MVP
  2. krotscheck
    1. krotscheck Create story to fix bugs in jsdoc-sphinx
    2. krotscheck, cardeois, and larainema to figure out what methods are needed to get to MVP
    3. krotscheck split design-by-documentation into to-implement segments.
  3. UNASSIGNED
    1. everyone Brainstorm outreach ideas.
    2. everyone Make sure you insist on documentation patches :)


People present (lines said)

  1. krotscheck (133)
  2. betherly (29)
  3. cardeois (28)
  4. vkramskikh (12)
  5. yujunz (9)
  6. msmol (7)
  7. openstack (4)
  8. breton (2)
  9. SotK (1)
  10. jprivard (1)


Generated by MeetBot 0.1.4.