14:00:20 <krotscheck> #startmeeting javascript
14:00:21 <openstack> Minutes:        http://eavesdrop.openstack.org/meetings/_javascript/2016/_javascript.2016-08-31-14.00.html
14:00:22 <openstack> Minutes (text): http://eavesdrop.openstack.org/meetings/_javascript/2016/_javascript.2016-08-31-14.00.txt
14:00:23 <openstack> Log:            http://eavesdrop.openstack.org/meetings/_javascript/2016/_javascript.2016-08-31-14.00.log.html
14:00:24 <openstack> Meeting started Wed Aug 31 14:00:20 2016 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <krotscheck> There we go
14:00:28 <openstack> The meeting name has been set to 'javascript'
14:00:35 <krotscheck> Good morning everyone!
14:00:36 <vkramskikh> hi
14:00:38 <cardeois> Hello !
14:00:44 <krotscheck> Wooo good progress this week!
14:00:59 <krotscheck> #link Agenda: https://etherpad.openstack.org/p/javascript-meeting-2016-08-31
14:01:09 <krotscheck> OUt of curiosity, who's been putting together the agenda each week?
14:01:14 * krotscheck wants to thank them.
14:01:43 <krotscheck> #topic Action Followup: jsdoc-sphinx
14:01:48 <krotscheck> Yeah, I totally didn't do that.
14:01:57 <krotscheck> #action krotscheck Create story to fix bugs in jsdoc-sphinx
14:02:09 <krotscheck> #topic Action Followup: MVP
14:02:18 <krotscheck> Ok, so lots of meat here.
14:02:24 <betherly> o/
14:02:52 <krotscheck> We've landed most of keystone. There's a bunch of things that shook out as work on glance and neutron started.
14:03:12 <cardeois> Yeah almost started
14:03:15 <krotscheck> cardeois put up a patch to genericize version negotiation. https://review.openstack.org/#/c/363304/
14:03:32 <cardeois> For glance DSVM jobs are failing but I found the issue and will fix before the end of the meeting
14:04:00 <krotscheck> cardeois: Oh? Nice! I was trying to figure out what's going on with this patch -> https://review.openstack.org/#/c/363301/
14:04:28 <krotscheck> Oh yeah, and we've got a patch up that will turn on voting for DSVM jobs.
14:04:47 <krotscheck> Glance has been built out all the way to imageList
14:05:10 <jprivard> sorry I'm late
14:05:17 <krotscheck> Nova's a bit stuck until we have cardeois' version negotiation patch, because nova registers its services differently
14:05:26 * krotscheck needs to build on that
14:05:49 <krotscheck> But with nova, glance, and neutron, that's really all we need to get the functional portion of the MVP done
14:05:58 <krotscheck> (We may need to add key management?
14:06:18 <krotscheck> The only outstanding part there then is documentation
14:06:35 <krotscheck> I do have a design discussion point on the MVP for later.
14:07:03 <krotscheck> Any questions on the MVP?
14:07:44 <krotscheck> Oh! I forgot. We ripped out all the requestInterception code, as it wasn't being used, and was causing our tests to fail. Once we need it we can always add it back
14:08:31 * msmol is sharing his laptop with cardeois, his keeps crashing
14:09:20 <krotscheck> See, now I'm thinking of this: http://vignette3.wikia.nocookie.net/forgottenrealms/images/e/e1/Ettin_-_Sam_Wood.jpg/revision/latest?cb=20070221031301
14:09:30 <krotscheck> But I digress, moving on
14:09:52 <krotscheck> #topic Action Followup: Documentation
14:09:58 <krotscheck> Not complete, will punt
14:10:02 <krotscheck> #action krotscheck split design-by-documentation into to-implement segments
14:10:22 <krotscheck> I think that's it for actions. Anyone have smoething they did last week that they want to highlight to the rest of us?
14:11:35 <cardeois_> well not much, just want to remind that all jobs should be green before merging now. As DSVM jobs were fixed
14:12:06 <krotscheck> Right, until https://review.openstack.org/#/c/363200/ forces it
14:12:11 <cardeois> Yes
14:12:11 <krotscheck> Alright, moving on.
14:12:12 <vkramskikh> yeah I've merged lots of stuff with red dsvm jobs, by bad
14:12:24 <cardeois> sure no pb, now you know
14:12:57 <krotscheck> #topic Action Followup: Brainstorm Outreach Ideas
14:13:07 <krotscheck> So, who's got ideas?
14:13:29 <krotscheck> My biggest idea this week was when I put to the list that I'm departing OpenStack, and suddenly everyone was interested in the Javascript SDK.
14:13:53 <krotscheck> In particular, TravT from searchlight.
14:14:10 <msmol> so what you're saying is, you should announce your depature on a more regular basis to keep interest levels high?
14:14:22 <krotscheck> msmol: Indeed. Keep coming back and leaving again :)
14:14:50 <krotscheck> Anyway- he wants to play with the SDK to see whether he can use it for the all-javascript components in the searchlight-ui.
14:15:06 <krotscheck> And he ran smack into the lack of a Readme or documentaiton
14:15:14 <krotscheck> So, yeah, we kinda need that before we ship
14:15:20 <cardeois> good point
14:15:47 <krotscheck> Also, he mentioned that he'd be able to contribute engineering resources to build out searchlight and murano.
14:16:44 <krotscheck> And advocate on our behalf inside of HPE. So I'm going to keep that converstaion going, and walk him through any and all pain points that he may encounter as he explores the SDK.
14:16:53 <krotscheck> i.e. a first user :)
14:17:13 <krotscheck> Another idea I had is sending out release announcements to the dev list
14:17:22 <krotscheck> Did anyone else have ideas?
14:17:41 <cardeois> mhh not really
14:17:59 <krotscheck> betherly, anything from you?
14:18:12 * krotscheck remembers that betherly was struggling with a check box yesterday.
14:18:51 <betherly> not really at the moment sorry! been pretty deep in ironic-ui stuff getting ready for next release
14:19:13 <krotscheck> Alrightey!
14:19:21 <betherly> checkbox issue solved thank goodness. more a case of looking at the same code for too long and not seeing wood for the trees
14:19:51 <krotscheck> Coolio.
14:19:54 <krotscheck> Moving on
14:20:06 <krotscheck> #topic Keystone Configuration object
14:20:18 <krotscheck> So, this is something that I encountered while I was building out glance and nova.
14:20:34 <krotscheck> Those two services are, by necessity, configured from their entries in the service catalog.
14:20:54 <krotscheck> Except... keystone's configured using the clouds.yaml format.
14:21:28 <krotscheck> I'd like to propose that keystone also is configured using the same catalog configuration entry, and that that clouds.yaml format be used for the OpenStack SDK wrapper.
14:21:51 <krotscheck> That way, Clouds,yaml is used to configure a cloud, and the service catalog is used to configure services.
14:21:56 <krotscheck> Any thoughts?
14:22:06 <cardeois> Yeah so I agree keystone should be contructed the same way glance and nova are. That means clouds.yaml is used somewhere else, or is optionnal for advanced users.
14:23:06 <krotscheck> vkramskikh? ^^
14:23:07 <msmol> sounds reasonable... +1
14:23:43 <vkramskikh> +1 from me
14:24:16 <krotscheck> Alrightey
14:24:25 <krotscheck> #agreed use catalog entry to configure keystone
14:24:44 <krotscheck> #topic switch to babel-transform-runtime
14:24:52 <krotscheck> Who put that on the agenda?
14:25:11 <vkramskikh> it was me
14:25:25 <vkramskikh> I think it's necessary before cutting MVP
14:25:32 <krotscheck> #link https://www.npmjs.com/package/babel-plugin-transform-runtime
14:25:35 <vkramskikh> because web bundle currently is about 300kb in size
14:25:54 <vkramskikh> because it includes the whole babel-polyfill
14:25:57 <krotscheck> So, just to clarify....
14:26:02 <cardeois> oh wow
14:26:15 <krotscheck> What this does is it takes all our polyfills, and makes sure they don't end up in the final package.
14:26:27 <krotscheck> That'd then require our end users to add them as dependencies themselves?
14:26:38 <krotscheck> (Which should be automatic)
14:27:01 <vkramskikh> no, it just polyfills only necessary parts which are actually used in the porject
14:27:20 <msmol> that's super cool, good idea vkramskikh
14:27:23 <krotscheck> Oh, gotcha
14:27:24 <krotscheck> Nice!
14:27:30 <vkramskikh> for example, we don't use generators, so it won't include polyfills for generators in the resulting bundle
14:27:49 <cardeois> +1 !
14:27:55 <krotscheck> +1
14:28:01 <msmol> have you tried including it yet? by how much can we expect to shrink?
14:28:13 <krotscheck> (Also, generators don't work that well, because apparently babel doesn't play well with yield
14:28:28 <vkramskikh> no i didn't do this yet for js-openstack-lib, though it's used in fuel
14:29:03 <krotscheck> vkramskikh: What was the impact on fuel?
14:29:45 <vkramskikh> krotscheck: I doubt I can remember exact number, but I think it was about 30-40 kb, but that' because fuel is quite large project
14:29:54 <vkramskikh> for js-openstack-lib it should reduce the size dramatically
14:29:55 <krotscheck> RIght, and we're still pretty small
14:30:15 <krotscheck> vkramskikh: Are you able to do that work?
14:30:22 * krotscheck doesn't know what the effort would be.
14:30:34 <vkramskikh> krotscheck: I think I am, shouldn't be too hard
14:30:41 <krotscheck> Awesome!
14:30:51 <krotscheck> #agreed swithc to babel-transform-runtime
14:31:05 <krotscheck> #action vkramskikh Swithc to babel-transform-runtime
14:31:26 <krotscheck> Any othequestions?
14:31:44 <cardeois> nope
14:31:51 <krotscheck> ALright.
14:31:56 <krotscheck> #topic Open Discussion
14:32:25 <krotscheck> So, as of next week I'm volunteer-time-only.
14:32:31 <krotscheck> Also, I will not be at the summit, as my talk was not accepte.d
14:32:41 <krotscheck> And new-employer will only send me if I have a talk
14:33:05 <msmol> what new adventures will you be embarking on krotscheck if you don't mind answering ;-)
14:33:36 <Zara> :(
14:33:38 <krotscheck> msmol: I will become an App-On-Openstack developer
14:33:48 <krotscheck> Or, well, an App-On-Cloud developer
14:34:06 <cardeois> Cool so that means, you "could" have to use the js-openstack-lib sdk
14:34:10 <vkramskikh> then I think we should elect more cores, since I cannot spend much time on this project
14:34:13 * msmol googles what that means
14:34:13 <krotscheck> "Could".
14:34:30 <cardeois> haha yeah "could"
14:34:36 <krotscheck> cardeois: Yes, continuing to work on it willd efinitely be part of my new job, only it won't be part of it immediately
14:34:55 * krotscheck can't name his new employer for legal reasons
14:35:15 <krotscheck> vkramskikh: I agree. I nominate cardeois, since he's been the most vocal on reviews, and has submitted patches ;)
14:35:34 <msmol> +1
14:35:52 <vkramskikh> +1
14:35:56 <cardeois> cool thanks ! I agree to volunteer
14:36:03 <krotscheck> cardeois: Sucker.
14:36:05 <krotscheck> ;)
14:36:11 <krotscheck> #agreed cardeois elected to core.
14:36:14 <cardeois> :)
14:36:21 <vkramskikh> should we organize a formal vote or we can just add him to the core group?
14:36:51 <krotscheck> vkramskikh: I'll doublecheck with fungi, since we're still technicall under infra.
14:36:52 <msmol> depends, who has voting rights? current cores only or open to the public
14:36:57 <krotscheck> Also, I don't apparently have the rigst to add someone
14:37:10 <krotscheck> msmol: Everyone has +1 rights, only cores can +2A and tag a release.
14:37:40 <msmol> to elect another core is the same?
14:37:55 <fungi> for infra projects, because we have multiple core review groups, the ptl is the group owner and controls addition/removal of core reviewers
14:38:02 <cardeois> Thought I have no idea what cores means except for the +2. Is there any other responsability that that?
14:38:22 <fungi> if you want to add core reviewers on one of the js repos in infra, just hit me up
14:38:25 <krotscheck> msmol: Ya know, we never settled on that. I always thought that election-by-consensus-of-cores was the thing, unless someone on the public list had a big big problem.
14:38:32 <krotscheck> fungi: Danke, willdo :)
14:38:54 <krotscheck> fungi: Actually, could you add cardeois as a core to js-openstack-lib? :D
14:38:59 <krotscheck> (we just elected him ^^)
14:39:07 <krotscheck> For now I think this is fine.
14:39:20 <fungi> in a general openstack developer community sense, core review teams are basically delegated by ptls. the ptl is in turn elected by all contributors to all repos under their project
14:39:34 <fungi> krotscheck: sure, just a sec and i'll take care of it
14:39:46 <krotscheck> Awesome.
14:40:02 <krotscheck> fungi: Thank you!
14:40:09 <krotscheck> Anything else for open discussion
14:40:11 <krotscheck> ??
14:40:28 <cardeois> nope
14:40:36 <fungi> #link https://review.openstack.org/#/admin/groups/1408,members
14:40:43 <fungi> cardeois has been added
14:40:49 <krotscheck> cardeois: Congratulations!
14:40:59 <cardeois> great, thanks fungi and krotscheck
14:41:02 <fungi> welcome to added responsibility! ;)
14:41:15 <msmol> Oh gee I hope this new power doesn't get to his head. I still have to sit next to him all day :o
14:41:26 <krotscheck> msmol: It's your job to keep him in chEKC
14:41:29 <krotscheck> Argh baby fingers
14:41:38 <krotscheck> Alright, i'm calling the meeting. Thanks everyone!
14:41:40 <krotscheck> #endmeeting