14:00:03 <krotscheck> #startmeeting javascript
14:00:04 <openstack> Meeting started Wed Sep 14 14:00:03 2016 UTC and is due to finish in 60 minutes. The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:07 <openstack> The meeting name has been set to 'javascript'
14:00:13 <krotscheck> #link Agenda: https://etherpad.openstack.org/p/javascript-meeting-2016-09-14
14:00:17 <krotscheck> Good morning everyone!
14:00:23 <vkramskikh> hi
14:00:49 * krotscheck wonders if cardeois is there
14:00:54 <msmol> he's here
14:00:57 <krotscheck> ncie
14:01:01 <cardeois> Hi, yes I'm here !
14:01:16 <krotscheck> #topic Action Followup: Build a better mousetrap (readme)
14:01:32 <cardeois> hum oops
14:01:48 <cardeois> I honestly didn't work on the project this week sorry
14:02:04 <cardeois> I'll try to catch up for the next meeting though
14:02:25 <larainema> o/
14:02:26 <krotscheck> Righto- that's understandable, my week's been similarly hard, plus you're blocked on neutorn ATM.
14:02:40 <krotscheck> #action Write a better README.md file
14:02:44 <krotscheck> #undo
14:02:44 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x7f23bd7a9c50>
14:02:50 <krotscheck> #action cardeois Write a better README.md file
14:03:03 <krotscheck> #topic propagate https://review.openstack.org/#/c/356473/1/doc/source/releasing.rst to js-openstack-lib and js-generator-openstack
14:03:19 <krotscheck> Not done. Spent my time building version detection and figuring out what's wrong with Neutron
14:03:25 <krotscheck> #action krotscheck propagate https://review.openstack.org/#/c/356473/1/doc/source/releasing.rst to js-openstack-lib and js-generator-openstack
14:03:32 <cardeois> Yes thanks for that
14:03:39 <krotscheck> #topic Action Followup: implement OpenStack class
14:03:44 <krotscheck> larainema has a patch up!
14:03:56 <krotscheck> #link https://review.openstack.org/#/c/369319/
14:04:12 <cardeois> \o/
14:04:17 <cardeois> will try to review it
14:04:21 <larainema> I have some problem to run test on my dev machine
14:04:42 <krotscheck> What kind of problems?
14:04:57 <krotscheck> (And what operating system?)
14:05:33 <larainema> it's problem to start the browse
14:06:09 <cardeois> what operating system are you on?
14:06:26 <larainema> it's ubuntu 14.04
14:07:48 <krotscheck> larainema: You may have to configure CHROME_BIN and FIREFOX_BIN to have karma properly find the executables
14:08:38 <larainema> oh, thanks krotscheck
14:08:58 <larainema> i didn't config it
14:09:18 <krotscheck> Ping me if you run into any other problems. Also, I noticed that a more recent version of karma-chrome-launcher and karma-firefox-launcher seem to work a lot better.
14:09:29 <krotscheck> So updating those in the package.json may help.
14:09:39 <krotscheck> Alright, so back to your patch:
14:09:56 <krotscheck> larainema: If it still doesn't work, you can just run `npm run test:node` as a smoketest
14:10:15 <krotscheck> Overall it looks pretty good.
14:10:26 <krotscheck> Definitely a good start.
14:10:37 <krotscheck> Does anyone have questions for larainema?
14:10:50 <cardeois> No looks good for me too
14:11:01 <krotscheck> Cool
14:11:16 <krotscheck> Moving on
14:11:17 <krotscheck> #topic MVP Status
14:11:18 <krotscheck> Last topic?
14:11:19 <krotscheck> woot
14:11:47 <krotscheck> Ok, so right now, we're blocked on neutron https://review.openstack.org/#/c/367529/
14:11:57 <krotscheck> Does anyone know any neutron cores that they can pester for reviews?
14:12:17 <cardeois> I can check on my department if people know some
14:12:26 <vkramskikh> I have 2 neutron cores in my line of sight, but they refuse to +2 the patch since they have no idea what it is doing :)
14:13:15 <cardeois> haha so does that mean we need to comment the code more to explain it?
14:13:33 <vkramskikh> that propbably could help :)
14:13:45 <krotscheck> vkramskikh: That's a little... disturbing, actually, when a core doesn't understand how their application is launched.
14:14:45 <krotscheck> vkramskikh: Ok, if I add more explanations on the commit message, can you pester them?
14:14:45 <vkramskikh> obondarev: what could speed up the review?
14:15:07 <vkramskikh> krotscheck: yes I'll try
14:15:19 <krotscheck> vkramskikh: Alright.
14:15:33 <krotscheck> #action krotscheck add better explanation on https://review.openstack.org/#/c/367529/2
14:15:43 <krotscheck> Other MVP things:
14:15:57 <obondarev> vkramskikh: the review can be promoted during Neutron weekly irc meeting :P
14:16:07 <krotscheck> I created two patches which attempt to recheck for the versions resource if a 401 is encountered from the service-catalog provided URL
14:16:24 <krotscheck> obondarev: When is that?
14:16:46 <krotscheck> https://review.openstack.org/#/c/369821/
14:16:56 <krotscheck> ^^ The one that rechecks when a 401 is encountered.
14:16:57 <obondarev> krotscheck: every other Monday 21 UTC, every other Tuesday 14 UTC
14:17:16 <krotscheck> obondarev: THe next one is... monday?
14:17:25 <obondarev> krotscheck: next is Tuesday Sep 20 14 UTC
14:17:57 <krotscheck> Oi, 6AM on a tuesday.
14:17:58 <krotscheck> ALright
14:18:14 <krotscheck> Anyone not-westcoastish care to volunteer to attend that meeting?
14:18:40 <vkramskikh> I'll attend
14:18:49 <krotscheck> Thank you, vkramskikh.
14:19:04 <obondarev> krotscheck: sorry, the next will be Monday Sep 19, 21 UTC
14:19:38 <krotscheck> Ok, that one's 2PM
14:19:50 <krotscheck> Probably better if I go to that, ok vkramskikh?
14:20:14 <vkramskikh> krotscheck: fine, I suddenly recalled that I'll have surgery on monday :)
14:20:20 <krotscheck> #action krotscheck Attend the neutron meeting at 2100 UTC next monday to advocate for https://review.openstack.org/#/c/367529/
14:20:38 <krotscheck> vkramskikh: Surgery? Finally having an RJ45 connector implanted, eh?
14:20:53 <krotscheck> (Seriously though- hope it goes well).
14:21:06 <vkramskikh> haha :) no, just some minor issues with my nose :)
14:21:33 <krotscheck> Well, best of luck then!
14:21:38 <vkramskikh> thanks :)
14:22:10 <krotscheck> Ok, so after being unblocked on neutron, cardeois's patch should pass the gate. I'm currenly working on nova, which (with better version detection) works now, but I need to flesh out the tests.
14:22:24 <krotscheck> #action krotscheck land Nova.flavorList
14:22:43 <cardeois> Yeah and on my side I need to implement neutronList
14:22:47 <cardeois> networkList sorry
14:23:16 <krotscheck> cardeois: You may be able to make progress if you manually modify neutron's paste.ini file to take my changes.
14:23:17 <krotscheck> If you have time
14:23:27 <krotscheck> Else, wait until monday?
14:23:46 <cardeois> Well node test can still work so I'm not blocked right now
14:24:00 <cardeois> It just blocks the gates
14:24:11 <krotscheck> Oh, sweet.
14:24:23 <krotscheck> Alright, those are the remaining pieces then. After that it's all documentation.
14:24:32 <krotscheck> Oh wait, no. We need instanceCreate
14:24:38 <krotscheck> I'll put that on the backlog.
14:24:51 <krotscheck> ANything else on MVP? ELse I'll move to Open Discussion
14:25:18 <vkramskikh> I've put one more topic to the agenda
14:25:46 <krotscheck> #topic Usage of js-openstack-lib in Fuel PoC (vkramskikh)
14:25:58 <krotscheck> The floor's yours!
14:26:03 <vkramskikh> today is HCF for Fuel 9.1, so I'll have more time for js-openstack-lib
14:26:14 <vkramskikh> and I want to try to use its keystone client in Fuel
14:26:28 <vkramskikh> just to see how it works and probably provide some feedback
14:26:37 <vkramskikh> I'll try to implement PoC by the next meeting
14:26:44 <vkramskikh> that's all from my side
14:27:05 <cardeois> awesome !
14:27:25 <msmol> agreed, a real user, amazing!
14:27:33 <Zara> :)
14:27:39 <krotscheck> SWESOME
14:27:43 <krotscheck> Woot real users.
14:27:53 <krotscheck> Ok, open discussion!
14:27:57 <krotscheck> #topic Open Discussion
14:28:05 <krotscheck> Hey, everyone, let's track our work in StoryBoard! Usage of js-openstack-lib in Fuel PoC (vkramskikh)
14:28:07 <krotscheck> oops
14:28:16 <Zara> hahaha :)
14:28:17 <krotscheck> https://storyboard.openstack.org/#!/project/844
14:28:21 <Zara> nice
14:28:22 <krotscheck> Wrong item in paste buffer
14:28:31 * msmol openly admits he feels bad he hasn't had much time to contribute to the project lately
14:29:04 <msmol> I'll try to at least be more active in doing reviews
14:29:19 <cardeois> Good idea so should create a story for MVP with subtasks?
14:29:31 <krotscheck> cardeois: Yes, can yo udo that?
14:29:32 <cardeois> (e.g. neutron, nova etc)
14:29:36 <cardeois> I can
14:29:50 <cardeois> and I will
14:29:51 <krotscheck> I'm noticing that as I start to work on a new project, my ability to keep track of OpenStack things in my brain is diminishing.
14:30:00 <krotscheck> StoryBoard makes for a nice shared brain
14:30:24 <Zara> heh, I also use it as a place to put all the things I can then instantly forget about.
14:31:14 <cardeois> I also have a detail to talk about, but it annoys me sorry. About code style, I've noticed that we have methods in classes written in 2 different ways: `name ()` and `name()` , notice the space. Some reviews did refactor the former to the later, some other did the opposite, so I'd like to clear things out on that point
14:31:16 <krotscheck> ok, anything else?
14:31:29 <krotscheck> oh?
14:31:48 <krotscheck> Ah. Hrm.
14:31:52 <cardeois> example: https://review.openstack.org/#/c/369821/1/src/util/abstract_service.js
14:31:53 <krotscheck> I have no preference.
14:32:10 <krotscheck> We can add a linting rule to enforce that.
14:32:18 <cardeois> Yeah I'd like that
14:32:25 <cardeois> I can try to do that too
14:32:38 <krotscheck> http://eslint.org/docs/rules/space-before-function-paren
14:32:40 <msmol> I prefer `name()` but I prefer consistency over everything else so, yeah whatever, linting rule either way would be great
14:33:15 <cardeois> Anybody else as a preference? (mine being `name()` too)
14:33:18 <krotscheck> cardeois: That should be fairly straightforward. Does anyone have a major beef with proposing that to eslint-config-openstack too?
14:34:03 <krotscheck> #action cardeois define a linting rule for space-before-function-parens.
14:34:21 <larainema> I have no preference, linting rule is my following
14:34:23 <cardeois> Ok so I add that to eslint-config-openstack or I start with our project first?
14:34:29 <krotscheck> cardeois, msmol: Y'all are the only ones who care enough. Go ahead and add it to js-openstack-lib, and see if you can build the necessary consensus for eslint-config-openstack.
14:34:59 <cardeois> sure
14:35:04 <krotscheck> Cool, anything else?
14:36:13 <msmol> all good in the hood over here
14:36:51 <krotscheck> Alright, thanks everyone!
14:36:54 <krotscheck> #endmeeting