14:00:10 <krotscheck> #startmeeting Javascript
14:00:15 <openstack> Meeting started Wed Sep 21 14:00:10 2016 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <krotscheck> Woohoo!
14:00:20 <openstack> The meeting name has been set to 'javascript'
14:00:22 <krotscheck> #chair vkmc
14:00:22 <openstack> Current chairs: krotscheck vkmc
14:00:24 <krotscheck> oops
14:00:25 <krotscheck> #undo
14:00:28 <krotscheck> #chair vkramskikh
14:00:31 <openstack> Current chairs: krotscheck vkmc vkramskikh
14:00:33 <betherly> o/
14:00:46 <vkmc> :o
14:00:47 <vkramskikh> hi
14:00:50 <krotscheck> Soooorrryyyy
14:00:54 <vkmc> haha it's ok
14:00:55 * krotscheck doesn't know how to unchair someone
14:01:04 <yujunz> chair again?
14:01:05 <larainema> o/
14:01:09 <krotscheck> #chair vkmc
14:01:10 <openstack> Current chairs: krotscheck vkmc vkramskikh
14:01:12 <krotscheck> Nope
14:01:15 <krotscheck> #unchair vkmc
14:01:16 <openstack> Current chairs: krotscheck vkramskikh
14:01:20 <krotscheck> Huhn.
14:01:20 <vkmc> (:
14:01:23 <krotscheck> Total guess
14:01:27 <cardeois> hi !
14:01:28 <betherly> :D
14:01:34 <krotscheck> Agenda!
14:01:36 <krotscheck> #link https://etherpad.openstack.org/p/javascript-meeting-2016-09-21
14:01:58 <krotscheck> PSA: Son is napping, will likely wake up in 30, vkramskikh will have to take over if that happens
14:02:23 <krotscheck> #topic Action Followup: Build a better readme
14:02:33 <cardeois> I'm working on it right now
14:02:34 <krotscheck> cardeois - just saw a storyboard update?
14:02:39 <krotscheck> Awesome. Review today?
14:02:44 <cardeois> totally forgot to work on js-openstack-lib sorry
14:02:55 <cardeois> but yeah  first draft today.
14:02:58 <krotscheck> Sweet
14:03:07 <krotscheck> #topic Action followup: Neutron patch
14:03:09 <krotscheck> Landed!
14:03:14 <krotscheck> And we now support neutron.
14:03:50 <cardeois> Yeah cool, we still need to merge the neutron review though
14:03:58 <cardeois> just added a patch this morning
14:04:02 <krotscheck> Or rather, we will after we land https://review.openstack.org/#/c/366905/
14:04:41 <cardeois> And I'll need to add a "networkList" review
14:04:46 <krotscheck> #topic Action followup: Propagate betherly's doc changes to other projects.
14:04:55 <krotscheck> Not done, moving to next week's todo list
14:05:01 <krotscheck> #action  propagate https://review.openstack.org/#/c/356473/1/doc/source/releasing.rst to js-openstack-lib and js-generator-openstack
14:05:14 <krotscheck> #topic Action followup: krotscheck land Nova.flavorList
14:05:39 <krotscheck> Patches are up and failing, best I can tell it's a Nova CORS thing, which is deeper than what wwas going on with neutron
14:05:59 * krotscheck was unable to debug that last night because silly airport ethernet blocks git ports
14:06:14 <cardeois> Yeah you need to rebase your reviews I guess
14:06:31 <krotscheck> Yeah, there's a bunch of things in there that aren't nova related, so I'll split those out.
14:06:33 <cardeois> because your first review depending on all of them work, but you didn't rebase
14:06:40 <cardeois> alright
14:06:41 <krotscheck> #topic Action Followup: cardeois define a linting rule for space-before-function-parens.
14:06:47 <krotscheck> Todo. Punt?
14:07:07 <cardeois> Yeah not done either, msmol told me he will help me on that though
14:07:20 <cardeois> so next week I hope
14:07:25 <krotscheck> Awesome
14:07:39 <krotscheck> Anything else left over from last week that I missed before we do discussion topics?
14:07:47 <msmol> funny thing about time, always seems to think there's plenty of it, until suddenly there's none at all
14:08:16 <cardeois> Yeah what's the actual documentation url?
14:08:21 <msmol> will do the linting rule thing right after this meeting, will have a review up today
14:08:25 <cardeois> I want to add that in the readme
14:08:49 <krotscheck> We're still arguing about that here -> https://review.openstack.org/#/c/346131/
14:09:06 * krotscheck hasn't followed up with ajaeger recently, though now might be good since he's in the infra sprint this week
14:09:06 <cardeois> k thanks
14:09:15 <krotscheck> #action krotscheck bother Ajaeger about doc publishing
14:09:48 <krotscheck> cardeois: I am 95% confident that the url will be developer.openstack.org/sdks/javascript/js-generator-openstack
14:10:01 <cardeois> Yeah ok that's what's I though too
14:10:18 <krotscheck> #action cardeois define a linting rule for space-before-function-parens.
14:10:23 <krotscheck> Ok, next topic:
14:10:32 <krotscheck> #topic MVP status
14:11:04 <cardeois> Yeah what was the list of MVP calls already? we had that somewhere but can't find it anymore
14:11:11 <krotscheck> Ok, so neutron needs to pass the gate, nova needs to have its upstream bug fixed, larainema's patch needs to land, and we need documentation.
14:11:15 <cardeois> I want to create a storyboard task for that
14:11:16 <krotscheck> I think that's all.
14:11:49 <krotscheck> The list was: Get flavors, get networks, get images, launch instance. (stretch: Get keys)
14:12:02 <cardeois> Ok thanks
14:12:46 <krotscheck> Alright, I can _try_ to get nova fixed, but nova's notorious for taking forever to land patches
14:13:12 <krotscheck> Assuming I can figure out what's wrong.
14:13:24 * krotscheck knows it's not a wsgi pipeline config, or a config setting.
14:13:50 <cardeois> oh ok, so you're saying cors is not working at all with nova?
14:13:59 <krotscheck> Any questions about MVP?
14:14:43 <krotscheck> Alright, let's move on to Barcelona, the big thing
14:14:44 <krotscheck> #topic Barcelona
14:15:22 <krotscheck> First things first, the foundation is seriously backing "Apps on openstack" as a thing starting in barcelona, and is creating a new app hacking lab to support that.
14:15:22 <krotscheck> The annoucnement is here: http://superuser.openstack.org/articles/kickstart-cloud-app-coding-skills/
14:16:16 <cardeois> awesome idea. Will help have real user feedback if we finish our mvp on time
14:17:15 <Zara> ooh, hat
14:22:34 * krotscheck peers at the channel
14:23:19 <krotscheck> Hello? Anyone here?
14:23:32 <krotscheck> meetbot seems to have died.
14:23:41 <cardeois> alright so what should we do about that? Should gives us the objective of complete the MVP before summit?
14:24:15 <krotscheck> Well, I think that largely depends on how much we care.
14:24:35 <krotscheck> Having a release by the summit will definiteily be awesome and useful and marketing yay
14:24:40 <krotscheck> And outreachy
14:24:46 <krotscheck> But, well, we're all part timer
14:25:03 <cardeois> Yeah so we'll need more people I guess?
14:25:10 <krotscheck> Yeah, chicken/egg
14:25:12 * larainema will not go Barcelona
14:25:29 <krotscheck> larainema: Yeah, I'm not either.
14:25:40 <cardeois> Just created this story: https://storyboard.openstack.org/#!/story/2000729 so people can see what's missing
14:25:49 <krotscheck> cardeois++
14:26:22 <krotscheck> Cool.
14:26:40 <krotscheck> How about this: We work as much as we can. We cut a release the week before barcelona.
14:26:45 <krotscheck> No matter what's in it, we ship it.
14:27:08 <cardeois> sure good idea
14:27:54 <krotscheck> vkramskikh?
14:28:00 <vkramskikh> +1 for the idea
14:28:06 <krotscheck> Any opposed?
14:28:25 <yujunz> nope
14:28:30 <vkramskikh> (just need to get rid of Test class exported by default and it would be fine)
14:29:04 <krotscheck> Cool.
14:29:14 <cardeois> Yeah this is opened and need reviews:  https://review.openstack.org/#/c/369319/
14:29:21 * krotscheck checks for dates.
14:29:50 <krotscheck> Ok, the last JS meeting we have before barcelona is the 19th. Let's set that as our release date.
14:30:03 <krotscheck> #agreed Release first version of js-openstack-lib on the 19th of october.
14:30:10 <krotscheck> That'll give us a few days to work out infra problems if htey arise
14:30:41 <cardeois> sounds good
14:30:57 <krotscheck> In the meantime, I invite everyone to hang out in the app developer's lounge to recruit contributors (and help people that need it), and to go to the SDK fishbowl session
14:31:30 <cardeois> app developer's lounge? you at the summit?
14:31:31 <krotscheck> Oh, wow.
14:31:41 <krotscheck> I posted a bunch of things that were lost. Sec.
14:32:04 <krotscheck> Quote from the email I got about it: "Accordingly, I would like to invite each of you to make this space your "home base" in Barcelona - a place to come and propose what we need to achieve over the next six months on our way to Boston to start building a wider cloud application community across all our companies and across all open clouds."
14:32:18 <krotscheck> So... yay! That's awesome!
14:32:21 <krotscheck> But that's not all!
14:32:26 <krotscheck> I proposed the cross-project SDK session, and it really sounds like it'll be accepted.
14:32:30 <krotscheck> #link https://etherpad.openstack.org/p/ocata-cross-project-sessions
14:32:34 <krotscheck> The only catch was that there wasn't anyone to lead it, and flanders tapped mordred and sean handley to do things there.
14:32:45 <krotscheck> HOwever, I'm fairly certain that mordred's ok to share the stage with anyone here that wants to step up.
14:32:46 <krotscheck> (On behalf of js things)
14:32:48 <krotscheck> cardeois, vkramskikh, msmol: Are any of y'all interested?
14:32:59 <krotscheck> (Did that all make it?)
14:33:54 <cardeois> Well I guess we can help yeah, I'm not very comfortable with how all of this work but I (we?) can try
14:34:11 <vkramskikh> not sure I'll be able to lead it, probably the most i can do is to answer a few js-related questions
14:34:45 <krotscheck> That's alright- the headliners for the room have already been set. It'll likley be a fog and shade show, but as long as JS is represented we're good.
14:34:47 <cardeois> +1 for vkramskikh  said
14:34:52 * krotscheck will not be at the sjmit
14:34:57 <krotscheck> *summit even
14:35:24 <krotscheck> Alright, anything else on barcelona?
14:35:36 <yujunz> Me.
14:35:50 <krotscheck> yujunz You'll be there?
14:35:51 <krotscheck> Awesome!
14:36:02 <yujunz> Yes, not just for js things
14:36:10 <krotscheck> Yes, you're working on vitrage, right?
14:36:19 <yujunz> I have been away from js for a while...
14:36:21 <yujunz> Yes
14:36:44 <krotscheck> \o/ Sounds like a fun project.
14:37:13 <krotscheck> Does one of the attendees want to collect contact info and maybe go out for tapas/wine one night?
14:37:40 <yujunz> Anyone familiar with Barcelona?
14:37:44 <yujunz> I have been there only once
14:37:58 <cardeois> Never been there
14:38:24 * krotscheck is not.
14:38:34 <krotscheck> There's a gathedral and a Dali museum?
14:38:37 <krotscheck> *cathedral
14:38:39 <vkramskikh> i've never been to barcelona
14:39:08 <yujunz> OK, I'll try to organise.
14:39:09 <cardeois> Yeah there is a nice gaudi park and cathedral that's all I know. But definitely there will be nice places to go out
14:39:16 <krotscheck> Woo!
14:39:29 <krotscheck> Ok, yujunz is your social contact in Barcelona for all things javascript :)
14:39:46 <krotscheck> Let's move on, time is going short
14:39:53 <krotscheck> #topic First User: vkramskikh
14:39:57 <krotscheck> Sounds like other things took you rtime?
14:40:11 <vkramskikh> Inot much progress here, i'm still recovering from surgery
14:40:25 <krotscheck> vkramskikh: Ick. Hope you get better soon :)
14:40:43 <vkramskikh> I'll try to use openstack-lib for Fuel by the next meeting
14:40:45 <krotscheck> #topic Other JS Projects.
14:40:58 <krotscheck> We've been talking about the SDK: Any of the other problems want the floor?
14:41:01 <krotscheck> *projects
14:41:41 <krotscheck> zara? vkramskikh? timothyb89?
14:41:56 <vkramskikh> any news about React's license? what's the source of truth here?
14:42:10 <vkramskikh> Fuel-UI and Tripleo-UI are using React
14:42:14 <Zara> (I'm sorry, distracted by other channels rn :/)
14:42:23 <yujunz> #action yujunz collect contact info and organise a js meetup in Barcelona
14:42:28 <krotscheck> None since what i posted last.
14:43:01 <krotscheck> In the end its up to the project, but adoption could be tricky because of that license
14:44:05 <timothyb89> one possible option there could be something like https://github.com/developit/preact
14:44:44 <krotscheck> IANAL: My opinion is that there's nothing preventing from you to using it, but that your project may not be adopted by openstack deployers because of that license.
14:45:08 <krotscheck> There's also vue.js which is similar to react, combined with reflux.js.
14:45:47 <krotscheck> But, frankly, I prefer angular because it embraces the DOM instead of forcing that component recalculation cycle
14:46:16 * krotscheck is having network issues
14:47:12 <krotscheck> Any other projects want the floor? Infra issues, etc?
14:48:10 <krotscheck> Moving on.
14:48:15 <krotscheck> #topic Open Discussino
14:48:18 <krotscheck> #undo
14:48:19 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x7f23bd73c0d0>
14:48:22 <krotscheck> #topic Open Discussion
14:49:59 <cardeois> Just created a draft for README, feel free to review https://review.openstack.org/#/c/374220/1
14:50:13 <krotscheck> cardeois++
14:50:35 <cardeois> What example should I provide btw?
14:50:50 <cardeois> create instance? of flavorList is ok?
14:51:07 <krotscheck> cardeois: I'd deep link into our documentation for examples, manage it there.
14:51:14 <cardeois> (in any case I think "Openstack" class should be used but we don't have any implemented method in it yet
14:51:23 <cardeois> alright
14:51:38 <krotscheck> Yeah, that's my bad, I promised to review larainema's patches and enver got around to it.
14:51:42 <krotscheck> Alright, let's call the meeting early. Thanks everyone! Don't forget to get yujunz your contact information while you're in barcelona (remember he's never met any of us).
14:51:56 <krotscheck> #endmeeting