14:00:15 <krotscheck> #startmeeting javascript
14:00:16 <openstack> Meeting started Wed Sep 28 14:00:15 2016 UTC and is due to finish in 60 minutes.  The chair is krotscheck. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:21 <openstack> The meeting name has been set to 'javascript'
14:00:29 <krotscheck> Good morning everyone!
14:00:35 <krotscheck> #agenda https://etherpad.openstack.org/p/javascript-meeting-2016-09-28
14:00:45 <cardeois> hello
14:00:49 <vkramskikh> рш
14:00:50 <larainema> o/
14:00:51 <vkramskikh> hi
14:01:39 <krotscheck> #topic Action followup: space-before-function-parens.
14:01:46 <krotscheck> cardeois, msmol were working on this?
14:01:57 <cardeois> review is here https://review.openstack.org/#/c/375068/ msmol did it and it's merged
14:02:17 <cardeois> there still is the eslint global config to update if we want to
14:02:29 <krotscheck> Woot!
14:02:34 <krotscheck> Right- the governance on theat project requires more votes.
14:02:38 <krotscheck> We could just gang land it though
14:02:40 <krotscheck> :)
14:03:01 <msmol> sorry i'm late, we're talking about es-lint stuff?
14:03:14 <krotscheck> Yeah, we mentioned that we can do a global update.
14:03:52 <msmol> Yes, I meant to open a review in that project, but I just haven't had a chance yet. I'll try to get that open today or tomorrow
14:04:02 <krotscheck> Excellent!
14:04:16 <krotscheck> #action msmol add space-before-funcitno-parens rule to eslint-config-openstack
14:04:19 <krotscheck> #topic Action Followup: All of krotscheck's things.
14:04:29 * krotscheck has had no time to work on anything, so I either have to delegate or punt again
14:04:48 <krotscheck> Task 1: bother Ajaeger about doc publishing
14:04:58 <krotscheck> That's my patch, I should probably just do that.
14:05:23 <cardeois> OK where's the patch already?
14:05:39 <krotscheck> Yeah: https://review.openstack.org/#/c/346131/
14:05:59 <cardeois> thanks
14:06:48 <krotscheck> Task 2: Propagate release documentation from eslint to other projects. https://review.openstack.org/#/c/356473/1/doc/source/releasing.rst
14:07:09 <cardeois> This one I can help if you want but I don't fully understand it
14:07:20 <cardeois> Is that to release a version to npm?
14:07:37 <krotscheck> No, it's to copy the documentation that betherly wrote into the other projects so we know how to do it.
14:08:29 <cardeois> Yeah but what's the goal of this doc? after you have a tag it will publish to npmjs ? or that's another step
14:09:01 <krotscheck> Tagging will trigger the release workflow, which will make the infra systems publish the package to npm.
14:09:24 <cardeois> Alright cool, so it's not complicated to do then, just copy/paste
14:09:46 <krotscheck> Yep.
14:09:57 <krotscheck> I can hand that off to you then?
14:10:08 <cardeois> Yes, can you add those 2 tasks in storyboard?
14:10:20 <krotscheck> Roger wilco.
14:10:31 <krotscheck> #action krotscheck create release documentation tasks in storyboard
14:10:49 <krotscheck> #topic Action Followup: js-lib in fuel-ui
14:10:56 <krotscheck> Sooooo.... keystonev2, eh?
14:11:05 <vkramskikh> hi, I posted an update yesterday
14:11:13 <vkramskikh> currently fuel uses v2 api
14:11:26 <vkramskikh> i'm figuring out if it's possible to migrate to v3
14:11:36 <krotscheck> Right, and it does so in a weird way that creates a random auth domain with every instance.
14:11:49 <vkramskikh> v3 api are available on the master node, but they require domain names which seems to be unique for every installation
14:12:20 <vkramskikh> I didn't see any other blockers in using js-openstack-lib, I was able to successfully include in tn the fuel build
14:12:29 <krotscheck> Context: auth and project domains are used for auth federation - one keystone master knowing to accept tokens from a different keystone master and so forth.
14:12:34 <krotscheck> Nice!
14:12:35 <cardeois> We could maybe also add support of keystone v2 in js-openstack-lib?
14:13:09 <krotscheck> I don't see any problem with that, except that we then have to solve the "How do you pick more than one supported version" problem.
14:14:10 <vkramskikh> I'll try to solve issues with switching to v3 and report on the next meeting and we'll see what we can do here
14:14:23 <cardeois> yeah true. I feel like for MVP we should focus on v3, and see if vkramskikh can figure out a way to use v3 in fuel. It's not like it's a lost of time to upgrate keystone in fuel
14:14:30 <cardeois> cool
14:15:03 <krotscheck> Alrightey.
14:15:19 <krotscheck> #topic Action Followup: Get your barcelona info to yujunz!
14:15:26 <krotscheck> Did everyone reach out to him?
14:15:47 <cardeois> Nope I didn't but I should !
14:15:50 <msmol> oops, nope
14:16:13 <larainema> I can easily connect with him:)
14:16:29 <vkramskikh> oh I didn't
14:16:32 <larainema> But I will not at Barcelona
14:16:48 <krotscheck> larainema: Yeah, I won't either.
14:17:21 <krotscheck> #action vkramskikh Try to make fuel support keystone v3, report back.
14:17:31 <msmol> we should start a gofundme to get you guys over there ;-)
14:17:34 <krotscheck> #action cardeois msmol vkramskikh Get contact info to yujunz
14:17:49 <krotscheck> msmol: Well, for atlanta I'm going to apply for a scholarship.
14:17:56 <krotscheck> msmol: But I missed the window this time.
14:18:29 <krotscheck> Even so, I strongly encourage everyone to hang out in the App Developer's lounge as much as possible.
14:18:43 <cardeois> Yep will try
14:18:43 <krotscheck> Oh, also, it looks like there _will_ be an SDK fishbowl.
14:19:05 * krotscheck probably mentioned that at one point.
14:19:12 <krotscheck> ALright, moving on.
14:19:16 <krotscheck> #topic MVP Status
14:19:22 <krotscheck> So, the biggest blocker righ tnow is nova.
14:19:25 <krotscheck> And CORS in nova.
14:19:38 <cardeois> Yeah did you figure it out?
14:19:54 <krotscheck> Nope. I spent 3-4 hours trying to get nova running in a debuggable environment
14:19:57 <krotscheck> And did not succeed.
14:20:32 <krotscheck> Next attempt is to modify the nova code live in a devstack instance and see if I can figure out why the CORS middleware isn't being triggered.
14:20:43 <cardeois> Ok so I could maybe try to help you on that next week
14:21:00 <cardeois> (even if I don't know how to do that)
14:21:15 <krotscheck> Yeah, I don't either. This is all new ground for me, and I don't have handy nova experts to reach out to anymore :)
14:21:21 <krotscheck> Actually....
14:21:25 * krotscheck makes a note to poke auggy
14:22:04 <krotscheck> Anyay
14:22:06 <cardeois> ok, so anyway if you want help or pair via screen sharing or whatever let me know
14:22:10 <krotscheck> #action krotscheck Try to unblock nova.
14:22:14 <krotscheck> Willdo.
14:22:36 <krotscheck> That's all I have today. Anyone else have progress on our things in storyboard?
14:22:45 <cardeois> for mvp neutron was merged
14:23:09 <cardeois> networklist is open : https://review.openstack.org/#/c/376997/
14:23:29 <cardeois> There's a merge conflict with this one: https://review.openstack.org/#/c/369319/
14:23:36 <cardeois> dong ma I guess need to rebase
14:24:08 <krotscheck> larainema ^^
14:24:09 <cardeois> And last for storyboard, I created this last week, feel free to assign any task if you want to contribute https://storyboard.openstack.org/#!/story/2000729
14:24:11 <larainema> sure, I will do it later
14:24:13 <vkramskikh> + I suggest to move openstack class from index.js to a separate file - since index.js contains only reexports now
14:24:45 <cardeois> Yeah didn't think about that but good idea
14:24:47 <krotscheck> cardeois +2 LGTM
14:25:00 <krotscheck> Sweet
14:25:26 <krotscheck> Alright, anything else Otherwise I'll end the meeting early
14:25:36 <cardeois> Well for the readme, I created that https://review.openstack.org/#/c/374220/
14:25:56 <cardeois> did a bunch of copy paste, english is not my native language so I'd like some reviews
14:25:59 <krotscheck> Right!
14:26:18 <cardeois> But this is a WIP mostly because the doc URL is not available yet
14:26:41 <cardeois> Should I maybe remove the WIP and depend-on https://review.openstack.org/#/c/346131/ ?
14:26:54 <krotscheck> Ah, it's WIP,Looks good, actually
14:27:18 <krotscheck> The docs job won't publish the readme, this is the docs page for npmjs.org
14:27:36 <cardeois> Yeah but readme contains this link: http://developer.openstack.org/sdks/javascript/js-openstack-lib
14:27:41 <cardeois> which is 404 for now
14:28:18 <krotscheck> Oh. Yes.
14:28:20 <krotscheck> Hrm.
14:28:33 <krotscheck> Yeah, maybe a depends-on would be good.
14:28:39 <cardeois> alright will do
14:28:43 <krotscheck> Coolio.
14:28:52 * krotscheck makes a note to wake up at 4 tomorrow to try and debug nvoa
14:29:02 <krotscheck> Thanks everyone, that wraps it!
14:29:05 <krotscheck> #endmeeting