14:00:16 <vkramskikh> #startmeeting javascript
14:00:17 <openstack> Meeting started Wed Oct  5 14:00:16 2016 UTC and is due to finish in 60 minutes.  The chair is vkramskikh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:21 <openstack> The meeting name has been set to 'javascript'
14:00:25 <vkramskikh> #chair krotscheck
14:00:25 <openstack> Current chairs: krotscheck vkramskikh
14:00:31 <vkramskikh> hi everyone
14:00:41 <vkramskikh> agenda is here https://etherpad.openstack.org/p/javascript-meeting-2016-10-05
14:01:01 <vkramskikh> who's here?
14:01:02 <msmol> hello all
14:01:19 <cardeois> hi
14:01:37 <vkramskikh> #topic cardeois msmol vkramskikh Get contact info to yujunz
14:01:54 <vkramskikh> I've shared my contacts, though I'll also get a local sim card in barcelona
14:02:08 <cardeois> Yeah I think I will too
14:02:19 <cardeois> where is your contact info?
14:02:47 <msmol> I might as well. I haven't given yujunz anything yet though, my bad
14:02:56 <vkramskikh> I've sent it to yujunz. It's actually IRC and my email vkramskikh@mirantis.com
14:03:00 <cardeois> oh I see
14:03:18 <cardeois> Yeah will do that this week with msmol so we don't forget
14:03:18 <msmol> vkramskikh: what is yujunz contact info so that I can send my info?
14:03:50 <vkramskikh> msmol: the email is here https://etherpad.openstack.org/p/javascript-meeting-2016-09-21
14:04:19 <msmol> thanks vkramskikh
14:04:33 <vkramskikh> #topic krotscheck's items
14:05:09 <vkramskikh> krotscheck has reported that he has no updates, so let's skip these topics and move them to the next metting
14:05:25 <vkramskikh> #action krotscheck create release documentation tasks in storyboard
14:05:33 <vkramskikh> #action krotscheck Try to unblock nova
14:05:44 <vkramskikh> #topic msmol add space-before-funcitno-parens rule to eslint-config-openstack
14:05:52 <msmol> https://review.openstack.org/#/c/381929/
14:06:27 <msmol> does anyone know what the docs gate is? didn't have much time to investigate what it is / why it's failing
14:06:43 <vkramskikh> I don't
14:06:44 <msmol> i was thinking betherly might know?
14:07:46 <vkramskikh> #action everyone to review https://review.openstack.org/#/c/381929/ and try to help with docs job failure
14:08:19 <vkramskikh> #topic vkramskikh Try to make fuel support keystone v3, report back
14:08:35 <msmol> how's that going vkramskikh?
14:08:42 <vkramskikh> so I've spent some time to make Fuel to use v3 API and had success
14:08:53 <cardeois> \o/
14:08:59 <msmol> :D
14:09:00 <vkramskikh> I figured out Fuel's master node is using non-default domains
14:09:08 <vkramskikh> named "fuel"
14:09:31 <vkramskikh> but unfortunately our Keystone client wasn't able to specify custom domains names, only ids
14:09:32 <cardeois> oh ok so you have to specify the domain name then
14:09:59 <vkramskikh> so first I decided to rewrite fuel code without switching to js-optnstack-lib first
14:10:15 <vkramskikh> currently it's under review https://review.openstack.org/#/c/379387/
14:10:27 <vkramskikh> but works fine
14:10:46 <cardeois> great
14:10:51 <vkramskikh> so to make Fuel use js-openstack-lib I see there are a few blockers
14:11:24 <vkramskikh> 1) fix the tests for js-openstack-lib to land the required changes: https://review.openstack.org/#/c/381837/4
14:11:48 <vkramskikh> cardeois: I think you can W+1 this patch, there is already +2 from me
14:12:09 <cardeois> well the +2 is from me :)
14:12:22 <vkramskikh> oh
14:12:31 <cardeois> but I can w+1 if krotscheck is not there, but I'll try to poke him
14:12:40 <vkramskikh> ok I've put W+1 already :)
14:12:44 <cardeois> ok cool problem solved
14:12:50 <msmol> I can code-review +1 if that helps at all
14:12:58 <msmol> nevermind
14:13:10 <vkramskikh> 2) support domain names in our keystone client https://review.openstack.org/#/c/381713/
14:13:39 <cardeois> YEah this one looks fine but I'd like to see some unit test if it's possible
14:14:09 <vkramskikh> cardeois: I have no idea how to unit test this change, though I've added some functional tests which override project and domains so we can be sure that provided porject and domains are taken into account
14:14:39 <cardeois> Alright so I'll take a deeper look into it and will comment/code review +2
14:15:03 <vkramskikh> #action cardeois to review https://review.openstack.org/#/c/381713/
14:15:08 <vkramskikh> thanks!
14:15:40 <vkramskikh> 3) Fuel needs an extra API call which we don't support yet: https://review.openstack.org/#/c/381608/
14:15:55 <vkramskikh> it's under development - I'm writing unit tests now
14:16:05 <cardeois> What's is tokenInfo giving you?
14:16:11 <vkramskikh> #action vkramskikh to implement tokenInfo() call
14:17:09 <vkramskikh> from this info Fuel needs roles (to see if admin role is here) and ID (to build URL to change user's password)
14:17:22 <vkramskikh> so that's the next item
14:17:24 <cardeois> Oh ok I see
14:17:35 <vkramskikh> 4) Implement password change in Keystone
14:17:55 <vkramskikh> #action vkramskikh to implement password change in Keystone
14:18:04 <vkramskikh> and the last one
14:18:08 <cardeois> I suggest you create stories/task in here https://storyboard.openstack.org/#!/project/844
14:18:19 <cardeois> so if anyone want to help could assign itself
14:18:27 <vkramskikh> cardeois: thanks, will create
14:18:56 <vkramskikh> 5) figure out what's the difference between Keystone API v3.6 vs v3.7
14:19:14 <vkramskikh> the latest release of Fuel uses Mitaka which is v3.6, but we support only v3.7
14:19:35 <vkramskikh> will try to figure it out in the nearest future
14:19:44 <breton> my guess is that the difference is only in some returned parameters
14:19:51 <vkramskikh> #action vkramskikh to try to support Keystone v3.6
14:20:07 <cardeois> haha yeah and that might bring the subject about different version implementations. But I'd like to have this discussion later as it will complexify the lib. I'm not sure we're the lib is mature enough to handle it
14:20:46 <vkramskikh> I'll figure out the changes, probably it won't affect us much
14:21:04 <cardeois> Yeah especially if it concerns a call we don't support yet
14:21:30 <vkramskikh> #topic open discussion
14:21:41 <vkramskikh> we don't have any topic on the agenda
14:21:51 <vkramskikh> does anyone want to discuss anything?
14:21:53 <cardeois> So on my side I'm starting to create patch for Openstack class
14:22:00 <cardeois> so we can use networkList in it
14:22:14 <cardeois> BTW I need W+1 on that once I rebase https://review.openstack.org/#/c/376997/
14:22:44 <cardeois> On this future review, I did a lot of decisions to go forward
14:22:51 <vkramskikh> yeah, let's wait for merge of tests fix
14:22:53 <cardeois> but I'm expecting to have feedback
14:22:54 <vkramskikh> and rebase
14:23:00 <vkramskikh> and I'll review it
14:23:15 <cardeois> cool
14:23:52 <cardeois> I have no other subject on my side
14:24:04 <msmol> nothing on my end either
14:24:47 <vkramskikh> let's close the meeting early then
14:24:50 <vkramskikh> #endmeeting