14:00:24 <vkramskikh> #startmeeting javascript
14:00:25 <openstack> Meeting started Wed Nov  2 14:00:24 2016 UTC and is due to finish in 60 minutes.  The chair is vkramskikh. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <openstack> The meeting name has been set to 'javascript'
14:00:30 <vkramskikh> hey everyone
14:00:48 <vkramskikh> the agenda is here https://etherpad.openstack.org/p/javascript-meeting-2016-11-02
14:00:53 <larainema> hi all
14:00:56 <vkramskikh> who's there?
14:01:21 <larainema> hi vkramskikh
14:01:33 <yujunz> hi all
14:02:33 <vkramskikh> #topic action followup: everyone to review https://review.openstack.org/#/c/385777/
14:02:49 <vkramskikh> the request has been merged, thanks everyone!
14:03:08 <vkramskikh> #topic action followup: yujunz to create doc about including js-openstack-lib into existing project
14:03:25 <vkramskikh> yujunz: how is it going?
14:03:28 <yujunz> I wrote to MIchael and will continue on his patch
14:03:41 <yujunz> #link https://review.openstack.org/#/c/351875/
14:04:02 <yujunz> He has already started a document, I'll continue on it
14:04:17 <vkramskikh> yujunz: cool, thanks
14:04:44 <vkramskikh> and we have the only topic for this meeting
14:04:48 <vkramskikh> #topic do we still need this meeting?
14:04:54 <vkramskikh> what do you guys think?
14:05:15 <vkramskikh> not so many people attend the meeting now
14:05:22 <yujunz> Sorry for missing lots of meetings.
14:05:38 <yujunz> Shall we reduce the frequency?
14:05:54 <vkramskikh> that's an option for sure
14:06:17 <vkramskikh> originally Michael planned to make it bi-weekly
14:06:28 <yujunz> Another option is turn it into casual meeting
14:06:45 <yujunz> No fixed agenda, just a time slot that most people will get online
14:07:00 <yujunz> And we may discuss freely
14:07:31 <larainema> I am OK with either:)
14:07:40 <larainema> will try to attend
14:07:53 <larainema> how about the summit? any plan to js-openstack-lib?
14:07:59 <vkramskikh> yujunz: maybe we just use #openstack-javascript instead?
14:08:17 <yujunz> Yes
14:08:17 <yujunz> For casual meeting, we can stay in javascript channel
14:08:21 <yujunz> Less noise
14:08:35 <vkramskikh> we had a short meeting and discussed some short-term plans for js-openstack-lib
14:09:22 <vkramskikh> they include support for Keystone v3.6 and password change api call - the only items which are left to use the library in Fuel
14:09:43 <yujunz> Yes, lunch time with vkramskikh and cardeois
14:10:41 <yujunz> The getting started document is also based on authentication
14:10:43 <vkramskikh> as for me, I have no further plans for js-openstack-lib - most likely I won't be contributing to Fuel a lot since I've started to work on another project
14:10:49 <cardeois> oh hi ! sorry to be late, I'm still in europe, not used to the time difference
14:11:45 <vkramskikh> but I will still review the patches and could help others with any kind of issues
14:12:29 <larainema> i have tried to make the nova api works last week, but not done it, have talked with michael, hope have some progress this week
14:12:51 <vkramskikh> larainema: great news!
14:13:05 <vkramskikh> cardeois: what to you think about this meeting? should we cancel it, make it bi-weekly or make it "casual"?
14:13:33 <cardeois> sure no pb, well you're right not many people attend this meeting, so either bi-weekly or just use #openstack-javascript is ok
14:13:56 <cardeois> But what do you mean by casual?
14:14:36 <cardeois> My only concern I'm afraid of is if we don't do any meeting anymore, we won't contribute much on it, or not at all
14:15:06 <vkramskikh> "just use #openstack-javascript" suits for my understanding of "casual"
14:15:17 <vkramskikh> ok, so let's start with making it bi-weekly for now
14:15:48 <yujunz> Casual =>  "Should it be formal meeting (i.e. sync-up) or just time-slot when most of active people will be available in IRC and ready for discussion?"
14:15:53 <cardeois> alright and we'll make it casual if we thinkg bi weekly is too much
14:15:55 <yujunz> Copied from mailing list
14:16:31 <vkramskikh> #agreed make this meeting bi-weekly
14:16:37 <vkramskikh> I'll create a patch
14:16:50 <yujunz> agree
14:16:53 <vkramskikh> does anybody have any other topics to discuss?
14:17:00 <yujunz> I have question on docs
14:17:10 <yujunz> Where does it publish finally?
14:17:18 <cardeois> good question, checking
14:17:35 <yujunz> I saw the job merged, but didn't find the page on docs site
14:17:51 <cardeois> http://developer.openstack.org/sdks/javascript/js-openstack-lib for js-openstack-lib
14:17:58 <cardeois> but it's published only at release time
14:18:20 <cardeois> so when we do a new tag. Not sure it's the best option, krotscheck did it like that so I kept it
14:18:55 <cardeois> And for js-generator-openstack I think it will be http://docs.openstack.org/developer/js-generator-openstack
14:19:14 <cardeois> As it's not clear if this is for app developers using openstack, or internal for openstack devs
14:19:28 <yujunz> Is there a time window for release?
14:19:37 <yujunz> Or we can tag whenever it is ready
14:19:55 <cardeois> Yeah we can tag whenever we want, but we have to poke infra
14:20:03 <clarkb> cardeois: I think the separation that the docs team is trying to achieve is that developer.openstack.org is for application developers looking for docs on how to use openstack. docs.openstack.org/developer is for openstack developers looking for docs on how to develop openstack
14:20:43 <cardeois> clarkb exactly and as js-generator-openstack puprpose was not clear I've set it to docs.openstack.org/developer for now
14:22:49 <cardeois> vkramskikh I don't have any subject this week, anybody else?
14:22:57 <yujunz> No more from my side
14:23:07 <cardeois> btw I'm in vacations this week and next week
14:23:16 <cardeois> so I might skip the next meeting as well
14:23:55 <vkramskikh> cardeois: since I'm going to modify the meeting, I want to add you to the chair list. do you have any objections? :)
14:24:04 <yujunz> If bi-weekly meeting start today, the next one will be on Nov 16?
14:24:05 <cardeois> sure no pb
14:24:24 <vkramskikh> yujunz: correct
14:24:35 <vkramskikh> no more topics from my side then
14:24:51 <larainema> no more topics from me
14:25:05 <vkramskikh> thanks everyone
14:25:08 <vkramskikh> #endmeeting