15:00:31 <cardeois> #startmeeting javascript
15:00:31 <openstack> Meeting started Wed Dec 14 15:00:31 2016 UTC and is due to finish in 60 minutes.  The chair is cardeois. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:36 <openstack> The meeting name has been set to 'javascript'
15:00:46 <cardeois> Hello, anyone there ?
15:00:54 <pboutin> I am
15:01:28 <cardeois> Agenda of the day https://etherpad.openstack.org/p/javascript-meeting-2016-12-14
15:01:34 <cardeois> vkramskikh msmol maybe?
15:04:00 <cardeois> Ok well seems like vkramskikh is not here
15:04:01 <msmol> hello
15:04:21 <cardeois> Anyway I'll start anyway
15:04:40 <cardeois> #topic "yujunz to create doc about including js-openstack-lib into existing project
15:04:40 <cardeois> MVP followup"
15:05:10 <cardeois> Since last meeting we didn't see any progress on that
15:05:18 <cardeois> and yujunz is not connected
15:05:34 <cardeois> let's go the next (hum and last topic)
15:05:44 <larainema> Hello cardeois
15:05:47 <cardeois> #topic MVP followup
15:05:50 <cardeois> hey !
15:06:50 <cardeois> So about MVP, nova reviews are ready to be merged.
15:07:05 <cardeois> I finished this https://review.openstack.org/#/c/370389/ and larainema did https://review.openstack.org/#/c/406612/
15:07:25 <cardeois> I guess we're waiting for workflow +1 on both
15:07:40 <cardeois> I can merge them but would like vkramskikh to do it ideally
15:08:45 <cardeois> Once this is merged, we have all our needed components implemented in js-openstack-lib. We next have to implement nova boot and we have a MVP
15:09:11 <cardeois> Anyone wants to volunteer?
15:10:01 <larainema> What is nova boot?
15:10:30 <cardeois> Well not sure about the name, but it's to create an VM through Nova
15:10:59 <cardeois> an instance sorry
15:11:06 <cardeois> http://developer.openstack.org/api-ref/compute/?expanded=create-server-detail
15:11:30 <larainema> Ah, I see
15:11:39 <cardeois> Alright, so I'll create an action for everyone instead
15:12:00 <cardeois> #action "everyone" Implement create server in Nova
15:12:30 <cardeois> I don't have any topic left does anyone has some?
15:12:45 <cardeois> (or we switch to open discussion)
15:13:40 <cardeois> #topic Open discussion
15:14:15 <cardeois> Well vkramskikh is not there, but I have to tell you guys I will be less active in js-openstack-lib
15:14:29 <cardeois> I gave my 2 weeks notice to Internap and my last day will be Friday.
15:14:48 <cardeois> Unfortunately my new job won't be related to OpenStack.
15:15:33 <pboutin> maybe in the near future me and msmol will try to catch up on this project
15:15:34 <larainema> :(, so if this project will continue?
15:16:06 <cardeois> So that means only vkramskikh will be an active core reviewer. So I have to topics:
15:16:06 <cardeois> - Do you think guys this project is still worth it and is there people to contribute?
15:16:06 <cardeois> - If we want to continue, should we elect a new core reviewer?
15:16:59 <cardeois> I guess larainema you are the only other active developer (present in meetings), so you could be a good candidate for core
15:16:59 <pboutin> as someone that is not too familiar with OpenStack core behaviours, it's kinda hard to grasp on this project
15:17:16 <msmol> I think we should ask vkramskikh what his intentions are moving forward as well before making any decisions
15:17:40 <cardeois> Alright let's do that
15:18:13 <cardeois> #action "cardeois" "Ask vkramskikh his opinion about the future of this project"
15:18:59 <cardeois> pboutin Yes I understand, but the project is small right now, that's a good occastion to catch up :)
15:19:20 <larainema> I would like to move this project forward, but it's also need more person to participate
15:19:45 <cardeois> Yes I agree, I will try to send an email to the dev mailing list today
15:21:28 <cardeois> Alright anything else?
15:22:25 <cardeois> Oh maybe one thing, do we want to continue this meeting every two weeks or should we do it informally on #openstack-javascript ?
15:23:14 <pboutin> maybe a next meeting should be planned in order to see which direction the projet will take
15:23:36 <cardeois> Ok
15:23:56 <cardeois> Alright that's it for me, I'm closing the meeting.
15:24:15 <larainema> Okay, thanks cardeois
15:24:37 <cardeois> Good luck for the future of this project, I would really like it not to die, but can't see going forward right now unfortunatelly, we need more contributors
15:24:40 <cardeois> Bye !
15:24:43 <cardeois> #endmeeting