09:02:41 <saggi> #startmeeting karbor
09:02:42 <openstack> Meeting started Tue Nov  8 09:02:41 2016 UTC and is due to finish in 60 minutes.  The chair is saggi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:45 <saggi> Hi everyone
09:02:46 <openstack> The meeting name has been set to 'karbor'
09:02:55 <leon_wang> hi
09:02:55 <xiangxinyong> hello
09:03:09 <zengchen> hello guys.
09:03:30 <saggi> Sorry for being a bit late, was busy looking at patches
09:03:30 <yuval> hey
09:04:11 <saggi> Speaking on patches....
09:04:11 <saggi> #topic The way to stability
09:04:37 <saggi> I spent the last couple of days triaging all the bugs on launchpad
09:05:07 <saggi> That means setting priorities and deciding what should get in Ocata.
09:05:48 <saggi> Patch sets that relate to bugs should get a much higher priority in review than other patches.
09:06:04 <saggi> Also, fixing bugs is of higher priority than cleanups.
09:06:43 <saggi> Further more, please open bugs on things that you know are broken. I will triage bugs every morning so we know what we need to do.
09:08:03 <xiangxinyong> ok
09:08:15 <saggi> Currently what is being stable means is only in our heads. It's better that we have a list of things we need to fix.
09:09:59 <xiangxinyong> do we need to mark them in the lauchpad?
09:10:00 <saggi> Please make sure to make the bug reports detailed and easy to understand even out of context since someone else might fix the problem you found
09:10:22 <saggi> xiangxinyong: It should be automatic
09:10:27 <leon_wang> ok
09:10:29 <saggi> If you set the proper headers in gerrit
09:10:47 <saggi> https://wiki.openstack.org/wiki/GitCommitMessages
09:11:22 <yuval> btw, chenying and zhonghua-lee here too?
09:12:23 <xiangxinyong> they are not available
09:12:56 <saggi> Just to sum up. If you see a problem and you can't send a patch immediately, open a bug. Otherwise things fall through the cracks.
09:13:16 <saggi> I will send an email to the mailing list and CC chenying and zhonghua-lee about it
09:13:49 <xiangxinyong> saggi:great
09:14:18 <xiangxinyong> do you mean every patch needs a bug or bp?
09:14:35 <yuval> we have some bugs with inactive assignee, I think
09:15:12 <saggi> xiangxinyong: It will get higher priority review from me and yuval. Also if a bug exists for the problem you are fixing you will need to set the bug in the commit message.
09:15:40 <xiangxinyong> saggi: agree
09:16:33 <xiangxinyong> the Standard commit message is important
09:17:21 <leon_wang> xiangxinyong:couldn't agree more.
09:17:35 <xiangxinyong> :)
09:18:36 <leon_wang> often be confused with the patch which doesn't contain any commit message :(
09:18:37 <saggi> Needless to say, working on fixing bugs is top priority.
09:19:46 <zengchen> totally agree.
09:19:57 <saggi> #topic Adding Karbor into Kolla and implementing container deployment (xiangxinyong)
09:20:44 <xiangxinyong> we discuss the feature with kolla team members. zhanglei and caiwei
09:21:04 <saggi> xiangxinyong: This relates to ease of installation so we might fit in the the O cycle. But I wonder what we need to change code wise for this to work.
09:21:32 <zhangshuai> zhanglei and caowei
09:21:33 <xiangxinyong> zhangshuai: are you around?
09:22:03 <xiangxinyong> zhangshuai is working on it
09:22:14 <zhangshuai> saggi:no
09:22:41 <xiangxinyong> I guess we only need to give the installation documents to kolla team
09:23:12 <saggi> xiangxinyong: can they convert the devstack scripts?
09:23:26 <zhangshuai> they make it as a docker image
09:23:48 <zhangshuai> xiangxinyong:you are right.
09:23:50 <yuval> I believe working on OpenStack Ansible deployment first could help
09:24:22 <xiangxinyong> yeah. caowei from 99cloud is an expert
09:24:24 <saggi> zaneb: What is the the delta between kolla and openstack-ansible
09:25:29 <xiangxinyong> but unfortunately caowei is not here today.
09:26:38 <xiangxinyong> It is easy for him to submit a patch in kolla to do this work
09:27:07 <xiangxinyong> it is very well for karbor and kolla
09:27:23 <saggi> What will the patch do is it a Dockerfile?
09:28:39 <xiangxinyong> saggi: not sure. but zhangshuai and caowei are working on it.
09:28:42 <zhangshuai> like https://review.openstack.org/#/c/374908
09:29:28 <xiangxinyong> zhangshuai: thanks
09:29:52 <zhangshuai> :)
09:30:06 <leon_wang> zhuangshuai:great
09:30:23 <saggi> zhangshuai, xiangxinyong: Great, Please put me as a reviewer for any patches for Karbor in Kolla.
09:30:30 <yuval> me too please
09:30:49 <xiangxinyong> :) no problem.
09:31:16 <zhangshuai> saggi,yuval: ok,  thank you.
09:31:34 <saggi> #topic Karbor integrated with Freezer Plan (xiangxinyong)
09:31:34 <xiangxinyong> we could keep touch with kolla's guys
09:31:45 <saggi> xiangxinyong: sure
09:31:55 <xiangxinyong> yangyapeng: are you around?
09:32:16 <yangyapeng> xiangxinyong: yeah
09:32:28 <xiangxinyong> welcome to join this meeting
09:32:50 <xiangxinyong> yangyapeng from 99cloud is the freezer's core member
09:32:52 <yangyapeng> :)
09:32:55 <xiangxinyong> he is very kind
09:33:16 <leon_wang> hi yapeng
09:33:27 <saggi> hi yangyapeng
09:33:35 <yuval> hey yangyapeng
09:33:43 <yangyapeng> hello  guys :)
09:33:59 <saggi> I have my ideas on how to integrate but I'd much rather hear what yangyapeng has to suggest.
09:33:59 <xiangxinyong> saggi: do we have some plans to integrate with freezer.?
09:34:06 <saggi> Yes
09:34:21 <saggi> It depends on freezer plugins
09:35:16 <yangyapeng> whether it have a  details  in etherpad
09:35:22 * saggi is looking for the freezer etherpad
09:35:50 <xiangxinyong> saggi: may we develop a freezer plugin to connect freezer?
09:35:57 <saggi> yangyapeng: can't find the etherpads from BCN : https://wiki.openstack.org/wiki/Design_Summit/Ocata/Etherpads
09:36:10 <yuval> https://etherpad.openstack.org/p/freezer_other_roadmap_ocata
09:36:13 <yuval> https://etherpad.openstack.org/p/freezer_new_archi
09:36:51 <saggi> The last one
09:37:25 <saggi> So if we look at what we need from freezer. It's guest cooperation.
09:38:37 <saggi> File level backups don't really make much since for the Karbor story. So what we want to do is invoke freezer and have it tell the applications to prepare for backup.
09:39:03 <saggi> Than we create the backup the usual Karbor way.
09:40:25 <saggi> The main question is if we can pass configuration about plugins in the API call itself.
09:40:38 <saggi> Instead of creating plans in freezer
09:41:03 <saggi> yangyapeng ^^
09:41:20 <xiangxinyong> saggi: I guess creating plans in freezer is not good
09:41:27 <chenying2016> hi
09:41:44 <chenying2016> I am
09:41:52 <xiangxinyong> :)
09:41:53 <saggi> xiangxinyong: We would like to user freezer as a stateless entity
09:41:54 <chenying2016> I am late
09:42:03 <saggi> chenying2016: :)
09:42:10 <xiangxinyong> saggi: agree with you
09:42:48 <xiangxinyong> saggi: it seems like we need to do more commuications with freezer team
09:42:49 <saggi> yangyapeng left
09:43:32 <saggi> xiangxinyong: You are right. I will add an item to their weekly meeting this week to talk about statelessness.
09:43:42 <xiangxinyong> ^^
09:44:02 <xiangxinyong> yeah. yangyapeng and Pierre-Arthur Mathieu could help us.
09:44:18 <zengchen> saggi: we can simply use freezer to do what it does. just invoke its api. but the question is the configuration of freezer agent is a little complex.
09:44:35 <xiangxinyong> saggi: thank you.
09:44:38 <saggi> zengchen: What configuration
09:44:50 <chenying2016> install
09:44:55 <chenying2016> freezer
09:45:39 <saggi> Yes, maybe we can also get them to have an agentless option.
09:45:42 <saggi> We'll see
09:46:32 <zengchen> saggi:you can see there are a little more configurations for the freezer agent. the user should know how to use them.
09:46:34 <saggi> chenying2016: In any case, freezer is not a mandatory requirement for karbor. We will only use it for application level consistency.
09:47:01 <zengchen> saggi:i had writed a plugin of freezer.
09:47:17 <xiangxinyong> zengchen: great
09:48:20 <yuval> this plugin architecture is not yet merged, right?
09:48:25 <zengchen> saggi:hope to see your detailf of solution.
09:48:32 <saggi> #action talk to Freezer team about using freezer as a stateless entity preferably without setting up schedulers.
09:48:55 <xiangxinyong> saggi: thanks
09:49:26 <zengchen> yuval:you asked me?
09:49:35 <yuval> as a general question
09:50:02 <saggi> yuval: IIRC it's in their roadmap for this cycle
09:50:07 <saggi> But I'm not sure.
09:50:25 <yuval> saggi: thumbs up emoji
09:50:51 <saggi> #topic open discussion
09:50:54 <saggi> Anything else?
09:51:46 <zengchen> i have came across a question
09:52:57 <chenying> I hope the patches about the operationengine could be merged,\.
09:53:07 <saggi> zengchen: ...
09:53:16 <saggi> chenying. I'll try and do it today
09:53:21 <zengchen> about this patch (https://review.openstack.org/#/c/384062/). the unit test can pass if i use 'ostestr' to run, if it failed when i use 'tox - e py27'
09:53:31 <chenying> The operationengine servcie could not work because of this patches.
09:54:16 <saggi> zengchen: You are asking why it fails?
09:54:26 <chenying> zengchen have a problom about tox -e to run unit test.
09:54:32 <zengchen> the reason is the 'mock' can not work when the run unit test with 'tox'
09:54:59 <saggi> zengchen: It fails all version of python
09:55:56 <zengchen> saggi:i just want to ask who know the difference between the 'ostestr' and 'tox'. I think if the 'ostestr' can work, the 'tox' can work too.
09:56:23 <saggi> It might be something in the configuration. I will have to look at it more closely to see what the problem is.
09:56:25 <zengchen> saggi:yes, both py27 and py34 failed.
09:57:02 <zengchen> saggi:thanks. I have spent a lot of time on it. but i failed to fix it.
09:57:27 <saggi> zengchen: I'll try and squeeze it in my schedule.
09:57:52 <saggi> Anything else?
09:58:12 <zengchen> saggi:thanks very much.
09:58:53 <saggi> I would like to just to thank xiangxinyong for his great suggestions for topics for this meeting. And in general trying to get Kolla and Freezer's cooperation.
09:59:01 <yuval> xiangxinyong: great job!
09:59:05 <saggi> Good day everyone
09:59:19 <zengchen> bye bye.
09:59:22 <saggi> #endmeeting