14:00:54 <mgoddard> #startmeeting kayobe
14:00:55 <openstack> Meeting started Mon Mar 18 14:00:54 2019 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:59 <openstack> The meeting name has been set to 'kayobe'
14:01:05 <mgoddard> Hello everyone
14:01:13 <mgoddard> #topic rollcall
14:01:14 <dougsz> o/
14:01:27 <mgoddard> Please raise your virtual hands
14:01:30 <mgoddard> \o
14:03:53 <priteau> o/
14:04:31 <mgoddard> #topic agenda
14:04:40 <mgoddard> * Roll-call
14:04:43 <mgoddard> * Announcements
14:04:45 <mgoddard> * Kayobe whiteboard https://etherpad.openstack.org/p/kayobe-whiteboard
14:04:47 <mgoddard> * Discussion
14:04:49 <mgoddard> ** Denver Summit Forum
14:04:51 <mgoddard> ** Switching to kolla master branch
14:04:53 <mgoddard> ** Stein release planning https://etherpad.openstack.org/p/kayobe-stein-release
14:04:55 <mgoddard> * Open Discussion
14:05:07 <mgoddard> No announcements on the agenda today. Anyone else have any?
14:05:24 <priteau> Nothing special frmo me
14:05:27 <mgoddard> I guess I could add the kolla feature freeze date
14:05:54 <mgoddard> #info Kolla will have feature freeze for Stein from March 18th - 21st
14:06:47 <mgoddard> #info OpenStack Stein release 8th - 12th April
14:06:56 <mgoddard> Kolla will follow a few weeks after
14:07:25 <mgoddard> #topic whiteboard
14:07:32 <mgoddard> #link https://etherpad.openstack.org/p/kayobe-whiteboard
14:08:05 <mgoddard> We had an issue with the coverage job, due to the base images being updated to bionic. Now fixed
14:08:48 <mgoddard> I'll give you all a couple minutes to update the whiteboard
14:09:04 <priteau> I see there are still occasional Zuul job failures, is there anything we can do about it?
14:09:43 <mgoddard> We seem to be seeing more than usual at the moment, all during the bare metal instance deploy. I wonder if something has changed
14:10:34 <jovial[m]> Have you got a link to an example where it failed?
14:11:15 <mgoddard> jovial[m]: I could dig one up
14:11:58 <mgoddard> This one has failed a few times: https://review.openstack.org/#/c/643572/
14:12:15 <mgoddard> jovial[m]: are you offering to investigate? :0
14:13:02 <jovial[m]> If I find some free time, I'll look into it :D
14:13:26 <mgoddard> I wonder if the inspector iptables filter is getting in the way?
14:14:28 <priteau> Not sure if it's related, but in the failing job there is:
14:14:32 <priteau> 2019-03-18 13:19:23.033491 | Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
14:14:32 <priteau> 2019-03-18 13:19:23.033587 | has been opened read-only.
14:14:53 <mgoddard> priteau: I think every CI job has that
14:15:40 <mgoddard> let's move on, we're not going to fix it here.
14:15:51 <mgoddard> #topic Denver Summit Forum
14:16:00 <priteau> I looked at just a couple of successful job and they were using another device (xvdd) but not emitting the read-only warning
14:16:00 * jovial[m] sent a long message:  < https://matrix.org/_matrix/media/v1/download/matrix.org/zbYQmLMRwiONWjtfKbrqYjDY >
14:16:58 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: Add missing space in argument description  https://review.openstack.org/642731
14:17:16 <mgoddard> We've had a session accepted for the forum
14:17:34 <priteau> Yay!
14:18:11 <mgoddard> #link https://www.openstack.org/summit/denver-2019/summit-schedule/events/23669/kayobe-user-feedback-and-roadmap
14:18:31 <mgoddard> same deal as in Berlin, mostly feedback, bit of roadmap
14:19:20 <mgoddard> I'll create an etherpad that we can start to populate, but please consider if there are any topics we should discuss
14:19:32 <mgoddard> #action mgoddard to create etherpad for forum
14:19:49 <priteau> It's the day after the tutorial, so we could get people who just started using Kayobe
14:20:11 <mgoddard> good thinking, we should make sure to make a link
14:20:26 <mgoddard> let's move on
14:20:28 <mgoddard> #topic Switching to kolla master branch
14:20:58 <mgoddard> I have a patch to switch to master for our dependencies
14:21:01 <mgoddard> #link https://review.openstack.org/615596
14:21:30 <mgoddard> It's not quite there yet, but getting closer. There is a bug in mariadb upgrade in kolla-ansible that I'm working on
14:21:49 <mgoddard> Just wanted to make everyone aware that it'll be happening soon
14:21:54 <priteau> Nice work
14:22:14 <priteau> You could remove the Depends-On if you want, as https://review.openstack.org/#/c/642034/ has merged.
14:22:24 <mgoddard> +1
14:22:55 <mgoddard> And now for everyone's favourite topic
14:22:58 <mgoddard> #topic Stein release planning https://etherpad.openstack.org/p/kayobe-stein-release
14:23:50 <mgoddard> The rest of openstack has a goal for 'python3 first'
14:23:59 <mgoddard> Should we do the same?
14:24:20 <mgoddard> I think the problem is that we are quite tied to centos, which is still in python2 land
14:25:14 <dougsz> Until RHEL 8 at least
14:25:41 <mgoddard> yeah
14:25:54 <priteau> It's worth having jobs testing with Python 3, but I would keep the default to Python 2 until we do a real end-to-end deployment using Python 3.
14:26:34 <mgoddard> so should we add a couple jobs for python3?
14:27:09 <priteau> I don't see why not. It would help to catch compatibility issues sooner.
14:27:16 <dougsz> Seems like a good idea to me
14:27:30 <dougsz> Would there be much work given that we install into a venv anyway?
14:27:35 <mgoddard> It's not immediately clear to me exactly what you'd need to do
14:27:57 <dougsz> Sorry, got another meeting, until next time
14:28:07 <mgoddard> ok, bye dougsz
14:29:50 <priteau> Would we want to test Kolla-Ansible against Python 3 as well?
14:30:05 <mgoddard> priteau: yes I think so
14:30:25 <priteau> Need to make sure the venv created by Kayobe uses the right Python then
14:30:52 <mgoddard> Yes, and also for remote execution (/opt/kayobe/venvs/)
14:31:15 <mgoddard> Would anyone like to pick up this work?
14:32:17 <mgoddard> I'll try throwing an initial patch together
14:32:30 <priteau> Not sure when I will have the time, but I will try to look into it if no one beats me to it.
14:33:19 <mgoddard> o
14:33:22 <mgoddard> k
14:33:31 <mgoddard> let's move on
14:33:36 <mgoddard> #topic open discussion
14:34:51 <mgoddard> Just going back to the whiteboard, just want to mention that I put the swift and YAML patches as a priority
14:35:08 <mgoddard> they seem to be the main ones ready right now
14:35:13 <mgoddard> Anyone have anything else?
14:37:03 <priteau> Is anyone working on the priorities at the top of the stein etherpad?
14:37:17 <mgoddard> Good question
14:37:21 <mgoddard> Not that I'm aware of
14:37:57 <mgoddard> Does anyone want to?
14:37:59 <priteau> If there no progress on them when we are in the position to make a Stein release, should we just move them to Train?
14:38:55 <mgoddard> Yes. They seem more like strategic things, not critical to any particular release
14:39:32 <mgoddard> I think we should see it as 'the first Stein release'
14:40:02 <mgoddard> we may make another - it's a long way to Train
14:40:04 <priteau> Do you foresee that eventually one release of Kayobe could work with multiple OpenStack versions, or would it be too much work to maintain?
14:40:46 <mgoddard> it would be nice if it could support a range of releases, but yes I think it could be quite hard to maintain
14:42:31 <mgoddard> perhaps one day we will get there
14:43:10 <mgoddard> lets call it. Thanks for attending
14:43:18 <mgoddard> #endmeeting