14:00:16 <priteau> #startmeeting kayobe
14:00:17 <openstack> Meeting started Mon Jun 10 14:00:16 2019 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:20 <openstack> The meeting name has been set to 'kayobe'
14:00:28 <priteau> #topic rollcall
14:00:47 <priteau> \o
14:00:49 <jovial[m]> \o
14:02:50 <priteau> Anyone else? dougsz Wasaac
14:02:59 <dougsz> \o
14:03:13 <Wasaac> Oh hey. Will pop on now
14:03:27 <priteau> #topic agenda
14:03:35 <oneswig> o/
14:03:48 <priteau> Hey oneswig
14:03:53 <priteau> * Roll-call
14:03:53 <priteau> * Announcements
14:03:53 <priteau> ** Requested feedback regarding becoming official http://lists.openstack.org/pipermail/openstack-discuss/2019-June/006901.html
14:03:55 <priteau> * Review actions from last meeting
14:03:57 <priteau> * Kayobe whiteboard https://etherpad.openstack.org/p/kayobe-whiteboard
14:03:59 <priteau> * Discussion
14:04:01 <priteau> ** Stein release https://etherpad.openstack.org/p/kayobe-stein-release
14:04:03 <priteau> * Open Discussion
14:04:14 <priteau> #topic announcements
14:04:34 <priteau> #info Requested feedback regarding becoming official
14:04:42 <priteau> #link http://lists.openstack.org/pipermail/openstack-discuss/2019-June/006901.html
14:04:58 <priteau> There are two possible options
14:05:02 <priteau> 1. become a deliverable of the Kolla project
14:05:02 <priteau> 2. become an official top level OpenStack project
14:05:34 <priteau> Thierry Carrez said that from governance, both options are fine
14:06:02 <priteau> It's really up to the Kolla and Kayobe communities to decide whether they want to become one
14:06:10 <oneswig> Option 1 is probably less admin overhead, right?
14:06:48 <priteau> Yes, because there will be only one PTL, one project update at the summit, etc.
14:07:25 <dougsz> My vote goes for option 1 to try and reduce the fixed costs of running the project
14:07:41 <dougsz> And also to try and bring the two communities together more
14:08:23 <Wasaac> The question then is, does the kolla community feel the same?
14:08:24 <priteau> I am favouring 1. as well. If it doesn't work out it's always possible to split, like placement did with nova
14:08:35 <dougsz> I suppose it is step away from support for both KA + OSA in Kayobe, but it seems unlikely someone will add OSA support anytime soon
14:09:31 <priteau> Unless we have a strong requirement to support OSA, I don't see it happening anytime soon
14:10:05 <priteau> I am not sure where the discussion is at within the Kolla community. I'll let mgoddard update when there's been progress.
14:10:31 <priteau> No other announcement, unless someone has any?
14:10:52 <dougsz> I think hrw said he would support, attendance was pretty low
14:11:00 <dougsz> Nothing from me
14:11:24 <priteau> Maybe this calls for a vote from the Kolla folks?
14:12:18 <priteau> The IRC bot has a voting feature ;-)
14:12:29 <priteau> #topic Review actions from last meeting
14:13:01 <priteau> Last meeting was four weeks ago, I found the following action items:
14:13:09 <priteau> jovial[m] to investigate seed upgrade job failure
14:13:15 <priteau> mgoddard to enquire about kayobe org on github
14:13:17 <priteau> mgoddard to schedule bug review and squash session
14:13:31 <priteau> jovial[m]: I believe these job failures are fixed?
14:14:57 <jovial[m]> I never got to the bottom of it.. it started working again, so I stopped looking
14:15:18 <jovial[m]> unsure whether it is now fixed or still flaky
14:15:55 <priteau> That's the problem with jobs relying on so many layers and an infra that's not always the most stable.
14:16:21 <priteau> We'll see if the failures come back
14:16:27 <priteau> The Kayobe namespace is under our control now
14:16:31 <priteau> #link https://github.com/kayobe
14:16:46 <priteau> IIRC the goal was to mirror Kayobe there
14:17:05 <priteau> However, if we become a Kolla deliverable we will go back in the openstack namespace
14:17:16 <priteau> So I think the plan is to wait and see
14:17:25 <jovial[m]> are we going to ask if the kayobe repository can be transferred to the new organization?
14:17:32 <jovial[m]> that way we get automatic redirects
14:19:10 <jovial[m]> wouldn't it be relatively straight forward to transfer back when that happens?
14:19:29 <priteau> I don't know how complex the process is
14:19:42 <jovial[m]> quite a few people stumble upon the old repo
14:19:49 <priteau> It is problematic that our GitHub repo is quite out of date now
14:19:51 <priteau> #link https://github.com/openstack/kayobe
14:20:25 <priteau> #action mgoddard to enquire about GitHub repository transfers
14:20:26 <jovial[m]> I think you just put the organization in the text field and click a button
14:20:53 <priteau> And then we would have to set up mirroring ourselves
14:21:42 <priteau> We can investigate how to do that once we know if the transfer is going to happen
14:21:54 <priteau> Regarding the bug review and squash session, I haven't heard from Mark
14:22:02 <priteau> I'll queue it up again in action items
14:22:09 <priteau> #action mgoddard to schedule bug review and squash session
14:22:34 <priteau> #topic Kayobe whiteboard
14:22:48 <priteau> #link https://etherpad.openstack.org/p/kayobe-whiteboard
14:23:10 <priteau> I've updated the whiteboard to reflect CI status and removed merged patches
14:23:42 <priteau> I've also added a few of my patches that are ready for review
14:24:40 <priteau> Please update with the status of your own patches
14:25:54 <priteau> Looks like we had job failures on https://review.opendev.org/#/c/663414/ recently
14:26:58 <priteau> jovial[m]: Can you please check if your question on https://review.opendev.org/#/c/645849/ has been addressed?
14:28:18 <priteau> dougsz: Did you see I left some comments on https://review.opendev.org/#/c/655669/
14:28:30 <priteau> Minor nits only
14:29:14 <dougsz> oh yeah, thanks
14:31:27 <openstackgerrit> Doug Szumski proposed x/kayobe master: Support customising Prometheus config  https://review.opendev.org/655669
14:32:04 <dougsz> fixed
14:32:17 <priteau> Thanks
14:33:05 <priteau> We have a couple of easy reviews
14:33:10 <priteau> https://review.opendev.org/#/c/662483/
14:33:14 <priteau> https://review.opendev.org/#/c/660973/
14:33:27 <priteau> Small documentation changes only
14:37:46 <priteau> We can take a look at the status of the Stein release
14:37:50 <priteau> #link https://etherpad.openstack.org/p/kayobe-stein-release
14:38:46 <priteau> As far as I am aware, there wasn't much progress on the first three priorities
14:38:58 <priteau> jovial[m] has proposed patches for https://storyboard.openstack.org/#!/story/2004367
14:39:20 <priteau> I am working on a new patch for Cumulus support
14:40:55 <priteau> We have python3 unit tests now, but is anyone working on adding kayobe-overcloud-deploy-python3 and kayobe-seed-deploy-python3 jobs
14:41:31 <priteau> dougsz: What's the status of the deprecation of post deploy (Monasca) grafana configuration?
14:41:49 <dougsz> Haven't had time to look at it yet
14:44:04 <priteau> OK
14:45:55 <priteau> Kolla hasn't cut their final Stein release yet, we have to wait for them anyway.
14:47:23 <priteau> There was a release blocker which was resolved last week: https://review.opendev.org/#/c/651601
14:48:38 <priteau> So it might happen soon-ish
14:48:58 <priteau> #topic Discussion
14:49:05 <priteau> Anything else to discuss folks?
14:50:21 <priteau> If not let's get back to our code!
14:50:28 <priteau> Thanks everyone
14:50:35 <priteau> #endmeeting